Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| 5068 | udp | Reserved | |||||||||
| scte30 | 5168 | tcp | SCTE30 Connection | Thomas Russell | Thomas Russell | 2005-05 | |||||
| scte30 | 5168 | udp | SCTE30 Connection | Thomas Russell | Thomas Russell | 2005-05 | |||||
| 5266-5268 | Unassigned | ||||||||||
| pcp-multicast | 5350 | udp | Port Control Protocol Multicast | IESG | IETF Chair | RFC 6887 | |||||
| pcp | 5351 | udp | Port Control Protocol | IESG | IETF Chair | RFC 6887 | |||||
| sdt | 5568 | tcp | Session Data Transport Multicast | Daniel W. Antonuk | Daniel W. Antonuk | 2006-05 | |||||
| sdt | 5568 | udp | Session Data Transport Multicast | Daniel W. Antonuk | Daniel W. Antonuk | 2006-05 | |||||
| auriga-router | 5680 | tcp | Auriga Router Service | Vincent Gaudeul | Vincent Gaudeul | 2006-02 | |||||
| auriga-router | 5680 | udp | Auriga Router Service | Vincent Gaudeul | Vincent Gaudeul | 2006-02 | |||||
| ncxcp | 5681 | tcp | Net-coneX Control Protocol | Ryan Werber | Ryan Werber | 2006-06 | |||||
| ncxcp | 5681 | udp | Net-coneX Control Protocol | Ryan Werber | Ryan Werber | 2006-06 | |||||
| 5682 | tcp | Reserved | |||||||||
| brightcore | 5682 | udp | BrightCore control & data transfer exchange | Marko Bjelac | Marko Bjelac | 2010-06-10 | |||||
| coap | 5683 | tcp | Constrained Application Protocol (CoAP) | IESG | IETF Chair | 2017-12-22 | RFC 8323 | ||||
| coap | 5683 | udp | Constrained Application Protocol | IESG | IETF Chair | 2011-06-13 | 2013-07-25 | RFC 7252 | |||
| coaps | 5684 | tcp | Constrained Application Protocol (CoAP) | IESG | IETF Chair | 2017-12-22 | RFC 7301; RFC 8323 | ||||
| coaps | 5684 | udp | DTLS-secured CoAP | IESG | IETF Chair | 2013-07-25 | RFC 7252 | ||||
| 5685-5686 | Unassigned | ||||||||||
| gog-multiplayer | 5687 | udp | GOG multiplayer game protocol | GOG.com | Michał Gruchała | 2014-07-31 | 2014-10-09 | ||||
| 5687 | tcp | Reserved | |||||||||
| ggz | 5688 | tcp | GGZ Gaming Zone | Josef Spillner | Josef Spillner | 2003-01 | |||||
| ggz | 5688 | udp | GGZ Gaming Zone | Josef Spillner | Josef Spillner | 2003-01 | |||||
| qmvideo | 5689 | tcp | QM video network management protocol | Jamie Lokier | Jamie Lokier | 2006-05 | |||||
| qmvideo | 5689 | udp | QM video network management protocol | Jamie Lokier | Jamie Lokier | 2006-05 | |||||
| openmailpxy | 5768 | tcp | OpenMail CMTS Server | OpenMail Encyclopedia; Don Loughry | OpenMail Encyclopedia; Don Loughry | ||||||
| openmailpxy | 5768 | udp | OpenMail CMTS Server | OpenMail Encyclopedia; Don Loughry | OpenMail Encyclopedia; Don Loughry | ||||||
| diameters | 5868 | tcp | Diameter over TLS/TCP | IESG | IETF Chair | RFC 6733 | |||||
| 5868 | udp | Reserved | |||||||||
| diameters | 5868 | sctp | Diameter over DTLS/SCTP | IESG | IETF Chair | RFC 6733 | |||||
| mppolicy-v5 | 5968 | tcp | mppolicy-v5 | Yutaka Ono | Yutaka Ono | ||||||
| mppolicy-v5 | 5968 | udp | mppolicy-v5 | Yutaka Ono | Yutaka Ono | ||||||
| gsmp-ancp | 6068 | tcp | GSMP/ANCP | Avri Doria | Avri Doria | RFC 6320 | |||||
| 6068 | udp | Reserved | |||||||||
| grid | 6268 | tcp | Grid Authentication | Jason Hamilton | Jason Hamilton | 2006-06 | |||||
| grid | 6268 | udp | Grid Authentication | Jason Hamilton | Jason Hamilton | 2006-06 | |||||
| canit-store | 6568 | tcp | CanIt Storage Manager IANA assigned this well-formed service name as a replacement for "canit_store". |
Dianne Skoll | Dianne Skoll | 2009-04-22 | 2017-05-25 | ||||
| canit_store | 6568 | tcp | CanIt Storage Manager | Dianne Skoll | Dianne Skoll | 2009-04-22 | 2017-05-25 | This entry is an alias to "canit-store". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||
| rp-reputation | 6568 | udp | Roaring Penguin IP Address Reputation Collection | Dianne Skoll | Dianne Skoll | 2010-02-05 | 2017-05-25 | ||||
| 6680-6686 | Unassigned | ||||||||||
| clever-ctrace | 6687 | tcp | CleverView for cTrace Message Service | David Cheng | David Cheng | 2010-02-01 | |||||
| 6687 | udp | Reserved | |||||||||
| clever-tcpip | 6688 | tcp | CleverView for TCP/IP Message Service | David Cheng | David Cheng | 2009-10-13 | |||||
| 6688 | udp | Reserved | |||||||||
| tsa | 6689 | tcp | Tofino Security Appliance | Scott Howard | Scott Howard | 2009-10-13 | |||||
| tsa | 6689 | udp | Tofino Security Appliance | Scott Howard | Scott Howard | 2009-10-13 | |||||
| babel-dtls | 6699 | udp | Babel Routing Protocol over DTLS | IESG | IETF Chair | 2020-09-04 | RFC 8968 | ||||
| bmc-perf-mgrd | 6768 | tcp | BMC PERFORM MGRD | Portnoy Boxman | Portnoy Boxman | ||||||
| bmc-perf-mgrd | 6768 | udp | BMC PERFORM MGRD | Portnoy Boxman | Portnoy Boxman | ||||||
| 6792-6800 | Unassigned | ||||||||||
| acnet | 6801 | tcp | ACNET Control System Protocol | Fermilab | Rich Neswold | 2007-02 | 2017-07-13 | ||||
| acnet | 6801 | udp | ACNET Control System Protocol | Fermilab | Rich Neswold | 2007-02 | 2017-07-13 | ||||
| 6802-6816 | Unassigned | ||||||||||
| pentbox-sim | 6817 | tcp | PenTBox Secure IM Protocol | Alberto Ortega Llamas | Alberto Ortega Llamas | 2009-11-04 | |||||
| 6817 | udp | Reserved | |||||||||
| 6818-6830 | Unassigned | ||||||||||
| ambit-lm | 6831 | tcp | ambit-lm | Don Hejna | Don Hejna | ||||||
| ambit-lm | 6831 | udp | ambit-lm | Don Hejna | Don Hejna | ||||||
| 6832-6840 | Unassigned | ||||||||||
| netmo-default | 6841 | tcp | Netmo Default | Urs Bertschinger | Urs Bertschinger | ||||||
| netmo-default | 6841 | udp | Netmo Default | Urs Bertschinger | Urs Bertschinger | ||||||
| netmo-http | 6842 | tcp | Netmo HTTP | Urs Bertschinger | Urs Bertschinger | ||||||
| netmo-http | 6842 | udp | Netmo HTTP | Urs Bertschinger | Urs Bertschinger | ||||||
| 6843-6849 | Unassigned | ||||||||||
| iccrushmore | 6850 | tcp | ICCRUSHMORE | Dave Hubbard | Dave Hubbard | ||||||
| iccrushmore | 6850 | udp | ICCRUSHMORE | Dave Hubbard | Dave Hubbard | ||||||
| 6851-6867 | Unassigned | ||||||||||
| acctopus-cc | 6868 | tcp | Acctopus Command Channel | Stefan Auweiler | Stefan Auweiler | 2009-11-16 | |||||
| acctopus-st | 6868 | udp | Acctopus Status | Stefan Auweiler | Stefan Auweiler | 2009-11-16 | |||||
| 6869-6887 | Unassigned | ||||||||||
| muse | 6888 | tcp | MUSE | Muse Communications Corporation | Muse Communications Corporation | ||||||
| muse | 6888 | udp | MUSE | Muse Communications Corporation | Muse Communications Corporation | ||||||
| 6889-6899 | Unassigned | ||||||||||
| 6967-6968 | Unassigned | ||||||||||
| cnckadserver | 7168 | tcp | cncKadServer DB & Inventory Services | Micha Ben-Efraim | Micha Ben-Efraim | 2011-01-31 | |||||
| 7168 | udp | Reserved | |||||||||
| 7567-7568 | Unassigned | ||||||||||
| authoritygate | 7668 | tcp | AuthorityGate Secure API communication for Orchestrated task sequencing | AuthorityGate Inc | Kevin Komlosy | 2025-03-28 | |||||
| 7668 | udp | Reserved | |||||||||
| ms-do | 7680 | tcp | Microsoft Delivery Optimization Peer-to-Peer | Microsoft Corporation | Narkis Engler | 2008-02-27 | 2022-05-03 | ||||
| ms-do | 7680 | udp | Microsoft Delivery Optimization Peer-to-Peer | Microsoft Corporation | Narkis Engler | 2008-02-27 | 2022-05-03 | ||||
| 7681-7682 | Unassigned | ||||||||||
| dmt | 7683 | tcp | Cleondris DMT | Cleondris GmbH | Christian Plattner | 2015-03-31 | |||||
| 7683 | udp | Reserved | |||||||||
| 7684-7686 | Unassigned | ||||||||||
| bolt | 7687 | tcp | Bolt database connection | Neo Technology, Inc | Julian Simpson | 2016-09-29 | |||||
| 7687 | udp | Reserved | |||||||||
| 7688 | Unassigned | ||||||||||
| collaber | 7689 | tcp | Collaber Network Service | Rajesh Akkineni | Rajesh Akkineni | 2007-01 | |||||
| collaber | 7689 | udp | Collaber Network Service | Rajesh Akkineni | Rajesh Akkineni | 2007-01 | |||||
| 7848-7868 | Unassigned | ||||||||||
| 7968-7978 | Unassigned | ||||||||||
| 8068-8069 | Unassigned | ||||||||||
| 8568-8599 | Unassigned | ||||||||||
| spartan | 8668 | tcp | Spartan management | Tenebris Technologies Inc. | Eric Jacksch | 2023-10-26 | |||||
| 8668 | udp | Reserved | |||||||||
| 8676-8685 | Unassigned | ||||||||||
| sun-as-jmxrmi | 8686 | tcp | Sun App Server - JMX/RMI | Abhijit Kumar | Abhijit Kumar | 2005-11 | |||||
| sun-as-jmxrmi | 8686 | udp | Sun App Server - JMX/RMI | Abhijit Kumar | Abhijit Kumar | 2005-11 | |||||
| 8687 | Unassigned | ||||||||||
| openremote-ctrl | 8688 | tcp | OpenRemote Controller HTTP/REST | OpenRemote, Inc. | Juha Lindfors | 2012-12-18 |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Abhijit Kumar | as-iana-ports&sun.com | 2005-11 | |
| Alberto Ortega Llamas | alberto.kun666&gmail.com | 2009-11-04 | |
| AuthorityGate Inc | support&authoritygate.com | 2025-03-28 | |
| Avri Doria | avri.doria&nokia.com | ||
| Christian Plattner | Cleondris GmbH | christian.plattner&cleondris.ch | 2015-03-31 |
| Cleondris GmbH | noc&cleondris.ch | 2015-03-31 | |
| Daniel W. Antonuk | dantonuk&etcconnect.com | 2006-05 | |
| Dave Hubbard | dave&icc.net | ||
| David Cheng | davec&aesclever.com | 2010-02-01 | |
| Dianne Skoll | dfs&roaringpenguin.com | 2017-05-25 | |
| Don Hejna | djhejna&ambit.com | ||
| Don Loughry | DON_LOUGHRY&hp-cupertino-om4.om.hp.com | ||
| Eric Jacksch | eric&tenebris.com | 2023-10-26 | |
| Fermilab | neswold&fnal.gov | 2017-07-13 | |
| GOG.com | admin&gog.com | 2014-07-31 | |
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| Jamie Lokier | jamie&jlokier.co.uk | 2006-05 | |
| Jason Hamilton | JHamilton&griddatasecurity.com | 2006-06 | |
| Josef Spillner | admin&ggzgamingzone.org | 2003-01 | |
| Juha Lindfors | OpenRemote, Inc. | juha&openremote.org | 2012-12-18 |
| Julian Simpson | Neo Technology, Inc | julian.simpson&neotechnology.com | 2016-09-29 |
| Kevin Komlosy | AuthorityGate Inc | support&authoritygate.com | 2025-03-28 |
| Marko Bjelac | marko.bjelac&elma.hr | 2010-06-10 | |
| Micha Ben-Efraim | micha&metalix.net | 2011-01-31 | |
| Michał Gruchała | GOG.com | admin&gog.com | 2014-07-31 |
| Microsoft Corporation | naenglerµsoft.com | 2022-05-03 | |
| Muse Communications Corporation | howard&muse3d.com | ||
| Narkis Engler | Microsoft Corporation | naenglerµsoft.com | 2022-05-03 |
| Neo Technology, Inc | admins&neotechnology.com | 2016-09-29 | |
| OpenMail Encyclopedia | opencyc&hpopd.pwd.hp.com | ||
| OpenRemote, Inc. | juha&openremote.org | 2012-12-18 | |
| Portnoy Boxman | portnoy_boxman&bmc.com | 2005-01 | |
| Rajesh Akkineni | rajesh&vimukti.com | 2007-01 | |
| Rich Neswold | neswold&fnal.gov | 2007-02 | |
| Ryan Werber | ryan&ncxti.com | 2006-06 | |
| Scott Howard | scott&byressecurity.com | 2009-10-13 | |
| Stefan Auweiler | stefan.auweiler&saitc.de | 2009-11-16 | |
| Tenebris Technologies Inc. | info&tenebris.com | 2023-10-26 | |
| Thomas Russell | trussell&scte.org | 2005-05 | |
| Urs Bertschinger | urs&netmosphere.com | ||
| Vincent Gaudeul | technique&auriga.fr | 2006-02 | |
| Yutaka Ono | ono&saint.nm.fujitsu.co.jp |