Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| 5696 | udp | Reserved | |||||||||
| 5697-5699 | Unassigned | ||||||||||
| spramsca | 5769 | tcp | x509solutions Internal CA | Brendan Fay | Brendan Fay | 2006-02 | |||||
| spramsca | 5769 | udp | x509solutions Internal CA | Brendan Fay | Brendan Fay | 2006-02 | |||||
| 5869-5882 | Unassigned | ||||||||||
| mppolicy-mgr | 5969 | tcp | mppolicy-mgr | Yutaka Ono | Yutaka Ono | ||||||
| mppolicy-mgr | 5969 | udp | mppolicy-mgr | Yutaka Ono | Yutaka Ono | ||||||
| trip | 6069 | tcp | TRIP | Hussein F. Salama | Hussein F. Salama | ||||||
| trip | 6069 | udp | TRIP | Hussein F. Salama | Hussein F. Salama | ||||||
| reload-config | 6084 | tcp | Peer to Peer Infrastructure Configuration | IESG | IETF Chair | 2009-01-29 | 2013-03-26 | RFC 6940 | |||
| grid-alt | 6269 | tcp | Grid Authentication Alt | Jason Hamilton | Jason Hamilton | 2006-06 | |||||
| grid-alt | 6269 | udp | Grid Authentication Alt | Jason Hamilton | Jason Hamilton | 2006-06 | |||||
| 6364-6369 | Unassigned | ||||||||||
| 6569-6578 | Unassigned | ||||||||||
| ircu | 6665-6669 | tcp | IRCU | Brian Tackett | Brian Tackett | ||||||
| 6665-6669 | udp | Reserved | |||||||||
| cleverdetect | 6690 | tcp | CLEVERDetect Message Service | Applied Expert Systems, Inc. | David Cheng | 2014-12-03 | |||||
| 6690 | udp | Reserved | |||||||||
| 6691-6695 | Unassigned | ||||||||||
| 6696 | tcp | Reserved | |||||||||
| babel | 6696 | udp | Babel Routing Protocol | 2011-08-15 | RFC 8966 | ||||||
| ircs-u | 6697 | tcp | Internet Relay Chat via TLS/SSL | 2014-02-11 | RFC 7194 | ||||||
| 6697 | udp | Reserved | 2014-02-11 | ||||||||
| 6698 | Unassigned | ||||||||||
| 6699 | tcp | Reserved | |||||||||
| babel-dtls | 6699 | udp | Babel Routing Protocol over DTLS | IESG | IETF Chair | 2020-09-04 | RFC 8968 | ||||
| adi-gxp-srvprt | 6769 | tcp | ADInstruments GxP Server | Mathew Pitchforth | Mathew Pitchforth | 2005-08 | |||||
| adi-gxp-srvprt | 6769 | udp | ADInstruments GxP Server | Mathew Pitchforth | Mathew Pitchforth | 2005-08 | |||||
| 6869-6887 | Unassigned | ||||||||||
| rtimeviewer | 6900 | tcp | R*TIME Viewer Data Interface | Curtiss-Wright Corporation | Robert Ammon | 2016-12-14 | |||||
| 6900 | udp | Reserved | |||||||||
| jetstream | 6901 | tcp | Novell Jetstream messaging protocol | Anil Tyagi | Anil Tyagi | 2010-06-11 | |||||
| 6901 | udp | Reserved | |||||||||
| 6902-6923 | Unassigned | ||||||||||
| split-ping | 6924 | tcp | Ping with RX/TX latency/loss split | Ben Cartwright-Cox | Ben Cartwright-Cox | 2020-02-12 | |||||
| split-ping | 6924 | udp | Ping with RX/TX latency/loss split | Ben Cartwright-Cox | Ben Cartwright-Cox | 2020-02-12 | |||||
| 6925-6934 | Unassigned | ||||||||||
| ethoscan | 6935 | tcp | EthoScan Service | Marty Campbell | Marty Campbell | 2011-06-10 | |||||
| ethoscan | 6935 | udp | EthoScan Service | Marty Campbell | Marty Campbell | 2011-06-10 | |||||
| xsmsvc | 6936 | tcp | XenSource Management Service | Roger Klorese | Roger Klorese | 2006-06 | |||||
| xsmsvc | 6936 | udp | XenSource Management Service | Roger Klorese | Roger Klorese | 2006-06 | |||||
| 6937-6945 | Unassigned | ||||||||||
| bioserver | 6946 | tcp | Biometrics Server | ISHII AKIO | ISHII AKIO | 2006-01 | |||||
| bioserver | 6946 | udp | Biometrics Server | ISHII AKIO | ISHII AKIO | 2006-01 | |||||
| 6947-6950 | Unassigned | ||||||||||
| otlp | 6951 | tcp | OTLP | Brent Foster | Brent Foster | 2006-04 | |||||
| otlp | 6951 | udp | OTLP | Brent Foster | Brent Foster | 2006-04 | |||||
| 6952-6960 | Unassigned | ||||||||||
| jmact3 | 6961 | tcp | JMACT3 | Yutaka Ono | Yutaka Ono | ||||||
| jmact3 | 6961 | udp | JMACT3 | Yutaka Ono | Yutaka Ono | ||||||
| jmevt2 | 6962 | tcp | jmevt2 | Yutaka Ono | Yutaka Ono | ||||||
| jmevt2 | 6962 | udp | jmevt2 | Yutaka Ono | Yutaka Ono | ||||||
| swismgr1 | 6963 | tcp | swismgr1 | Yutaka Ono | Yutaka Ono | ||||||
| swismgr1 | 6963 | udp | swismgr1 | Yutaka Ono | Yutaka Ono | ||||||
| swismgr2 | 6964 | tcp | swismgr2 | Yutaka Ono | Yutaka Ono | ||||||
| swismgr2 | 6964 | udp | swismgr2 | Yutaka Ono | Yutaka Ono | ||||||
| swistrap | 6965 | tcp | swistrap | Yutaka Ono | Yutaka Ono | ||||||
| swistrap | 6965 | udp | swistrap | Yutaka Ono | Yutaka Ono | ||||||
| swispol | 6966 | tcp | swispol | Yutaka Ono | Yutaka Ono | ||||||
| swispol | 6966 | udp | swispol | Yutaka Ono | Yutaka Ono | ||||||
| 6967-6968 | Unassigned | ||||||||||
| acmsoda | 6969 | tcp | acmsoda | Daniel Simms | Daniel Simms | ||||||
| acmsoda | 6969 | udp | acmsoda | Daniel Simms | Daniel Simms | ||||||
| conductor | 6970 | tcp | Conductor test coordination protocol | George Neville-Neil | George Neville-Neil | 2014-09-18 | |||||
| 6970 | udp | Reserved | |||||||||
| conductor-mpx | 6970 | sctp | conductor for multiplex | George Neville-Neil | George Neville-Neil | 2014-07-29 | |||||
| 6971-6979 | Unassigned | ||||||||||
| 6980 | tcp | Reserved | |||||||||
| qolyester | 6980 | udp | QoS-extended OLSR protocol | Green Communications SAS | Ignacy Gawedzki | 2022-05-24 | |||||
| 6981-6996 | Unassigned | ||||||||||
| MobilitySrv | 6997 | tcp | Mobility XE Protocol | Joseph T Savarese | Joseph T Savarese | 2007-06 | |||||
| MobilitySrv | 6997 | udp | Mobility XE Protocol | Joseph T Savarese | Joseph T Savarese | 2007-06 | |||||
| iatp-highpri | 6998 | tcp | IATP-highPri | John Murphy | John Murphy | ||||||
| iatp-highpri | 6998 | udp | IATP-highPri | John Murphy | John Murphy | ||||||
| iatp-normalpri | 6999 | tcp | IATP-normalPri | John Murphy | John Murphy | ||||||
| iatp-normalpri | 6999 | udp | IATP-normalPri | John Murphy | John Murphy | ||||||
| 7041-7069 | Unassigned | ||||||||||
| ccag-pib | 7169 | tcp | Consequor Consulting Process Integration Bridge | Frank Goenninger | Frank Goenninger | 2010-02-22 | |||||
| ccag-pib | 7169 | udp | Consequor Consulting Process Integration Bridge | Frank Goenninger | Frank Goenninger | 2010-02-22 | |||||
| dell-eql-asm | 7569 | tcp | Dell EqualLogic Host Group Management | James E. King, III | James E. King, III | ||||||
| 7569 | udp | Reserved | |||||||||
| 7669-7671 | Unassigned | ||||||||||
| sovd | 7690 | tcp | Service-Oriented Vehicle Diagnostics | ASAM e.V. | Bernd Wenzel | 2022-07-01 | |||||
| 7690 | udp | Reserved | |||||||||
| 7691-7696 | Unassigned | ||||||||||
| klio | 7697 | tcp | KLIO communications | Helmut Giritzer | Helmut Giritzer | 2005-08 | |||||
| klio | 7697 | udp | KLIO communications | Helmut Giritzer | Helmut Giritzer | 2005-08 | |||||
| 7698-7699 | Unassigned | ||||||||||
| mobileanalyzer | 7869 | tcp | MobileAnalyzer& MobileMonitor | Jonas Gyllensvaan | Jonas Gyllensvaan | 2009-04-27 | |||||
| 7869 | udp | Reserved | |||||||||
| 8068-8069 | Unassigned | ||||||||||
| 8267-8269 | Unassigned | ||||||||||
| 8458-8469 | Unassigned | ||||||||||
| 8669-8674 | Unassigned | ||||||||||
| 8689-8698 | Unassigned | ||||||||||
| vnyx | 8699 | tcp | VNYX Primary Port | Gregg Green | Gregg Green | 2004-11 | |||||
| 8699 | udp | Reserved | 2004-11 | 2013-05-24 | This entry is being removed on 2013-05-24. | ||||||
| oktaauthenticat | 8769 | tcp | Okta MultiPlatform Access Mgmt for Cloud Svcs | Okta Inc | Tom Belote | 2019-12-19 | |||||
| 8769 | udp | Reserved | |||||||||
| 9669-9693 | Unassigned | ||||||||||
| client-wakeup | 9694 | tcp | T-Mobile Client Wakeup Message | Michael Schönborn | Michael Schönborn | 2009-09-11 |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Anil Tyagi | tanil&novell.com | 2010-06-11 | |
| Applied Expert Systems, Inc. | davec&aesclever.com | 2014-12-03 | |
| ASAM e.V. | marius.dupuis&asam.net | 2022-07-01 | |
| Ben Cartwright-Cox | ben&benjojo.co.uk | 2020-02-12 | |
| Bernd Wenzel | ASAM e.V. | bernd.wenzel&asam.net | 2022-07-01 |
| Brendan Fay | brendan.fay&x509solutions.com | 2006-02 | |
| Brent Foster | brent.foster&onstreamsystems.com | 2006-04 | |
| Brian Tackett | cym&acrux.net | ||
| Curtiss-Wright Corporation | rammon&curtisswright.com | 2016-12-14 | |
| Daniel Simms | dsimms&acm.uiuc.edu | ||
| David Cheng | davec&aesclever.com | 2010-02-01 | |
| Frank Goenninger | frank.goenninger&consequor.de | 2010-02-22 | |
| George Neville-Neil | gnn&neville-neil.com | 2014-07-29 | |
| Green Communications SAS | contact&green-communications.fr | 2022-05-24 | |
| Gregg Green | legal&vnyx.net | 2004-11 | |
| Helmut Giritzer | helmut.giritzer&o.roteskreuz.at | 2005-08 | |
| Hussein F. Salama | hsalama&cisco.com | ||
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| Ignacy Gawedzki | Green Communications SAS | ignacy.gawedzki&green-communications.fr | 2022-05-24 |
| ISHII AKIO | ishii.akio&jp.fujitsu.com | 2006-01 | |
| James E. King, III | James_E_K&dell.com | 2010-06-24 | |
| Jason Hamilton | JHamilton&griddatasecurity.com | 2006-06 | |
| John Murphy | john.m.murphy&mci.com | ||
| Jonas Gyllensvaan | jonas&conceivium.com | 2009-04-27 | |
| Joseph T Savarese | joesa&nmwco.com | 2007-06 | |
| Marty Campbell | martycðosinfo.com | 2011-06-10 | |
| Mathew Pitchforth | mathew&adinstruments.co.nz | 2005-08 | |
| Michael Schönborn | T-Mobile International AG | michael.schoenborn&t-mobile.net | 2009-09-11 |
| Okta Inc | tbelote&okta.com | 2019-12-19 | |
| Robert Ammon | rammon&curtisswright.com | 2016-12-14 | |
| Roger Klorese | roger&xensource.com | 2006-06 | |
| Tom Belote | tbelote&okta.com | 2019-12-19 | |
| Yutaka Ono | ono&saint.nm.fujitsu.co.jp |