Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| vision-elmd | 6673 | tcp | vision_elmd IANA assigned this well-formed service name as a replacement for "vision_elmd". |
Chris Kramer | Chris Kramer | ||||||
| vision_elmd | 6673 | tcp | vision_elmd | Chris Kramer | Chris Kramer | This entry is an alias to "vision-elmd". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| vision-elmd | 6673 | udp | vision_elmd IANA assigned this well-formed service name as a replacement for "vision_elmd". |
Chris Kramer | Chris Kramer | ||||||
| vision_elmd | 6673 | udp | vision_elmd | Chris Kramer | Chris Kramer | This entry is an alias to "vision-elmd". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| martalk | 7073 | tcp | MarTalk protocol | Mahr GmbH Göttingen | Kevin Bube | 2013-09-02 | |||||
| 7073 | udp | Reserved | |||||||||
| zsecure | 7173 | tcp | zSecure Server | Hans Schoone | Hans Schoone | 2010-10-01 | |||||
| 7173 | udp | Reserved | |||||||||
| oma-rlp | 7273 | tcp | OMA Roaming Location | Larry A. Young | Larry A. Young | 2005-08 | |||||
| oma-rlp | 7273 | udp | OMA Roaming Location | Larry A. Young | Larry A. Young | 2005-08 | |||||
| swx | 7300-7359 | The Swiss Exchange | Edgar Blum | Edgar Blum | |||||||
| 7360-7364 | Unassigned | 2006-02-06 | |||||||||
| lcm-server | 7365 | tcp | LifeKeeper Communications | James Bottomley | James Bottomley | 2006-02 | |||||
| lcm-server | 7365 | udp | LifeKeeper Communications | James Bottomley | James Bottomley | 2006-02 | |||||
| 7366-7390 | Unassigned | 2006-02-06 | |||||||||
| mindfilesys | 7391 | tcp | mind-file system server | Dave Porter | Dave Porter | ||||||
| mindfilesys | 7391 | udp | mind-file system server | Dave Porter | Dave Porter | ||||||
| mrssrendezvous | 7392 | tcp | mrss-rendezvous server | Dave Porter | Dave Porter | ||||||
| mrssrendezvous | 7392 | udp | mrss-rendezvous server | Dave Porter | Dave Porter | ||||||
| nfoldman | 7393 | tcp | nFoldMan Remote Publish | Richard McDonald | Richard McDonald | 2006-01 | |||||
| nfoldman | 7393 | udp | nFoldMan Remote Publish | Richard McDonald | Richard McDonald | 2006-01 | |||||
| fse | 7394 | tcp | File system export of backup images | Weibao Wu | Weibao Wu | 2006-04 | |||||
| fse | 7394 | udp | File system export of backup images | Weibao Wu | Weibao Wu | 2006-04 | |||||
| winqedit | 7395 | tcp | winqedit | David Greer | David Greer | ||||||
| winqedit | 7395 | udp | winqedit | David Greer | David Greer | ||||||
| 7396 | Unassigned | ||||||||||
| hexarc | 7397 | tcp | Hexarc Command Language | George Moromisato | George Moromisato | 2004-11 | |||||
| hexarc | 7397 | udp | Hexarc Command Language | George Moromisato | George Moromisato | 2004-11 | |||||
| 7398-7399 | Unassigned | ||||||||||
| rise | 7473 | tcp | Rise: The Vieneo Province | Jason Reskin | Jason Reskin | 2007-03 | |||||
| rise | 7473 | udp | Rise: The Vieneo Province | Jason Reskin | Jason Reskin | 2007-03 | |||||
| 7571-7573 | Unassigned | ||||||||||
| imqstomps | 7673 | tcp | iMQ STOMP Server over SSL | Amy Kang | Amy Kang | 2009-03-10 | |||||
| 7673 | udp | Reserved | |||||||||
| 7729-7733 | Unassigned | ||||||||||
| smip | 7734 | tcp | Smith Protocol over IP | Guidant Measurement | Jim Pettinato | 2007-04 | 2024-10-08 | ||||
| smip | 7734 | udp | Smith Protocol over IP | Guidant Measurement | Jim Pettinato | 2007-04 | 2024-10-08 | ||||
| 7735-7737 | Unassigned | ||||||||||
| aiagent | 7738 | tcp | HP Enterprise Discovery Agent | Matthew Darwin | Matthew Darwin | 2005-08 | |||||
| aiagent | 7738 | udp | HP Enterprise Discovery Agent | Matthew Darwin | Matthew Darwin | 2005-08 | |||||
| 7739-7740 | Unassigned | ||||||||||
| 7873-7877 | Unassigned | ||||||||||
| 8071-8073 | Unassigned | ||||||||||
| vp2p | 8473 | tcp | Virtual Point to Point | Jerome Grimbert | Jerome Grimbert | ||||||
| vp2p | 8473 | udp | Virtual Point to Point | Jerome Grimbert | Jerome Grimbert | ||||||
| 8712-8731 | Unassigned | ||||||||||
| 8732 | tcp | Reserved | |||||||||
| dtp-net | 8732 | udp | DASGIP Net Services | Dr. Matthias Arnold | Dr. Matthias Arnold | 2009-03-23 | |||||
| ibus | 8733 | tcp | iBus | Silvano Maffeis | Silvano Maffeis | ||||||
| ibus | 8733 | udp | iBus | Silvano Maffeis | Silvano Maffeis | ||||||
| 8734-8749 | Unassigned | ||||||||||
| dxspider | 8873 | tcp | dxspider linking protocol | Dirk Koopman | Dirk Koopman | 2005-08 | |||||
| dxspider | 8873 | udp | dxspider linking protocol | Dirk Koopman | Dirk Koopman | 2005-08 | |||||
| 9347-9373 | Unassigned | ||||||||||
| t5-straton | 11173 | tcp | Straton Runtime Programing | COPALP | Jerome FOLLUT | 2012-03-01 | |||||
| 11173 | udp | Reserved | |||||||||
| 12173-12299 | Unassigned | ||||||||||
| 15661-15739 | Unassigned | ||||||||||
| 17730-17753 | Unassigned | ||||||||||
| wnn6 | 22273 | tcp | wnn6 | Yasunari Gon Yamasita | Yasunari Gon Yamasita | ||||||
| wnn6 | 22273 | udp | wnn6 | Yasunari Gon Yamasita | Yasunari Gon Yamasita | ||||||
| 23273-23293 | Unassigned | ||||||||||
| 27018-27344 | Unassigned | Unauthorized Use Known on ports 27018 and 27019 | |||||||||
| imagepump | 27345 | tcp | ImagePump | Richard Minner | Richard Minner | ||||||
| imagepump | 27345 | udp | ImagePump | Richard Minner | Richard Minner | ||||||
| 27346-27441 | Unassigned | ||||||||||
| filenet-cm | 32773 | tcp | FileNET Component Manager | Chris Adkins | Chris Adkins | 2003-08 | |||||
| filenet-cm | 32773 | udp | FileNET Component Manager | Chris Adkins | Chris Adkins | 2003-08 | |||||
| 37473-37474 | Unassigned | ||||||||||
| 38473-38637 | Unassigned | ||||||||||
| brski-reg-cmp | tcp | Bootstrapping Remote Secure Key Infrastructure registrar with CMP capabilities according to the Lightweight CMP Profile (LCMPP) RFC 9483 | IESG | IETF Chair | 2024-09-23 | RFC 9733 | Defined TXT keys: None | ||||
| dccp-ping | dccp | ping/traceroute using DCCP | Samuel Jero | Samuel Jero | 2012-11-14 | 1885957735 | Defined TXT keys: None | ||||
| dots-call-home | tcp | DOTS Signal Channel Call Home Protocol. The service name is used to construct the SRV service names "_dots-call-home._udp" and "_dots-call-home._tcp" for discovering Call Home DOTS clients used to establish DOTS signal channel call home. | IESG | IETF Chair | 2020-11-19 | RFC 8973 | Defined TXT keys: None | ||||
| dots-call-home | udp | DOTS Signal Channel Call Home Protocol. The service name is used to construct the SRV service names "_dots-call-home._udp" and "_dots-call-home._tcp" for discovering Call Home DOTS clients used to establish DOTS signal channel call home. | IESG | IETF Chair | 2020-11-19 | RFC 8973 | Defined TXT keys: None | ||||
| dots-data | tcp | DOTS Data Channel Protocol. The service name is used to construct the SRV service name "_dots-data._tcp" for discovering DOTS servers used to establish DOTS data channel. | IESG | IETF Chair | 2020-11-19 | RFC 8973 | Defined TXT keys: None | ||||
| hpr-bldlnx | HP Remote Build System for Linux-based Systems | Jeffrey J. Walls | Jeffrey J. Walls | Defined TXT keys: rh73, rhel3, rhel4, deb31, suse102 | |||||||
| hpr-toollnx | HP Remote System that houses compilers and tools for Linux-based Systems | Jeffrey J. Walls | Jeffrey J. Walls | Defined TXT keys: rh73, rhel3, rhel4, deb31, suse102 | |||||||
| hpr-tstlnx | HP Remote Test System for Linux-based Systems | Jeffrey J. Walls | Jeffrey J. Walls | Defined TXT keys: rh73, rhel3, rhel4, deb31, suse102 |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Amy Kang | amy.kang&sun.com | 2009-03-10 | |
| Chris Adkins | cadkins&filenet.com | 2006-10 | |
| Chris Kramer | CKramer&gis.shl.com | ||
| COPALP | jf&copalp.com | 2012-03-01 | |
| Dave Porter | porter&mango.com | ||
| David Greer | david_greer&robelle.com | ||
| Dirk Koopman | djk&tobit.co.uk | 2005-08 | |
| Dr. Matthias Arnold | m.arnold&dasgip.de | 2009-03-23 | |
| Edgar Blum | edgar.blum&swx.ch | ||
| George Moromisato | gpm&neurohack.com | 2004-11 | |
| Guidant Measurement | james.pettinato&guidantmeasurement.com | 2024-10-08 | |
| Hans Schoone | Hans.Schoone&nl.ibm.com | 2010-10-01 | |
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| James Bottomley | James.Bottomley&steeleye.com | 2006-02 | |
| Jason Reskin | cases&unistellar.fogbugz.com | 2019-11-22 | |
| Jeffrey J. Walls | jeff.walls&hp.com | ||
| Jerome FOLLUT | COPALP | jf&copalp.com | 2012-03-01 |
| Jerome Grimbert | jerome.grimbert&atosorigin.com | ||
| Jim Pettinato | james.pettinato&guidantmeasurement.com | 2024-10-08 | |
| Kevin Bube | Mahr GmbH Göttingen | kevin.bube&mahr.de | 2013-09-02 |
| Larry A. Young | Larry.A.Young&mail.sprint.com | 2005-08 | |
| Mahr GmbH Göttingen | info&mahr.de | 2013-09-02 | |
| Matthew Darwin | matthew.darwin&hp.com | 2005-08 | |
| Richard McDonald | ve3nvm&spamcop.net | 2006-01 | |
| Richard Minner | http://xippix.com | ||
| Samuel Jero | sj323707&ohio.edu | 2012-11-14 | |
| Silvano Maffeis | maffeis&softwired.ch | ||
| Weibao Wu | weibao_wu&symantec.com | 2006-04 | |
| Yasunari Gon Yamasita | yamasita&omronsoft.co.jp |