Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| watchdoc-pod | 5743 | udp | Watchdoc NetPOD Protocol | Christophe Chevalier | Christophe Chevalier | 2005-08 | |||||
| watchdoc | 5744 | tcp | Watchdoc Server | Christophe Chevalier | Christophe Chevalier | 2004-11 | |||||
| watchdoc | 5744 | udp | Watchdoc Server | Christophe Chevalier | Christophe Chevalier | 2004-11 | |||||
| fcopy-server | 5745 | tcp | fcopy-server | Moshe Leibovitch | Moshe Leibovitch | ||||||
| fcopy-server | 5745 | udp | fcopy-server | Moshe Leibovitch | Moshe Leibovitch | ||||||
| fcopys-server | 5746 | tcp | fcopys-server | Moshe Leibovitch | Moshe Leibovitch | ||||||
| fcopys-server | 5746 | udp | fcopys-server | Moshe Leibovitch | Moshe Leibovitch | ||||||
| tunatic | 5747 | tcp | Wildbits Tunatic | Sylvain Demongeot | Sylvain Demongeot | 2005-08 | |||||
| tunatic | 5747 | udp | Wildbits Tunatic | Sylvain Demongeot | Sylvain Demongeot | 2005-08 | |||||
| tunalyzer | 5748 | tcp | Wildbits Tunalyzer | Sylvain Demongeot | Sylvain Demongeot | 2005-08 | |||||
| tunalyzer | 5748 | udp | Wildbits Tunalyzer | Sylvain Demongeot | Sylvain Demongeot | 2005-08 | |||||
| 5749 | Unassigned | ||||||||||
| max | 6074 | tcp | Microsoft Max | Jay Beavers | Jay Beavers | 2006-02 | |||||
| max | 6074 | udp | Microsoft Max | Jay Beavers | Jay Beavers | 2006-02 | |||||
| 6674-6677 | Unassigned | ||||||||||
| 7074-7079 | Unassigned | ||||||||||
| clutild | 7174 | tcp | Clutild | Cheryl Stoutenburg | Cheryl Stoutenburg | ||||||
| clutild | 7174 | udp | Clutild | Cheryl Stoutenburg | Cheryl Stoutenburg | ||||||
| oma-rlp-s | 7274 | tcp | OMA Roaming Location SEC | Larry A. Young | Larry A. Young | 2005-08 | |||||
| oma-rlp-s | 7274 | udp | OMA Roaming Location SEC | Larry A. Young | Larry A. Young | 2005-08 | |||||
| rtps-discovery | 7400 | tcp | RTPS Discovery | Gerardo Pardo-Castellote | Gerardo Pardo-Castellote | 2005-10 | |||||
| rtps-discovery | 7400 | udp | RTPS Discovery | Gerardo Pardo-Castellote | Gerardo Pardo-Castellote | 2005-10 | |||||
| rtps-dd-ut | 7401 | tcp | RTPS Data-Distribution User-Traffic | Gerardo Pardo-Castellote | Gerardo Pardo-Castellote | 2005-10 | |||||
| rtps-dd-ut | 7401 | udp | RTPS Data-Distribution User-Traffic | Gerardo Pardo-Castellote | Gerardo Pardo-Castellote | 2005-10 | |||||
| rtps-dd-mt | 7402 | tcp | RTPS Data-Distribution Meta-Traffic | Gerardo Pardo-Castellote | Gerardo Pardo-Castellote | 2005-10 | |||||
| rtps-dd-mt | 7402 | udp | RTPS Data-Distribution Meta-Traffic | Gerardo Pardo-Castellote | Gerardo Pardo-Castellote | 2005-10 | |||||
| 7403-7409 | Unassigned | ||||||||||
| ionixnetmon | 7410 | tcp | Ionix Network Monitor | Maxime Renaud | Maxime Renaud | 2006-04 | |||||
| ionixnetmon | 7410 | udp | Ionix Network Monitor | Maxime Renaud | Maxime Renaud | 2006-04 | |||||
| daqstream | 7411 | tcp | Streaming of measurement data | Hottinger Baldwin Messtechnik GmbH | Stephan Gatzka | 2013-03-15 | |||||
| daqstream | 7411 | udp | Streaming of measurement data | Hottinger Baldwin Messtechnik GmbH | Stephan Gatzka | 2013-03-15 | |||||
| 7412-7419 | Unassigned | ||||||||||
| 7420 | tcp | Reserved | |||||||||
| ipluminary | 7420 | udp | Multichannel real-time lighting control | Tristan Seifert | Tristan Seifert | 2018-01-18 | |||||
| mtportmon | 7421 | tcp | Matisse Port Monitor | Didier Cabannes | Didier Cabannes | 2004-11 | |||||
| mtportmon | 7421 | udp | Matisse Port Monitor | Didier Cabannes | Didier Cabannes | 2004-11 | |||||
| 7422-7425 | Unassigned | ||||||||||
| pmdmgr | 7426 | tcp | OpenView DM Postmaster Manager | Dave Lamb | Dave Lamb | ||||||
| pmdmgr | 7426 | udp | OpenView DM Postmaster Manager | Dave Lamb | Dave Lamb | ||||||
| oveadmgr | 7427 | tcp | OpenView DM Event Agent Manager | Dave Lamb | Dave Lamb | ||||||
| oveadmgr | 7427 | udp | OpenView DM Event Agent Manager | Dave Lamb | Dave Lamb | ||||||
| ovladmgr | 7428 | tcp | OpenView DM Log Agent Manager | Dave Lamb | Dave Lamb | ||||||
| ovladmgr | 7428 | udp | OpenView DM Log Agent Manager | Dave Lamb | Dave Lamb | ||||||
| opi-sock | 7429 | tcp | OpenView DM rqt communication | Dave Lamb | Dave Lamb | ||||||
| opi-sock | 7429 | udp | OpenView DM rqt communication | Dave Lamb | Dave Lamb | ||||||
| xmpv7 | 7430 | tcp | OpenView DM xmpv7 api pipe | Dave Lamb | Dave Lamb | ||||||
| xmpv7 | 7430 | udp | OpenView DM xmpv7 api pipe | Dave Lamb | Dave Lamb | ||||||
| pmd | 7431 | tcp | OpenView DM ovc/xmpv3 api pipe | Dave Lamb | Dave Lamb | ||||||
| pmd | 7431 | udp | OpenView DM ovc/xmpv3 api pipe | Dave Lamb | Dave Lamb | ||||||
| 7432-7436 | Unassigned | ||||||||||
| faximum | 7437 | tcp | Faximum | George Pajari | George Pajari | ||||||
| faximum | 7437 | udp | Faximum | George Pajari | George Pajari | ||||||
| 7438-7442 | Unassigned | ||||||||||
| oracleas-https | 7443 | tcp | Oracle Application Server HTTPS | David McMarlin | David McMarlin | 2006-08 | |||||
| oracleas-https | 7443 | udp | Oracle Application Server HTTPS | David McMarlin | David McMarlin | 2006-08 | |||||
| 7444-7470 | Unassigned | ||||||||||
| sttunnel | 7471 | tcp | Stateless Transport Tunneling Protocol | Bruce Davie | Bruce Davie | 2014-04-28 | |||||
| 7471 | udp | Reserved | |||||||||
| 7472 | Unassigned | ||||||||||
| rise | 7473 | tcp | Rise: The Vieneo Province | Jason Reskin | Jason Reskin | 2007-03 | |||||
| rise | 7473 | udp | Rise: The Vieneo Province | Jason Reskin | Jason Reskin | 2007-03 | |||||
| neo4j | 7474 | tcp | Neo4j Graph Database | Neo Technology, Inc | Julian Simpson | 2013-02-08 | |||||
| 7474 | udp | Reserved | |||||||||
| 7475-7477 | Unassigned | ||||||||||
| openit | 7478 | tcp | IT Asset Management | OpeniT Inc. | Monette Maano | 2016-11-17 | |||||
| 7478 | udp | Reserved | |||||||||
| 7479-7490 | Unassigned | ||||||||||
| telops-lmd | 7491 | tcp | telops-lmd | David Spencer | David Spencer | ||||||
| telops-lmd | 7491 | udp | telops-lmd | David Spencer | David Spencer | ||||||
| 7492-7499 | Unassigned | Known Unauthorized Use on port 7499 | |||||||||
| coherence | 7574 | tcp | Oracle Coherence Cluster Service | Oracle | Mark Falco | 2014-07-09 | |||||
| coherence-disc | 7574 | udp | Oracle Coherence Cluster discovery service | Oracle | Mark Falco | 2014-07-09 | |||||
| imqtunnels | 7674 | tcp | iMQ SSL tunnel | Shailesh S. Bavadekar | Shailesh S. Bavadekar | 2002-04 | |||||
| imqtunnels | 7674 | udp | iMQ SSL tunnel | Shailesh S. Bavadekar | Shailesh S. Bavadekar | 2002-04 | |||||
| 7739-7740 | Unassigned | ||||||||||
| scriptview | 7741 | tcp | ScriptView Network | Reinhard Wolf | Reinhard Wolf | 2010-08-19 | |||||
| scriptview | 7741 | udp | ScriptView Network | Reinhard Wolf | Reinhard Wolf | 2010-08-19 | |||||
| msss | 7742 | tcp | Mugginsoft Script Server Service | Jonathan Mitchell | Jonathan Mitchell | 2008-09-08 | |||||
| 7742 | udp | Reserved | |||||||||
| sstp-1 | 7743 | tcp | Sakura Script Transfer Protocol | Kouichi Takeda | Kouichi Takeda | ||||||
| sstp-1 | 7743 | udp | Sakura Script Transfer Protocol | Kouichi Takeda | Kouichi Takeda | ||||||
| raqmon-pdu | 7744 | tcp | RAQMON PDU | RFC 4712 | |||||||
| raqmon-pdu | 7744 | udp | RAQMON PDU | RFC 4712 | |||||||
| 7745-7746 | Unassigned | ||||||||||
| prgp | 7747 | tcp | Put/Run/Get Protocol | Jayasooriah | Jayasooriah | 2008-02-22 | |||||
| prgp | 7747 | udp | Put/Run/Get Protocol | Jayasooriah | Jayasooriah | 2008-02-22 | |||||
| 7748-7776 | Unassigned | ||||||||||
| gadugadu | 8074 | tcp | Gadu-Gadu | Marcin Gozdalik | Marcin Gozdalik | 2006-05 | |||||
| gadugadu | 8074 | udp | Gadu-Gadu | Marcin Gozdalik | Marcin Gozdalik | 2006-05 | |||||
| noteshare | 8474 | tcp | AquaMinds NoteShare | Michael McNabb | Michael McNabb | 2005-10 | |||||
| noteshare | 8474 | udp | AquaMinds NoteShare | Michael McNabb | Michael McNabb | 2005-10 | |||||
| lsp-self-ping | 8503 | udp | MPLS LSP Self-Ping | IESG | IETF Chair | 2015-06-11 | 2016-02-01 | RFC 7746 | |||
| 8669-8674 | Unassigned | ||||||||||
| 8734-8749 | Unassigned | ||||||||||
| 8874-8879 | Unassigned | ||||||||||
| fjdmimgr | 9374 | tcp | fjdmimgr | Yutaka Ono | Yutaka Ono | ||||||
| fjdmimgr | 9374 | udp | fjdmimgr | Yutaka Ono | Yutaka Ono | ||||||
| 9701-9746 | Unassigned | ||||||||||
| l5nas-parchan | 9747 | tcp | L5NAS Parallel Channel | Lawrence J. Dickson | Lawrence J. Dickson | 2002-03 | |||||
| l5nas-parchan | 9747 | udp | L5NAS Parallel Channel | Lawrence J. Dickson | Lawrence J. Dickson | 2002-03 | |||||
| 9748-9749 | Unassigned |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Bruce Davie | bdavie&vmware.com | 2014-04-28 | |
| Cheryl Stoutenburg | cstoutenburg&vnet.ibm.com | ||
| Christophe Chevalier | chevalier&archimed.fr | 2005-08 | |
| Dave Lamb | rdl&rdl.cnd.hp.com | ||
| David McMarlin | david.mcmarlin&oracle.com | 2006-08 | |
| David Spencer | dspencer&telops.com | ||
| Didier Cabannes | Didier&matisse.com | 2004-11 | |
| George Pajari | George.Pajari&faximum.com | ||
| Gerardo Pardo-Castellote | gerardo.pardo&rti.com | 2005-10 | |
| Hottinger Baldwin Messtechnik GmbH | stephan.gatzka&hbm.com | 2013-03-15 | |
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| Jason Reskin | cases&unistellar.fogbugz.com | 2019-11-22 | |
| Jay Beavers | Jay.Beaversµsoft.com | 2006-02 | |
| Jayasooriah | jayasooriah&cast.com.au | 2008-02-22 | |
| Jonathan Mitchell | jonathan&mugginsoft.com | 2008-09-08 | |
| Julian Simpson | Neo Technology, Inc | julian.simpson&neotechnology.com | 2016-09-29 |
| Kouichi Takeda | KHBO5271&nifty.com | ||
| Larry A. Young | Larry.A.Young&mail.sprint.com | 2005-08 | |
| Lawrence J. Dickson | Land-5 Corporation | ldickson&land-5.com | 2002-03 |
| Marcin Gozdalik | gozdal&gadu-gadu.pl | 2006-05 | |
| Mark Falco | Oracle | mark.falco&oracle.com | 2014-07-09 |
| Maxime Renaud | maxdrenaud&gmail.com | 2015-12-07 | |
| Michael McNabb | michael&aquaminds.com | 2005-10 | |
| Monette Maano | mmaano&openit.com | 2016-11-17 | |
| Moshe Leibovitch | moshe&softlinkusa.com | ||
| Neo Technology, Inc | admins&neotechnology.com | 2016-09-29 | |
| OpeniT Inc. | mmaano&openit.com | 2016-11-17 | |
| Oracle | mark.falco&oracle.com | 2014-07-09 | |
| Reinhard Wolf | Adsoft AG | adsoft&vtxmail.ch | 2010-08-19 |
| Shailesh S. Bavadekar | shailesh.bavadekar&sun.com | 2002-04 | |
| Stephan Gatzka | Hottinger Baldwin Messtechnik GmbH | stephan.gatzka&hbm.com | 2013-03-15 |
| Sylvain Demongeot | sylvain.demongeot&wildbits.com | 2005-08 | |
| Tristan Seifert | t&tseifert.me | 2018-01-18 | |
| Yutaka Ono | ono&saint.nm.fujitsu.co.jp |