Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| cpdlc | 5911 | sctp | Controller Pilot Data Link Communication | Justin Yu | Justin Yu | 2011-05-18 | |||||
| ais-met | 5912 | tcp | Aeronautical Information Service/Meteorological applications using ACARS | Eivan Cerasi | Greg Saccone | 2008-10-10 | 2022-08-08 | ||||
| ais-met | 5912 | udp | Aeronautical Information Service/Meteorological applications using ACARS | Eivan Cerasi | Greg Saccone | 2008-10-10 | 2022-08-08 | ||||
| fis | 5912 | sctp | Flight Information Services | Justin Yu | Justin Yu | 2011-05-25 | |||||
| aoc-acars | 5913 | tcp | Airline operational communications applications using ACARS | Eivan Cerasi | Greg Saccone | 2008-10-10 | 2022-08-08 | ||||
| aoc-acars | 5913 | udp | Airline operational communications applications using ACARS | Eivan Cerasi | Greg Saccone | 2008-10-10 | 2022-08-08 | ||||
| ads-c | 5913 | sctp | Automatic Dependent Surveillance | Justin Yu | Justin Yu | 2011-05-25 | |||||
| ipsdtls | 5914 | tcp | Security for Internet Protocol Suite | International Civil Aviation Organisation (ICAO) | Nathan Lackey | 2024-11-19 | Defined TXT keys: IPSDTLS | ||||
| ipsdtls | 5914 | udp | Security for Internet Protocol Suite | International Civil Aviation Organisation (ICAO) | Nathan Lackey | 2024-11-19 | Defined TXT keys: IPSDTLS | ||||
| ipsdtls | 5914 | sctp | Security for Internet Protocol Suite | International Civil Aviation Organisation (ICAO) | Nathan Lackey | 2024-11-19 | Defined TXT keys: IPSDTLS | ||||
| 5915-5962 | Unassigned | ||||||||||
| nuxsl | 5991 | tcp | NUXSL | Kai Kretschmann | Kai Kretschmann | 2002-03 | |||||
| nuxsl | 5991 | udp | NUXSL | Kai Kretschmann | Kai Kretschmann | 2002-03 | |||||
| 6391-6399 | Unassigned | ||||||||||
| netconf-tls | 6513 | tcp | NETCONF over TLS | IESG | IETF Chair | 2024-01-24 | RFC 7589; RFC 9918 | ||||
| 6691-6695 | Unassigned | ||||||||||
| hnm | 6791 | tcp | Halcyon Network Manager | Fortra | Henriët Wilkinson | 2005-05 | 2023-05-24 | ||||
| hnm | 6791 | udp | Halcyon Network Manager | Fortra | Henriët Wilkinson | 2005-05 | 2023-05-24 | ||||
| mindfilesys | 7391 | tcp | mind-file system server | Dave Porter | Dave Porter | ||||||
| mindfilesys | 7391 | udp | mind-file system server | Dave Porter | Dave Porter | ||||||
| telops-lmd | 7491 | tcp | telops-lmd | David Spencer | David Spencer | ||||||
| telops-lmd | 7491 | udp | telops-lmd | David Spencer | David Spencer | ||||||
| 7691-7696 | Unassigned | ||||||||||
| 7904-7912 | Unassigned | ||||||||||
| qo-secure | 7913 | tcp | QuickObjects secure port | Jonas Bovin | Jonas Bovin | ||||||
| qo-secure | 7913 | udp | QuickObjects secure port | Jonas Bovin | Jonas Bovin | ||||||
| 7914-7931 | Unassigned | ||||||||||
| jamlink | 8091 | tcp | Jam Link Framework | Evgeniy Filatov | Evgeniy Filatov | 2009-11-25 | |||||
| 8091 | udp | Reserved | |||||||||
| limnerpressure | 8191 | tcp | Limner Pressure | Aaron Kleinsteiber | Aaron Kleinsteiber | 2014-01-16 | |||||
| 8191 | udp | Reserved | |||||||||
| 8283-8291 | Unassigned | ||||||||||
| ddi-tcp-4 | 8891 | tcp | Desktop Data TCP 3: NESS application | Fred Yao | Fred Yao | ||||||
| ddi-udp-4 | 8891 | udp | Desktop Data UDP 3: NESS application | Fred Yao | Fred Yao | ||||||
| manyone-http | 8910 | tcp | manyone-http | Matt King | Matt King | 2002-04 | |||||
| manyone-http | 8910 | udp | manyone-http | Matt King | Matt King | 2002-04 | |||||
| manyone-xml | 8911 | tcp | manyone-xml | Matt King | Matt King | 2002-04 | |||||
| manyone-xml | 8911 | udp | manyone-xml | Matt King | Matt King | 2002-04 | |||||
| wcbackup | 8912 | tcp | Windows Client Backup | Jim Lyon | Jim Lyon | 2005-11 | |||||
| wcbackup | 8912 | udp | Windows Client Backup | Jim Lyon | Jim Lyon | 2005-11 | |||||
| dragonfly | 8913 | tcp | Dragonfly System Service | Paul Hodara | Paul Hodara | 2005-11 | |||||
| dragonfly | 8913 | udp | Dragonfly System Service | Paul Hodara | Paul Hodara | 2005-11 | |||||
| 8914-8936 | Unassigned | ||||||||||
| https-wmap | 8991 | tcp | webmail HTTPS service | Chris Newman | Chris Newman | 2007-12-03 | |||||
| https-wmap | 8991 | udp | webmail HTTPS service | Chris Newman | Chris Newman | 2007-12-03 | |||||
| xmltec-xmlmail | 9091 | tcp | xmltec-xmlmail | Mitch Kaufman | Mitch Kaufman | ||||||
| xmltec-xmlmail | 9091 | udp | xmltec-xmlmail | Mitch Kaufman | Mitch Kaufman | ||||||
| hp-pdl-datastr | 9100 | tcp | PDL Data Streaming Port | Shivaun Albright | Shivaun Albright | 2002-04 | |||||
| hp-pdl-datastr | 9100 | udp | PDL Data Streaming Port | Shivaun Albright | Shivaun Albright | 2002-04 | |||||
| pdl-datastream | 9100 | tcp | Printer PDL Data Stream | Stuart Cheshire | Stuart Cheshire | 2002-09 | The protocol name "pdl-datastream" is primarily registered for use in DNS SRV records (RFC 2782). DNS SRV records allow a protocol to run on any port number, but the default port for this protocol is 9100. | ||||
| pdl-datastream | 9100 | udp | Printer PDL Data Stream | Stuart Cheshire | Stuart Cheshire | 2002-09 | The protocol name "pdl-datastream" is primarily registered for use in DNS SRV records (RFC 2782). DNS SRV records allow a protocol to run on any port number, but the default port for this protocol is 9100. | ||||
| bacula-dir | 9101 | tcp | Bacula Director | Kern Sibbald | Kern Sibbald | 2002-01 | |||||
| bacula-dir | 9101 | udp | Bacula Director | Kern Sibbald | Kern Sibbald | 2002-01 | |||||
| bacula-fd | 9102 | tcp | Bacula File Daemon | Kern Sibbald | Kern Sibbald | 2002-01 | |||||
| bacula-fd | 9102 | udp | Bacula File Daemon | Kern Sibbald | Kern Sibbald | 2002-01 | |||||
| bacula-sd | 9103 | tcp | Bacula Storage Daemon | Kern Sibbald | Kern Sibbald | 2002-01 | |||||
| bacula-sd | 9103 | udp | Bacula Storage Daemon | Kern Sibbald | Kern Sibbald | 2002-01 | |||||
| peerwire | 9104 | tcp | PeerWire | Steven Gerhardt | Steven Gerhardt | 2004-02 | |||||
| peerwire | 9104 | udp | PeerWire | Steven Gerhardt | Steven Gerhardt | 2004-02 | |||||
| xadmin | 9105 | tcp | Xadmin Control Service | Ariën Huisken <xadmin&huisken-systems.nl> 15 June 2009 | |||||||
| xadmin | 9105 | udp | Xadmin Control Service | Ariën Huisken <xadmin&huisken-systems.nl> 15 June 2009 | |||||||
| astergate | 9106 | tcp | Astergate Control Service | Ariën Huisken | Ariën Huisken | 2010-01-04 | |||||
| astergate-disc | 9106 | udp | Astergate Discovery Service | Ariën Huisken | Ariën Huisken | 2010-01-04 | |||||
| astergatefax | 9107 | tcp | AstergateFax Control Service | Gijs Middelkamp | Gijs Middelkamp | 2010-02-03 | |||||
| 9107 | udp | Reserved | |||||||||
| 9108-9110 | Unassigned | ||||||||||
| hexxorecore | 9111 | tcp | Multiple Purpose, Distributed Message Bus | Hexxore | Patrick Roozeboom | 2018-07-31 | |||||
| hexxorecore | 9111 | udp | Multiple Purpose, Distributed Message Bus | Hexxore | Patrick Roozeboom | 2018-07-31 | |||||
| 9112-9118 | Unassigned | ||||||||||
| mxit | 9119 | tcp | MXit Instant Messaging | Marnus Freeman | Marnus Freeman | 2006-02 | |||||
| mxit | 9119 | udp | MXit Instant Messaging | Marnus Freeman | Marnus Freeman | 2006-02 | |||||
| 9120-9121 | Unassigned | ||||||||||
| grcmp | 9122 | tcp | Global Relay compliant mobile instant messaging protocol | Global Relay Communications Inc | Lu Vo | 2012-11-28 | 2025-06-12 | ||||
| 9122 | udp | Reserved | |||||||||
| grcp | 9123 | tcp | Global Relay compliant instant messaging protocol | Global Relay Communications Inc | Lu Vo | 2012-11-28 | 2025-06-12 | ||||
| 9123 | udp | Reserved | |||||||||
| 9124-9130 | Unassigned | ||||||||||
| dddp | 9131 | tcp | Dynamic Device Discovery | Shane Dick | Shane Dick | 2005-08 | |||||
| dddp | 9131 | udp | Dynamic Device Discovery | Shane Dick | Shane Dick | 2005-08 | |||||
| 9132-9159 | Unassigned | ||||||||||
| apani1 | 9160 | tcp | apani1 | Neal Taylor | Neal Taylor | ||||||
| apani1 | 9160 | udp | apani1 | Neal Taylor | Neal Taylor | ||||||
| apani2 | 9161 | tcp | apani2 | Neal Taylor | Neal Taylor | ||||||
| apani2 | 9161 | udp | apani2 | Neal Taylor | Neal Taylor | ||||||
| apani3 | 9162 | tcp | apani3 | Neal Taylor | Neal Taylor | ||||||
| apani3 | 9162 | udp | apani3 | Neal Taylor | Neal Taylor | ||||||
| apani4 | 9163 | tcp | apani4 | Neal Taylor | Neal Taylor | ||||||
| apani4 | 9163 | udp | apani4 | Neal Taylor | Neal Taylor | ||||||
| apani5 | 9164 | tcp | apani5 | Neal Taylor | Neal Taylor | ||||||
| apani5 | 9164 | udp | apani5 | Neal Taylor | Neal Taylor | ||||||
| 9165-9182 | Unassigned | ||||||||||
| sirius-agent | 9183 | tcp | Sirius Configuration Agent | Sirius Computer, Inc | Jason Van der Schyff | 2026-03-09 | |||||
| sirius-agent | 9183 | udp | Sirius Configuration Agent | Sirius Computer, Inc | Jason Van der Schyff | 2026-03-09 | |||||
| 9184-9190 | Unassigned | ||||||||||
| sun-as-jpda | 9191 | tcp | Sun AppSvr JPDA | Abhijit Kumar | Abhijit Kumar | 2005-11 | |||||
| sun-as-jpda | 9191 | udp | Sun AppSvr JPDA | Abhijit Kumar | Abhijit Kumar | 2005-11 | |||||
| 9192-9199 | Unassigned | ||||||||||
| 9288-9291 | Unassigned | ||||||||||
| 9391-9395 | Unassigned | ||||||||||
| 9560-9591 | Unassigned | ||||||||||
| 9910 | Unassigned |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Aaron Kleinsteiber | protocol&limnerapp.com | 2014-01-16 | |
| Abhijit Kumar | as-iana-ports&sun.com | 2005-11 | |
| Ariën Huisken | astergate&huisken-systems.nl | 2010-01-04 | |
| Chris Newman | chris.newman&oracle.com | 2017-01-26 | |
| Dave Porter | porter&mango.com | ||
| David Spencer | dspencer&telops.com | ||
| Eivan Cerasi | eivan.cerasi&eurocontrol.int | 2022-08-08 | |
| Evgeniy Filatov | evgeniyfilatov&yandex.ru | 2009-11-25 | |
| Fortra | info&fortra.com | 2023-05-24 | |
| Fred Yao | Fred_Yao&ddigate2.desktopdata.com | ||
| Gijs Middelkamp | astergate-fax&huisken-systems.nl | 2010-02-03 | |
| Global Relay Communications Inc | info&globalrelay.net | 2025-06-12 | |
| Greg Saccone | gregory.t.saccone&boeing.com | 2022-08-08 | |
| Henriët Wilkinson | henriet.wilkinson&fortra.com | 2023-05-24 | |
| Hexxore | info&hexxore.nl | 2018-07-31 | |
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| International Civil Aviation Organisation (ICAO) | gisinbox&icao.int | 2024-11-19 | |
| Jason Van der Schyff | jason&sirius.computer | 2026-03-09 | |
| Jim Lyon | JimLyonµsoft.com | 2005-11 | |
| Jonas Bovin | jonas.bovin&quickobjects.com | ||
| Justin Yu | yyu&mitre.org | 2011-05-25 | |
| Kai Kretschmann | K.Kretschmann&security-gui.de | 2002-03 | |
| Kern Sibbald | kern&sibbald.com | 2002-01 | |
| Lu Vo | Global Relay Communications Inc | lu.vo&globalrelay.net | 2025-06-12 |
| Marnus Freeman | marnus&swistgroup.com | 2006-02 | |
| Matt King | m&manyone.net | 2002-04 | |
| Mitch Kaufman | mk&weconnectyou.com | ||
| Nathan Lackey | nathan.lackey&boeing.com | 2024-11-19 | |
| Neal Taylor | ianareg&apani.com | ||
| Patrick Roozeboom | info&hexxore.nl | 2018-07-31 | |
| Paul Hodara | phodara&netwave.com | 2005-11 | |
| Shane Dick | shane.dick&amx.com | 2005-08 | |
| Shivaun Albright | shivaun_albright&hp.com | 2002-04 | |
| Sirius Computer, Inc | jason&sirius.computer | 2026-03-09 | |
| Steven Gerhardt | sgerhardt&ixiononline.com | 2004-02 | |
| Stuart Cheshire | pdl-datastream&apple.com | 2002-09 |