Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
wso2esb-console 9444 udp WSO2 ESB Administration Console HTTPS Ruwan Linton Ruwan Linton 2008-08-20
mindarray-ca 9445 tcp MindArray Systems Console Agent MINDARRAY SYSTEMS (P) LTD. ALPESH DHAMELIA 2011-10-25
9445 udp Reserved
9446-9449 Unassigned
sntlkeyssrvr 9450 tcp Sentinel Keys Server Martin Ziskind Martin Ziskind 2008-08-21
sntlkeyssrvr 9450 udp Sentinel Keys Server Martin Ziskind Martin Ziskind 2008-08-21
9451-9499 Unassigned
msgsys 9594 tcp Message System Alan Butt Alan Butt
msgsys 9594 udp Message System Alan Butt Alan Butt
client-wakeup 9694 tcp T-Mobile Client Wakeup Message Michael Schönborn Michael Schönborn 2009-09-11
client-wakeup 9694 udp T-Mobile Client Wakeup Message Michael Schönborn Michael Schönborn 2009-09-11
9926-9949 Unassigned
palace-3 9994 tcp OnLive-3 Douglas Crockford Douglas Crockford
palace-3 9994 udp OnLive-3 Douglas Crockford Douglas Crockford
11002-11094 Unassigned
ucontrol 13894 tcp Ultimate Control communication protocol NEGU Soft borja lopez urkidi 2012-09-10
ucontrol 13894 udp Ultimate Control communication protocol NEGU Soft borja lopez urkidi 2012-09-10
16901-16949 Unassigned
amt-redir-tcp 16994 tcp Intel(R) AMT Redirection/TCP Nimrod Diamant Nimrod Diamant 2005-02
amt-redir-tcp 16994 udp Intel(R) AMT Redirection/TCP Nimrod Diamant Nimrod Diamant 2005-02
ua-secureagent 19194 tcp UserAuthority SecureAgent Reuven Harrison Reuven Harrison 2003-01
ua-secureagent 19194 udp UserAuthority SecureAgent Reuven Harrison Reuven Harrison 2003-01
19399-19409 Unassigned
hp-sco 19410 tcp hp-sco Larry Schwartz Larry Schwartz
hp-sco 19410 udp hp-sco Larry Schwartz Larry Schwartz
hp-sca 19411 tcp hp-sca Larry Schwartz Larry Schwartz
hp-sca 19411 udp hp-sca Larry Schwartz Larry Schwartz
hp-sessmon 19412 tcp HP-SESSMON Gita Murthy Gita Murthy
hp-sessmon 19412 udp HP-SESSMON Gita Murthy Gita Murthy
19413-19538 Unassigned
5afe-dir 23294 tcp 5AFE SDN Directory Ayoda GmbH Laurenz Eschwey 2016-04-01
5afe-disc 23294 udp 5AFE SDN Directory discovery Ayoda GmbH Laurenz Eschwey 2016-04-01
udpstp 24601 udp UDP-based IP-Layer Capacity and Performance Measurement protocol IESG IETF Chair 2025-09-26 RFC 9946
25794-25899 Unassigned
30940-30998 Unassigned
31766-31947 Unassigned
iceedcp-tx 31948 tcp Embedded Device Configuration Protocol TX

IANA assigned this well-formed service name as a replacement for "iceedcp_tx".
Oliver Lewis Oliver Lewis 2006-08
iceedcp_tx 31948 tcp Embedded Device Configuration Protocol TX Oliver Lewis Oliver Lewis 2006-08 This entry is an alias to "iceedcp-tx". This entry is now historic, not usable for use with many common service discovery mechanisms.
iceedcp-tx 31948 udp Embedded Device Configuration Protocol TX

IANA assigned this well-formed service name as a replacement for "iceedcp_tx".
Oliver Lewis Oliver Lewis 2006-08
iceedcp_tx 31948 udp Embedded Device Configuration Protocol TX Oliver Lewis Oliver Lewis 2006-08 This entry is an alias to "iceedcp-tx". This entry is now historic, not usable for use with many common service discovery mechanisms.
iceedcp-rx 31949 tcp Embedded Device Configuration Protocol RX

IANA assigned this well-formed service name as a replacement for "iceedcp_rx".
Oliver Lewis Oliver Lewis 2006-08
iceedcp_rx 31949 tcp Embedded Device Configuration Protocol RX Oliver Lewis Oliver Lewis 2006-08 This entry is an alias to "iceedcp-rx". This entry is now historic, not usable for use with many common service discovery mechanisms.
iceedcp-rx 31949 udp Embedded Device Configuration Protocol RX

IANA assigned this well-formed service name as a replacement for "iceedcp_rx".
Oliver Lewis Oliver Lewis 2006-08
iceedcp_rx 31949 udp Embedded Device Configuration Protocol RX Oliver Lewis Oliver Lewis 2006-08 This entry is an alias to "iceedcp-rx". This entry is now historic, not usable for use with many common service discovery mechanisms.
crestron-cip 41794 tcp Crestron Control Port Crestron Electronics, Inc. John Pavlik 2003-01 2019-10-17
crestron-cip 41794 udp Crestron Control Port Crestron Electronics, Inc. John Pavlik 2003-01 2019-10-17
brski-reg-cmp tcp Bootstrapping Remote Secure Key Infrastructure registrar with CMP capabilities according to the Lightweight CMP Profile (LCMPP) RFC 9483 IESG IETF Chair 2024-09-23 RFC 9733 Defined TXT keys: None

Contact Information

Name Organization Contact URI Last Updated
Alan Butt alan.butt&landesk.com 2006-03
ALPESH DHAMELIA MINDARRAY SYSTEMS (P) LTD. alpesh&mindarraysystems.com 2011-10-25
Ayoda GmbH info&ayoda.net 2016-04-01
borja lopez urkidi NEGU Soft lopezurkidi&gmail.com 2012-09-10
Crestron Electronics, Inc. jpavlik&crestron.com 2019-10-17
Douglas Crockford douglas&crockford.com
Gita Murthy gita&cup.hp.com
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
John Pavlik jpavlik&crestron.com 2019-10-17
Larry Schwartz lrs&cup.hp.com
Laurenz Eschwey laurenz.eschwey&ayoda.net 2016-04-01
Martin Ziskind ziskind&us.ibm.com 2008-08-21
Michael Schönborn T-Mobile International AG michael.schoenborn&t-mobile.net 2009-09-11
MINDARRAY SYSTEMS (P) LTD. info&mindarraysystems.com 2011-10-25
NEGU Soft info&negusoft.com 2012-09-10
Nimrod Diamant nimrod.diamant&intel.com 2005-02
Oliver Lewis o.lewis&icerobotics.co.uk 2006-08
Reuven Harrison rharrison&checkpoint.com 2003-01
Ruwan Linton ruwan&wso2.com 2008-08-20