Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-22
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| 6068 | udp | Reserved | |||||||||
| trip | 6069 | tcp | TRIP | Hussein F. Salama | Hussein F. Salama | ||||||
| trip | 6069 | udp | TRIP | Hussein F. Salama | Hussein F. Salama | ||||||
| messageasap | 6070 | tcp | Messageasap | Murray Freeman | Murray Freeman | ||||||
| messageasap | 6070 | udp | Messageasap | Murray Freeman | Murray Freeman | ||||||
| ssdtp | 6071 | tcp | SSDTP | Michael Shearson | Michael Shearson | ||||||
| ssdtp | 6071 | udp | SSDTP | Michael Shearson | Michael Shearson | ||||||
| diagnose-proc | 6072 | tcp | DIAGNOSE-PROC | Allan Miller | Allan Miller | ||||||
| diagnose-proc | 6072 | udp | DIAGNOSE-PROC | Allan Miller | Allan Miller | ||||||
| directplay8 | 6073 | tcp | DirectPlay8 | John Kane | John Kane | ||||||
| directplay8 | 6073 | udp | DirectPlay8 | John Kane | John Kane | ||||||
| max | 6074 | tcp | Microsoft Max | Jay Beavers | Jay Beavers | 2006-02 | |||||
| max | 6074 | udp | Microsoft Max | Jay Beavers | Jay Beavers | 2006-02 | |||||
| dpm-acm | 6075 | tcp | Microsoft DPM Access Control Manager | Prabu Ambravaneswaran | Prabu Ambravaneswaran | 2009-10-29 | |||||
| 6075 | udp | Reserved | |||||||||
| msft-dpm-cert | 6076 | tcp | Microsoft DPM WCF Certificates | Microsoft Corporation | Prateek Sharma | 2011-08-04 | |||||
| 6076 | udp | Reserved | |||||||||
| iconstructsrv | 6077 | tcp | iConstruct Server | iConstruct (Aus) Pty Ltd | Afshin Jafari | 2012-12-21 | |||||
| 6077 | udp | Reserved | |||||||||
| 6078-6079 | Unassigned | ||||||||||
| gue | 6080 | udp | Generic UDP Encapsulation | Tom Herbert | Tom Herbert | 2015-03-05 | draft-herbert-gue-02 | ||||
| 6080 | tcp | Reserved | |||||||||
| geneve | 6081 | udp | Generic Network Virtualization Encapsulation (Geneve) | IESG | IETF Chair | 2014-03-27 | 2020-05-04 | RFC 8926 | |||
| 6081 | tcp | Reserved | |||||||||
| 6082 | tcp | Reserved | |||||||||
| p25cai | 6082 | udp | APCO Project 25 Common Air Interface - UDP encapsulation | Steve Glass | Steve Glass | 2011-05-13 | |||||
| 6083 | tcp | Reserved | |||||||||
| miami-bcast | 6083 | udp | telecomsoftware miami broadcast | Peter Steiner | Peter Steiner | 2011-02-22 | |||||
| reload-config | 6084 | tcp | Peer to Peer Infrastructure Configuration | IESG | IETF Chair | 2009-01-29 | 2013-03-26 | RFC 6940 | |||
| 6084 | udp | Reserved | |||||||||
| konspire2b | 6085 | tcp | konspire2b p2p network | Jason Rohrer | Jason Rohrer | 2002-10 | |||||
| konspire2b | 6085 | udp | konspire2b p2p network | Jason Rohrer | Jason Rohrer | 2002-10 | |||||
| pdtp | 6086 | tcp | PDTP P2P | Tony Arcieri | Tony Arcieri | 2006-03 | |||||
| pdtp | 6086 | udp | PDTP P2P | Tony Arcieri | Tony Arcieri | 2006-03 | |||||
| ldss | 6087 | tcp | Local Download Sharing Service | Clifford Heath | Clifford Heath | 2006-05 | |||||
| ldss | 6087 | udp | Local Download Sharing Service | Clifford Heath | Clifford Heath | 2006-05 | |||||
| doglms | 6088 | tcp | SuperDog License Manager | SafeNet | Rob Tao | 2012-07-26 | |||||
| doglms-notify | 6088 | udp | SuperDog License Manager Notifier | SafeNet | Rob Tao | 2012-07-26 | |||||
| 6089-6098 | Unassigned | ||||||||||
| raxa-mgmt | 6099 | tcp | RAXA Management | Sukanta Ganguly | Sukanta Ganguly | ||||||
| 6099 | udp | Reserved | |||||||||
| synchronet-db | 6100 | tcp | SynchroNet-db | Arne Haugland | Arne Haugland | Known Unauthorized Use on port 6100 | |||||
| synchronet-db | 6100 | udp | SynchroNet-db | Arne Haugland | Arne Haugland | Known Unauthorized Use on port 6100 | |||||
| synchronet-rtc | 6101 | tcp | SynchroNet-rtc | Arne Haugland | Arne Haugland | ||||||
| synchronet-rtc | 6101 | udp | SynchroNet-rtc | Arne Haugland | Arne Haugland | ||||||
| synchronet-upd | 6102 | tcp | SynchroNet-upd | Arne Haugland | Arne Haugland | ||||||
| synchronet-upd | 6102 | udp | SynchroNet-upd | Arne Haugland | Arne Haugland | ||||||
| rets | 6103 | tcp | RETS | Jeremy Crawford | Jeremy Crawford | ||||||
| rets | 6103 | udp | RETS | Jeremy Crawford | Jeremy Crawford | ||||||
| dbdb | 6104 | tcp | DBDB | Aaron Brick | Aaron Brick | ||||||
| dbdb | 6104 | udp | DBDB | Aaron Brick | Aaron Brick | ||||||
| primaserver | 6105 | tcp | Prima Server | Prima Designs Systems Ltd. | Prima Designs Systems Ltd. | ||||||
| primaserver | 6105 | udp | Prima Server | Prima Designs Systems Ltd. | Prima Designs Systems Ltd. | ||||||
| mpsserver | 6106 | tcp | MPS Server | Prima Designs Systems Ltd. | Prima Designs Systems Ltd. | ||||||
| mpsserver | 6106 | udp | MPS Server | Prima Designs Systems Ltd. | Prima Designs Systems Ltd. | ||||||
| etc-control | 6107 | tcp | ETC Control | Electronic Theatre Controls, Inc. | ETC IANA Registration | 2021-09-24 | |||||
| etc-control | 6107 | udp | ETC Control | Electronic Theatre Controls, Inc. | ETC IANA Registration | 2021-09-24 | |||||
| sercomm-scadmin | 6108 | tcp | Sercomm-SCAdmin | Melinda Tsao | Melinda Tsao | ||||||
| sercomm-scadmin | 6108 | udp | Sercomm-SCAdmin | Melinda Tsao | Melinda Tsao | ||||||
| globecast-id | 6109 | tcp | GLOBECAST-ID | Piers Scannell | Piers Scannell | ||||||
| globecast-id | 6109 | udp | GLOBECAST-ID | Piers Scannell | Piers Scannell | ||||||
| softcm | 6110 | tcp | HP SoftBench CM | Scott A. Kramer | Scott A. Kramer | ||||||
| softcm | 6110 | udp | HP SoftBench CM | Scott A. Kramer | Scott A. Kramer | ||||||
| 6119-6120 | Unassigned | ||||||||||
| damewaremobgtwy | 6130 | tcp | The DameWare Mobile Gateway Service | SolarWinds | David Gayler | 2013-05-29 | |||||
| 6130 | udp | Reserved | |||||||||
| pulsonixnls | 6140 | tcp | Pulsonix Network License Service | David Manns | David Manns | 2008-02-28 | |||||
| pulsonixnls | 6140 | udp | Pulsonix Network License Service | David Manns | David Manns | 2008-02-28 | |||||
| 6150-6158 | Unassigned | ||||||||||
| ecmp | 6160 | tcp | Emerson Extensible Control and Management Protocol | Bryce Beeston | Bryce Beeston | 2011-06-23 | |||||
| ecmp-data | 6160 | udp | Emerson Extensible Control and Management Protocol Data | Bryce Beeston | Bryce Beeston | 2011-06-23 | |||||
| lm-x | 6200 | tcp | LM-X License Manager by X-Formation | Henrik Goldman | Henrik Goldman | 2006-10 | Known Unauthorized Use on port 6200 | ||||
| lm-x | 6200 | udp | LM-X License Manager by X-Formation | Henrik Goldman | Henrik Goldman | 2006-10 | Known Unauthorized Use on port 6200 | ||||
| 6201 | tcp | Reserved | |||||||||
| thermo-calc | 6201 | udp | Management of service nodes in a processing grid for thermodynamic calculations | Thermo-Calc Software AB | Thomas Revesz | 2012-06-28 | |||||
| 6202-6208 | Unassigned | ||||||||||
| qmtps | 6209 | tcp | QMTP over TLS | FEHCom | Erwin Hoffmann | 2015-01-09 | |||||
| qmtps | 6209 | udp | QMTP over TLS | FEHCom | Erwin Hoffmann | 2015-01-09 | |||||
| 6210-6221 | Unassigned | ||||||||||
| 6223-6240 | Unassigned | ||||||||||
| 6245-6250 | Unassigned | ||||||||||
| 6270-6299 | Unassigned | ||||||||||
| bmc-grx | 6300 | tcp | BMC GRX | Portnoy Boxman | Portnoy Boxman | ||||||
| bmc-grx | 6300 | udp | BMC GRX | Portnoy Boxman | Portnoy Boxman | ||||||
| bmc-ctd-ldap | 6301 | tcp | BMC CONTROL-D LDAP SERVER IANA assigned this well-formed service name as a replacement for "bmc_ctd_ldap". |
Portnoy Boxman | Portnoy Boxman | 2006-09 | |||||
| bmc_ctd_ldap | 6301 | tcp | BMC CONTROL-D LDAP SERVER | Portnoy Boxman | Portnoy Boxman | 2006-09 | This entry is an alias to "bmc-ctd-ldap". This entry is now historic, not usable for use with many common service discovery mechanisms. | ||||
| bmc-ctd-ldap | 6301 | udp | BMC CONTROL-D LDAP SERVER IANA assigned this well-formed service name as a replacement for "bmc_ctd_ldap". |
Portnoy Boxman | Portnoy Boxman | 2006-09 | |||||
| bmc_ctd_ldap | 6301 | udp | BMC CONTROL-D LDAP SERVER | Portnoy Boxman | Portnoy Boxman | 2006-09 | This entry is an alias to "bmc-ctd-ldap". This entry is now historic, not usable for use with many common service discovery mechanisms. | ||||
| 6302-6305 | Unassigned | ||||||||||
| ufmp | 6306 | tcp | Unified Fabric Management Protocol | Mellanox Technologies, Inc. | Shachar Dor | 2009-12-17 | 2019-07-02 | ||||
| ufmp | 6306 | udp | Unified Fabric Management Protocol | Mellanox Technologies, Inc. | Shachar Dor | 2009-12-17 | 2019-07-02 | ||||
| 6307-6314 | Unassigned | ||||||||||
| repsvc | 6320 | tcp | Double-Take Replication Service | Carbonite, Inc. | James Wilkinson | 2006-04 | 2019-08-23 | ||||
| repsvc | 6320 | udp | Double-Take Replication Service | Carbonite, Inc. | James Wilkinson | 2006-04 | 2019-08-23 | ||||
| adap | 6350 | tcp | App Discovery and Access Protocol | Thomas Kjoernes | Thomas Kjoernes | 2010-06-22 | |||||
| adap | 6350 | udp | App Discovery and Access Protocol | Thomas Kjoernes | Thomas Kjoernes | 2010-06-22 | |||||
| metaedit-mu | 6360 | tcp | MetaEdit+ Multi-User | Steven Kelly | Steven Kelly | 2007-11-12 | |||||
| metaedit-mu | 6360 | udp | MetaEdit+ Multi-User | Steven Kelly | Steven Kelly | 2007-11-12 | |||||
| metaedit-se | 6370 | tcp | MetaEdit+ Server Administration | Steven Kelly | Steven Kelly | 2007-11-12 | |||||
| metaedit-se | 6370 | udp | MetaEdit+ Server Administration | Steven Kelly | Steven Kelly | 2007-11-12 | |||||
| 6380-6381 | Unassigned |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Steve Glass | APCO Project 25 | admin&sedition.org.au | 2011-05-13 |
| Aaron Brick | aa&lithic.org | ||
| Afshin Jafari | iConstruct (Aus) Pty Ltd | jafari&pdcwa.com.au | 2012-12-21 |
| Allan Miller | amiller&handsfreenetworks.com | ||
| Arne Haugland | Arne.Haugland¶soldev.com | ||
| Bryce Beeston | bryce.beeston&emerson.com | 2011-06-23 | |
| Carbonite, Inc. | jwilkinson&carbonite.com | 2019-08-23 | |
| Clifford Heath | cjh&managesoft.com | 2006-05 | |
| David Gayler | SolarWinds | david.gayler&solarwinds.com | 2013-05-29 |
| David Manns | davidm&pulsonix.com | 2008-02-28 | |
| Electronic Theatre Controls, Inc. | ianaregistration&etcconnect.com | 2021-09-24 | |
| Erwin Hoffmann | FEHCom | feh&fehcom.de | 2015-01-09 |
| ETC IANA Registration | Electronic Theatre Controls, Inc. | ianaregistration&etcconnect.com | 2021-09-24 |
| FEHCom | feh&fehcom.de | 2015-01-09 | |
| Henrik Goldman | hg&x-formation.com | 2006-10 | |
| Hussein F. Salama | hsalama&cisco.com | ||
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| iConstruct (Aus) Pty Ltd | jafari&pdcwa.com.au | 2012-12-21 | |
| James Wilkinson | jwilkinson&carbonite.com | 2019-08-23 | |
| Jason Rohrer | rohrer&cse.ucsc.edu | 2002-10 | |
| Jay Beavers | Jay.Beaversµsoft.com | 2006-02 | |
| Jeremy Crawford | jeremy&reso.org | 2015-09-07 | |
| John Kane | johnkanµsoft.com | ||
| Melinda Tsao | melinda_tsao&mail.sercomm.com.tw | ||
| Mellanox Technologies, Inc. | info&mellanox.com | 2019-07-02 | |
| Michael Shearson | mikes&softsys-inc.com | ||
| Microsoft Corporation | pratsharµsoft.com | 2011-08-04 | |
| Murray Freeman | murray&officedomain.com | ||
| Peter Steiner | steiner&telecomsoftware.com | 2011-02-22 | |
| Piers Scannell | piers&globecastne.com | ||
| Portnoy Boxman | portnoy_boxman&bmc.com | 2005-01 | |
| Portnoy Boxman | Portnoy_Boxman&bmc.com | 2006-09 | |
| Prabu Ambravaneswaran | prambravµsoft.com | 2009-10-29 | |
| Prateek Sharma | pratsharµsoft.com | 2011-08-04 | |
| Prima Designs Systems Ltd. | info&prima.com.hk | ||
| Rob Tao | SafeNet | rtao&safenet-inc.com | 2012-07-26 |
| SafeNet | rtao&safenet-inc.com | 2012-07-26 | |
| Scott A. Kramer | sk&tleilaxu.sde.hp.com | ||
| Shachar Dor | Mellanox Technologies, Inc. | shachard&mellanox.com | 2019-07-02 |
| SolarWinds | david.gayler&solarwinds.com | 2013-05-29 | |
| Steven Kelly | stevek&metacase.com | 2007-11-12 | |
| Sukanta Ganguly | sganguly&kineticnetworks.com | ||
| Thermo-Calc Software AB | thomasr&thermocalc.se | 2012-06-28 | |
| Thomas Kjoernes | thomas&ipv.no | 2010-06-22 | |
| Thomas Revesz | Thermo-Calc Software AB | thomasr&thermocalc.se | 2012-06-28 |
| Tom Herbert | tom&herbertland.com | 2017-05-19 | |
| Tony Arcieri | bascule&gmail.com | 2006-03 |