Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-22

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
6380-6381 Unassigned
clariion-evr01 6389 tcp clariion-evr01 Dave DesRoches Dave DesRoches
clariion-evr01 6389 udp clariion-evr01 Dave DesRoches Dave DesRoches
metaedit-ws 6390 tcp MetaEdit+ WebService API Steven Kelly Steven Kelly 2007-11-12
metaedit-ws 6390 udp MetaEdit+ WebService API Steven Kelly Steven Kelly 2007-11-12
boe-cms 6400 Business Objects CMS contact port SAP Giriraj Harapanahalli 2008-05-05 2026-05-27
boe-was 6401 boe-was SAP Giriraj Harapanahalli 2008-05-05 2026-05-27
boe-eventsrv 6402 boe-eventsrv SAP Giriraj Harapanahalli 2008-05-05 2026-05-27
boe-cachesvr 6403 boe-cachesvr SAP Giriraj Harapanahalli 2008-05-05 2026-05-27
boe-filesvr 6404 Business Objects Enterprise internal server SAP Giriraj Harapanahalli 2008-05-05 2026-05-27
boe-pagesvr 6405 Business Objects Enterprise internal server SAP Giriraj Harapanahalli 2008-05-05 2026-05-27
boe-processsvr 6406 Business Objects Enterprise internal server SAP Giriraj Harapanahalli 2008-05-05 2026-05-27
boe-resssvr1 6407 Business Objects Enterprise internal server SAP Giriraj Harapanahalli 2008-05-05 2026-05-27
boe-resssvr2 6408 Business Objects Enterprise internal server SAP Giriraj Harapanahalli 2008-05-05 2026-05-27
boe-resssvr3 6409 Business Objects Enterprise internal server SAP Giriraj Harapanahalli 2008-05-05 2026-05-27
boe-resssvr4 6410 Business Objects Enterprise internal server SAP Giriraj Harapanahalli 2008-05-05 2026-05-27
nim-vdrshell 6420 tcp NIM_VDRShell Rik Ditter Rik Ditter 2006-02
nim-vdrshell 6420 udp NIM_VDRShell Rik Ditter Rik Ditter 2006-02
heliosd 6440 tcp heliosd daemon Cartesian Theatre Kip Warner 2020-02-28
6440 udp Reserved
ieee11073-20701 6464 tcp Port assignment for medical device communication in accordance to IEEE 11073-20701 David Gregorczyk David Gregorczyk 2017-03-02
ieee11073-20701 6464 udp Port assignment for medical device communication in accordance to IEEE 11073-20701 David Gregorczyk David Gregorczyk 2017-03-02
6465-6470 Unassigned
sun-sr-http 6480 tcp Service Registry Default HTTP Domain Paul Sterk Paul Sterk 2006-03
sun-sr-http 6480 udp Service Registry Default HTTP Domain Paul Sterk Paul Sterk 2006-03
6490-6499 Unassigned
boks 6500 tcp BoKS Master Magnus Nystrom Magnus Nystrom
boks 6500 udp BoKS Master Magnus Nystrom Magnus Nystrom
boks-servc 6501 tcp BoKS Servc

IANA assigned this well-formed service name as a replacement for "boks_servc".
Magnus Nystrom Magnus Nystrom Known Unauthorized Use on port 6501
boks_servc 6501 tcp BoKS Servc Magnus Nystrom Magnus Nystrom Known Unauthorized Use on port 6501 This entry is an alias to "boks-servc". This entry is now historic, not usable for use with many common service discovery mechanisms.
boks-servc 6501 udp BoKS Servc

IANA assigned this well-formed service name as a replacement for "boks_servc".
Magnus Nystrom Magnus Nystrom
boks_servc 6501 udp BoKS Servc Magnus Nystrom Magnus Nystrom This entry is an alias to "boks-servc". This entry is now historic, not usable for use with many common service discovery mechanisms.
boks-servm 6502 tcp BoKS Servm

IANA assigned this well-formed service name as a replacement for "boks_servm".
Magnus Nystrom Magnus Nystrom
boks_servm 6502 tcp BoKS Servm Magnus Nystrom Magnus Nystrom This entry is an alias to "boks-servm". This entry is now historic, not usable for use with many common service discovery mechanisms.
boks-servm 6502 udp BoKS Servm

IANA assigned this well-formed service name as a replacement for "boks_servm".
Magnus Nystrom Magnus Nystrom
boks_servm 6502 udp BoKS Servm Magnus Nystrom Magnus Nystrom This entry is an alias to "boks-servm". This entry is now historic, not usable for use with many common service discovery mechanisms.
boks-clntd 6503 tcp BoKS Clntd

IANA assigned this well-formed service name as a replacement for "boks_clntd".
Magnus Nystrom Magnus Nystrom
boks_clntd 6503 tcp BoKS Clntd Magnus Nystrom Magnus Nystrom This entry is an alias to "boks-clntd". This entry is now historic, not usable for use with many common service discovery mechanisms.
boks-clntd 6503 udp BoKS Clntd

IANA assigned this well-formed service name as a replacement for "boks_clntd".
Magnus Nystrom Magnus Nystrom
boks_clntd 6503 udp BoKS Clntd Magnus Nystrom Magnus Nystrom This entry is an alias to "boks-clntd". This entry is now historic, not usable for use with many common service discovery mechanisms.
6504 Unassigned
badm-priv 6505 tcp BoKS Admin Private Port

IANA assigned this well-formed service name as a replacement for "badm_priv".
Magnus Nystrom Magnus Nystrom
badm_priv 6505 tcp BoKS Admin Private Port Magnus Nystrom Magnus Nystrom This entry is an alias to "badm-priv". This entry is now historic, not usable for use with many common service discovery mechanisms.
badm-priv 6505 udp BoKS Admin Private Port

IANA assigned this well-formed service name as a replacement for "badm_priv".
Magnus Nystrom Magnus Nystrom
badm_priv 6505 udp BoKS Admin Private Port Magnus Nystrom Magnus Nystrom This entry is an alias to "badm-priv". This entry is now historic, not usable for use with many common service discovery mechanisms.
badm-pub 6506 tcp BoKS Admin Public Port

IANA assigned this well-formed service name as a replacement for "badm_pub".
Magnus Nystrom Magnus Nystrom
badm_pub 6506 tcp BoKS Admin Public Port Magnus Nystrom Magnus Nystrom This entry is an alias to "badm-pub". This entry is now historic, not usable for use with many common service discovery mechanisms.
badm-pub 6506 udp BoKS Admin Public Port

IANA assigned this well-formed service name as a replacement for "badm_pub".
Magnus Nystrom Magnus Nystrom
badm_pub 6506 udp BoKS Admin Public Port Magnus Nystrom Magnus Nystrom This entry is an alias to "badm-pub". This entry is now historic, not usable for use with many common service discovery mechanisms.
bdir-priv 6507 tcp BoKS Dir Server, Private Port

IANA assigned this well-formed service name as a replacement for "bdir_priv".
Magnus Nystrom Magnus Nystrom
bdir_priv 6507 tcp BoKS Dir Server, Private Port Magnus Nystrom Magnus Nystrom This entry is an alias to "bdir-priv". This entry is now historic, not usable for use with many common service discovery mechanisms.
bdir-priv 6507 udp BoKS Dir Server, Private Port

IANA assigned this well-formed service name as a replacement for "bdir_priv".
Magnus Nystrom Magnus Nystrom
bdir_priv 6507 udp BoKS Dir Server, Private Port Magnus Nystrom Magnus Nystrom This entry is an alias to "bdir-priv". This entry is now historic, not usable for use with many common service discovery mechanisms.
bdir-pub 6508 tcp BoKS Dir Server, Public Port

IANA assigned this well-formed service name as a replacement for "bdir_pub".
Magnus Nystrom Magnus Nystrom
bdir_pub 6508 tcp BoKS Dir Server, Public Port Magnus Nystrom Magnus Nystrom This entry is an alias to "bdir-pub". This entry is now historic, not usable for use with many common service discovery mechanisms.
bdir-pub 6508 udp BoKS Dir Server, Public Port

IANA assigned this well-formed service name as a replacement for "bdir_pub".
Magnus Nystrom Magnus Nystrom
bdir_pub 6508 udp BoKS Dir Server, Public Port Magnus Nystrom Magnus Nystrom This entry is an alias to "bdir-pub". This entry is now historic, not usable for use with many common service discovery mechanisms.
mgcs-mfp-port 6509 tcp MGCS-MFP Port Minoru Ozaki Minoru Ozaki
mgcs-mfp-port 6509 udp MGCS-MFP Port Minoru Ozaki Minoru Ozaki
mcer-port 6510 tcp MCER Port Portnoy Boxman Portnoy Boxman
mcer-port 6510 udp MCER Port Portnoy Boxman Portnoy Boxman
syslog-tls 6514 udp syslog over DTLS RFC 6012
syslog-tls 6514 dccp syslog over DTLS RFC 6012
fg-sysupdate 6550 tcp fg-sysupdate Mark Beyer Mark Beyer
fg-sysupdate 6550 udp fg-sysupdate Mark Beyer Mark Beyer
6567 Reserved 2007-01 2011-08-26 This entry has been removed on 2011-08-26.
parsec-master 6580 tcp Parsec Masterserver Andreas Varga Andreas Varga
parsec-master 6580 udp Parsec Masterserver Andreas Varga Andreas Varga
mshvlm 6600 tcp Microsoft Hyper-V Live Migration Rajesh Davé Rajesh Davé 2009-02-03
6600 udp Reserved
mstmg-sstp 6601 tcp Microsoft Threat Management Gateway SSTP Ori Yosefi Ori Yosefi 2009-05-04
6601 udp Reserved
wsscomfrmwk 6602 tcp Windows WSS Communication Framework Rong Yu Rong Yu 2010-08-10
6602 udp Reserved
6603-6609 Unassigned
bencher 6610 tcp Bencher API Bencher Everett Pompeii 2026-06-17
bencher 6610 udp Bencher API Bencher Everett Pompeii 2026-06-17
odette-ftps 6619 tcp ODETTE-FTP over TLS/SSL Ieuan Friend Ieuan Friend 2006-03 RFC 5024
odette-ftps 6619 udp ODETTE-FTP over TLS/SSL Ieuan Friend Ieuan Friend 2006-03 RFC 5024
kftp-data 6620 tcp Kerberos V5 FTP Data Robert J. Scott Robert J. Scott 2005-08
kftp-data 6620 udp Kerberos V5 FTP Data Robert J. Scott Robert J. Scott 2005-08
6630 Unassigned
mpls-udp 6635 udp Encapsulate MPLS packets in UDP tunnels. IESG IETF Chair 2015-02-10 RFC 7510
mpls-udp-dtls 6636 udp Encapsulate MPLS packets in UDP tunnels with DTLS. IESG IETF Chair 2015-02-10 RFC 7510
ovsdb 6640 tcp Open vSwitch Database protocol Bruce Davie Bruce Davie 2013-07-31 RFC 7047
6640 udp Reserved
vocaltec-gold 6670 tcp Vocaltec Global Online Directory Scott Petrack Scott Petrack
vocaltec-gold 6670 udp Vocaltec Global Online Directory Scott Petrack Scott Petrack
6680-6686 Unassigned
cleverdetect 6690 tcp CLEVERDetect Message Service Applied Expert Systems, Inc. David Cheng 2014-12-03
6690 udp Reserved
6700 Unassigned 2010-01-26
kti-icad-srvr 6701 tcp KTI/ICAD Nameserver Stanley Knutson Stanley Knutson
kti-icad-srvr 6701 udp KTI/ICAD Nameserver Stanley Knutson Stanley Knutson
6701 sctp Unassigned 2010-01-26
e-design-net 6702 tcp e-Design network Janos Lerch Janos Lerch 2006-02
e-design-net 6702 udp e-Design network Janos Lerch Janos Lerch 2006-02
6702 sctp Unassigned 2010-01-26
e-design-web 6703 tcp e-Design web Janos Lerch Janos Lerch 2006-02
e-design-web 6703 udp e-Design web Janos Lerch Janos Lerch 2006-02
6704 udp Reserved

Contact Information

Name Organization Contact URI Last Updated
Andreas Varga sid&parsec.org
Applied Expert Systems, Inc. davec&aesclever.com 2014-12-03
Bencher info&bencher.dev 2026-06-17
Bruce Davie bdavie&vmware.com 2013-07-31
Cartesian Theatre kip&heliosmusic.io 2024-01-25
Dave DesRoches ddesroches&clariion.com
David Cheng davec&aesclever.com 2010-02-01
David Gregorczyk david.gregorczyk&draeger.com 2017-03-02
Everett Pompeii everett&bencher.dev 2026-06-17
Giriraj Harapanahalli giriraj.harapanahalli&sap.com 2026-05-27
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Ieuan Friend ieuan.friend&dip.co.uk 2006-03
Janos Lerch lerch&softic.hu 2006-02
Kip Warner Cartesian Theatre kip&heliosmusic.io 2024-01-25
Magnus Nystrom magnus&dynas.se
Mark Beyer mbeyer&freegate.com
Minoru Ozaki Minoru.Ozaki&rdmg.mgcs.mei.co.jp
Ori Yosefi Ori.Yosefi&microsoft.com 2009-05-04
Paul Sterk paul.sterk&sun.com 2006-03
Portnoy Boxman portnoy_boxman&bmc.com 2005-01
Rajesh Davé rajdave&microsoft.com 2009-02-03
Rik Ditter managers&generationtechnologies.com 2006-02
Robert J. Scott rob&hpcmo.hpc.mil 2005-08
Rong Yu rongyu&microsoft.com 2010-08-10
SAP Giriraj Harapanahalli 2026-05-27
Scott Petrack Scott_Petrack&vocaltec.com
Stanley Knutson Stanley.Knutson&ktiworld.com
Steven Kelly stevek&metacase.com 2007-11-12