Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-22

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
iwg1 7071 tcp IWGADTS Aircraft Housekeeping Message Don Sullivan Don Sullivan 2010-02-16
iwg1 7071 udp IWGADTS Aircraft Housekeeping Message Don Sullivan Don Sullivan 2010-02-16
iba-cfg 7072 tcp iba Device Configuration Protocol iba AG Alexander Melamed 2018-02-12
iba-cfg-disc 7072 udp iba Device Configuration Protocol iba AG Alexander Melamed 2018-02-12
martalk 7073 tcp MarTalk protocol Mahr GmbH Göttingen Kevin Bube 2013-09-02
7073 udp Reserved
7074-7079 Unassigned
empowerid 7080 tcp EmpowerID Communication Matthew Whited Matthew Whited 2008-01-16
empowerid 7080 udp EmpowerID Communication Matthew Whited Matthew Whited 2008-01-16
7081-7087 Unassigned
7088 tcp Reserved
zixi-transport 7088 udp Zixi live video transport protocol Zixi Igor Ratner 2015-11-16
7089-7094 Unassigned
jdp-disc 7095 udp Java Discovery Protocol OpenJDK Florian Weimer 2013-03-12
7095 tcp Reserved
7096-7098 Unassigned
lazy-ptop 7099 tcp lazy-ptop Guy Keren Guy Keren
lazy-ptop 7099 udp lazy-ptop Guy Keren Guy Keren
font-service 7100 tcp X Font Service Stephen Gildea Stephen Gildea
font-service 7100 udp X Font Service Stephen Gildea Stephen Gildea
elcn 7101 tcp Embedded Light Control Network Michael Scarito Michael Scarito 2007-02
elcn 7101 udp Embedded Light Control Network Michael Scarito Michael Scarito 2007-02
7102-7106 Unassigned
7107 tcp Reserved
aes-x170 7107 udp AES-X170 Richard Foss Richard Foss 2011-02-10
7108-7116 Unassigned
7118-7120 Unassigned
snif 7123 tcp SNIF End-to-End TLS Relay Control Connection VESvault Corp Jim Zubov 2021-12-24 2026-07-22 draft-zubov-snif-05, Section 4.3
snif 7123 udp SNIF End-to-End TLS Relay over QUIC VESvault Corp Jim Zubov 2026-07-22 2026-07-22 draft-zubov-snif-05, Section 4.4
7130-7160 Unassigned
nsrp 7170 tcp Adaptive Name/Service Resolution Geoff Back Geoff Back 2010-02-01
nsrp 7170 udp Adaptive Name/Service Resolution Geoff Back Geoff Back 2010-02-01
7175-7180 Unassigned
fodms 7200 tcp FODMS FLIP David Anthony David Anthony
fodms 7200 udp FODMS FLIP David Anthony David Anthony
dlip 7201 tcp DLIP Albert Manfredi Albert Manfredi
dlip 7201 udp DLIP Albert Manfredi Albert Manfredi
pon-ictp 7202 tcp Inter-Channel Termination Protocol (ICTP) for multi-wavelength PON (Passive Optical Network) systems Broadband Forum Broadband Forum 2017-02-22 2019-12-16 TR-352; Inter-Channel-Termination protocol (ICTP) is a peer-to-peer protocol with a binary message format that is used by a set of optical line terminal (OLT) channel terminations (CT) comprising a 40-Gigabit-capable next-generation passive optical network (NG-PON2) system to exchange channel profile configuration and status information and to coordinate the operation of tunable optical network units (ONUs) in a multi-wavelength channel environment.
7202 udp Reserved
7203-7214 Unassigned
7230-7233 Unassigned
itactionserver1 7280 tcp ITACTIONSERVER 1 Brian Taylor Brian Taylor
itactionserver1 7280 udp ITACTIONSERVER 1 Brian Taylor Brian Taylor
swx 7300-7359 The Swiss Exchange Edgar Blum Edgar Blum
7360-7364 Unassigned 2006-02-06
7366-7390 Unassigned 2006-02-06
rtps-discovery 7400 tcp RTPS Discovery Gerardo Pardo-Castellote Gerardo Pardo-Castellote 2005-10
rtps-discovery 7400 udp RTPS Discovery Gerardo Pardo-Castellote Gerardo Pardo-Castellote 2005-10
rtps-dd-ut 7401 tcp RTPS Data-Distribution User-Traffic Gerardo Pardo-Castellote Gerardo Pardo-Castellote 2005-10
rtps-dd-ut 7401 udp RTPS Data-Distribution User-Traffic Gerardo Pardo-Castellote Gerardo Pardo-Castellote 2005-10
rtps-dd-mt 7402 tcp RTPS Data-Distribution Meta-Traffic Gerardo Pardo-Castellote Gerardo Pardo-Castellote 2005-10
rtps-dd-mt 7402 udp RTPS Data-Distribution Meta-Traffic Gerardo Pardo-Castellote Gerardo Pardo-Castellote 2005-10
7403-7409 Unassigned
ionixnetmon 7410 tcp Ionix Network Monitor Maxime Renaud Maxime Renaud 2006-04
ionixnetmon 7410 udp Ionix Network Monitor Maxime Renaud Maxime Renaud 2006-04
7420 tcp Reserved
ipluminary 7420 udp Multichannel real-time lighting control Tristan Seifert Tristan Seifert 2018-01-18
xmpv7 7430 tcp OpenView DM xmpv7 api pipe Dave Lamb Dave Lamb
xmpv7 7430 udp OpenView DM xmpv7 api pipe Dave Lamb Dave Lamb
7444-7470 Unassigned
7479-7490 Unassigned
silhouette 7500 tcp Silhouette User Anthony Payne Anthony Payne 2004-02
silhouette 7500 udp Silhouette User Anthony Payne Anthony Payne 2004-02
ovbus 7501 tcp HP OpenView Bus Daemon David M. Rhodes David M. Rhodes Known Unauthorized Use on port 7501
ovbus 7501 udp HP OpenView Bus Daemon David M. Rhodes David M. Rhodes Known Unauthorized Use on port 7501
7502-7507 Unassigned
adcp 7508 tcp Automation Device Configuration Protocol Festo AG & Co. KG Joerg Ullmann 2011-05-27 2012-07-26
7508 udp Reserved
acplt 7509 tcp ACPLT - process automation service The Chair for Process Control Engineering Ulrich Epple 2010-12-07 2012-08-07
7509 udp Reserved
ovhpas 7510 tcp HP OpenView Application Server Jeff Conrad Jeff Conrad
ovhpas 7510 udp HP OpenView Application Server Jeff Conrad Jeff Conrad
7550 tcp Reserved
cloudsignaling 7550 udp Cloud Signaling Service Scott Dawson Scott Dawson 2011-07-01
sncp 7560 tcp Sniffer Command Protocol Dominick Cafarelli Dominick Cafarelli 2005-08
sncp 7560 udp Sniffer Command Protocol Dominick Cafarelli Dominick Cafarelli 2005-08
cfw 7563 tcp Control Framework RFC 6230
aries-kfinder 7570 tcp Aries Kfinder James King III James King III
aries-kfinder 7570 udp Aries Kfinder James King III James King III
7589-7605 Unassigned
mipi-debug 7606 tcp MIPI Alliance Debug Mipi Alliance Peter Lefkin 2016-02-26
mipi-debug 7606 udp MIPI Alliance Debug Mipi Alliance Peter Lefkin 2016-02-26
7607-7623 Unassigned
simco 7626 tcp SImple Middlebox COnfiguration (SIMCO) Server RFC 4540
hawk 7630 tcp HA Web Konsole Tim Serong Tim Serong 2010-03-31
7630 udp Reserved
ms-do 7680 tcp Microsoft Delivery Optimization Peer-to-Peer Microsoft Corporation Narkis Engler 2008-02-27 2022-05-03
ms-do 7680 udp Microsoft Delivery Optimization Peer-to-Peer Microsoft Corporation Narkis Engler 2008-02-27 2022-05-03
sovd 7690 tcp Service-Oriented Vehicle Diagnostics ASAM e.V. Bernd Wenzel 2022-07-01
7690 udp Reserved
em7-secom 7700 tcp EM7 Secure Communications Christopher Cordray Christopher Cordray 2008-06-05
7700 udp Reserved
7701 tcp Reserved
7701 udp Reserved
nfapi 7701 sctp SCF nFAPI defining MAC/PHY split Small Cell Forum Richard Kennedy 2017-01-24
7702-7706 Unassigned
sync-em7 7707 tcp EM7 Dynamic Updates Christopher Cordray Christopher Cordray 2004-11
sync-em7 7707 udp EM7 Dynamic Updates Christopher Cordray Christopher Cordray 2004-11
scinet 7708 tcp scientia.net Christoph Anton Mitterer Christoph Anton Mitterer 2006-01
scinet 7708 udp scientia.net Christoph Anton Mitterer Christoph Anton Mitterer 2006-01
7709-7719 Unassigned

Contact Information

Name Organization Contact URI Last Updated
Albert Manfredi manfredi&engr05.comsys.rockwell.com
Alexander Melamed alexander.melamed&iba-ag.com 2018-02-12
Anthony Payne opayne&pacbell.net 2004-02
ASAM e.V. marius.dupuis&asam.net 2022-07-01
Bernd Wenzel ASAM e.V. bernd.wenzel&asam.net 2022-07-01
Brian Taylor btaylor&imagetag.com
Broadband Forum help&broadband-forum.org 2020-03-17
The Chair for Process Control Engineering ks&plt.rwth-aachen.de 2012-08-07
Christoph Anton Mitterer calestyo&scientia.net 2009-03-10
Christopher Cordray ccordray&sciencelogic.com 2008-06-05
Dave Lamb rdl&rdl.cnd.hp.com
David Anthony anthony&power.amasd.anatcp.rockwell.com
David M. Rhodes davidrho&cnd.hp.com
Dominick Cafarelli dominick.cafarelli&networkgeneral.com 2005-08
Don Sullivan donald.v.sullivan&nasa.gov 2010-02-16
Edgar Blum edgar.blum&swx.ch
Festo AG & Co. KG Software-Support&de.festo.com 2012-07-26
Florian Weimer fweimer&redhat.com 2013-03-12
Geoff Back geoff&demonlair.co.uk 2010-02-01
Gerardo Pardo-Castellote gerardo.pardo&rti.com 2005-10
Guy Keren Guy_Keren&mail.stil.scitex.com
iba AG info&iba-ag.com 2018-02-12
Igor Ratner igor&zixi.com 2015-11-16
James King III jking&ariessys.com
Jeff Conrad jeff_conrad&hp.com
Jim Zubov VESvault Corp jz&vesvault.com 2021-12-29
Joerg Ullmann Festo AG & Co. KG jgu&de.festo.com 2012-07-26
Kevin Bube Mahr GmbH Göttingen kevin.bube&mahr.de 2013-09-02
Mahr GmbH Göttingen info&mahr.de 2013-09-02
Matthew Whited matt&thedotnetfactory.com 2008-01-16
Maxime Renaud maxdrenaud&gmail.com 2015-12-07
Michael Scarito ms&mit.edu 2007-02
Microsoft Corporation naengler&microsoft.com 2022-05-03
Mipi Alliance secretary&mipi.org 2016-02-26
Narkis Engler Microsoft Corporation naengler&microsoft.com 2022-05-03
OpenJDK discuss&openjdk.java.net 2013-03-12
Peter Lefkin peter.lefkin&mipi.org 2016-02-26
Richard Foss r.foss&ru.ac.za 2011-02-10
Richard Kennedy Richard&smallcellforum.org 2017-01-24
Scott Dawson sdawson&arbor.net 2011-07-01
Small Cell Forum Richard&smallcellforum.org 2017-01-24
Stephen Gildea gildea&lcs.mit.edu
Tim Serong tserong&novell.com 2010-03-31
Tristan Seifert t&tseifert.me 2018-01-18
Ulrich Epple ks&plt.rwth-aachen.de 2012-08-07
VESvault Corp info&vesvault.com 2021-12-29
Zixi igor&zixi.com 2015-11-16