Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-22

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
senomix01 8052 udp Senomix Timesheets Server Charles O'Dale Charles O'Dale 2006-07
senomix02 8053 tcp Senomix Timesheets Client [1 year assignment] Charles O'Dale Charles O'Dale 2006-07
senomix02 8053 udp Senomix Timesheets Client [1 year assignment] Charles O'Dale Charles O'Dale 2006-07
senomix03 8054 tcp Senomix Timesheets Server [1 year assignment] Charles O'Dale Charles O'Dale 2006-07
senomix03 8054 udp Senomix Timesheets Server [1 year assignment] Charles O'Dale Charles O'Dale 2006-07
senomix04 8055 tcp Senomix Timesheets Server [1 year assignment] Charles O'Dale Charles O'Dale 2006-07
senomix04 8055 udp Senomix Timesheets Server [1 year assignment] Charles O'Dale Charles O'Dale 2006-07
senomix05 8056 tcp Senomix Timesheets Server [1 year assignment] Charles O'Dale Charles O'Dale 2006-07
senomix05 8056 udp Senomix Timesheets Server [1 year assignment] Charles O'Dale Charles O'Dale 2006-07
senomix06 8057 tcp Senomix Timesheets Client [1 year assignment] Charles O'Dale Charles O'Dale 2006-07
senomix06 8057 udp Senomix Timesheets Client [1 year assignment] Charles O'Dale Charles O'Dale 2006-07
senomix07 8058 tcp Senomix Timesheets Client [1 year assignment] Charles O'Dale Charles O'Dale 2006-07
senomix07 8058 udp Senomix Timesheets Client [1 year assignment] Charles O'Dale Charles O'Dale 2006-07
senomix08 8059 tcp Senomix Timesheets Client [1 year assignment] Charles O'Dale Charles O'Dale 2006-07
senomix08 8059 udp Senomix Timesheets Client [1 year assignment] Charles O'Dale Charles O'Dale 2006-07
8060 tcp Reserved
aero 8060 udp Asymmetric Extended Route Optimization (AERO) IESG IETF Chair RFC 6706
nikatron-dev 8061 tcp Nikatron Device Protocol Nikatron Marcel Uhlir 2023-09-07
8061 udp Reserved
8062-8065 Unassigned
toad-bi-appsrvr 8066 tcp Toad BI Application Server Quest Software Greg Cottman 2013-04-19
8066 udp Reserved
infi-async 8067 tcp Infinidat async replication INFINIDAT Eldar Kleiner 2015-05-01
8067 udp Reserved
8068-8069 Unassigned
ucs-isc 8070 tcp Oracle Unified Communication Suite's Indexed Search Converter Oracle Corp Bharathi Sivaramakrishnan 2017-02-10
8070 udp Reserved
8071-8073 Unassigned
gadugadu 8074 tcp Gadu-Gadu Marcin Gozdalik Marcin Gozdalik 2006-05
gadugadu 8074 udp Gadu-Gadu Marcin Gozdalik Marcin Gozdalik 2006-05
8075-8076 Unassigned
8077 tcp Reserved 2024-01-05 De-Assigned on 2024-01-05.
8077 udp Reserved
8078-8079 Unassigned
http-alt 8080 tcp HTTP Alternate (see port 80) Stephen Casner Stephen Casner
http-alt 8080 udp HTTP Alternate (see port 80) Stephen Casner Stephen Casner
sunproxyadmin 8081 tcp Sun Proxy Admin Service Arvind Srinivasan Arvind Srinivasan 2005-08
sunproxyadmin 8081 udp Sun Proxy Admin Service Arvind Srinivasan Arvind Srinivasan 2005-08
us-cli 8082 tcp Utilistor (Client) Andy Brewerton Andy Brewerton 2005-08
us-cli 8082 udp Utilistor (Client) Andy Brewerton Andy Brewerton 2005-08
us-srv 8083 tcp Utilistor (Server) Andy Brewerton Andy Brewerton 2005-08
us-srv 8083 udp Utilistor (Server) Andy Brewerton Andy Brewerton 2005-08
websnp 8084 tcp Snarl Network Protocol over HTTP full phat products Chris Peel 2019-08-08
8084 udp Reserved
8085 Unassigned
d-s-n 8086 tcp Distributed SCADA Networking Rendezvous Port Gary Hampton Gary Hampton 2008-02-27
d-s-n 8086 udp Distributed SCADA Networking Rendezvous Port Gary Hampton Gary Hampton 2008-02-27
simplifymedia 8087 tcp Simplify Media SPP Protocol Emmanuel Saint-Loubert Emmanuel Saint-Loubert 2008-08-08
simplifymedia 8087 udp Simplify Media SPP Protocol Emmanuel Saint-Loubert Emmanuel Saint-Loubert 2008-08-08
radan-http 8088 tcp Radan HTTP Steve Hay Steve Hay 2008-06-13
radan-http 8088 udp Radan HTTP Steve Hay Steve Hay 2008-06-13
8089 Unassigned
opsmessaging 8090 tcp Vehicle to station messaging LAN-ACES Robert Ripberger 2017-02-08
8090 udp Reserved
jamlink 8091 tcp Jam Link Framework Evgeniy Filatov Evgeniy Filatov 2009-11-25
8091 udp Reserved
8092-8096 Unassigned
sac 8097 tcp SAC Port Id Girish Bhat Girish Bhat 2006-04
sac 8097 udp SAC Port Id Girish Bhat Girish Bhat 2006-04
8098-8099 Unassigned
xprint-server 8100 tcp Xprint Server John McKernan John McKernan
xprint-server 8100 udp Xprint Server John McKernan John McKernan
ldoms-migr 8101 tcp Logical Domains Migration Liam Merwick Liam Merwick 2009-01-16
8101 udp Reserved
kz-migr 8102 tcp Oracle Kernel zones migration server Oracle John Levon 2013-12-24
8102 udp Reserved
8103-8110 Unassigned
mtl8000-matrix 8115 tcp MTL8000 Matrix David Pinch David Pinch 2002-04
mtl8000-matrix 8115 udp MTL8000 Matrix David Pinch David Pinch 2002-04
8119-8120 Unassigned
indigo-vrmi 8130 tcp INDIGO-VRMI Colin Caughie Colin Caughie
indigo-vrmi 8130 udp INDIGO-VRMI Colin Caughie Colin Caughie
puppet 8140 tcp The Puppet master service Puppet Charles Dunbar 2014-09-18
8140 udp Reserved
8150-8152 Unassigned
patrol 8160 tcp Patrol Portnoy Boxman Portnoy Boxman
patrol 8160 udp Patrol Portnoy Boxman Portnoy Boxman
8163-8180 Unassigned
gcp-rphy 8190 tcp Generic control plane for RPHY CableLabs Karthik Sundaresan 2015-11-24
8190 udp Reserved
trivnet1 8200 tcp TRIVNET Saar Wilf Saar Wilf
trivnet1 8200 udp TRIVNET Saar Wilf Saar Wilf
trivnet2 8201 tcp TRIVNET Saar Wilf Saar Wilf
trivnet2 8201 udp TRIVNET Saar Wilf Saar Wilf
8202 tcp Reserved
aesop 8202 udp Audio+Ethernet Standard Open Protocol POWERSOFT S.R.L. Paolo Desii; Claudio Lastrucci 2012-01-03
8203-8203 Unassigned
lm-perfworks 8204 tcp LM Perfworks Chris Flynn Chris Flynn
lm-perfworks 8204 udp LM Perfworks Chris Flynn Chris Flynn
lm-instmgr 8205 tcp LM Instmgr Chris Flynn Chris Flynn
lm-instmgr 8205 udp LM Instmgr Chris Flynn Chris Flynn
lm-dta 8206 tcp LM Dta Chris Flynn Chris Flynn
lm-dta 8206 udp LM Dta Chris Flynn Chris Flynn
lm-sserver 8207 tcp LM SServer Chris Flynn Chris Flynn
lm-sserver 8207 udp LM SServer Chris Flynn Chris Flynn
lm-webwatcher 8208 tcp LM Webwatcher Chris Flynn Chris Flynn
lm-webwatcher 8208 udp LM Webwatcher Chris Flynn Chris Flynn
8209-8210 Unassigned
rexecj 8230 tcp RexecJ Server Curtiss Howard Curtiss Howard 2004-11
rexecj 8230 udp RexecJ Server Curtiss Howard Curtiss Howard 2004-11
robot-remote 8270 tcp Robot Framework Remote Library Interface Robot Framework Foundation Chris Newman 2017-01-26

Contact Information

Name Organization Contact URI Last Updated
Andy Brewerton andy.brewerton&otium.co.uk 2005-08
Arvind Srinivasan arvind.srinivasan&sun.com 2005-08
Bharathi Sivaramakrishnan bharathi.sivaramakrishnan&oracle.com 2017-02-10
CableLabs info&cablelabs.com 2015-11-24
Charles Dunbar Puppet charles&puppet.com 2016-04-12
Charles O'Dale codale&hfx.andara.com 2006-07
Chris Flynn cflynn&landmark.com
Chris Newman chris.newman&oracle.com 2017-01-26
Chris Peel chris.gsi&fullphat.net 2014-05-16
Claudio Lastrucci POWERSOFT S.R.L. claudio.lastrucci&powersoft.it 2012-01-03
Colin Caughie cfc&indigo-avs.com
Curtiss Howard cjhoward&unity.ncsu.edu 2004-11
David Pinch dpinch&mtl-inst.com 2002-04
Eldar Kleiner INFINIDAT eldark&infinidat.com 2015-05-01
Emmanuel Saint-Loubert emmanuel&simplifymedia.com 2008-08-08
Evgeniy Filatov evgeniyfilatov&yandex.ru 2009-11-25
full phat products chris.gsi&fullphat.net 2019-08-08
Gary Hampton GH&2hti.com 2008-02-27
Girish Bhat gbhat&cranite.com 2006-04
Greg Cottman Quest Software Greg.Cottman&quest.com 2013-04-19
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
INFINIDAT info&infinidat.com 2015-05-01
John Levon Oracle john.levon&oracle.com 2013-12-24
John McKernan John.McKernan&sun.com
Karthik Sundaresan k.sundaresan&cablelabs.com 2015-11-24
LAN-ACES rip&lan-aces.com 2017-02-08
Liam Merwick ldoms-iana-ports&sun.com 2009-01-16
Marcel Uhlir Nikatron marcel.uhlir&nikatron.cz 2023-09-07
Marcin Gozdalik gozdal&gadu-gadu.pl 2006-05
Nikatron marcel.uhlir&nikatron.cz 2023-09-07
Oracle john.levon&oracle.com 2013-12-24
Oracle Corp bharathi.sivaramakrishnan&oracle.com
chris.newman&oracle.com
2017-02-10
Paolo Desii POWERSOFT S.R.L. paolo.desii&powersoft.it 2012-01-03
Portnoy Boxman portnoy_boxman&bmc.com 2005-01
POWERSOFT S.R.L. claudio.lastrucci&powersoft.it 2012-01-03
Puppet sysops-dept&puppetlabs.com 2016-04-12
Quest Software Greg.Cottman&quest.com 2013-04-19
Robert Ripberger rip&lan-aces.com 2017-02-08
Robot Framework Foundation robotframework-foundation&googlegroups.com 2017-01-26
Saar Wilf saar&trivnet.com
Stephen Casner casner&precpt.com
Steve Hay SteveHay&planit.com 2008-06-13