Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-22
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| robot-remote | 8270 | tcp | Robot Framework Remote Library Interface | Robot Framework Foundation | Chris Newman | 2017-01-26 | |||||
| 8270 | udp | Reserved | |||||||||
| synapse-nhttp | 8280 | tcp | Synapse Non Blocking HTTP | Ruwan Linton | Ruwan Linton | 2008-06-05 | |||||
| synapse-nhttp | 8280 | udp | Synapse Non Blocking HTTP | Ruwan Linton | Ruwan Linton | 2008-06-05 | |||||
| tmi | 8300 | tcp | Transport Management Interface | Steve Kneizys | Steve Kneizys | 2006-11 | |||||
| tmi | 8300 | udp | Transport Management Interface | Steve Kneizys | Steve Kneizys | 2006-11 | |||||
| amberon | 8301 | tcp | Amberon PPC/PPS | Ronald Snyder | Ronald Snyder | 2006-03 | |||||
| amberon | 8301 | udp | Amberon PPC/PPS | Ronald Snyder | Ronald Snyder | 2006-03 | |||||
| 8302-8312 | Unassigned | ||||||||||
| tnp-discover | 8320 | tcp | Thin(ium) Network Protocol | Aly Orady | Aly Orady | 2007-08-07 | |||||
| tnp-discover | 8320 | udp | Thin(ium) Network Protocol | Aly Orady | Aly Orady | 2007-08-07 | |||||
| 8323-8350 | Unassigned | ||||||||||
| cruise-update | 8380 | tcp | Cruise UPDATE | Steve Husak | Steve Husak | ||||||
| cruise-update | 8380 | udp | Cruise UPDATE | Steve Husak | Steve Husak | ||||||
| cvd | 8400 | tcp | cvd | Aaron Bilbrey | Aaron Bilbrey | ||||||
| cvd | 8400 | udp | cvd | Aaron Bilbrey | Aaron Bilbrey | ||||||
| sabarsd | 8401 | tcp | sabarsd | Aaron Bilbrey | Aaron Bilbrey | ||||||
| sabarsd | 8401 | udp | sabarsd | Aaron Bilbrey | Aaron Bilbrey | ||||||
| abarsd | 8402 | tcp | abarsd | Aaron Bilbrey | Aaron Bilbrey | ||||||
| abarsd | 8402 | udp | abarsd | Aaron Bilbrey | Aaron Bilbrey | ||||||
| admind | 8403 | tcp | admind | Aaron Bilbrey | Aaron Bilbrey | ||||||
| admind | 8403 | udp | admind | Aaron Bilbrey | Aaron Bilbrey | ||||||
| svcloud | 8404 | tcp | SuperVault Cloud | Nine Technology, LLC | Alex Stoev | 2009-09-14 | 2011-08-01 | ||||
| 8404 | udp | Reserved | |||||||||
| svbackup | 8405 | tcp | SuperVault Backup | Nine Technology, LLC | Alex Stoev | 2009-09-14 | 2011-08-01 | ||||
| 8405 | udp | Reserved | |||||||||
| 8406-8414 | Unassigned | ||||||||||
| npmp | 8450 | tcp | npmp | Ian Chard | Ian Chard | ||||||
| npmp | 8450 | udp | npmp | Ian Chard | Ian Chard | ||||||
| cisco-avp | 8470 | tcp | Cisco Address Validation Protocol | Cullen Jennings | Cullen Jennings | 2009-02-13 | |||||
| 8470 | udp | Reserved | |||||||||
| fmtp | 8500 | tcp | Flight Message Transfer Protocol | Eivan Cerasi | Eivan Cerasi | 2003-12 | |||||
| fmtp | 8500 | udp | Flight Message Transfer Protocol | Eivan Cerasi | Eivan Cerasi | 2003-12 | |||||
| cmtp-mgt | 8501 | tcp | CYTEL Message Transfer Management | ||||||||
| cmtp-av | 8501 | udp | CYTEL Message Transfer Audio and Video | Frank Jäkel | Frank Jäkel | 2011-04-29 | |||||
| ftnmtp | 8502 | tcp | FTN Message Transfer Protocol | Yuri Myakotin | Yuri Myakotin | 2014-01-07 | |||||
| 8502 | udp | Reserved | |||||||||
| lsp-self-ping | 8503 | udp | MPLS LSP Self-Ping | IESG | IETF Chair | 2015-06-11 | 2016-02-01 | RFC 7746 | |||
| 8503 | tcp | Reserved | |||||||||
| 8504-8553 | Unassigned | ||||||||||
| asterix | 8600 | tcp | Surveillance Data | Eivan Cerasi | Eivan Cerasi | 2005-11 | |||||
| asterix | 8600 | udp | Surveillance Data | Eivan Cerasi | Eivan Cerasi | 2005-11 | |||||
| 8601-8608 | Unassigned | ||||||||||
| 8609 | tcp | Reserved | |||||||||
| canon-cpp-disc | 8609 | udp | Canon Compact Printer Protocol Discovery | Canon Inc. | Ryusuke Okuhara | 2012-06-08 | 2012-06-15 | ||||
| canon-mfnp | 8610 | tcp | Canon MFNP Service | Ritsuto Sako | Ritsuto Sako | 2009-05-04 | |||||
| canon-mfnp | 8610 | udp | Canon MFNP Service | Ritsuto Sako | Ritsuto Sako | 2009-05-04 | |||||
| 8699 | udp | Reserved | 2004-11 | 2013-05-24 | This entry is being removed on 2013-05-24. | ||||||
| 8700-8709 | Unassigned | ||||||||||
| semi-grpc | 8710 | tcp | gRPC for SEMI Standards implementations | SEMI | Albert Fuchigami | 2020-01-10 | |||||
| 8710 | udp | Reserved | |||||||||
| dey-keyneg | 8750 | tcp | DEY Storage Key Negotiation | DEY Storage Systems, Inc. | Garrett D'Amore | 2013-03-01 | |||||
| 8750 | udp | Reserved | |||||||||
| dpap | 8770 | tcp | Digital Photo Access Protocol (iPhoto) | Amandeep Jawa | Amandeep Jawa | 2004-11 | Defined TXT keys: txtvers, Version, iPSh Version, Machine ID, Machine Name, Password | ||||
| dpap | 8770 | udp | Digital Photo Access Protocol (iPhoto) | Amandeep Jawa | Amandeep Jawa | 2004-11 | Defined TXT keys: txtvers, Version, iPSh Version, Machine ID, Machine Name, Password | ||||
| sunwebadmin | 8800 | tcp | Sun Web Server Admin Service | Jyri J. Virkki | Jyri J. Virkki | 2005-12 | |||||
| sunwebadmin | 8800 | udp | Sun Web Server Admin Service | Jyri J. Virkki | Jyri J. Virkki | 2005-12 | |||||
| 8801-8803 | Unassigned | Known UNAUTHORIZED USE: Port 8801 | |||||||||
| truecm | 8804 | tcp | truecm | Scott Kramer | Scott Kramer | ||||||
| truecm | 8804 | udp | truecm | Scott Kramer | Scott Kramer | ||||||
| 8805 | tcp | Reserved | |||||||||
| pfcp | 8805 | udp | Destination Port number for PFCP | Kimmo Kymalainen | Kimmo Kymalainen | 2017-05-08 | |||||
| 8806 | Unassigned | ||||||||||
| 8807 | tcp | Reserved | |||||||||
| hes-clip | 8807 | udp | HES-CLIP Interoperability protocol | Tim Schoechle | Ludo Bertsch | 2018-09-07 | |||||
| 8808 | tcp | Reserved | |||||||||
| ssports-bcast | 8808 | udp | STATSports Broadcast Service | Statsports_International | Catalin Caranfil | 2016-12-22 | |||||
| 8809 | tcp | Reserved | |||||||||
| 3gpp-monp | 8809 | udp | MCPTT Off-Network Protocol (MONP) | 3GPP | Dongwook Kim | 2019-04-15 | 2026-01-23 | 3GPP TS 24.379 v13.5.0s | |||
| 8810-8872 | Unassigned | ||||||||||
| cddbp-alt | 8880 | tcp | CDDBP | Steve Scherf | Steve Scherf | ||||||
| cddbp-alt | 8880 | udp | CDDBP | Steve Scherf | Steve Scherf | ||||||
| ddi-tcp-3 | 8890 | tcp | Desktop Data TCP 2 | Fred Yao | Fred Yao | Known Unauthorized Use on port 8890 | |||||
| ddi-udp-3 | 8890 | udp | NewsEDGE client broadcast | Fred Yao | Fred Yao | Known Unauthorized Use on port 8890 | |||||
| jmb-cds1 | 8900 | tcp | JMB-CDS 1 | Curtis Bray | Curtis Bray | ||||||
| jmb-cds1 | 8900 | udp | JMB-CDS 1 | Curtis Bray | Curtis Bray | ||||||
| jmb-cds2 | 8901 | tcp | JMB-CDS 2 | Curtis Bray | Curtis Bray | ||||||
| jmb-cds2 | 8901 | udp | JMB-CDS 2 | Curtis Bray | Curtis Bray | ||||||
| 8902-8907 | Unassigned | ||||||||||
| dpp | 8908 | tcp | WFA Device Provisioning Protocol | Wi-Fi Alliance | Dr. Jun Tian | 2020-10-19 | |||||
| 8908 | udp | Reserved | |||||||||
| 8909 | Unassigned | ||||||||||
| manyone-http | 8910 | tcp | manyone-http | Matt King | Matt King | 2002-04 | |||||
| manyone-http | 8910 | udp | manyone-http | Matt King | Matt King | 2002-04 | |||||
| nod-provider | 8980 | tcp | Network of Devices Provider | David Müller | David Müller | 2015-02-22 | |||||
| nod-provider | 8980 | udp | Network of Devices Provider | David Müller | David Müller | 2015-02-22 | |||||
| http-wmap | 8990 | tcp | webmail HTTP service | Chris Newman | Chris Newman | 2007-12-03 | |||||
| http-wmap | 8990 | udp | webmail HTTP service | Chris Newman | Chris Newman | 2007-12-03 | |||||
| cslistener | 9000 | tcp | CSlistener | David Jones | David Jones | ||||||
| cslistener | 9000 | udp | CSlistener | David Jones | David Jones | ||||||
| etlservicemgr | 9001 | tcp | ETL Service Manager | Stephen McCrea | Stephen McCrea | 2002-03 | Known Unauthorized Use on port 9001 | ||||
| etlservicemgr | 9001 | udp | ETL Service Manager | Stephen McCrea | Stephen McCrea | 2002-03 | Known Unauthorized Use on port 9001 | ||||
| dynamid | 9002 | tcp | DynamID authentication | Jerome Dusautois | Jerome Dusautois | 2002-03 | |||||
| dynamid | 9002 | udp | DynamID authentication | Jerome Dusautois | Jerome Dusautois | 2002-03 | |||||
| 9003-9004 | Unassigned | ||||||||||
| golem | 9005 | tcp | Golem Inter-System RPC | Jose Luis Tallon | Jose Luis Tallon | 2015-03-09 | |||||
| 9005 | udp | Reserved | |||||||||
| 9006 | De-Commissioned Port | 2000-02-24 | |||||||||
| 9007 | tcp | Reserved | |||||||||
| ogs-client | 9007 | udp | Open Grid Services Client | Gareth Nelson | Gareth Nelson | 2008-08-22 | |||||
| ogs-server | 9008 | tcp | Open Grid Services Server | Gareth Nelson | Gareth Nelson | 2008-08-22 |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| 3GPP | info&3gpp.org | 2026-10-20 | |
| Aaron Bilbrey | abilbrey&commvault.com | ||
| Albert Fuchigami | albert.fuchigami&peergroup.com | 2020-01-10 | |
| Alex Stoev | Nine Technology, LLC | astoev&ninetechnology.com | 2011-08-01 |
| Aly Orady | Atto Devices Inc. | aly.orady&attodevices.com | 2007-08-07 |
| Amandeep Jawa | dpap&apple.com | 2004-11 | |
| Canon Inc. | fujii.ken-ichi149&canon.co.jp | 2011-10-10 | |
| Catalin Caranfil | c.caranfil&statsports.com | 2016-12-22 | |
| Chris Newman | chris.newman&oracle.com | 2017-01-26 | |
| Cullen Jennings | fluffy&cisco.com | 2010-02-03 | |
| Curtis Bray | CurtisB&creativedesign.com | ||
| David Jones | djones&cincom.com | ||
| David Müller | david.muller.cz&gmail.com | 2015-02-22 | |
| DEY Storage Systems, Inc. | garrett&dey-sys.com | 2013-03-01 | |
| Dongwook Kim | 3GPP | info&3gpp.org | 2026-10-20 |
| Dr. Jun Tian | jtian&wi-fi.org | 2020-10-19 | |
| Eivan Cerasi | eivan.cerasi&eurocontrol.int | 2022-08-08 | |
| Frank Jäkel | Frank.Jaekel&cytel.de | 2011-04-29 | |
| Fred Yao | Fred_Yao&ddigate2.desktopdata.com | ||
| Gareth Nelson | gareth&litesim.com | 2008-08-22 | |
| Garrett D'Amore | DEY Storage Systems, Inc. | garrett&dey-sys.com | 2013-03-01 |
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| Ian Chard | ian&tanagra.demon.co.uk | ||
| Jerome Dusautois | jdusautois&scrypto.fr | 2002-03 | |
| Jose Luis Tallon | joseluis&talloncorp.com | 2015-03-09 | |
| Jyri J. Virkki | jyri.virkki&sun.com | 2005-12 | |
| Kimmo Kymalainen | kimmo.kymalainen&etsi.org | 2017-05-08 | |
| Ludo Bertsch | Horizon Technologies Inc. | iana&horizontec.com | 2018-09-07 |
| Matt King | m&manyone.net | 2002-04 | |
| Nine Technology, LLC | astoev&ninetechnology.com | 2011-08-01 | |
| Ritsuto Sako | sakou.ritsuto&canon.co.jp | 2009-05-04 | |
| Robot Framework Foundation | robotframework-foundation&googlegroups.com | 2017-01-26 | |
| Ronald Snyder | pugaroni&sssnet.com | 2006-03 | |
| Ruwan Linton | ruwan&wso2.com | 2008-08-20 | |
| Ryusuke Okuhara | Canon Inc. | okuhara.ryuusuke&canon.co.jp | 2012-06-08 |
| Scott Kramer | scottk&truebluesoftware.com | ||
| SEMI | jamano&semi.org | 2020-01-10 | |
| Statsports_International | iana_liaison&statsports.com | 2016-12-22 | |
| Stephen McCrea | smccrea&etlelectronique.com | 2002-03 | |
| Steve Husak | portmaster&cruisetech.com | ||
| Steve Kneizys | skneizys&erpdata.com | 2006-11 | |
| Steve Scherf | steve&moonsoft.com | ||
| Tim Schoechle | ISO/IEC JTC1 SC25/WG1 | timothy&schoechle.org | 2018-09-07 |
| Wi-Fi Alliance | technical&wi-fi.org | 2020-10-19 | |
| Yuri Myakotin | yuri&ym-com.net | 2014-01-07 |