Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-22
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| wap-vcal-s | 9207 | udp | WAP vCal Secure | WAP Forum | WAP Forum | ||||||
| rjcdb-vcards | 9208 | tcp | rjcdb vCard | Robert John Churchill | Robert John Churchill | 2006-01 | |||||
| rjcdb-vcards | 9208 | udp | rjcdb vCard | Robert John Churchill | Robert John Churchill | 2006-01 | |||||
| almobile-system | 9209 | tcp | ALMobile System Service | Rob Graber | Rob Graber | 2006-01 | |||||
| almobile-system | 9209 | udp | ALMobile System Service | Rob Graber | Rob Graber | 2006-01 | |||||
| oma-mlp | 9210 | tcp | OMA Mobile Location Protocol | Hans Rohnert | Hans Rohnert | 2002-04 | |||||
| oma-mlp | 9210 | udp | OMA Mobile Location Protocol | Hans Rohnert | Hans Rohnert | 2002-04 | |||||
| pgps | 9280 | tcp | Predicted GPS | Jeremy Freeman | Jeremy Freeman | 2008-02-14 | |||||
| pgps | 9280 | udp | Predicted GPS | Jeremy Freeman | Jeremy Freeman | 2008-02-14 | |||||
| vrace | 9300 | tcp | Virtual Racing Service | Pete Loeffen | Pete Loeffen | 2006-10 | |||||
| vrace | 9300 | udp | Virtual Racing Service | Pete Loeffen | Pete Loeffen | 2006-10 | |||||
| 9301-9305 | Unassigned | ||||||||||
| sphinxql | 9306 | tcp | Sphinx search server (MySQL listener) | Andrew Aksyonoff | Andrew Aksyonoff | 2009-10-20 | |||||
| 9306 | udp | Reserved | |||||||||
| 9307-9309 | Unassigned | ||||||||||
| sapms | 9310 | tcp | SAP Message Server | SAP SE | Stefan Hagen | 2020-03-12 | |||||
| 9310 | udp | Reserved | |||||||||
| 9319-9320 | Unassigned | ||||||||||
| gribi | 9340 | tcp | gRPC Routing Information Base Interface | Google Networking | Rob Shakir | 2022-03-29 | |||||
| 9340 | udp | Reserved | |||||||||
| boxp | 9380 | tcp | Brivs! Open Extensible Protocol | Danko Alexeyev | Danko Alexeyev | 2007-08-08 | |||||
| boxp | 9380 | udp | Brivs! Open Extensible Protocol | Danko Alexeyev | Danko Alexeyev | 2007-08-08 | |||||
| otp | 9390 | tcp | OpenVAS Transfer Protocol | Tim Brown | Tim Brown | 2008-12-24 | |||||
| 9390 | udp | Reserved | |||||||||
| sec-t4net-srv | 9400 | tcp | Samsung Twain for Network Server | Dongkeun Kim | Dongkeun Kim | 2007-02 | |||||
| sec-t4net-srv | 9400 | udp | Samsung Twain for Network Server | Dongkeun Kim | Dongkeun Kim | 2007-02 | |||||
| sec-t4net-clt | 9401 | tcp | Samsung Twain for Network Client | Dongkeun Kim | Dongkeun Kim | 2007-02 | |||||
| sec-t4net-clt | 9401 | udp | Samsung Twain for Network Client | Dongkeun Kim | Dongkeun Kim | 2007-02 | |||||
| sec-pc2fax-srv | 9402 | tcp | Samsung PC2FAX for Network Server | HyeongBae Yu | HyeongBae Yu | 2008-07-31 | |||||
| sec-pc2fax-srv | 9402 | udp | Samsung PC2FAX for Network Server | HyeongBae Yu | HyeongBae Yu | 2008-07-31 | |||||
| 9403-9417 | Unassigned | ||||||||||
| sntlkeyssrvr | 9450 | tcp | Sentinel Keys Server | Martin Ziskind | Martin Ziskind | 2008-08-21 | |||||
| sntlkeyssrvr | 9450 | udp | Sentinel Keys Server | Martin Ziskind | Martin Ziskind | 2008-08-21 | |||||
| ismserver | 9500 | tcp | ismserver | Ian Gordon | Ian Gordon | ||||||
| ismserver | 9500 | udp | ismserver | Ian Gordon | Ian Gordon | ||||||
| 9501-9521 | Unassigned | ||||||||||
| 9560-9591 | Unassigned | ||||||||||
| micromuse-ncpw | 9600 | tcp | MICROMUSE-NCPW | Hing Wing To | Hing Wing To | ||||||
| micromuse-ncpw | 9600 | udp | MICROMUSE-NCPW | Hing Wing To | Hing Wing To | ||||||
| 9601-9611 | Unassigned | ||||||||||
| peoctlr | 9630 | tcp | Peovica Controller | Adrian Hungate | Adrian Hungate | 2009-09-14 | |||||
| 9630 | udp | Reserved | |||||||||
| pqsflows | 9640 | tcp | ProQueSys Flows Service | Sarene Caiazza | Sarene Caiazza | 2010-04-27 | |||||
| 9640 | udp | Reserved | |||||||||
| board-roar | 9700 | tcp | Board M.I.T. Service | Francesco Rosi | Francesco Rosi | 2006-01 | |||||
| board-roar | 9700 | udp | Board M.I.T. Service | Francesco Rosi | Francesco Rosi | 2006-01 | |||||
| 9701-9746 | Unassigned | ||||||||||
| board-voip | 9750 | tcp | Board M.I.T. Synchronous Collaboration | Francesco Rosi | Francesco Rosi | 2006-01 | |||||
| board-voip | 9750 | udp | Board M.I.T. Synchronous Collaboration | Francesco Rosi | Francesco Rosi | 2006-01 | |||||
| davsrc | 9800 | tcp | WebDav Source Port | Ethan Fremen | Ethan Fremen | ||||||
| davsrc | 9800 | udp | WebDav Source Port | Ethan Fremen | Ethan Fremen | ||||||
| sstp-2 | 9801 | tcp | Sakura Script Transfer Protocol-2 | Kouichi Takeda | Kouichi Takeda | ||||||
| sstp-2 | 9801 | udp | Sakura Script Transfer Protocol-2 | Kouichi Takeda | Kouichi Takeda | ||||||
| davsrcs | 9802 | tcp | WebDAV Source TLS/SSL | Rob Isaac | Rob Isaac | 2003-07 | |||||
| davsrcs | 9802 | udp | WebDAV Source TLS/SSL | Rob Isaac | Rob Isaac | 2003-07 | |||||
| 9803-9874 | Unassigned | ||||||||||
| x510 | 9877 | tcp | The X.510 wrapper protocol | ITU/TSB (ITU-T Study Group 17) | Erik Andersen | 2019-09-30 | ITU-T X.510 / ISO/IEC 9584-11 | ||||
| kca-service | 9878 | udp | The KX509 Kerberized Certificate Issuance Protocol in Use in 2012 | IESG | IETF Chair | 2012-07-12 | RFC 6717 | Historically, this service has been referred to as "kca_service", but this service name does not meet the registry requirements. | |||
| 9890-9897 | Unassigned | ||||||||||
| iua | 9900 | tcp | IUA | Lyndon Ong | Lyndon Ong | ||||||
| iua | 9900 | udp | IUA | Lyndon Ong | Lyndon Ong | ||||||
| iua | 9900 | sctp | IUA | Lyndon Ong | Lyndon Ong | ||||||
| enrp | 9901 | udp | enrp server channel | ||||||||
| enrp-sctp | 9901 | sctp | enrp server channel | RFC 5353 | |||||||
| enrp-sctp-tls | 9902 | sctp | enrp/tls server channel | RFC 5353 | |||||||
| 9903 | tcp | Reserved | |||||||||
| multicast-ping | 9903 | udp | Multicast Ping Protocol | 2011-12-09 | RFC 6450 | ||||||
| 9904-9908 | Unassigned | ||||||||||
| domaintime | 9909 | tcp | domaintime | Jeffry Dwight | Jeffry Dwight | ||||||
| domaintime | 9909 | udp | domaintime | Jeffry Dwight | Jeffry Dwight | ||||||
| 9910 | Unassigned | ||||||||||
| apc-9950 | 9950 | tcp | APC 9950 | American Power Conversion | American Power Conversion | ||||||
| apc-9950 | 9950 | udp | APC 9950 | American Power Conversion | American Power Conversion | ||||||
| 9980 | Unassigned | ||||||||||
| osm-appsrvr | 9990 | tcp | OSM Applet Server | Vinay Gupta | Vinay Gupta | 2003-08 | |||||
| osm-appsrvr | 9990 | udp | OSM Applet Server | Vinay Gupta | Vinay Gupta | 2003-08 | |||||
| ndmp | 10000 | tcp | Network Data Management Protocol | Brian Ehrmantraut | Brian Ehrmantraut | ||||||
| ndmp | 10000 | udp | Network Data Management Protocol | Brian Ehrmantraut | Brian Ehrmantraut | ||||||
| scp-config | 10001 | tcp | SCP Configuration | Michael Benz | Michael Benz | 2010-08-06 | |||||
| scp-config | 10001 | udp | SCP Configuration | Michael Benz | Michael Benz | 2010-08-06 | |||||
| documentum | 10002 | tcp | EMC-Documentum Content Server Product | Reza Bagherian | Reza Bagherian | 2007-07-19 | |||||
| documentum | 10002 | udp | EMC-Documentum Content Server Product | Reza Bagherian | Reza Bagherian | 2007-07-19 | |||||
| documentum-s | 10003 | tcp | EMC-Documentum Content Server Product IANA assigned this well-formed service name as a replacement for "documentum_s". |
Reza Bagherian | Reza Bagherian | 2007-07-19 | |||||
| documentum_s | 10003 | tcp | EMC-Documentum Content Server Product | Reza Bagherian | Reza Bagherian | 2007-07-19 | This entry is an alias to "documentum-s". This entry is now historic, not usable for use with many common service discovery mechanisms. | ||||
| documentum-s | 10003 | udp | EMC-Documentum Content Server Product IANA assigned this well-formed service name as a replacement for "documentum_s". |
Reza Bagherian | Reza Bagherian | 2007-07-19 | |||||
| documentum_s | 10003 | udp | EMC-Documentum Content Server Product | Reza Bagherian | Reza Bagherian | 2007-07-19 | This entry is an alias to "documentum-s". This entry is now historic, not usable for use with many common service discovery mechanisms. | ||||
| emcrmirccd | 10004 | tcp | EMC Replication Manager Client | Robert Boudrie | Robert Boudrie | 2008-06-09 | |||||
| 10004 | udp | Reserved | |||||||||
| emcrmird | 10005 | tcp | EMC Replication Manager Server | Robert Boudrie | Robert Boudrie | 2008-06-09 | |||||
| 10005 | udp | Reserved | |||||||||
| netapp-sync | 10006 | tcp | Sync replication protocol among different NetApp platforms | NetApp | Paul Mu | 2014-08-07 | |||||
| 10006 | udp | Reserved | |||||||||
| mvs-capacity | 10007 | tcp | MVS Capacity | Donna Dillenberger | Donna Dillenberger | ||||||
| mvs-capacity | 10007 | udp | MVS Capacity | Donna Dillenberger | Donna Dillenberger | ||||||
| octopus | 10008 | tcp | Octopus Multiplexer | Chris Koeritz | Chris Koeritz | 2002-10 | |||||
| octopus | 10008 | udp | Octopus Multiplexer | Chris Koeritz | Chris Koeritz | 2002-10 | |||||
| swdtp-sv | 10009 | tcp | Systemwalker Desktop Patrol | Akira Ide | Akira Ide | 2006-03 | |||||
| swdtp-sv | 10009 | udp | Systemwalker Desktop Patrol | Akira Ide | Akira Ide | 2006-03 | |||||
| rxapi | 10010 | tcp | ooRexx rxapi services | David Ashley | David Ashley | 2009-07-24 | |||||
| 10010 | udp | Reserved | |||||||||
| 10011-10019 | Unassigned |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Adrian Hungate | adrian&tlspu.com | 2014-07-11 | |
| Akira Ide | ide.akira&jp.fujitsu.com | 2006-09 | |
| American Power Conversion | ports&apcc.com | 2002-02 | |
| Andrew Aksyonoff | shodan&sphinxsearch.com | 2009-10-20 | |
| Brian Ehrmantraut | bae&netapp.com | ||
| Chris Koeritz | fred&gruntose.com | 2002-10 | |
| Danko Alexeyev | virtuall&virtuall.info | 2007-08-08 | |
| David Ashley | david.ashley.ibm&gmail.com | 2009-07-24 | |
| Dongkeun Kim | dongkeun70.kim&samsung.com | 2007-02 | |
| Donna Dillenberger | engd&us.ibm.com | ||
| Erik Andersen | era&x500.eu | 2019-08-13 | |
| Ethan Fremen | mindlace&digicool.com | ||
| Francesco Rosi | frosi&orenburg.com | 2006-01 | |
| Google Networking | gribi-maintainers&google.com | 2022-03-29 | |
| Hans Rohnert | hans.rohnert&siemens.com | 2002-04 | |
| Hing Wing To | wing.toµmuse.com | ||
| HyeongBae Yu | hyeongbae.yu&samsung.com | 2008-07-31 | |
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| Ian Gordon | iangµmuse.co.uk | ||
| ITU/TSB (ITU-T Study Group 17) | tsbsg17&itu.int | 2019-09-30 | |
| Jeffry Dwight | jeffryd&greyware.com | ||
| Jeremy Freeman | jeremy&rxnetworks.ca | 2008-02-14 | |
| Kouichi Takeda | KHB05271&nifty.com | ||
| Lyndon Ong | Lyong&ciena.com | ||
| Martin Ziskind | ziskind&us.ibm.com | 2008-08-21 | |
| Michael Benz | michael.benz&lsi.com | 2010-08-06 | |
| NetApp | pmu&netapp.com. | 2014-08-12 | |
| Paul Mu | NetApp | pmu&netapp.com | 2014-08-07 |
| Pete Loeffen | President at Digital Rowing Inc. | peterl&digitalrowing.com | 2006-10 |
| Reza Bagherian | bagherian_reza&emc.com | 2007-07-19 | |
| Rob Graber | r.graber&austinlane.com | 2006-01 | |
| Rob Isaac | rob&automagic.org | 2003-07 | |
| Rob Shakir | Google Networking | robjs&google.com | 2022-03-29 |
| Robert Boudrie | boudrie_rob&emc.com | 2008-06-09 | |
| Robert John Churchill | rjc&rjcdb.com | 2006-01 | |
| SAP SE | stefan.hagen&sap.com | 2020-03-12 | |
| Sarene Caiazza | scaiazza&proquesys.com | 2010-04-27 | |
| Stefan Hagen | stefan.hagen&sap.com | 2020-03-12 | |
| Tim Brown | timb&openvas.org | 2008-12-24 | |
| Vinay Gupta | vinay.gupta&hp.com | 2003-08 | |
| WAP Forum | wap-feedback&mail.wapforum.org
pg&uplanet.com |