Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-22
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| 10011-10019 | Unassigned | ||||||||||
| abb-hw | 10020 | tcp | Hardware configuration and maintenance | ABB | Adam Norén | 2017-03-28 | |||||
| 10020 | udp | Reserved | |||||||||
| 10021-10022 | Unassigned | ||||||||||
| cefd-vmp | 10023 | udp | Comtech EF-Data's Vipersat Management Protocol | Comtech | Nathan Jeffords | 2014-01-23 | |||||
| 10023 | tcp | Reserved | |||||||||
| 10024-10049 | Unassigned | ||||||||||
| zabbix-agent | 10050 | tcp | Zabbix Agent | Alexei Vladishev | Alexei Vladishev | 2006-02 | |||||
| zabbix-agent | 10050 | udp | Zabbix Agent | Alexei Vladishev | Alexei Vladishev | 2006-02 | |||||
| zabbix-trapper | 10051 | tcp | Zabbix Trapper | Alexei Vladishev | Alexei Vladishev | 2006-02 | |||||
| zabbix-trapper | 10051 | udp | Zabbix Trapper | Alexei Vladishev | Alexei Vladishev | 2006-02 | |||||
| 10052-10054 | Unassigned | ||||||||||
| qptlmd | 10055 | tcp | Quantapoint FLEXlm Licensing Service | Justin Vegso | Justin Vegso | 2010-07-01 | |||||
| 10055 | udp | Reserved | |||||||||
| 10056-10079 | Unassigned | ||||||||||
| amanda | 10080 | tcp | Amanda | John Jackson | John Jackson | ||||||
| amanda | 10080 | udp | Amanda | John Jackson | John Jackson | ||||||
| famdc | 10081 | tcp | FAM Archive Server | Frode Randers | Frode Randers | 2006-01 | |||||
| famdc | 10081 | udp | FAM Archive Server | Frode Randers | Frode Randers | 2006-01 | |||||
| 10082-10099 | Unassigned | ||||||||||
| itap-ddtp | 10100 | tcp | VERITAS ITAP DDTP | Saugata Guha | Saugata Guha | 2004-05 | |||||
| itap-ddtp | 10100 | udp | VERITAS ITAP DDTP | Saugata Guha | Saugata Guha | 2004-05 | |||||
| ezmeeting-2 | 10101 | tcp | eZmeeting | Albert C. Yang | Albert C. Yang | 2002-03 | |||||
| ezmeeting-2 | 10101 | udp | eZmeeting | Albert C. Yang | Albert C. Yang | 2002-03 | |||||
| ezproxy-2 | 10102 | tcp | eZproxy | Albert C. Yang | Albert C. Yang | 2002-03 | |||||
| ezproxy-2 | 10102 | udp | eZproxy | Albert C. Yang | Albert C. Yang | 2002-03 | |||||
| ezrelay | 10103 | tcp | eZrelay | Albert C. Yang | Albert C. Yang | 2002-03 | |||||
| ezrelay | 10103 | udp | eZrelay | Albert C. Yang | Albert C. Yang | 2002-03 | |||||
| swdtp | 10104 | tcp | Systemwalker Desktop Patrol | Akira Ide | Akira Ide | 2006-09 | |||||
| swdtp | 10104 | udp | Systemwalker Desktop Patrol | Akira Ide | Akira Ide | 2006-09 | |||||
| 10105-10106 | Unassigned | ||||||||||
| bctp-server | 10107 | tcp | VERITAS BCTP, server | Saugata Guha | Saugata Guha | 2004-05 | |||||
| bctp-server | 10107 | udp | VERITAS BCTP, server | Saugata Guha | Saugata Guha | 2004-05 | |||||
| 10108-10109 | Unassigned | ||||||||||
| nmea-0183 | 10110 | tcp | NMEA-0183 Navigational Data | Meindert Sprang | Meindert Sprang | 2009-02-18 | |||||
| nmea-0183 | 10110 | udp | NMEA-0183 Navigational Data | Meindert Sprang | Meindert Sprang | 2009-02-18 | |||||
| 10111 | tcp | Reserved | |||||||||
| nmea-onenet | 10111 | udp | NMEA OneNet multicast messaging | National Marine Electronics Association | Mark Oslund | 2011-09-15 | 2023-12-27 | ||||
| 10112 | Unassigned | ||||||||||
| netiq-endpoint | 10113 | tcp | NetIQ Endpoint | John Wood | John Wood | ||||||
| netiq-endpoint | 10113 | udp | NetIQ Endpoint | John Wood | John Wood | ||||||
| netiq-qcheck | 10114 | tcp | NetIQ Qcheck | Michael Sharpe | Michael Sharpe | 2010-09-14 | |||||
| netiq-qcheck | 10114 | udp | NetIQ Qcheck | Michael Sharpe | Michael Sharpe | 2010-09-14 | |||||
| netiq-endpt | 10115 | tcp | NetIQ Endpoint | Gary Weichinger | Gary Weichinger | ||||||
| netiq-endpt | 10115 | udp | NetIQ Endpoint | Gary Weichinger | Gary Weichinger | ||||||
| netiq-voipa | 10116 | tcp | NetIQ VoIP Assessor | Gary Weichinger | Gary Weichinger | ||||||
| netiq-voipa | 10116 | udp | NetIQ VoIP Assessor | Gary Weichinger | Gary Weichinger | ||||||
| iqrm | 10117 | tcp | NetIQ IQCResource Managament Svc | Michael Sharpe | Michael Sharpe | 2010-09-14 | |||||
| iqrm | 10117 | udp | NetIQ IQCResource Managament Svc | Michael Sharpe | Michael Sharpe | 2010-09-14 | |||||
| 10118-10124 | Unassigned | ||||||||||
| cimple | 10125 | tcp | HotLink CIMple REST API | HotLink Corporation | Richard Offer | 2014-12-18 | |||||
| 10125 | udp | Reserved | |||||||||
| 10126-10127 | Unassigned | ||||||||||
| bmc-perf-sd | 10128 | tcp | BMC-PERFORM-SERVICE DAEMON | Portnoy Boxman | Portnoy Boxman | ||||||
| bmc-perf-sd | 10128 | udp | BMC-PERFORM-SERVICE DAEMON | Portnoy Boxman | Portnoy Boxman | ||||||
| bmc-gms | 10129 | tcp | BMC General Manager Server | Dima Seliverstov | Dima Seliverstov | 2009-07-28 | |||||
| 10129 | udp | Reserved | |||||||||
| 10130-10159 | Unassigned | ||||||||||
| qb-db-server | 10160 | tcp | QB Database Server | Wei Wang | Wei Wang | 2005-11 | |||||
| qb-db-server | 10160 | udp | QB Database Server | Wei Wang | Wei Wang | 2005-11 | |||||
| snmptls | 10161 | tcp | SNMP-TLS | RFC 6353 | |||||||
| snmpdtls | 10161 | udp | SNMP-DTLS | RFC 6353 | |||||||
| snmptls-trap | 10162 | tcp | SNMP-Trap-TLS | RFC 6353 | |||||||
| snmpdtls-trap | 10162 | udp | SNMP-Trap-DTLS | RFC 6353 | |||||||
| 10163-10199 | Unassigned | ||||||||||
| trisoap | 10200 | tcp | Trigence AE Soap Service | Brigitte Gagne | Brigitte Gagne | 2006-08 | |||||
| trisoap | 10200 | udp | Trigence AE Soap Service | Brigitte Gagne | Brigitte Gagne | 2006-08 | |||||
| rsms | 10201 | tcp | Remote Server Management Service | Patrick H. Piper | Patrick H. Piper | 2009-03-06 | |||||
| rscs | 10201 | udp | Remote Server Control and Test Service | Patrick H. Piper | Patrick H. Piper | 2009-03-06 | |||||
| 10202-10251 | Unassigned | ||||||||||
| apollo-relay | 10252 | tcp | Apollo Relay Port | Anthony Carrabino | Anthony Carrabino | 2003-08 | |||||
| apollo-relay | 10252 | udp | Apollo Relay Port | Anthony Carrabino | Anthony Carrabino | 2003-08 | |||||
| eapol-relay | 10253 | udp | Relay of EAPOL frames | Wi-SUN Alliance | Phil Beecher | 2015-06-26 | |||||
| 10253 | tcp | Reserved | |||||||||
| 10254-10259 | Unassigned | ||||||||||
| axis-wimp-port | 10260 | tcp | Axis WIMP Port | Stefan Eriksson | Stefan Eriksson | ||||||
| axis-wimp-port | 10260 | udp | Axis WIMP Port | Stefan Eriksson | Stefan Eriksson | ||||||
| tile-ml | 10261 | tcp | Tile remote machine learning | 1026 Labs | Rob Earhart | 2016-09-27 | |||||
| 10261 | udp | Reserved | |||||||||
| 10262-10287 | Unassigned | ||||||||||
| blocks | 10288 | tcp | Blocks | Carl Malamud | Carl Malamud | ||||||
| blocks | 10288 | udp | Blocks | Carl Malamud | Carl Malamud | ||||||
| 10289-10320 | Unassigned | ||||||||||
| 10321 | tcp | Reserved | 2023-12-05 | De-Assigned on 2023-12-05. | |||||||
| 10321 | udp | Reserved | |||||||||
| 10322-10438 | Unassigned | ||||||||||
| bngsync | 10439 | udp | BalanceNG session table synchronization protocol | Inlab Software GmbH | Thomas G. Obermair | 2014-05-02 | |||||
| 10439 | tcp | Reserved | |||||||||
| 10440-10442 | Unassigned | ||||||||||
| cirrossp | 10443 | tcp | CirrosSP Workstation Communication | Cirros Document Solutions Ltd | Andy Garratt | 2020-02-12 | |||||
| 10443 | udp | Reserved | |||||||||
| 10444-10499 | Unassigned | ||||||||||
| 10500 | tcp | Reserved | |||||||||
| hip-nat-t | 10500 | udp | HIP NAT-Traversal | IESG | IETF Chair | 2020-08-12 | RFC 5770; RFC 9028 | ||||
| 10501-10539 | Unassigned | ||||||||||
| MOS-lower | 10540 | tcp | MOS Media Object Metadata Port | Eric Thorniley | Eric Thorniley | 2007-09-17 | |||||
| MOS-lower | 10540 | udp | MOS Media Object Metadata Port | Eric Thorniley | Eric Thorniley | 2007-09-17 | |||||
| MOS-upper | 10541 | tcp | MOS Running Order Port | Eric Thorniley | Eric Thorniley | 2007-09-17 | |||||
| MOS-upper | 10541 | udp | MOS Running Order Port | Eric Thorniley | Eric Thorniley | 2007-09-17 | |||||
| MOS-aux | 10542 | tcp | MOS Low Priority Port | Eric Thorniley | Eric Thorniley | 2007-09-17 | |||||
| MOS-aux | 10542 | udp | MOS Low Priority Port | Eric Thorniley | Eric Thorniley | 2007-09-17 |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| 1026 Labs | contact&1026labs.com | 2016-09-27 | |
| ABB | adam.noren&se.abb.com | 2017-03-28 | |
| Adam Norén | ABB | adam.noren&se.abb.com | 2017-03-28 |
| Akira Ide | ide.akira&jp.fujitsu.com | 2006-09 | |
| Albert C. Yang | albert.yang&ezmeeting.com | 2002-03 | |
| Alexei Vladishev | alexei.vladishev&zabbix.com | 2006-02 | |
| Andy Garratt | Cirros Document Solutions Ltd | admin&cirros.net | 2020-02-12 |
| Anthony Carrabino | anthonyc&vistasoftware.com | 2003-08 | |
| Brigitte Gagne | bgagne&trigence.com | 2006-08 | |
| Carl Malamud | |||
| Cirros Document Solutions Ltd | admin&cirros.net | 2020-02-12 | |
| Comtech | njeffords&comtechefdata.com | 2014-01-23 | |
| Dima Seliverstov | Dima_Seliverstov&bmc.com | 2009-07-28 | |
| Eric Thorniley | eric&etcomms.co.uk | 2007-09-17 | |
| Frode Randers | Frode.Randers&tietoenator.com | 2006-01 | |
| Gary Weichinger | gary.weichinger&netiq.com | ||
| HotLink Corporation | roffer&hotlink.com | 2014-12-18 | |
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| Inlab Software GmbH | info&inlab.de | 2014-05-02 | |
| John Jackson | amanda.org | jrj&gandalf.cc.purdue.edu | |
| John Wood | John.Wood&netiq.com | ||
| Justin Vegso | jvegso&quantapoint.com | 2010-07-01 | |
| Mark Oslund | National Marine Electronics Association | info&nmea.org | 2023-12-27 |
| Meindert Sprang | ms&customware.nl | 2009-02-18 | |
| Michael Sharpe | iana-ports&netiq.com | 2010-09-14 | |
| Nathan Jeffords | Comtech | njeffords&comtechefdata.com | 2014-01-23 |
| National Marine Electronics Association | standards&nmea.org | 2023-12-27 | |
| Patrick H. Piper | ppiper&netlinxinc.com | 2009-03-06 | |
| Phil Beecher | Wi-SUN Alliance | pbeecher&wi-sun.org | 2015-06-26 |
| Portnoy Boxman | portnoy_boxman&bmc.com | 2005-01 | |
| Richard Offer | HotLink Corporation | roffer&hotlink.com | 2014-12-18 |
| Rob Earhart | rob&1026labs.com | 2016-09-27 | |
| Saugata Guha | sguha&veritas.com | 2004-05 | |
| Stefan Eriksson | contact-iana&axis.com | ||
| Thomas G. Obermair | Inlab Software GmbH | thomas.obermair&inlab.de | 2014-05-02 |
| Wei Wang | Wei_Wang&intuit.com | 2005-11 | |
| Wi-SUN Alliance | admin&wi-sun.org | 2015-06-26 |