Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-22

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
netviewdm3 731 udp IBM NetView DM/6000 receive/tcp Philippe Binet Philippe Binet
732-740 Unassigned
rfile 750 tcp
loadav 750 udp
kerberos-iv 750 udp kerberos version iv Martin Hamilton Martin Hamilton
ns 760 tcp
ns 760 udp
cadlock 770 tcp
cadlock 770 udp
wpgs 780 tcp Josyula R. Rao Josyula R. Rao
wpgs 780 udp Josyula R. Rao Josyula R. Rao
mdbs-daemon 800 tcp IANA assigned this well-formed service name as a replacement for "mdbs_daemon".
mdbs_daemon 800 tcp This entry is an alias to "mdbs-daemon". This entry is now historic, not usable for use with many common service discovery mechanisms.
mdbs-daemon 800 udp IANA assigned this well-formed service name as a replacement for "mdbs_daemon".
mdbs_daemon 800 udp This entry is an alias to "mdbs-daemon". This entry is now historic, not usable for use with many common service discovery mechanisms.
device 801 tcp
device 801 udp
mbap-s 802 tcp Modbus Application Protocol Secure modbus.org Dennis Dube 2014-06-10
mbap-s 802 udp Modbus Application Protocol Secure modbus.org Dennis Dube 2014-06-10
803-809 Unassigned
fcp-udp 810 tcp FCP Paul Whittemore Paul Whittemore
fcp-udp 810 udp FCP Datagram Paul Whittemore Paul Whittemore
netconf-ssh 830 tcp NETCONF over SSH RFC 6242
netconf-ssh 830 udp NETCONF over SSH RFC 6242
831 tcp Reserved 2025-09-29 Previously assigned to NETCONF over BEEP but released by RFC 9900
831 udp Reserved 2025-09-29 Previously assigned to NETCONF over BEEP but released by RFC 9900
832 tcp Reserved 2025-09-29 Previously assigned to NETCONF over SOAP but released by RFC 9900
832 udp Reserved 2025-09-29 Previously assigned to NETCONF over SOAP but released by RFC 9900
833 tcp Reserved 2025-09-29 Previously assigned to NETCONF over SOAP but released by RFC 9900
833 udp Reserved 2025-09-29 Previously assigned to NETCONF over SOAP but released by RFC 9900
domain-s 853 udp DNS query-response protocol run over DTLS or QUIC IESG IETF Chair 2015-10-08 2022-04-01 RFC 7858; RFC 8094; RFC 9250
iscsi 860 tcp iSCSI IESG IETF Chair 2013-08-27 RFC 7143
iscsi 860 udp iSCSI IESG IETF Chair 2013-08-27 RFC 7143
omginitialrefs 900 tcp OMG Initial Refs Christian Callsen Christian Callsen
omginitialrefs 900 udp OMG Initial Refs Christian Callsen Christian Callsen
smpnameres 901 tcp SMPNAMERES Leif Ekblad Leif Ekblad
smpnameres 901 udp SMPNAMERES Leif Ekblad Leif Ekblad
ideafarm-door 902 tcp self documenting Telnet Door
ideafarm-door 902 udp self documenting Door: send 0x00 for info
ideafarm-panic 903 tcp self documenting Telnet Panic Door Wo'o Ideafarm Wo'o Ideafarm
ideafarm-panic 903 udp self documenting Panic Door: send 0x00 for info Wo'o Ideafarm Wo'o Ideafarm
904-909 Unassigned
kink 910 tcp Kerberized Internet Negotiation of Keys (KINK) RFC 4430
kink 910 udp Kerberized Internet Negotiation of Keys (KINK) RFC 4430
apex-edge 913 tcp APEX endpoint-relay service RFC 3340
apex-edge 913 udp APEX endpoint-relay service RFC 3340
ftps 990 tcp ftp protocol, control, over TLS/SSL Christopher Allen Christopher Allen
ftps 990 udp ftp protocol, control, over TLS/SSL Christopher Allen Christopher Allen
nas 991 tcp Netnews Administration System Vera Heinau; Heiko Schlichting Vera Heinau; Heiko Schlichting 2017-02-10 RFC 4707
nas 991 udp Netnews Administration System Vera Heinau; Heiko Schlichting Vera Heinau; Heiko Schlichting 2017-02-10 RFC 4707
imaps 993 tcp IMAP over TLS protocol IESG IETF Chair 2021-02-22 RFC 3501; RFC 8314; RFC 9051
993 udp Reserved 2021-02-22 RFC 9051
cadlock2 1000 tcp
cadlock2 1000 udp
webpush 1001 tcp HTTP Web Push IESG IETF Chair 2016-11-01 RFC 8030
1001 udp Reserved
1002-1007 Unassigned
1008 udp Possibly used by Sun Solaris????
1009 Unassigned
surf 1010 tcp surf Joseph Geer Joseph Geer
surf 1010 udp surf Joseph Geer Joseph Geer
1011-1020 Reserved
exp1 1021 tcp RFC3692-style Experiment 1 IESG IETF Chair [1]RFC 4727; RFC 6335
exp1 1021 udp RFC3692-style Experiment 1 IESG IETF Chair [1]RFC 4727; RFC 6335
exp1 1021 sctp RFC3692-style Experiment 1 IESG IETF Chair [1]RFC 4727; RFC 6335
exp1 1021 dccp RFC3692-style Experiment 1 IESG IETF Chair [1]RFC 4727; RFC 6335
exp2 1022 tcp RFC3692-style Experiment 2 IESG IETF Chair [1]RFC 4727; RFC 6335
exp2 1022 udp RFC3692-style Experiment 2 IESG IETF Chair [1]RFC 4727; RFC 6335
exp2 1022 sctp RFC3692-style Experiment 2 IESG IETF Chair [1]RFC 4727; RFC 6335
exp2 1022 dccp RFC3692-style Experiment 2 IESG IETF Chair [1]RFC 4727; RFC 6335
1023 tcp Reserved 2024-12-20 RFC 6335
1023 udp Reserved 2024-12-20 RFC 6335
1024 tcp Reserved 2024-12-20 RFC 6335
1024 udp Reserved 2024-12-20 RFC 6335
blackjack 1025 tcp network blackjack
blackjack 1025 udp network blackjack
cap 1026 tcp Calendar Access Protocol Doug Royer Doug Royer 2010-12-09
cap 1026 udp Calendar Access Protocol Doug Royer Doug Royer 2010-12-09
6a44 1027 udp IPv6 Behind NAT44 CPEs IESG IETF Chair 2012-08-02 RFC 6751
1027 tcp Reserved
1028 Deprecated 2004-02
solid-mux 1029 tcp Solid Mux Server Anders Borg Anders Borg 2004-11
solid-mux 1029 udp Solid Mux Server Anders Borg Anders Borg 2004-11
1030 Reserved 2013-05-24 This entry is being removed on 2013-05-24.
1031 Reserved 2013-05-24 This entry is being removed on 2013-05-24.
1032 Reserved 2013-05-24 This entry is being removed on 2013-05-24.
netinfo-local 1033 tcp local netinfo port Marc Majka Marc Majka 2002-08
netinfo-local 1033 udp local netinfo port Marc Majka Marc Majka 2002-08
activesync 1034 tcp ActiveSync Notifications Sandra Vargas Sandra Vargas 2003-03
activesync 1034 udp ActiveSync Notifications Sandra Vargas Sandra Vargas 2003-03
mxxrlogin 1035 tcp MX-XR RPC Valassis John Eckert 2003-04 2015-05-05
mxxrlogin 1035 udp MX-XR RPC Valassis John Eckert 2003-04 2015-05-05
nsstp 1036 tcp Nebula Secure Segment Transfer Protocol Steve Ravida Steve Ravida
nsstp 1036 udp Nebula Secure Segment Transfer Protocol Steve Ravida Steve Ravida
ams 1037 tcp AMS Ronald R. Ohmer Ronald R. Ohmer 2004-02
ams 1037 udp AMS Ronald R. Ohmer Ronald R. Ohmer 2004-02
mtqp 1038 tcp Message Tracking Query Protocol RFC 3887
mtqp 1038 udp Message Tracking Query Protocol RFC 3887
sbl 1039 tcp Streamlined Blackhole Jonathan A. Zdziaraski Jonathan A. Zdziaraski 2004-11
sbl 1039 udp Streamlined Blackhole Jonathan A. Zdziaraski Jonathan A. Zdziaraski 2004-11
netarx 1040 tcp Netarx Netcare Sandy Kronenberg Sandy Kronenberg 2008-04-03

Contact Information

Name Organization Contact URI Last Updated
Anders Borg anders.borg&solid.se 2004-11
Christian Callsen Christian.Callsen&eng.sun.com
Christopher Allen ChristopherA&consensus.com
Dennis Dube dennis.dube&schneider-electric.com 2014-06-10
Doug Royer DouglasRoyer&gmail.com 2010-12-09
Heiko Schlichting heiko.schlichting&fu-berlin.de 2022-06-07
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
John Eckert Valassis eckertj&valassis.com 2015-05-05
Jonathan A. Zdziaraski jonathan&nuclearelephant.com 2004-11
Joseph Geer jgeer&peapod.com
Josyula R. Rao jrrao&watson.ibm.com
Leif Ekblad leif&rdos.net
Marc Majka majka&apple.com 2002-08
Martin Hamilton martin&mrrl.lut.as.uk
modbus.org rbelliardi&modbus.org 2014-06-10
Paul Whittemore paul&softarc.com
Philippe Binet phbinet&vnet.ibm.com
Ronald R. Ohmer rohmer&aisconsulting.net 2004-02
Sandra Vargas Sandrama&microsoft.com 2003-03
Sandy Kronenberg sandy&netarx.com 2008-04-03
Steve Ravida steve.ravida&nebulaholdings.com
Valassis eckertj&valassis.com 2015-05-05
Vera Heinau vera.heinau&fu-berlin.de 2022-06-07
Wo'o Ideafarm b85f3c23.9ad6f42c&ideafarm.com