Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| nbx-au | 2094 | udp | NBX AU | ||||||||
| nbx-ser | 2095 | tcp | NBX SER | ||||||||
| nbx-ser | 2095 | udp | NBX SER | ||||||||
| nbx-dir | 2096 | tcp | NBX DIR | Henry Houh | Henry Houh | ||||||
| nbx-dir | 2096 | udp | NBX DIR | Henry Houh | Henry Houh | ||||||
| jetformpreview | 2097 | tcp | Jet Form Preview | Zygmunt Wiercioch | Zygmunt Wiercioch | ||||||
| jetformpreview | 2097 | udp | Jet Form Preview | Zygmunt Wiercioch | Zygmunt Wiercioch | ||||||
| dialog-port | 2098 | tcp | Dialog Port | Joseph Mathew | Joseph Mathew | ||||||
| dialog-port | 2098 | udp | Dialog Port | Joseph Mathew | Joseph Mathew | ||||||
| h2250-annex-g | 2099 | tcp | H.225.0 Annex G Signalling | ITU-T | ITU-T TSB | 2013-01-31 | |||||
| h2250-annex-g | 2099 | udp | H.225.0 Annex G Signalling | ITU-T | ITU-T TSB | 2013-01-31 | |||||
| qencp | 2120 | tcp | Quick Eagle Networks CP | Santa Dasu | Santa Dasu | ||||||
| qencp | 2120 | udp | Quick Eagle Networks CP | Santa Dasu | Santa Dasu | ||||||
| 2200 | tcp | Reserved | This entry has been removed on 2019-07-05. | ||||||||
| 2200 | udp | Reserved | This entry has been removed on 2019-07-05. | ||||||||
| ats | 2201 | tcp | Advanced Training System Program | ||||||||
| ats | 2201 | udp | Advanced Training System Program | ||||||||
| imtc-map | 2202 | tcp | Int. Multimedia Teleconferencing Cosortium | Pat Galvin | Pat Galvin | ||||||
| imtc-map | 2202 | udp | Int. Multimedia Teleconferencing Cosortium | Pat Galvin | Pat Galvin | ||||||
| b2-runtime | 2203 | tcp | b2 Runtime Protocol | ||||||||
| b2-runtime | 2203 | udp | b2 Runtime Protocol | ||||||||
| b2-license | 2204 | tcp | b2 License Server | Helge-Frank Zimpel | Helge-Frank Zimpel | 2006-01 | |||||
| b2-license | 2204 | udp | b2 License Server | Helge-Frank Zimpel | Helge-Frank Zimpel | 2006-01 | |||||
| jps | 2205 | tcp | Java Presentation Server | Leif Jakob | Leif Jakob | 2006-01 | |||||
| jps | 2205 | udp | Java Presentation Server | Leif Jakob | Leif Jakob | 2006-01 | |||||
| hpocbus | 2206 | tcp | HP OpenCall bus | Jerome Forissier | Jerome Forissier | 2005-12 | |||||
| hpocbus | 2206 | udp | HP OpenCall bus | Jerome Forissier | Jerome Forissier | 2005-12 | |||||
| hpssd | 2207 | tcp | HP Status and Services | Donald Welch | Donald Welch | 2006-05 | |||||
| hpssd | 2207 | udp | HP Status and Services | Donald Welch | Donald Welch | 2006-05 | |||||
| hpiod | 2208 | tcp | HP I/O Backend | David Suffield | David Suffield | 2006-05 | |||||
| hpiod | 2208 | udp | HP I/O Backend | David Suffield | David Suffield | 2006-05 | |||||
| rimf-ps | 2209 | tcp | HP RIM for Files Portal Service | Patty Ho | Patty Ho | 2007-05 | |||||
| rimf-ps | 2209 | udp | HP RIM for Files Portal Service | Patty Ho | Patty Ho | 2007-05 | |||||
| netiq | 2220 | tcp | NetIQ End2End | Michael Sharpe | Michael Sharpe | 2010-09-14 | |||||
| netiq | 2220 | udp | NetIQ End2End | Michael Sharpe | Michael Sharpe | 2010-09-14 | |||||
| EtherNet-IP-1 | 2222 | tcp | EtherNet/IP I/O IANA assigned this well-formed service name as a replacement for "EtherNet/IP-1". |
Brian Batke | Brian Batke | New contact added for port 2222 on 2008-02-01 | |||||
| EtherNet/IP-1 | 2222 | tcp | EtherNet/IP I/O | Brian Batke | Brian Batke | New contact added for port 2222 on 2008-02-01 This entry is an alias to "EtherNet-IP-1". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| EtherNet-IP-1 | 2222 | udp | EtherNet/IP I/O IANA assigned this well-formed service name as a replacement for "EtherNet/IP-1". |
Brian Batke | Brian Batke | New contact added for port 2222 on 2008-02-01 | |||||
| EtherNet/IP-1 | 2222 | udp | EtherNet/IP I/O | Brian Batke | Brian Batke | New contact added for port 2222 on 2008-02-01 This entry is an alias to "EtherNet-IP-1". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| siebel-ns | 2320 | tcp | Siebel NS | Gilberto Arnaiz | Gilberto Arnaiz | ||||||
| siebel-ns | 2320 | udp | Siebel NS | Gilberto Arnaiz | Gilberto Arnaiz | ||||||
| ansysli | 2325 | tcp | ANSYS Licensing Interconnect | Suzanne Lorrin | Suzanne Lorrin | Modified: 27 October 2008 | |||||
| ansysli | 2325 | udp | ANSYS Licensing Interconnect | Suzanne Lorrin | Suzanne Lorrin | Modified: 27 October 2008 | |||||
| oi-2000 | 2364 | tcp | OI-2000 | Software Horizons Inc. | Software Horizons Inc. | ||||||
| oi-2000 | 2364 | udp | OI-2000 | Software Horizons Inc. | Software Horizons Inc. | ||||||
| taskmaster2000 | 2402 | tcp | TaskMaster 2000 Server | ||||||||
| taskmaster2000 | 2402 | udp | TaskMaster 2000 Server | ||||||||
| taskmaster2000 | 2403 | tcp | TaskMaster 2000 Web | Ed Odjaghian | Ed Odjaghian | ||||||
| taskmaster2000 | 2403 | udp | TaskMaster 2000 Web | Ed Odjaghian | Ed Odjaghian | ||||||
| 2408 | udp | Reserved | 2012-03-09 | This entry is being removed on 2012-03-09. | |||||||
| dslremote-mgmt | 2420 | tcp | DSL Remote Management | Westell, Inc. | Westell, Inc. | ||||||
| dslremote-mgmt | 2420 | udp | DSL Remote Management | Westell, Inc. | Westell, Inc. | ||||||
| vcmp | 2426 | tcp | VeloCloud MultiPath Protocol | VeloCloud Networks | Tim Van Herck | 2014-11-13 | This port was previously removed on 2002-04-29. | ||||
| vcmp | 2426 | udp | VeloCloud MultiPath Protocol | VeloCloud Networks | Tim Van Herck | 2014-11-13 | This port was previously removed on 2002-04-29. | ||||
| pvsw | 2520 | tcp | Pervasive Listener | Chuck Talk | Chuck Talk | ||||||
| pvsw | 2520 | udp | Pervasive Listener | Chuck Talk | Chuck Talk | ||||||
| lpsrecommender | 2620 | tcp | LPSRecommender | Pritham Shetty | Pritham Shetty | ||||||
| lpsrecommender | 2620 | udp | LPSRecommender | Pritham Shetty | Pritham Shetty | ||||||
| 2693 | tcp | Unassigned | (Removed 2004-2-6) | ||||||||
| 2693 | udp | Unassigned | (Removed 2004-2-6) | ||||||||
| wkars | 2720 | tcp | wkars | Barry Shelton | Barry Shelton | ||||||
| wkars | 2720 | udp | wkars | Barry Shelton | Barry Shelton | ||||||
| univision | 2820 | tcp | UniVision | Keith Ansell | Keith Ansell | ||||||
| univision | 2820 | udp | UniVision | Keith Ansell | Keith Ansell | ||||||
| roboeda | 2920 | tcp | roboEDA | Paul Snook | Paul Snook | ||||||
| roboeda | 2920 | udp | roboEDA | Paul Snook | Paul Snook | ||||||
| origo-native | 3001 | tcp | OrigoDB Server Native Interface | Devrex Labs | Robert Friberg | 2013-03-29 | port 3001 previously "Removed on 2006-05-25" | ||||
| 3001 | udp | Reserved | 2013-03-29 | port 3001 previously "Removed on 2006-05-25" | |||||||
| cifs | 3020 | tcp | CIFS | Paul Leach | Paul Leach | ||||||
| cifs | 3020 | udp | CIFS | Paul Leach | Paul Leach | ||||||
| orbix-locator | 3075 | tcp | Orbix 2000 Locator | ||||||||
| orbix-locator | 3075 | udp | Orbix 2000 Locator | ||||||||
| orbix-config | 3076 | tcp | Orbix 2000 Config | ||||||||
| orbix-config | 3076 | udp | Orbix 2000 Config | ||||||||
| orbix-loc-ssl | 3077 | tcp | Orbix 2000 Locator SSL | ||||||||
| orbix-loc-ssl | 3077 | udp | Orbix 2000 Locator SSL | ||||||||
| orbix-cfg-ssl | 3078 | tcp | Orbix 2000 Locator SSL | Eric Newcomer | Eric Newcomer | ||||||
| orbix-cfg-ssl | 3078 | udp | Orbix 2000 Locator SSL | Eric Newcomer | Eric Newcomer | ||||||
| d2000kernel | 3119 | tcp | D2000 Kernel Port | ||||||||
| d2000kernel | 3119 | udp | D2000 Kernel Port | ||||||||
| d2000webserver | 3120 | tcp | D2000 Webserver Port | Tomas Rajcan | Tomas Rajcan | ||||||
| d2000webserver | 3120 | udp | D2000 Webserver Port | Tomas Rajcan | Tomas Rajcan | ||||||
| pcmk-remote | 3121 | tcp | The pacemaker remote (pcmk-remote) service extends high availability functionality outside of the Linux cluster into remote nodes. | David Vossel | Andrew Beekhof | 2013-03-15 | port 3121 previously noted "Removed on 2003-09-17" | ||||
| 3121 | udp | Reserved | 2013-03-15 | port 3121 previously noted "Removed on 2003-09-17" | |||||||
| tick-port | 3200 | tcp | Press-sense Tick Port | Boris Svetlitsky | Boris Svetlitsky | ||||||
| tick-port | 3200 | udp | Press-sense Tick Port | Boris Svetlitsky | Boris Svetlitsky | ||||||
| cpq-tasksmart | 3201 | tcp | CPQ-TaskSmart | Jackie Lau | Jackie Lau | ||||||
| cpq-tasksmart | 3201 | udp | CPQ-TaskSmart | Jackie Lau | Jackie Lau | ||||||
| intraintra | 3202 | tcp | IntraIntra | Matthew Asham | Matthew Asham | ||||||
| intraintra | 3202 | udp | IntraIntra | Matthew Asham | Matthew Asham | ||||||
| netwatcher-mon | 3203 | tcp | Network Watcher Monitor | ||||||||
| netwatcher-mon | 3203 | udp | Network Watcher Monitor | ||||||||
| netwatcher-db | 3204 | tcp | Network Watcher DB Access | Hirokazu Fujisawa | Hirokazu Fujisawa | ||||||
| netwatcher-db | 3204 | udp | Network Watcher DB Access | Hirokazu Fujisawa | Hirokazu Fujisawa | ||||||
| isns | 3205 | tcp | iSNS Server Port | RFC 4171 | |||||||
| isns | 3205 | udp | iSNS Server Port | RFC 4171 | |||||||
| ironmail | 3206 | tcp | IronMail POP Proxy | Mike Hudack | Mike Hudack | ||||||
| ironmail | 3206 | udp | IronMail POP Proxy | Mike Hudack | Mike Hudack | ||||||
| vx-auth-port | 3207 | tcp | Veritas Authentication Port | Senthil Ponnuswamy | Senthil Ponnuswamy | ||||||
| vx-auth-port | 3207 | udp | Veritas Authentication Port | Senthil Ponnuswamy | Senthil Ponnuswamy | ||||||
| pfu-prcallback | 3208 | tcp | PFU PR Callback | Tetsuharu Hanada | Tetsuharu Hanada |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Andrew Beekhof | andrew&beekhof.net | 2013-03-15 | |
| Barry Shelton | bshelton&wirelessknowledge.com | ||
| Boris Svetlitsky | boris&press-sense.com | ||
| Brian Batke | eip.jsig&gmail.com | ||
| Chuck Talk | ctalk&pervasive.com | ||
| David Suffield | david.suffield&hp.com | 2006-05 | |
| David Vossel | dvossel&redhat.com | 2013-03-15 | |
| Devrex Labs | robert.friberg&devrex.se | 2013-03-29 | |
| Donald Welch | donald.welch&hp.com | 2006-05 | |
| Ed Odjaghian | edo&datacap.com | ||
| Eric Newcomer | eric.newcomer&iona.com | ||
| Gilberto Arnaiz | garnaiz&siebel.com | ||
| Helge-Frank Zimpel | helge.zimpel&baeurer.de | 2006-01 | |
| Henry Houh | hhouh&nbxcorp.com | ||
| Hirokazu Fujisawa | fujisawa&pfu.fujitsu.com | ||
| ITU-T | tsbsg16&itu.int | 2013-01-31 | |
| ITU-T TSB | ITU-T | tsbsg16&itu.int | 2013-01-31 |
| Jackie Lau | jackie.lau&compaq.com | ||
| Jerome Forissier | Jerome.Forissier&hp.com | 2005-12 | |
| Joseph Mathew | mjoseph&dosa.cisco.com | ||
| Keith Ansell | KeithA&fastfreenet.com | ||
| Leif Jakob | leif+iana&cube.ch | 2006-01 | |
| Matthew Asham | matthew&asham.ca | 2019-11-22 | |
| Michael Sharpe | iana-ports&netiq.com | 2010-09-14 | |
| Mike Hudack | mike&mhudack.com | ||
| Pat Galvin | pgalvin&databeam.com | ||
| Patty Ho | rimf&core.rose.hp.com | 2007-05 | |
| Paul Leach | paulleµsoft.com | ||
| Paul Snook | paul.snook&itheon.com | ||
| Pritham Shetty | pritham&andromedia.com | ||
| Robert Friberg | Devrex Labs | robert.friberg&devrex.se | 2013-03-29 |
| Santa Dasu | Santa_Dasu&quickeagle.com | ||
| Senthil Ponnuswamy | senthil&veritas.com | ||
| Software Horizons Inc. | oi2000&shorizons.com | ||
| Suzanne Lorrin | suzanne.lorrin&ansys.com | ||
| Tetsuharu Hanada | hanada&pfu.fujitsu.com | ||
| Tim Van Herck | VeloCloud Networks | herckt&velocloud.net | 2014-11-13 |
| Tomas Rajcan | trajcan&ipesoft.sk | ||
| VeloCloud Networks | ops&velocloud.net | 2014-11-13 | |
| Westell, Inc. | jronk&westell.com | ||
| Zygmunt Wiercioch | zyg&jetform.com |