Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| lan900_remote | 2395 | udp | LAN900 Remote | Tom Quinlan | Tom Quinlan | This entry is an alias to "lan900-remote". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| wusage | 2396 | tcp | Wusage | Thomas Boutell | Thomas Boutell | ||||||
| wusage | 2396 | udp | Wusage | Thomas Boutell | Thomas Boutell | ||||||
| ncl | 2397 | tcp | NCL | Robert Wiebe | Robert Wiebe | ||||||
| ncl | 2397 | udp | NCL | Robert Wiebe | Robert Wiebe | ||||||
| orbiter | 2398 | tcp | Orbiter | David Goldberg | David Goldberg | ||||||
| orbiter | 2398 | udp | Orbiter | David Goldberg | David Goldberg | ||||||
| fmpro-fdal | 2399 | tcp | FileMaker, Inc. - Data Access Layer | Clay Maeckel | Clay Maeckel | ||||||
| fmpro-fdal | 2399 | udp | FileMaker, Inc. - Data Access Layer | Clay Maeckel | Clay Maeckel | ||||||
| rnrp | 2423 | tcp | RNRP | Per Sahlqvist | Per Sahlqvist | ||||||
| rnrp | 2423 | udp | RNRP | Per Sahlqvist | Per Sahlqvist | ||||||
| call-sig-trans | 2517 | tcp | H.323 Annex E Call Control Signalling Transport | ITU-T | ITU-T TSB | 2013-01-31 | |||||
| call-sig-trans | 2517 | udp | H.323 Annex E Call Control Signalling Transport | ITU-T | ITU-T TSB | 2013-01-31 | |||||
| qke-llc-v3 | 2523 | tcp | Qke LLC V.3 | Joerg Niehoff | Joerg Niehoff | ||||||
| qke-llc-v3 | 2523 | udp | Qke LLC V.3 | Joerg Niehoff | Joerg Niehoff | ||||||
| lmdp | 2623 | tcp | LMDP | Ken Bailey | Ken Bailey | ||||||
| lmdp | 2623 | udp | LMDP | Ken Bailey | Ken Bailey | ||||||
| watchdog-nt | 2723 | tcp | WatchDog NT Protocol | Loftware | Glen Sansoucie | 2020-07-20 | |||||
| watchdog-nt | 2723 | udp | WatchDog NT Protocol | Loftware | Glen Sansoucie | 2020-07-20 | |||||
| cqg-netlan | 2823 | tcp | CQG Net/LAN | ||||||||
| cqg-netlan | 2823 | udp | CQG Net/LAN | ||||||||
| wta-wsp-wtp-s | 2923 | tcp | WTA-WSP-WTP-S | Sebastien Bury | Sebastien Bury | ||||||
| wta-wsp-wtp-s | 2923 | udp | WTA-WSP-WTP-S | Sebastien Bury | Sebastien Bury | ||||||
| magicnotes | 3023 | tcp | magicnotes | Karl Edwall | Karl Edwall | ||||||
| magicnotes | 3023 | udp | magicnotes | Karl Edwall | Karl Edwall | ||||||
| edix | 3123 | tcp | EDI Translation Protocol | William Randolph Royere III | William Randolph Royere III | ||||||
| edix | 3123 | udp | EDI Translation Protocol | William Randolph Royere III | William Randolph Royere III | ||||||
| digivote | 3223 | tcp | DIGIVOTE (R) Vote-Server | Christian Treczoks | Christian Treczoks | ||||||
| digivote | 3223 | udp | DIGIVOTE (R) Vote-Server | Christian Treczoks | Christian Treczoks | ||||||
| sftdst-port | 3230 | tcp | Software Distributor Port | Andrea Lanza | Andrea Lanza | 2014-02-21 | |||||
| sftdst-port | 3230 | udp | Software Distributor Port | Andrea Lanza | Andrea Lanza | 2014-02-21 | |||||
| vidigo | 3231 | tcp | VidiGo communication (previous was: Delta Solutions Direct) | Peter Ijkhout | Peter Ijkhout | ||||||
| vidigo | 3231 | udp | VidiGo communication (previous was: Delta Solutions Direct) | Peter Ijkhout | Peter Ijkhout | ||||||
| mdtp | 3232 | tcp | MDT port | 2012-02-21 | RFC 6513 | ||||||
| mdtp | 3232 | udp | MDT port | 2012-02-21 | RFC 6513 | ||||||
| whisker | 3233 | tcp | WhiskerControl main port | Rudolf Cardinal | Rudolf Cardinal | 2002-02 | |||||
| whisker | 3233 | udp | WhiskerControl main port | Rudolf Cardinal | Rudolf Cardinal | 2002-02 | |||||
| alchemy | 3234 | tcp | Alchemy Server | Mikhail Belov | Mikhail Belov | 2002-02 | |||||
| alchemy | 3234 | udp | Alchemy Server | Mikhail Belov | Mikhail Belov | 2002-02 | |||||
| mdap-port | 3235 | tcp | MDAP port | Johan Deleu | Johan Deleu | 2002-02 | |||||
| mdap-port | 3235 | udp | MDAP Port | Johan Deleu | Johan Deleu | 2002-02 | |||||
| apparenet-ts | 3236 | tcp | appareNet Test Server | ||||||||
| apparenet-ts | 3236 | udp | appareNet Test Server | ||||||||
| apparenet-tps | 3237 | tcp | appareNet Test Packet Sequencer | ||||||||
| apparenet-tps | 3237 | udp | appareNet Test Packet Sequencer | ||||||||
| apparenet-as | 3238 | tcp | appareNet Analysis Server | ||||||||
| apparenet-as | 3238 | udp | appareNet Analysis Server | ||||||||
| apparenet-ui | 3239 | tcp | appareNet User Interface | Fred Klassen | Fred Klassen | 2002-02 | |||||
| apparenet-ui | 3239 | udp | appareNet User Interface | Fred Klassen | Fred Klassen | 2002-02 | |||||
| xtrm | 3423 | tcp | xTrade Reliable Messaging | ||||||||
| xtrm | 3423 | udp | xTrade Reliable Messaging | ||||||||
| ipether232port | 3497 | tcp | ipEther232Port | Marcus Leufgen | Marcus Leufgen | 2002-05 | |||||
| ipether232port | 3497 | udp | ipEther232Port | Marcus Leufgen | Marcus Leufgen | 2002-05 | |||||
| odeumservlink | 3523 | tcp | Odeum Serverlink | Mads Peter Back | Mads Peter Back | 2002-06 | |||||
| odeumservlink | 3523 | udp | Odeum Serverlink | Mads Peter Back | Mads Peter Back | 2002-06 | |||||
| haipe-discover | 3623 | tcp | HAIPIS Dynamic Discovery | Mike Irani | Mike Irani | 2002-10 | |||||
| haipe-discover | 3623 | udp | HAIPIS Dynamic Discovery | Mike Irani | Mike Irani | 2002-10 | |||||
| sychrond | 3723 | tcp | Sychron Service Daemon | Robert Marinelli | Robert Marinelli | 2003-03 | |||||
| sychrond | 3723 | udp | Sychron Service Daemon | Robert Marinelli | Robert Marinelli | 2003-03 | |||||
| acp-conduit | 3823 | tcp | Compute Pool Conduit | ||||||||
| acp-conduit | 3823 | udp | Compute Pool Conduit | ||||||||
| 3864 | udp | Reserved | This entry has been removed on 2006-06-23. | ||||||||
| symb-sb-port | 3923 | tcp | Symbian Service Broker | Ian McDowall | Ian McDowall | 2003-11 | |||||
| symb-sb-port | 3923 | udp | Symbian Service Broker | Ian McDowall | Ian McDowall | 2003-11 | |||||
| esnm-zoning | 4023 | tcp | ESNM Zoning Port | Yong Cai | Yong Cai | ||||||
| esnm-zoning | 4023 | udp | ESNM Zoning Port | Yong Cai | Yong Cai | ||||||
| z-wave | 4123 | tcp | Z-Wave Protocol | Sigma Designs, Inc. | Anders Brandt; Mary Miller | 2007-02 | 2012-11-08 | ||||
| z-wave | 4123 | udp | Z-Wave Protocol | Sigma Designs, Inc. | Anders Brandt; Mary Miller | 2007-02 | 2012-11-08 | ||||
| trim-ice | 4323 | tcp | TRIM ICE Service | Siva Poobalasingam | Siva Poobalasingam | 2007-02 | |||||
| trim-ice | 4323 | udp | TRIM ICE Service | Siva Poobalasingam | Siva Poobalasingam | 2007-02 | |||||
| thingkit | 4423 | tcp | thingkit secure mesh | thingkit, inc. | Chris Bell | 2016-06-27 | |||||
| 4423 | udp | Reserved | |||||||||
| htuilsrv | 5023 | tcp | Htuil Server for PLD2 | Dennis Reinhardt | Dennis Reinhardt | ||||||
| htuilsrv | 5023 | udp | Htuil Server for PLD2 | Dennis Reinhardt | Dennis Reinhardt | ||||||
| hpvirtgrp | 5223 | tcp | HP Virtual Machine Group Management | John Williams | John Williams | 2007-06 | |||||
| hpvirtgrp | 5223 | udp | HP Virtual Machine Group Management | John Williams | John Williams | 2007-06 | |||||
| jaxflow-data | 5230 | tcp | JaxMP RealFlow application and protocol data | JaxMP | Stephen Hull | 2014-08-15 | |||||
| 5230 | udp | Reserved | |||||||||
| crusecontrol | 5231 | tcp | Remote Control of Scan Software for Cruse Scanners | Cruse Spezialmaschinen GmbH | Christof J. Reetz | 2014-08-15 | |||||
| 5231 | udp | Reserved | |||||||||
| csedaemon | 5232 | tcp | Cruse Scanning System Service | Christof J. Reetz | Christof J. Reetz | 2011-03-09 | |||||
| 5232 | udp | Reserved | |||||||||
| enfs | 5233 | tcp | Etinnae Network File Service | Chris Peel | Chris Peel | 2011-03-09 | |||||
| 5233 | udp | Reserved | |||||||||
| eenet | 5234 | tcp | EEnet communications | Helmut Giritzer | Helmut Giritzer | 2005-11 | |||||
| eenet | 5234 | udp | EEnet communications | Helmut Giritzer | Helmut Giritzer | 2005-11 | |||||
| galaxy-network | 5235 | tcp | Galaxy Network Service | Michael Andre | Michael Andre | 2007-10-04 | |||||
| galaxy-network | 5235 | udp | Galaxy Network Service | Michael Andre | Michael Andre | 2007-10-04 | |||||
| padl2sim | 5236 | tcp | |||||||||
| padl2sim | 5236 | udp | |||||||||
| mnet-discovery | 5237 | tcp | m-net discovery | Andy Crick | Andy Crick | 2007-11-13 | |||||
| mnet-discovery | 5237 | udp | m-net discovery | Andy Crick | Andy Crick | 2007-11-13 | |||||
| 5238-5241 | Unassigned | ||||||||||
| virtualuser | 5423 | tcp | VIRTUALUSER | Chad Williams | Chad Williams | ||||||
| virtualuser | 5423 | udp | VIRTUALUSER | Chad Williams | Chad Williams | ||||||
| coap | 5683 | tcp | Constrained Application Protocol (CoAP) | IESG | IETF Chair | 2017-12-22 | RFC 8323 | ||||
| coaps | 5684 | tcp | Constrained Application Protocol (CoAP) | IESG | IETF Chair | 2017-12-22 | RFC 7301; RFC 8323 | ||||
| omhs | 5723 | tcp | Operations Manager - Health Service | Gerardo Dilillo | Gerardo Dilillo | 2006-08 | |||||
| omhs | 5723 | udp | Operations Manager - Health Service | Gerardo Dilillo | Gerardo Dilillo | 2006-08 | |||||
| backup-express | 6123 | tcp | Backup Express | Catalogic Software, Inc. | Chi Shih Chang | 2008-03-19 | 2015-02-04 | ||||
| backup-express | 6123 | udp | Backup Express | Catalogic Software, Inc. | Chi Shih Chang | 2008-03-19 | 2015-02-04 |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Anders Brandt | Sigma Designs, Inc. | Anders_Brandt&sigmadesigns.com | 2012-11-08 |
| Andrea Lanza | andrea&andrealanza.eu | 2014-02-21 | |
| Andy Crick | acrick&haascnc.com | 2007-11-13 | |
| Catalogic Software, Inc. | cchang&catalogicsoftware.com | 2015-02-04 | |
| Chad Williams | chad&apple.com | ||
| Chi Shih Chang | Catalogic Software, Inc. | cchang&catalogicsoftware.com | 2015-02-04 |
| Chris Bell | cb&thingkit.co | 2016-06-27 | |
| Chris Peel | chrispeel.gsi&googlemail.com | 2011-03-09 | |
| Christian Treczoks | ct&braehler.com | ||
| Christof J. Reetz | cjr&netplan.de | 2011-03-09 | |
| Christof J. Reetz | Cruse Spezialmaschinen GmbH | cjr&crusescanner.com | 2014-08-15 |
| Clay Maeckel | clay&claris.com | 2023-09-12 | |
| Cruse Spezialmaschinen GmbH | cjr&crusescanner.com | 2014-08-15 | |
| David Goldberg | dgoldberg&callisto.com | ||
| Dennis Reinhardt | DennisR&dair.com | ||
| Fred Klassen | fklassen&jaalam.com | 2002-02 | |
| Gerardo Dilillo | MOMIANAµsoft.com | 2006-08 | |
| Glen Sansoucie | Loftware | gsansoucie&loftware.com | 2020-07-20 |
| Helmut Giritzer | helmut.giritzer&epluse.at | 2005-11 | |
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| ITU-T | tsbsg16&itu.int | 2013-01-31 | |
| ITU-T TSB | ITU-T | tsbsg16&itu.int | 2013-01-31 |
| Ian McDowall | ian.mcdowall&symbian.com | 2003-11 | |
| JaxMP | shull&jaxmp.com | 2014-08-15 | |
| Joerg Niehoff | joerg.niehoff&alcatel-ke.de | ||
| Johan Deleu | johan.deleu&alcatel.be | 2002-02 | |
| John Williams | John.H.Williams&hp.com | 2007-06 | |
| Karl Edwall | karl&magicnotes.com | ||
| Ken Bailey | kbailey&rockettalk.com | ||
| Loftware | gsansoucie&loftware.com | 2020-07-20 | |
| Mads Peter Back | iana-contact&webhouse.dk | 2002-06 | |
| Marcus Leufgen | leufgen&ipcas.de | 2002-05 | |
| Mary Miller | Sigma Designs, Inc. | Mary_Miller&sigmadesigns.com | 2012-11-08 |
| Michael Andre | mandre&gatewayticketing.com | 2007-10-04 | |
| Mike Irani | irani_mike&bah.com | 2002-10 | |
| Mikhail Belov | mikhail&imrgold.com | 2002-02 | |
| Per Sahlqvist | psahlqvi&sw.seisy.abb.se | ||
| Peter Ijkhout | peter&deltasolutions.nl | ||
| Robert Marinelli | bob&sychron.com | 2003-03 | |
| Robert Wiebe | crw010&email.mot.com | ||
| Rudolf Cardinal | rudolf&pobox.com | 2002-02 | |
| Sebastien Bury | WAP Forum | sebastien.bury&art.alcatel.fr | |
| Sigma Designs, Inc. | pr&sdesigns.com | 2012-11-08 | |
| Siva Poobalasingam | Siva.Poobalasingam&towersoft.com.au | 2007-02 | |
| Stephen Hull | JaxMP | shull&jaxmp.com | 2014-08-15 |
| thingkit, inc. | cb&thingkit.co | 2016-06-27 | |
| Thomas Boutell | boutell&boutell.com | ||
| Tom Quinlan | tquinlan&digitechinc.com | ||
| William Randolph Royere III | william&royere.net | ||
| Yong Cai | ycai&emc.com |