Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
esp-encap 2797 udp esp-encap Jorn Sierwald Jorn Sierwald
tmesis-upshot 2798 tcp TMESIS-UPShot Brian Schenkenberger Brian Schenkenberger
tmesis-upshot 2798 udp TMESIS-UPShot Brian Schenkenberger Brian Schenkenberger
icon-discover 2799 tcp ICON Discover Alexander Falk Alexander Falk
icon-discover 2799 udp ICON Discover Alexander Falk Alexander Falk
slc-ctrlrloops 2827 tcp slc ctrlrloops Erwin Hogeweg Erwin Hogeweg
slc-ctrlrloops 2827 udp slc ctrlrloops Erwin Hogeweg Erwin Hogeweg
unimobilectrl 2927 tcp UNIMOBILECTRL Vikas Vikas
unimobilectrl 2927 udp UNIMOBILECTRL Vikas Vikas
LiebDevMgmt-C 3027 tcp LiebDevMgmt_C

IANA assigned this well-formed service name as a replacement for "LiebDevMgmt_C".
LiebDevMgmt_C 3027 tcp LiebDevMgmt_C This entry is an alias to "LiebDevMgmt-C". This entry is now historic, not usable for use with many common service discovery mechanisms.
LiebDevMgmt-C 3027 udp LiebDevMgmt_C

IANA assigned this well-formed service name as a replacement for "LiebDevMgmt_C".
LiebDevMgmt_C 3027 udp LiebDevMgmt_C This entry is an alias to "LiebDevMgmt-C". This entry is now historic, not usable for use with many common service discovery mechanisms.
ctx-bridge 3127 tcp CTX Bridge Port Alexander Dubrovsky Alexander Dubrovsky
ctx-bridge 3127 udp CTX Bridge Port Alexander Dubrovsky Alexander Dubrovsky
dwnmshttp 3227 tcp DiamondWave NMS Server
dwnmshttp 3227 udp DiamondWave NMS Server
verismart 3270 tcp Verismart Jay Weber Jay Weber
verismart 3270 udp Verismart Jay Weber Jay Weber
csoft-prev 3271 tcp CSoft Prev Port Nedelcho Stanev Nedelcho Stanev
csoft-prev 3271 udp CSoft Prev Port Nedelcho Stanev Nedelcho Stanev
user-manager 3272 tcp Fujitsu User Manager Yukihiko Sakurai Yukihiko Sakurai
user-manager 3272 udp Fujitsu User Manager Yukihiko Sakurai Yukihiko Sakurai
sxmp 3273 tcp Simple Extensible Multiplexed Protocol admin admin
sxmp 3273 udp Simple Extensible Multiplexed Protocol admin admin
ordinox-server 3274 tcp Ordinox Server Denis Ducharme Denis Ducharme
ordinox-server 3274 udp Ordinox Server Denis Ducharme Denis Ducharme
samd 3275 tcp SAMD Edgar Circenis Edgar Circenis
samd 3275 udp SAMD Edgar Circenis Edgar Circenis
maxim-asics 3276 tcp Maxim ASICs Dave Inman Dave Inman
maxim-asics 3276 udp Maxim ASICs Dave Inman Dave Inman
awg-proxy 3277 tcp AWG Proxy Alex McDonald Alex McDonald
awg-proxy 3277 udp AWG Proxy Alex McDonald Alex McDonald
lkcmserver 3278 tcp LKCM Server Javier Jimenez Javier Jimenez
lkcmserver 3278 udp LKCM Server Javier Jimenez Javier Jimenez
admind 3279 tcp admind Jeff Haynes Jeff Haynes
admind 3279 udp admind Jeff Haynes Jeff Haynes
bbars 3327 tcp BBARS Lou Harris Lou Harris
bbars 3327 udp BBARS Lou Harris Lou Harris
websphere-snmp 3427 tcp WebSphere SNMP Richard Mills Richard Mills 2002-02
websphere-snmp 3427 udp WebSphere SNMP Richard Mills Richard Mills 2002-02
nut 3493 tcp Network UPS Tools Network UPS Tools Project Evgeny Klimov 2002-05 2022-05-18 RFC 9271
beserver-msg-q 3527 tcp VERITAS Backup Exec Server Katherine Wattwood Katherine Wattwood 2002-06
beserver-msg-q 3527 udp VERITAS Backup Exec Server Katherine Wattwood Katherine Wattwood 2002-06
jamserverport 3627 tcp Jam Server Port Art Pope Art Pope 2002-10
jamserverport 3627 udp Jam Server Port Art Pope Art Pope 2002-10
e-mdu 3727 tcp Ericsson Mobile Data Unit
e-mdu 3727 udp Ericsson Mobile Data Unit
netmpi 3827 tcp Netadmin Systems MPI service Göran Runfeldt Göran Runfeldt 2007-07-10
netmpi 3827 udp Netadmin Systems MPI service Göran Runfeldt Göran Runfeldt 2007-07-10
natdataservice 3927 tcp ScsTsr Ghanshyam Patel Ghanshyam Patel 2003-11
natdataservice 3927 udp ScsTsr Ghanshyam Patel Ghanshyam Patel 2003-11
bxp 4027 tcp bitxpress Morgan Doyle Morgan Doyle
bxp 4027 udp bitxpress Morgan Doyle Morgan Doyle
unikeypro 4127 tcp NetUniKeyServer Raymond Chaw Raymond Chaw 2007-05
unikeypro 4127 udp NetUniKeyServer Raymond Chaw Raymond Chaw 2007-05
jaxer-web 4327 tcp Jaxer Web Protocol Uri Sarid Uri Sarid 2008-01-07
jaxer-web 4327 udp Jaxer Web Protocol Uri Sarid Uri Sarid 2008-01-07
drizzle 4427 tcp Drizzle database server Elliot Murphy Elliot Murphy 2008-07-09
4427 udp Reserved
fcis 4727 tcp F-Link Client Information Service
fcis-disc 4727 udp F-Link Client Information Service Discovery Makoto Zukawa Makoto Zukawa 2010-10-15
htcp 4827 tcp HTCP Paul Vixie Paul Vixie
htcp 4827 udp HTCP Paul Vixie Paul Vixie
strexec-s 5027 tcp Storix I/O daemon (stat) Storix Inc. David Huffman 2005-08
strexec-s 5027 udp Storix I/O daemon (stat) Storix Inc. David Huffman 2005-08
perfd 5227 tcp HP System Performance Metric Service Chris Bertin Chris Bertin 2009-05-19
perfd 5227 udp HP System Performance Metric Service Chris Bertin Chris Bertin 2009-05-19
cartographerxmp 5270 tcp Cartographer XMP Bobby Krupczak Bobby Krupczak 2008-04-03 2011-08-31
cartographerxmp 5270 udp Cartographer XMP Bobby Krupczak Bobby Krupczak 2008-04-03 2011-08-31
cuelink 5271 tcp StageSoft CueLink messaging Todd Pichler Todd Pichler 2010-03-26
cuelink-disc 5271 udp StageSoft CueLink discovery Todd Pichler Todd Pichler 2010-03-26
pk 5272 tcp PK Patrick Kara Patrick Kara
pk 5272 udp PK Patrick Kara Patrick Kara
5273-5279 Unassigned
sco-peer-tta 5427 tcp SCO-PEER-TTA Andrew Shire Andrew Shire
sco-peer-tta 5427 udp SCO-PEER-TTA Andrew Shire Andrew Shire
ninaf 5627 tcp Node Initiated Network Association Forma Thomas Scholl Thomas Scholl 2006-03
ninaf 5627 udp Node Initiated Network Association Forma Thomas Scholl Thomas Scholl 2006-03
asgenf 5727 tcp ASG Event Notification Framework Arman Bedonian Arman Bedonian 2009-07-15
5727 udp Reserved
6270-6299 Unassigned
6327-6342 Unassigned
nexgen 6627 tcp Allied Electronics NeXGen Lou Seitchik Lou Seitchik 2005-08
nexgen 6627 udp Allied Electronics NeXGen Lou Seitchik Lou Seitchik 2005-08
7027-7029 Unassigned
7124-7127 Unassigned
ramp 7227 tcp Registry A & M Protocol John Havard John Havard 2003-11
ramp 7227 udp Registry A & M Protocol John Havard John Havard 2003-11
7263-7271 Unassigned
watchme-7272 7272 tcp WatchMe Monitoring 7272 Oliver Heinz Oliver Heinz 2005-08
watchme-7272 7272 udp WatchMe Monitoring 7272 Oliver Heinz Oliver Heinz 2005-08
oma-rlp 7273 tcp OMA Roaming Location Larry A. Young Larry A. Young 2005-08
oma-rlp 7273 udp OMA Roaming Location Larry A. Young Larry A. Young 2005-08
oma-rlp-s 7274 tcp OMA Roaming Location SEC Larry A. Young Larry A. Young 2005-08
oma-rlp-s 7274 udp OMA Roaming Location SEC Larry A. Young Larry A. Young 2005-08
oma-ulp 7275 tcp OMA UserPlane Location Larry A. Young Larry A. Young 2006-02
oma-ulp 7275 udp OMA UserPlane Location Larry A. Young Larry A. Young 2006-02
oma-ilp 7276 tcp OMA Internal Location Protocol Khiem Tran Khiem Tran 2007-11-06
oma-ilp 7276 udp OMA Internal Location Protocol Khiem Tran Khiem Tran 2007-11-06
oma-ilp-s 7277 tcp OMA Internal Location Secure Protocol Khiem Tran Khiem Tran 2007-11-06

Contact Information

Name Organization Contact URI Last Updated
Alex McDonald alexm&an.hp.com
Alexander Dubrovsky dubrovsky_alex&emc.com
Alexander Falk falk&icon.at
Andrew Shire sndrewsh&sco.com
Arman Bedonian Arman.Bedonian&asg.com 2009-07-15
Art Pope apope&sarnoff.com 2002-10
Bobby Krupczak rdk&krupczak.org 2008-04-03
Brian Schenkenberger VAXman&tmesis.com
Chris Bertin chris.bertin&hp.com 2009-05-19
David Huffman sba&storix.com 2016-03-22
Dave Inman davei&mxim.com
Denis Ducharme dducharme&softek.com
Edgar Circenis ec&fc.hp.com
Elliot Murphy elliot.murphy&gmail.com 2008-07-09
Erwin Hogeweg erwin&airtech.demon.nl
Evgeny Klimov jimklimov+nut&gmail.com 2020-12-16
Göran Runfeldt goran&netadmin.se 2007-07-10
Ghanshyam Patel gpatel&natinc.com 2003-11
Javier Jimenez
Jay Weber weber&vfi.com
Jeff Haynes haynes&chistech.com
John Havard jh&hxe.us 2003-11
Jorn Sierwald joern.sierwald&datafellows.com
Katherine Wattwood katherine.wattwood&veritas.com 2002-06
Khiem Tran Khiem.Tran&andrew.com 2007-11-06
Larry A. Young Larry.A.Young&mail.sprint.com 2005-08
Larry A. Young Larry.A.Young&sprint.com 2006-02
Lou Harris lharris&outlx.bandl.com
Lou Seitchik lou&alliedelectronics.com 2005-08
Makoto Zukawa zukawa&jp.fujitsu.com 2010-10-15
Morgan Doyle morgan&mpt.ie
Nedelcho Stanev decho&iname.com
Network UPS Tools Project iana&networkupstools.org 2020-12-16
Oliver Heinz heinz&arago.de 2005-08
Patrick Kara Patrick&eba.net
Paul Vixie paul&vix.com
Raymond Chaw Raymond&esecutech.com 2007-05
Richard Mills ramills&us.ibm.com 2002-02
Storix Inc. sba&storix.com 2016-03-22
Thomas Scholl tscholl&spf.is-is.ca 2006-03
Todd Pichler todd.pichler&stagesoft.com 2010-03-26
Uri Sarid uri&aptana.com 2008-01-22
Vikas vikas&graycell.com
Yukihiko Sakurai y-sakurai&ael.fujitsu.co.jp
admin iana&sightlinesystems.com