Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| ntz-p2p-storage | 6778 | tcp | netTsunami p2p storage system | Tomahawk Holdings Ltd | Sagara Wijetunga | 2013-05-01 | |||||
| 6778 | udp | Reserved | |||||||||
| 6779-6783 | Unassigned | ||||||||||
| 6784 | tcp | Reserved | |||||||||
| bfd-lag | 6784 | udp | Bidirectional Forwarding Detection (BFD) on Link Aggregation Group (LAG) Interfaces | IESG | IETF BFD Working Group Chairs | 2012-11-08 | 2014-01-09 | RFC 7130 | |||
| dgpf-exchg | 6785 | tcp | DGPF Individual Exchange | Thomas Weise | Thomas Weise | 2006-04 | |||||
| dgpf-exchg | 6785 | udp | DGPF Individual Exchange | Thomas Weise | Thomas Weise | 2006-04 | |||||
| smc-jmx | 6786 | tcp | Sun Java Web Console JMX | Bill Edwards | Bill Edwards | 2005-08 | |||||
| smc-jmx | 6786 | udp | Sun Java Web Console JMX | Bill Edwards | Bill Edwards | 2005-08 | |||||
| smc-admin | 6787 | tcp | Sun Web Console Admin | Bill Edwards | Bill Edwards | 2005-08 | |||||
| smc-admin | 6787 | udp | Sun Web Console Admin | Bill Edwards | Bill Edwards | 2005-08 | |||||
| smc-http | 6788 | tcp | SMC-HTTP | Ratnadeep Bhattacharjee | Ratnadeep Bhattacharjee | 2002-11 | |||||
| smc-http | 6788 | udp | SMC-HTTP | Ratnadeep Bhattacharjee | Ratnadeep Bhattacharjee | 2002-11 | |||||
| radg | 6789 | tcp | GSS-API for the Oracle Remote Administration Daemon | Oracle | Shawn Emery | 2002-08 | 2016-09-15 | ||||
| 6789 | udp | Reserved | 2002-08 | 2016-09-15 | |||||||
| hnmp | 6790 | tcp | HNMP | Jude George | Jude George | ||||||
| hnmp | 6790 | udp | HNMP | Jude George | Jude George | ||||||
| hnm | 6791 | tcp | Halcyon Network Manager | Fortra | Henriët Wilkinson | 2005-05 | 2023-05-24 | ||||
| hnm | 6791 | udp | Halcyon Network Manager | Fortra | Henriët Wilkinson | 2005-05 | 2023-05-24 | ||||
| 6792-6800 | Unassigned | ||||||||||
| 6851-6867 | Unassigned | ||||||||||
| 6967-6968 | Unassigned | ||||||||||
| casrmagent | 7167 | tcp | CA SRM Agent | Venkata Krishna | Venkata Krishna | 2010-02-24 | |||||
| 7167 | udp | Reserved | |||||||||
| 7567-7568 | Unassigned | ||||||||||
| 7664-7667 | Unassigned | ||||||||||
| 7669-7671 | Unassigned | ||||||||||
| imqstomp | 7672 | tcp | iMQ STOMP Server | Amy Kang | Amy Kang | 2009-03-10 | |||||
| 7672 | udp | Reserved | |||||||||
| imqstomps | 7673 | tcp | iMQ STOMP Server over SSL | Amy Kang | Amy Kang | 2009-03-10 | |||||
| 7673 | udp | Reserved | |||||||||
| imqtunnels | 7674 | tcp | iMQ SSL tunnel | Shailesh S. Bavadekar | Shailesh S. Bavadekar | 2002-04 | |||||
| imqtunnels | 7674 | udp | iMQ SSL tunnel | Shailesh S. Bavadekar | Shailesh S. Bavadekar | 2002-04 | |||||
| imqtunnel | 7675 | tcp | iMQ Tunnel | Shailesh S. Bavadekar | Shailesh S. Bavadekar | 2002-04 | |||||
| imqtunnel | 7675 | udp | iMQ Tunnel | Shailesh S. Bavadekar | Shailesh S. Bavadekar | 2002-04 | |||||
| imqbrokerd | 7676 | tcp | iMQ Broker Rendezvous | Joseph Di Pol | Joseph Di Pol | 2002-04 | |||||
| imqbrokerd | 7676 | udp | iMQ Broker Rendezvous | Joseph Di Pol | Joseph Di Pol | 2002-04 | |||||
| sun-user-https | 7677 | tcp | Sun App Server - HTTPS | Abhijit Kumar | Abhijit Kumar | 2005-11 | |||||
| sun-user-https | 7677 | udp | Sun App Server - HTTPS | Abhijit Kumar | Abhijit Kumar | 2005-11 | |||||
| 7678-7679 | Unassigned | ||||||||||
| supercell | 7967 | tcp | Supercell | Kevin Nakagawa | Kevin Nakagawa | ||||||
| supercell | 7967 | udp | Supercell | Kevin Nakagawa | Kevin Nakagawa | ||||||
| aero | 8060 | udp | Asymmetric Extended Route Optimization (AERO) | IESG | IETF Chair | RFC 6706 | |||||
| infi-async | 8067 | tcp | Infinidat async replication | INFINIDAT | Eldar Kleiner | 2015-05-01 | |||||
| 8067 | udp | Reserved | |||||||||
| 8267-8269 | Unassigned | ||||||||||
| dof-tunnel | 8567 | tcp | DOF Tunneling Protocol | OpenDOF | Bryant Eastham | 2005-08 | 2015-04-23 | ||||
| dof-tunnel | 8567 | udp | DOF Tunneling Protocol | OpenDOF | Bryant Eastham | 2005-08 | 2015-04-23 | ||||
| 8667 | Unassigned | ||||||||||
| 8669-8674 | Unassigned | ||||||||||
| msi-cps-rm | 8675 | tcp | Motorola Solutions Customer Programming Software for Radio Management | Motorola Solutions, Inc. | Jenish Amin | 2012-03-14 | |||||
| msi-cps-rm-disc | 8675 | udp | Motorola Solutions Customer Programming Software for Radio Management Discovery | Motorola Solutions, Inc. | Jenish Amin | 2012-03-14 | |||||
| 8676-8685 | Unassigned | ||||||||||
| core-of-source | 8767 | tcp | Online mobile multiplayer game | Alt Solve Sdn Bhd | Almaz Hong | 2019-07-24 | |||||
| 8767 | udp | Reserved | |||||||||
| xmms2 | 9667 | tcp | Cross-platform Music Multiplexing System | Juho Vähä-Herttua | Juho Vähä-Herttua | 2009-04-14 | |||||
| xmms2 | 9667 | udp | Cross-platform Music Multiplexing System | Juho Vähä-Herttua | Juho Vähä-Herttua | ||||||
| kca-service | 9878 | udp | The KX509 Kerberized Certificate Issuance Protocol in Use in 2012 | IESG | IETF Chair | 2012-07-12 | RFC 6717 | Historically, this service has been referred to as "kca_service", but this service name does not meet the registry requirements. | |||
| 9967-9977 | Unassigned | ||||||||||
| atm-uhas | 11367 | tcp | ATM UHAS | Todd Barker | Todd Barker | ||||||
| atm-uhas | 11367 | udp | ATM UHAS | Todd Barker | Todd Barker | ||||||
| sysinfo-sp | 11967 | tcp | SysInfo Service Protocol | Mike Cooper | Mike Cooper | 2003-03 | |||||
| sysinfo-sp | 11967 | udp | SysInfo Service Protocol | Mike Cooper | Mike Cooper | 2003-03 | |||||
| 12122-12167 | Unassigned | ||||||||||
| netserialext3 | 16367 | tcp | Network Serial Extension Ports Three | Michael J Hoy | Michael J Hoy | ||||||
| netserialext3 | 16367 | udp | Network Serial Extension Ports Three | Michael J Hoy | Michael J Hoy | ||||||
| 16667-16788 | Unassigned | ||||||||||
| cadsisvr | 16789 | tcp | This server provides callable services to mainframe External Security Managers from any TCP/IP platform | Broadcom | Thomas Sakowski | 2015-06-02 | 2023-03-29 | ||||
| 16789 | udp | Reserved | |||||||||
| 16790-16899 | Unassigned | ||||||||||
| 18636-18667 | Unassigned | ||||||||||
| nfsrdma | 20049 | tcp | Network File System (NFS) over RDMA | 2017-09-05 | RFC 8267 | ||||||
| nfsrdma | 20049 | udp | Network File System (NFS) over RDMA | 2017-09-05 | RFC 8267 | ||||||
| nfsrdma | 20049 | sctp | Network File System (NFS) over RDMA | 2017-09-05 | RFC 8267 | ||||||
| tolfab | 20167 | tcp | TOLfab Data Change | Pierre Couderc | Pierre Couderc | 2006-03 | |||||
| tolfab | 20167 | udp | TOLfab Data Change | Pierre Couderc | Pierre Couderc | 2006-03 | |||||
| track | 20670 | tcp | Track | Michael Sweet | Michael Sweet | ||||||
| track | 20670 | udp | Track | Michael Sweet | Michael Sweet | ||||||
| 20671-20809 | Unassigned | ||||||||||
| 24667-24675 | Unassigned | ||||||||||
| canditv | 24676 | tcp | Canditv Message Service | Gary Aston | Gary Aston | 2009-03-10 | |||||
| canditv | 24676 | udp | Canditv Message Service | Gary Aston | Gary Aston | 2009-03-10 | |||||
| flashfiler | 24677 | tcp | FlashFiler | Ben Oram | Ben Oram | ||||||
| flashfiler | 24677 | udp | FlashFiler | Ben Oram | Ben Oram | ||||||
| proactivate | 24678 | tcp | Turbopower Proactivate | Ben Oram | Ben Oram | ||||||
| proactivate | 24678 | udp | Turbopower Proactivate | Ben Oram | Ben Oram | ||||||
| 24679 | Unassigned | ||||||||||
| otmp | 29167 | tcp | ObTools Message Protocol | Paul Clark | Paul Clark | 2006-02 | |||||
| otmp | 29167 | udp | ObTools Message Protocol | Paul Clark | Paul Clark | 2006-02 | |||||
| filenet-powsrm | 32767 | tcp | FileNet BPM WS-ReliableMessaging Client | Chris Adkins | Chris Adkins | 2006-08 | |||||
| filenet-powsrm | 32767 | udp | FileNet BPM WS-ReliableMessaging Client | Chris Adkins | Chris Adkins | 2006-08 | |||||
| dhanalakshmi | 34567 | tcp | dhanalakshmi.org EDI Service | Girish Gopalakrishnan | Girish Gopalakrishnan | 2010-04-20 | |||||
| edi_service | 34567 | udp | dhanalakshmi.org EDI Service | Girish Gopalakrishnan | Girish Gopalakrishnan | 2016-10-26 | |||||
| 34967-34979 | Unassigned | ||||||||||
| mapx | 36700 | tcp | MapX communication | MicroTechniX | Yarochkin Michail | 2014-10-13 | |||||
| 36700 | udp | Reserved | |||||||||
| 36701-36864 | Unassigned | ||||||||||
| 45515-45677 | Unassigned | ||||||||||
| eba | 45678 | tcp | EBA PRISE | Patrick Kara | Patrick Kara | ||||||
| eba | 45678 | udp | EBA PRISE | Patrick Kara | Patrick Kara | ||||||
| 45679-45823 | Unassigned |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Abhijit Kumar | as-iana-ports&sun.com | 2005-11 | |
| Almaz Hong | almaz.hong&altsolve.com | 2019-07-24 | |
| Alt Solve Sdn Bhd | support&altsolve.com | 2019-07-24 | |
| Amy Kang | amy.kang&sun.com | 2009-03-10 | |
| Ben Oram | beno&turbopower.com | ||
| IETF BFD Working Group Chairs | bfd-chairs&tools.ietf.org | 2014-01-09 | |
| Bill Edwards | bill.edwards&sun.com | 2005-08 | |
| Broadcom | thomas.sakowski&broadcom.com | 2023-03-29 | |
| Bryant Eastham | OenDOF | protocol&opendof.org | 2015-04-23 |
| Chris Adkins | cadkins&filenet.com | 2006-10 | |
| Eldar Kleiner | INFINIDAT | eldark&infinidat.com | 2015-05-01 |
| Fortra | info&fortra.com | 2023-05-24 | |
| Gary Aston | Gary.Aston&datadrivenlogistics.com | 2009-03-10 | |
| Girish Gopalakrishnan | girish&shankar-software.org | 2016-10-26 | |
| Henriët Wilkinson | henriet.wilkinson&fortra.com | 2023-05-24 | |
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| INFINIDAT | info&infinidat.com | 2015-05-01 | |
| Jenish Amin | Motorola Solutions, Inc. | jenish&motorolasolutions.com | 2012-03-14 |
| Joseph Di Pol | joe.dipol&sun.com | 2002-04 | |
| Jude George | jude&nas.nasa.gov | ||
| Juho Vähä-Herttua | juhovh&iki.fi | 2009-04-14 | |
| Kevin Nakagawa | nakagawa&sigsci.com | ||
| Michael J Hoy | mhoy&canberra-abq.com | ||
| Michael Sweet | msweet&ctr.nawcad.navy.mil | ||
| MicroTechniX | Infoµtechnix.com | 2014-10-13 | |
| Mike Cooper | mcooper&magnicomp.com | 2003-03 | |
| Motorola Solutions, Inc. | jenish&motorolasolutions.com | 2012-03-14 | |
| OpenDOF | protocol&opendof.org | 2015-04-23 | |
| Oracle | shawn.emery&oracle.com | 2016-09-15 | |
| Patrick Kara | Patrick&eba.net | ||
| Paul Clark | paul&xmill.com | 2006-02 | |
| Pierre Couderc | pcouderc&tol.fr | 2006-03 | |
| Ratnadeep Bhattacharjee | ratnadeep.bhattacharjee&sun.com | 2002-11 | |
| Sagara Wijetunga | Tomahawk Holdings Ltd | sagara&tomahawk.lk | 2013-05-01 |
| Shailesh S. Bavadekar | shailesh.bavadekar&sun.com | 2002-04 | |
| Shawn Emery | shawn.emery&oracle.com | 2016-09-15 | |
| Thomas Sakowski | Broadcom | thomas.sakowski&broadcom.com | 2023-03-29 |
| Thomas Weise | weise&vs.uni-kassel.de | 2006-04 | |
| Todd Barker | toddba&attachmate.com | ||
| Tomahawk Holdings Ltd | sagara&tomahawk.lk | 2013-05-01 | |
| Venkata Krishna | VenkataKrishna.Bezawada&ca.com | 2010-02-24 | |
| Yarochkin Michail | MicroTechniX | Michail.Yarochkinµtechnix.com | 2014-10-13 |