Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| openremote-ctrl | 8688 | tcp | OpenRemote Controller HTTP/REST | OpenRemote, Inc. | Juha Lindfors | 2012-12-18 | |||||
| 8688 | udp | Reserved | |||||||||
| 8689-8698 | Unassigned | ||||||||||
| sandpolis | 8768 | tcp | Sandpolis Server | Tyler Cook | Tyler Cook | 2019-11-22 | |||||
| 8768 | udp | Reserved | |||||||||
| tec5-sdctp | 9668 | tcp | tec5 Spectral Device Control Protocol | Michael Muth | Michael Muth | 2009-05-11 | |||||
| tec5-sdctp | 9668 | udp | tec5 Spectral Device Control Protocol | Michael Muth | Michael Muth | 2009-05-11 | |||||
| 11368-11370 | Unassigned | ||||||||||
| 11968-11970 | Unassigned | ||||||||||
| cawas | 12168 | tcp | CA Web Access Service | Jon Press | Jon Press | 2005-08 | |||||
| cawas | 12168 | udp | CA Web Access Service | Jon Press | Jon Press | 2005-08 | |||||
| netserialext4 | 16368 | tcp | Network Serial Extension Ports Four | Michael J Hoy | Michael J Hoy | ||||||
| netserialext4 | 16368 | udp | Network Serial Extension Ports Four | Michael J Hoy | Michael J Hoy | ||||||
| 16790-16899 | Unassigned | ||||||||||
| vdmmesh | 18668 | tcp | Manufacturing Execution Systems Mesh Communication | Van Doren MES | Edwin van de Burgt | 2016-10-31 | |||||
| vdmmesh-disc | 18668 | udp | Manufacturing Execution Systems Mesh Communication | Van Doren MES | Edwin van de Burgt | 2016-10-31 | |||||
| 18669-18768 | Unassigned | ||||||||||
| 20168-20201 | Unassigned | ||||||||||
| tcc-http | 24680 | tcp | TCC User HTTP Service | Brian Kennedy | Brian Kennedy | 2006-08 | |||||
| tcc-http | 24680 | udp | TCC User HTTP Service | Brian Kennedy | Brian Kennedy | 2006-08 | |||||
| 24681-24726 | Unassigned | ||||||||||
| 29168 | tcp | Reserved | |||||||||
| 29168 | udp | Reserved | |||||||||
| sbcap | 29168 | sctp | SBcAP in 3GPP | Dongwook Kim | Dongwook Kim | 2009-06-11 | |||||
| 31621-31684 | Unassigned | ||||||||||
| dsx-monitor | 31685 | tcp | DS Expert Monitor IANA assigned this well-formed service name as a replacement for "dsx_monitor". |
John Lowery | John Lowery | 2008-08-21 | |||||
| dsx_monitor | 31685 | tcp | DS Expert Monitor | John Lowery | John Lowery | 2008-08-21 | This entry is an alias to "dsx-monitor". This entry is now historic, not usable for use with many common service discovery mechanisms. | ||||
| 31685 | udp | Reserved | |||||||||
| 31686-31764 | Unassigned | ||||||||||
| filenet-tms | 32768 | tcp | Filenet TMS | Daniel Whelan | Daniel Whelan | ||||||
| filenet-tms | 32768 | udp | Filenet TMS | Daniel Whelan | Daniel Whelan | ||||||
| 34568-34961 | Unassigned | ||||||||||
| 36701-36864 | Unassigned | ||||||||||
| kastenxpipe | 36865 | tcp | KastenX Pipe | Guy Cheng | Guy Cheng | ||||||
| kastenxpipe | 36865 | udp | KastenX Pipe | Guy Cheng | Guy Cheng | ||||||
| 36866-37471 | Unassigned | ||||||||||
| 39064-39680 | Unassigned | ||||||||||
| turbonote-1 | 39681 | tcp | TurboNote Default Port | Peter Hyde | Peter Hyde | ||||||
| turbonote-1 | 39681 | udp | TurboNote Default Port | Peter Hyde | Peter Hyde | ||||||
| 39682-39999 | Unassigned | ||||||||||
| 44323 | udp | Unassigned | "pcp" assignment withdrawn, moved to port 5351 per RFC 6887 |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Brian Kennedy | BrianK&targetedconvergence.com | 2006-08 | |
| Daniel Whelan | dwhelan&filenet.com | ||
| Edwin van de Burgt | edwin.van.de.burgt&vandoren.nl | 2016-10-31 | |
| Dongwook Kim | 3GPP Specifications Manager | dongwook.kim&etsi.org | 2026-01-23 |
| Guy Cheng | GCHE&kastenchase.com | ||
| John Lowery | NetPro Computing | jlowery&netpro.com | 2008-08-21 |
| Jon Press | IANA.Registions&ca.com | 2005-09 | |
| Juha Lindfors | OpenRemote, Inc. | juha&openremote.org | 2012-12-18 |
| Michael J Hoy | mhoy&canberra-abq.com | ||
| Michael Muth | m.muth&tec5.com | 2009-05-11 | |
| OpenRemote, Inc. | juha&openremote.org | 2012-12-18 | |
| Peter Hyde | peter&spis.co.nz | ||
| Tyler Cook | tcc&sandpolis.com | 2019-11-22 | |
| Van Doren MES | mes&vandoren.nl | 2016-10-31 |