Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
client-wakeup 9694 tcp T-Mobile Client Wakeup Message Michael Schönborn Michael Schönborn 2009-09-11
client-wakeup 9694 udp T-Mobile Client Wakeup Message Michael Schönborn Michael Schönborn 2009-09-11
ccnx 9695 tcp Content Centric Networking Van Jacobson; Simon Barber Van Jacobson; Simon Barber 2009-09-29
ccnx 9695 udp Content Centric Networking Van Jacobson; Simon Barber Van Jacobson; Simon Barber 2009-09-29
9696-9699 Unassigned
sctp-tunneling 9899 udp SCTP TUNNELING IESG IETF Chair 2013-04-10 RFC 6951
12169-12171 Unassigned
16369-16383 Unassigned
newbay-snc-mc 16900 tcp Newbay Mobile Client Update Service Srinivasa Nayudu Srinivasa Nayudu 2009-07-06
newbay-snc-mc 16900 udp Newbay Mobile Client Update Service Srinivasa Nayudu Srinivasa Nayudu 2009-07-06
16901-16949 Unassigned
sgcip 16950 tcp Simple Generic Client Interface Protocol John Aquilino John Aquilino
sgcip 16950 udp Simple Generic Client Interface Protocol John Aquilino John Aquilino
16951-16990 Unassigned
intel-rci-mp 16991 tcp INTEL-RCI-MP Jane Dashevsky Jane Dashevsky
intel-rci-mp 16991 udp INTEL-RCI-MP Jane Dashevsky Jane Dashevsky
amt-soap-http 16992 tcp Intel(R) AMT SOAP/HTTP David T. Hines David T. Hines 2005-02
amt-soap-http 16992 udp Intel(R) AMT SOAP/HTTP David T. Hines David T. Hines 2005-02
amt-soap-https 16993 tcp Intel(R) AMT SOAP/HTTPS David T. Hines David T. Hines 2005-02
amt-soap-https 16993 udp Intel(R) AMT SOAP/HTTPS David T. Hines David T. Hines 2005-02
amt-redir-tcp 16994 tcp Intel(R) AMT Redirection/TCP Nimrod Diamant Nimrod Diamant 2005-02
amt-redir-tcp 16994 udp Intel(R) AMT Redirection/TCP Nimrod Diamant Nimrod Diamant 2005-02
amt-redir-tls 16995 tcp Intel(R) AMT Redirection/TLS Nimrod Diamant Nimrod Diamant 2005-02
amt-redir-tls 16995 udp Intel(R) AMT Redirection/TLS Nimrod Diamant Nimrod Diamant 2005-02
16996-17006 Unassigned
18669-18768 Unassigned
ique 18769 tcp IQue Protocol Avi Drissman Avi Drissman 2002-07
ique 18769 udp IQue Protocol Avi Drissman Avi Drissman 2002-07
20481-20669 Unassigned
26490-26999 Unassigned
iuhsctpassoc 29169 sctp HNBAP and RUA Common Association Dongwook Kim Dongwook Kim 2009-09-08 2026-01-23
filenet-rpc 32769 tcp Filenet RPC Daniel Whelan Daniel Whelan
filenet-rpc 32769 udp Filenet RPC Daniel Whelan Daniel Whelan
36603-36699 Unassigned
46337-46997 Unassigned
spremotetablet 46998 tcp Connection between a desktop computer or server and a signature tablet to capture handwritten signatures SOFTPRO GmbH Christoph Hipp 2012-07-19 2013-08-02
46998 udp Reserved
mediabox 46999 tcp MediaBox Server Alexander Graef Alexander Graef 2004-11
mediabox 46999 udp MediaBox Server Alexander Graef Alexander Graef 2004-11

Contact Information

Name Organization Contact URI Last Updated
Alexander Graef alex&graef.cc 2004-11
Avi Drissman ique-protocol&harrisbaseview.com 2002-07
Christoph Hipp SOFTPRO GmbH christoph.hipp&softpro.de 2013-08-02
Daniel Whelan dwhelan&filenet.com
David T. Hines david.hines&intel.com 2005-02
Dongwook Kim 3GPP dongwook.kim&etsi.org 2026-01-23
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Jane Dashevsky jane.dashevsky&intel.com
John Aquilino john.aquilino&maryville.com
Michael Schönborn T-Mobile International AG michael.schoenborn&t-mobile.net 2009-09-11
Nimrod Diamant nimrod.diamant&intel.com 2005-02
Simon Barber simon.barber&parc.com 2009-09-29
SOFTPRO GmbH christoph.hipp&softpro.de 2013-08-02
Srinivasa Nayudu sn156n&att.com 2009-07-06
Van Jacobson van&parc.com 2009-09-29