Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| 9748-9749 | Unassigned | ||||||||||
| 9803-9874 | Unassigned | ||||||||||
| sapv1 | 9875 | tcp | Session Announcement v1 | RFC 2974 | |||||||
| sapv1 | 9875 | udp | Session Announcement v1 | RFC 2974 | |||||||
| oemcacao-rmi | 11174 | tcp | OEM cacao rmi registry access point | David Sechrest | David Sechrest | 2010-09-22 | |||||
| 11174 | udp | Reserved | |||||||||
| ptp | 15740 | tcp | Picture Transfer Protocol | Petronel Bigioi | Petronel Bigioi | 2004-11 | Defined TXT keys: guid=<Device guid> | ||||
| ptp | 15740 | udp | Picture Transfer Protocol | Petronel Bigioi | Petronel Bigioi | 2004-11 | Defined TXT keys: guid=<Device guid> | ||||
| 15741-15997 | Unassigned | ||||||||||
| 17236-17499 | Unassigned | ||||||||||
| 22274-22304 | Unassigned | ||||||||||
| 27346-27441 | Unassigned | ||||||||||
| jesmsjc | 27442 | tcp | Job controller service | Chris Newman | Chris Newman | 2010-10-15 | |||||
| jesmsjc | 27442 | udp | Job controller service | Chris Newman | Chris Newman | 2010-10-15 | |||||
| 27443-27503 | Unassigned | ||||||||||
| filenet-re | 32774 | tcp | FileNET Rules Engine | Chris Adkins | Chris Adkins | 2003-08 | |||||
| filenet-re | 32774 | udp | FileNET Rules Engine | Chris Adkins | Chris Adkins | 2003-08 | |||||
| 36866-37471 | Unassigned | ||||||||||
| 37472 | tcp | Reserved | |||||||||
| 37472 | udp | Reserved | |||||||||
| 3gpp-w1ap | 37472 | sctp | W1 signalling transport | 3GPP | Lionel Morand | 2020-07-16 | |||||
| 37473-37474 | Unassigned | ||||||||||
| neckar | 37475 | tcp | science + computing's Venus Administration Port | Ralf Allrutz | Ralf Allrutz | 2002-02 | |||||
| neckar | 37475 | udp | science + computing's Venus Administration Port | Ralf Allrutz | Ralf Allrutz | 2002-02 | |||||
| 37476-37482 | Unassigned | ||||||||||
| gdrive-sync | 37483 | tcp | Google Drive Sync | Google Inc. | Jason Schiller | 2013-02-01 | 2015-07-31 | ||||
| 37483 | udp | Reserved | |||||||||
| 37484-37600 | Unassigned | ||||||||||
| netconf-beep | NETCONF over BEEP | RFC 4744; RFC 9900 | |||||||||
| netconfsoapbeep | NETCONF for SOAP over BEEP | RFC 4743; RFC 9900 | |||||||||
| netconfsoaphttp | NETCONF for SOAP over HTTPS | RFC 4743; RFC 9900 |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| 3GPP | lionel.morand&orange.com | 2020-07-16 | |
| Chris Adkins | cadkins&filenet.com | 2006-10 | |
| Chris Newman | chris.newman&oracle.com | 2017-01-26 | |
| David Sechrest | david.sechrest&oracle.com | 2010-09-22 | |
| Google Inc. | numbers&google.com | 2015-07-31 | |
| Jason Schiller | Google Inc. | jschiller&google.com | 2015-07-31 |
| Lionel Morand | lionel.morand&orange.com | 2020-07-16 | |
| Petronel Bigioi | petronel&fotonation.com | 2004-11 | |
| Ralf Allrutz | R.Allrutz&science-computing.de | 2002-02 |