Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
9910 Unassigned
sype-transport 9911 tcp SYPECom Transport Protocol Sylvain Pedneault Sylvain Pedneault 2003-03
sype-transport 9911 udp SYPECom Transport Protocol Sylvain Pedneault Sylvain Pedneault 2003-03
9912-9924 Unassigned
osm-oev 9991 tcp OSM Event Server Vinay Gupta Vinay Gupta 2003-08
osm-oev 9991 udp OSM Event Server Vinay Gupta Vinay Gupta 2003-08
10991-10999 Unassigned
intel-rci-mp 16991 tcp INTEL-RCI-MP Jane Dashevsky Jane Dashevsky
intel-rci-mp 16991 udp INTEL-RCI-MP Jane Dashevsky Jane Dashevsky
19021-19190 Unassigned
opsec-uaa 19191 tcp OPSEC UAA Reuven Harrison Reuven Harrison
opsec-uaa 19191 udp OPSEC UAA Reuven Harrison Reuven Harrison
19192-19193 Unassigned
ua-secureagent 19194 tcp UserAuthority SecureAgent Reuven Harrison Reuven Harrison 2003-01
ua-secureagent 19194 udp UserAuthority SecureAgent Reuven Harrison Reuven Harrison 2003-01
19195-19219 Unassigned
19791-19997 Unassigned
21591-21799 Unassigned
29001-29117 Unassigned
29118 tcp Reserved
29118 udp Reserved
sgsap 29118 sctp SGsAP in 3GPP Dongwook Kim Dongwook Kim 2009-06-11
29119-29166 Unassigned
otmp 29167 tcp ObTools Message Protocol Paul Clark Paul Clark 2006-02
otmp 29167 udp ObTools Message Protocol Paul Clark Paul Clark 2006-02
29168 tcp Reserved
29168 udp Reserved
sbcap 29168 sctp SBcAP in 3GPP Dongwook Kim Dongwook Kim 2009-06-11
iuhsctpassoc 29169 sctp HNBAP and RUA Common Association Dongwook Kim Dongwook Kim 2009-09-08 2026-01-23
29170-29998 Unassigned
33891-34248 Unassigned
noit-transport 43191 tcp Reconnoiter Agent Data Transport Theo Schlossnagle Theo Schlossnagle 2009-05-19
43191 udp Reserved
49002-49149 Unassigned
inspider 49150 tcp InSpider System AnRobot Zhang Xinnan 2017-11-06
49150 udp Reserved
49151 Reserved 2024-12-20 RFC 6335
core-rd tcp Resource Directory accessed using CoAP over TCP IESG IETF Chair 2021-03-16 RFC 9176 Defined TXT keys: None
core-rd udp Resource Directory accessed using CoAP IESG IETF Chair 2021-03-16 RFC 9176 Defined TXT keys: None
core-rd-tls tcp Resource Directory accessed using CoAP over TLS IESG IETF Chair 2021-03-16 2022-04-14 RFC 9176 Defined TXT keys: None
core-rd-dtls udp Resource Directory accessed using CoAP over DTLS IESG IETF Chair 2021-03-16 RFC 9176 Defined TXT keys: None
est-coaps udp EST over secure CoAP (EST-coaps) Toerless Eckert Toerless Eckert 2022-05-03 2022-05-04 RFC 9148. Defined TXT keys: None
jnx-kcsync tcp jollys keychain cloud sync protocol Patrick Stein Patrick Stein 2011-10-24 Defined TXT keys: hash=<40hex characters> salt=<40hex characters> uuid=<40hex characters> Example: hash=5e7580598c0d7064d4fc79faaeb42585e1a675f8 salt=f0164cb3a0c3d7efe75abea8fda86d2d56c8dda9 uuid=db61dc092922252e45bbb264f59147138c7fd5fa

Contact Information

Name Organization Contact URI Last Updated
AnRobot webmaster&anrobot.org 2017-11-06
Dongwook Kim 3GPP dongwook.kim&etsi.org 2026-01-23
Dongwook Kim 3GPP Specifications Manager dongwook.kim&etsi.org 2026-01-23
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Jane Dashevsky jane.dashevsky&intel.com
Patrick Stein Patrick.Stein&jinx.eu 2011-10-24
Paul Clark paul&xmill.com 2006-02
Reuven Harrison rnd_ana&checkpoint.com
Reuven Harrison rharrison&checkpoint.com 2003-01
Sylvain Pedneault sylvain&sypecom.qc.ca 2003-03
Theo Schlossnagle jesus&omniti.com 2009-05-19
Toerless Eckert tte&cs.fau.de 2022-05-03
Vinay Gupta vinay.gupta&hp.com 2003-08
Zhang Xinnan 70331471&qq.com 2017-11-06