Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-22

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
db-lsp 17500 tcp Dropbox LanSync Protocol Paul Bohm Paul Bohm 2010-01-21
db-lsp-disc 17500 udp Dropbox LanSync Discovery Paul Bohm Paul Bohm 2010-01-21
17501-17554 Unassigned
17730-17753 Unassigned
biimenu 18000 tcp Beckman Instruments, Inc. R. L. Meyering R. L. Meyering
biimenu 18000 udp Beckman Instruments, Inc. R. L. Meyering R. L. Meyering
18001-18103 Unassigned
radpdf 18104 tcp RAD PDF Service Christopher Truxaw Christopher Truxaw 2010-10-15
18104 udp Reserved
18105-18135 Unassigned
18137-18180 Unassigned
18188-18240 Unassigned
18260-18261 Unassigned
18770-18880 Unassigned
igrid 19000 tcp iGrid Server Massimo Cafaro Massimo Cafaro 2004-11
igrid 19000 udp iGrid Server Massimo Cafaro Massimo Cafaro 2004-11
19001-19006 Unassigned
scintilla 19007 tcp Scintilla protocol for device services Veejansh Inc Chirag Patel 2014-03-04
scintilla 19007 udp Scintilla protocol for device services Veejansh Inc Chirag Patel 2014-03-04
19008-19019 Unassigned
j-link 19020 tcp J-Link TCP/IP Protocol SEGGER Microcontroller GmbH & Co. KG SEGGER Microcontroller GmbH & Co. KG
19020 udp Reserved
19021-19190 Unassigned
cora 19220 tcp Client Connection Management and Data Exchange Service Softvise GmbH Ronny Krüger 2016-11-10
cora-disc 19220 udp Discovery for Client Connection Management and Data Exchange Service Softvise GmbH Ronny Krüger 2016-11-10
19399-19409 Unassigned
hp-sco 19410 tcp hp-sco Larry Schwartz Larry Schwartz
hp-sco 19410 udp hp-sco Larry Schwartz Larry Schwartz
sxuptp 19540 tcp SXUPTP Keiji Okuma Keiji Okuma 2002-08
sxuptp 19540 udp SXUPTP Keiji Okuma Keiji Okuma 2002-08
faircom-db 19790 tcp FairCom Database FairCom Corporation Michael Bowers 2020-12-04
19790 udp Reserved
iec-104-sec 19998 tcp IEC 60870-5-104 process control - secure Grant Gilchrist Grant Gilchrist 2010-10-18
dnp 20000 tcp DNP Michael Thesing Michael Thesing
dnp 20000 udp DNP Michael Thesing Michael Thesing
dnp 20000 sctp Distributed Network Protocol DNP Users Group Andrew West 2022-12-20
microsan 20001 tcp MicroSAN Thomas E. Ludwig Thomas E. Ludwig 2004-02
microsan 20001 udp MicroSAN Thomas E. Ludwig Thomas E. Ludwig 2004-02
commtact-http 20002 tcp Commtact HTTP Tomas Svoboda Tomas Svoboda 2004-12
commtact-http 20002 udp Commtact HTTP Tomas Svoboda Tomas Svoboda 2004-12
commtact-https 20003 tcp Commtact HTTPS Tomas Svoboda Tomas Svoboda 2004-12
commtact-https 20003 udp Commtact HTTPS Tomas Svoboda Tomas Svoboda 2004-12
20004 Unassigned
openwebnet 20005 tcp OpenWebNet protocol for electric network BTicino S.p.A. BTicino S.p.A. 2008-04-09
openwebnet 20005 udp OpenWebNet protocol for electric network BTicino S.p.A. BTicino S.p.A. 2008-04-09
20006-20011 Unassigned
20012 tcp Reserved
ss-idi-disc 20012 udp Samsung Interdevice Interaction discovery Hong, Jungkih Hong, Jungkih
ss-idi 20013 tcp Samsung Interdevice Interaction Hong, Jungkih Hong, Jungkih
20013 udp Reserved
opendeploy 20014 tcp OpenDeploy Listener Todd Scallan Todd Scallan 2005-08
opendeploy 20014 udp OpenDeploy Listener Todd Scallan Todd Scallan 2005-08
20015-20033 Unassigned
nburn-id 20034 tcp NetBurner ID Port

IANA assigned this well-formed service name as a replacement for "nburn_id".
Paul Breed Paul Breed 2003-11
nburn_id 20034 tcp NetBurner ID Port Paul Breed Paul Breed 2003-11 This entry is an alias to "nburn-id". This entry is now historic, not usable for use with many common service discovery mechanisms.
nburn-id 20034 udp NetBurner ID Port

IANA assigned this well-formed service name as a replacement for "nburn_id".
Paul Breed Paul Breed 2003-11
nburn_id 20034 udp NetBurner ID Port Paul Breed Paul Breed 2003-11 This entry is an alias to "nburn-id". This entry is now historic, not usable for use with many common service discovery mechanisms.
20035-20045 Unassigned
tmophl7mts 20046 tcp TMOP HL7 Message Transfer Service Tim Riley Tim Riley 2009-07-31
tmophl7mts 20046 udp TMOP HL7 Message Transfer Service Tim Riley Tim Riley 2009-07-31
20047-20047 Unassigned
mountd 20048 tcp NFS mount protocol Nicolas Williams Nicolas Williams 2010-08-09
mountd 20048 udp NFS mount protocol Nicolas Williams Nicolas Williams 2010-08-09
nfsrdma 20049 tcp Network File System (NFS) over RDMA 2017-09-05 RFC 8267
nfsrdma 20049 udp Network File System (NFS) over RDMA 2017-09-05 RFC 8267
nfsrdma 20049 sctp Network File System (NFS) over RDMA 2017-09-05 RFC 8267
20050-20056 Unassigned
avesterra 20057 tcp AvesTerra Hypergraph Transfer Protocol (HGTP) Georgetown University J.C. Smart 2016-06-06
20057 udp Reserved
20058-20166 Unassigned
tolfab 20167 tcp TOLfab Data Change Pierre Couderc Pierre Couderc 2006-03
tolfab 20167 udp TOLfab Data Change Pierre Couderc Pierre Couderc 2006-03
20168-20201 Unassigned
ipdtp-port 20202 tcp IPD Tunneling Port Vikki Yin Wei Vikki Yin Wei 2003-01
ipdtp-port 20202 udp IPD Tunneling Port Vikki Yin Wei Vikki Yin Wei 2003-01
20203-20221 Unassigned
ipulse-ics 20222 tcp iPulse-ICS Meggie Garica-Woodruff Meggie Garica-Woodruff
ipulse-ics 20222 udp iPulse-ICS Meggie Garica-Woodruff Meggie Garica-Woodruff
20223-20479 Unassigned
emwavemsg 20480 tcp emWave Message Service Harald Striepe Harald Striepe 2008-02-14
emwavemsg 20480 udp emWave Message Service Harald Striepe Harald Striepe 2008-02-14
20481-20669 Unassigned
track 20670 tcp Track Michael Sweet Michael Sweet
track 20670 udp Track Michael Sweet Michael Sweet
20671-20809 Unassigned
crtech-nlm 20810 tcp CRTech NLM Cullimore And Ring Technologies Dave Wilkins 2021-06-24
20810 udp Reserved
20811-20998 Unassigned
athand-mmp 20999 tcp At Hand MMP Stepan Riha Stepan Riha
athand-mmp 20999 udp AT Hand MMP Stepan Riha Stepan Riha
irtrans 21000 tcp IRTrans Control Marcus Mueller Marcus Mueller 2004-11
irtrans 21000 udp IRTrans Control Marcus Mueller Marcus Mueller 2004-11
21001-21009 Unassigned
notezilla-lan 21010 tcp Notezilla.Lan Server Conceptworld Corporation Gautam Jain 2013-08-20
21010 udp Reserved
21011-21211 Unassigned
21214-21220 Unassigned
vofr-gateway 21590 tcp VoFR Gateway Marty Borden Marty Borden
vofr-gateway 21590 udp VoFR Gateway Marty Borden Marty Borden
tvpm 21800 tcp TVNC Pro Multiplexing Brian Blevins Brian Blevins
tvpm 21800 udp TVNC Pro Multiplexing Brian Blevins Brian Blevins

Contact Information

Name Organization Contact URI Last Updated
Andrew West andrew.west&ieee.org 2022-12-20
BTicino S.p.A. admin-myopen&myopen-bticino.it 2008-04-09
Brian Blevins brian.blevins&tridia.com
Chirag Patel Veejansh Inc cpatel&veejansh.com 2014-03-04
Christopher Truxaw ctruxaw&redsoftware.com 2010-10-15
Conceptworld Corporation admin&conceptworld.com 2013-08-20
Cullimore And Ring Technologies dave.wilkins&crtech.com 2021-06-24
Dave Wilkins dave.wilkins&crtech.com 2021-06-24
DNP Users Group chair_tech&dnp.org 2022-12-20
FairCom Corporation alysha.brown&faircom.com 2020-12-04
Gautam Jain Conceptworld Corporation admin&conceptworld.com 2013-08-20
Georgetown University smart&georgetown.edu 2016-06-06
Grant Gilchrist grant&enernex.com 2010-10-18
Harald Striepe harald&quantumintech.com 2008-02-14
Hong, Jungkih jungkih.hong&samsung.com 2010-09-20
J.C. Smart smart&georgetown.edu 2016-06-06
Keiji Okuma okuma&silex.jp 2005-08
Larry Schwartz lrs&cup.hp.com
Marcus Mueller marcus&irtrans.de 2004-11
Marty Borden mborden&tollbridgetech.com
Massimo Cafaro massimo.cafaro&unile.it 2004-11
Meggie Garica-Woodruff ipulse&ericsson.com
Michael Bowers FairCom Corporation mike.bowers&faircom.com 2020-12-04
Michael Sweet msweet&ctr.nawcad.navy.mil
Michael Thesing michael.thesing&acsatlanta.com
Nicolas Williams Nicolas.Williams&oracle.com 2010-08-09
Paul Bohm paul&dropbox.com 2010-01-21
Paul Breed paul&netburner.com 2003-11
Pierre Couderc pcouderc&tol.fr 2006-03
R. L. Meyering RLMEYERING&biivax.dp.beckman.com
Ronny Krüger from-iana&softvise.de 2016-11-10
SEGGER Microcontroller GmbH & Co. KG info&segger.com 2009-01-16
Softvise GmbH from-iana&softvise.de 2016-11-10
Stepan Riha stepan.riha&hand.com
Thomas E. Ludwig tom.ludwig&zetera.com 2004-02
Tim Riley rileyt&saic.com 2009-07-31
Todd Scallan tscallan&interwoven.com 2005-08
Tomas Svoboda svoboda&infima.cz 2004-12
Veejansh Inc admin&veejansh.com 2014-03-04
Vikki Yin Wei vikki&ipdynamics.com 2003-01