Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-22

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
tvpm 21800 udp TVNC Pro Multiplexing Brian Blevins Brian Blevins
sal 21801 tcp Safe AutoLogon WM Software Inc. WM Software Inc. 2022-07-05 2022-07-06
21802-21844 Unassigned
21850-21999 Unassigned
snapenetio 22000 tcp SNAPenetIO Kevin Kuhns Kevin Kuhns
snapenetio 22000 udp SNAPenetIO Kevin Kuhns Kevin Kuhns
optocontrol 22001 tcp OptoControl Kevin Kuhns Kevin Kuhns
optocontrol 22001 udp OptoControl Kevin Kuhns Kevin Kuhns
optohost002 22002 tcp Opto Host Port 2 Doug Leany Doug Leany 2006-09
optohost002 22002 udp Opto Host Port 2 Doug Leany Doug Leany 2006-09
optohost003 22003 tcp Opto Host Port 3 Doug Leany Doug Leany 2006-09
optohost003 22003 udp Opto Host Port 3 Doug Leany Doug Leany 2006-09
optohost004 22004 tcp Opto Host Port 4 Doug Leany Doug Leany 2006-09
optohost004 22004 udp Opto Host Port 4 Doug Leany Doug Leany 2006-09
optohost004 22005 tcp Opto Host Port 5 Doug Leany Doug Leany 2006-09
optohost004 22005 udp Opto Host Port 5 Doug Leany Doug Leany 2006-09
22006-22124 Unassigned
22274-22304 Unassigned
cis 22305 tcp CompactIS Tunnel Justin Paupore Justin Paupore 2007-08-16
cis 22305 udp CompactIS Tunnel Justin Paupore Justin Paupore 2007-08-16
22306-22332 Unassigned
codemeter 22350 tcp CodeMeter Standard Wolfgang Voelker Wolfgang Voelker 2007-06
codemeter 22350 udp CodeMeter Standard Wolfgang Voelker Wolfgang Voelker 2007-06
aws-brf 22800 tcp Telerate Information Platform LAN Timo Sivonen Timo Sivonen
aws-brf 22800 udp Telerate Information Platform LAN Timo Sivonen Timo Sivonen
22801-22950 Unassigned
inovaport1 23000 tcp Inova LightLink Server Type 1 Chris Koeritz Chris Koeritz 2006-10
inovaport1 23000 udp Inova LightLink Server Type 1 Chris Koeritz Chris Koeritz 2006-10
inovaport2 23001 tcp Inova LightLink Server Type 2 Chris Koeritz Chris Koeritz 2006-10
inovaport2 23001 udp Inova LightLink Server Type 2 Chris Koeritz Chris Koeritz 2006-10
inovaport3 23002 tcp Inova LightLink Server Type 3 Chris Koeritz Chris Koeritz 2006-10
inovaport3 23002 udp Inova LightLink Server Type 3 Chris Koeritz Chris Koeritz 2006-10
inovaport4 23003 tcp Inova LightLink Server Type 4 Chris Koeritz Chris Koeritz 2006-10
inovaport4 23003 udp Inova LightLink Server Type 4 Chris Koeritz Chris Koeritz 2006-10
inovaport5 23004 tcp Inova LightLink Server Type 5 Chris Koeritz Chris Koeritz 2006-10
inovaport5 23004 udp Inova LightLink Server Type 5 Chris Koeritz Chris Koeritz 2006-10
inovaport6 23005 tcp Inova LightLink Server Type 6 Chris Koeritz Chris Koeritz 2006-10
inovaport6 23005 udp Inova LightLink Server Type 6 Chris Koeritz Chris Koeritz 2006-10
23006-23052 Unassigned
gntp 23053 tcp Generic Notification Transport Protocol The Growl Project Chris Forsythe 2012-02-07
23053 udp Reserved
23054-23271 Unassigned
s102 23272 udp S102 application Kimmo Kymalainen Kimmo Kymalainen 2009-08-26
novar-dbase 23400 tcp Novar Data Keith Kilroy Keith Kilroy 2006-02
novar-dbase 23400 udp Novar Data Keith Kilroy Keith Kilroy 2006-02
novar-alarm 23401 tcp Novar Alarm Keith Kilroy Keith Kilroy 2006-02
novar-alarm 23401 udp Novar Alarm Keith Kilroy Keith Kilroy 2006-02
novar-global 23402 tcp Novar Global Keith Kilroy Keith Kilroy 2006-02
novar-global 23402 udp Novar Global Keith Kilroy Keith Kilroy 2006-02
23403-23455 Unassigned
med-ltp 24000 tcp med-ltp Juergen Fischbach Juergen Fischbach
med-ltp 24000 udp med-ltp Juergen Fischbach Juergen Fischbach
med-fsp-rx 24001 tcp med-fsp-rx Juergen Fischbach Juergen Fischbach
med-fsp-rx 24001 udp med-fsp-rx Juergen Fischbach Juergen Fischbach
med-fsp-tx 24002 tcp med-fsp-tx Juergen Fischbach Juergen Fischbach
med-fsp-tx 24002 udp med-fsp-tx Juergen Fischbach Juergen Fischbach
med-supp 24003 tcp med-supp Juergen Fischbach Juergen Fischbach
med-supp 24003 udp med-supp Juergen Fischbach Juergen Fischbach
med-ovw 24004 tcp med-ovw Juergen Fischbach Juergen Fischbach
med-ovw 24004 udp med-ovw Juergen Fischbach Juergen Fischbach
med-ci 24005 tcp med-ci Juergen Fischbach Juergen Fischbach
med-ci 24005 udp med-ci Juergen Fischbach Juergen Fischbach
med-net-svc 24006 tcp med-net-svc Juergen Fischbach Juergen Fischbach
med-net-svc 24006 udp med-net-svc Juergen Fischbach Juergen Fischbach
24007-24241 Unassigned
24250-24320 Unassigned
24578-24600 Unassigned
udpstp 24601 udp UDP-based IP-Layer Capacity and Performance Measurement protocol IESG IETF Chair 2025-09-26 RFC 9946
24601 tcp Reserved
24602-24665 Unassigned
tcc-http 24680 tcp TCC User HTTP Service Brian Kennedy Brian Kennedy 2006-08
tcc-http 24680 udp TCC User HTTP Service Brian Kennedy Brian Kennedy 2006-08
24850 tcp Reserved
assoc-disc 24850 udp Device Association Discovery Microsoft Corporation Sachin Sheth 2012-06-27
icl-twobase1 25000 tcp icl-twobase1 J. A. (Tony) Sever J. A. (Tony) Sever
icl-twobase1 25000 udp icl-twobase1 J. A. (Tony) Sever J. A. (Tony) Sever
icl-twobase2 25001 tcp icl-twobase2 J. A. (Tony) Sever J. A. (Tony) Sever
icl-twobase2 25001 udp icl-twobase2 J. A. (Tony) Sever J. A. (Tony) Sever
icl-twobase3 25002 tcp icl-twobase3 J. A. (Tony) Sever J. A. (Tony) Sever
icl-twobase3 25002 udp icl-twobase3 J. A. (Tony) Sever J. A. (Tony) Sever
icl-twobase4 25003 tcp icl-twobase4 J. A. (Tony) Sever J. A. (Tony) Sever
icl-twobase4 25003 udp icl-twobase4 J. A. (Tony) Sever J. A. (Tony) Sever
icl-twobase5 25004 tcp icl-twobase5 J. A. (Tony) Sever J. A. (Tony) Sever
icl-twobase5 25004 udp icl-twobase5 J. A. (Tony) Sever J. A. (Tony) Sever
icl-twobase6 25005 tcp icl-twobase6 J. A. (Tony) Sever J. A. (Tony) Sever
icl-twobase6 25005 udp icl-twobase6 J. A. (Tony) Sever J. A. (Tony) Sever
icl-twobase7 25006 tcp icl-twobase7 J. A. (Tony) Sever J. A. (Tony) Sever
icl-twobase7 25006 udp icl-twobase7 J. A. (Tony) Sever J. A. (Tony) Sever
icl-twobase8 25007 tcp icl-twobase8 J. A. (Tony) Sever J. A. (Tony) Sever
icl-twobase8 25007 udp icl-twobase8 J. A. (Tony) Sever J. A. (Tony) Sever
icl-twobase9 25008 tcp icl-twobase9 J. A. (Tony) Sever J. A. (Tony) Sever
icl-twobase9 25008 udp icl-twobase9 J. A. (Tony) Sever J. A. (Tony) Sever
icl-twobase10 25009 tcp icl-twobase10 J. A. (Tony) Sever J. A. (Tony) Sever
icl-twobase10 25009 udp icl-twobase10 J. A. (Tony) Sever J. A. (Tony) Sever
25010-25099 Unassigned
db2c-tls 25100 tcp IBM Db2 Client Interface - Encrypted IBM Matthew Emmerton 2024-03-05
25100 udp Reserved
25101-25470 Unassigned
25577-25603 Unassigned
idtp 25604 tcp Identifier Tracing Protocol Huang Neng-geng Huang Neng-geng 2011-08-09
25604 udp Reserved

Contact Information

Name Organization Contact URI Last Updated
Brian Blevins brian.blevins&tridia.com
Brian Kennedy BrianK&targetedconvergence.com 2006-08
Chris Forsythe The Growl Project chris&growl.info 2012-02-07
Chris Koeritz portmanager&inovasolutions.com 2006-10
Doug Leany DLEANY&opto22.com 2006-09
The Growl Project support&growl.info 2012-02-07
Huang Neng-geng huangng&ngweb.org
nghuang&ieee.org
2011-08-09
IBM memmerto&ca.ibm.com 2024-03-05
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
J. A. (Tony) Sever J.A.Sever&bra0119.wins.icl.co.uk
Juergen Fischbach juergen.fischbach&philips.com
Justin Paupore jpaupore&blueshiftlabs.net 2007-08-16
Keith Kilroy Keith.Kilroy&novarcontrols.com 2006-02
Kevin Kuhns kkuhns&opto22.com
Kimmo Kymalainen kimmo.kymalainen&etsi.org 2017-05-08
Matthew Emmerton IBM memmerto&ca.ibm.com 2024-03-05
Microsoft Corporation sachins&microsoft.com 2012-06-27
Sachin Sheth Microsoft Corporation sachins&microsoft.com 2012-06-27
Timo Sivonen timo.sivonen&ccmail.dowjones.com
WM Software Inc. support&wmsoftware.com 2022-07-18
Wolfgang Voelker wolfgang.voelker&wibu.com 2007-06