Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-22
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| 40844-40852 | Unassigned | ||||||||||
| 40853 | tcp | Reserved | |||||||||
| ortec-disc | 40853 | udp | ORTEC Service Discovery | Jesse Ursery | Jesse Ursery | 2010-11-22 | |||||
| 40854-41110 | Unassigned | ||||||||||
| 41112-41120 | Unassigned | ||||||||||
| z-wave-s | 41230 | tcp | Z-Wave Protocol over SSL/TLS | Sigma Designs | Anders Brandt | 2015-06-26 | |||||
| z-wave-s | 41230 | udp | Z-Wave Protocol over DTLS | Sigma Designs | Anders Brandt | 2015-06-26 | |||||
| 41798-42507 | Unassigned | Unauthorized Use Known on port 42000 | |||||||||
| candp | 42508 | tcp | Computer Associates network discovery protocol | Jon Press | Jon Press | 2005-09 | |||||
| candp | 42508 | udp | Computer Associates network discovery protocol | Jon Press | Jon Press | 2005-09 | |||||
| candrp | 42509 | tcp | CA discovery response | Jon Press | Jon Press | 2005-08 | |||||
| candrp | 42509 | udp | CA discovery response | Jon Press | Jon Press | 2005-08 | |||||
| caerpc | 42510 | tcp | CA eTrust RPC | Jon Press | Jon Press | 2005-08 | |||||
| caerpc | 42510 | udp | CA eTrust RPC | Jon Press | Jon Press | 2005-08 | |||||
| recvr-rc | 43000 | tcp | Receiver Remote Control | Research Electronics International | Ross Binkley | 2012-12-20 | |||||
| recvr-rc-disc | 43000 | udp | Receiver Remote Control Discovery | Research Electronics International | Ross Binkley | 2012-12-20 | |||||
| 43001-43187 | Unassigned | ||||||||||
| ip-provision | 43190 | tcp | IP-PROVISION | Roman Kriis | Roman Kriis | ||||||
| ip-provision | 43190 | udp | IP-PROVISION | Roman Kriis | Roman Kriis | ||||||
| 43192-43209 | Unassigned | ||||||||||
| shaperai | 43210 | tcp | Shaper Automation Server Management | Shaper Automation Inc. | Yohann Sulaiman | 2012-06-22 | |||||
| shaperai-disc | 43210 | udp | Shaper Automation Server Management Discovery | Shaper Automation Inc. | Yohann Sulaiman | 2012-06-22 | |||||
| ew-mgmt | 43440 | tcp | Cisco EnergyWise Management | ||||||||
| ew-disc-cmd | 43440 | udp | Cisco EnergyWise Discovery and Command Flooding | John Parello | John Parello | 2009-05-19 | |||||
| 44124-44320 | Unassigned | ||||||||||
| 44600 | tcp | Reserved | |||||||||
| asihpi | 44600 | udp | AudioScience HPI | Eliot Blennerhassett | Eliot Blennerhassett | 2011-07-07 | |||||
| 44601-44817 | Unassigned | ||||||||||
| EtherNet-IP-2 | 44818 | tcp | EtherNet/IP messaging IANA assigned this well-formed service name as a replacement for "EtherNet/IP-2". |
Brian Batke | Brian Batke | New contact added for port 44818 on 2008-02-01 | |||||
| EtherNet/IP-2 | 44818 | tcp | EtherNet/IP messaging | Brian Batke | Brian Batke | New contact added for port 44818 on 2008-02-01 This entry is an alias to "EtherNet-IP-2". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| EtherNet-IP-2 | 44818 | udp | EtherNet/IP messaging IANA assigned this well-formed service name as a replacement for "EtherNet/IP-2". |
Brian Batke | Brian Batke | New contact added for port 44818 on 2008-02-01 | |||||
| EtherNet/IP-2 | 44818 | udp | EtherNet/IP messaging | Brian Batke | Brian Batke | New contact added for port 44818 on 2008-02-01 This entry is an alias to "EtherNet-IP-2". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| m3da | 44900 | tcp | M3DA is used for efficient machine-to-machine communications | Eclipse Foundation | Didier Lahay | 2013-02-22 | |||||
| m3da-disc | 44900 | udp | M3DA Discovery is used for efficient machine-to-machine communications | Eclipse Foundation | Didier Lahay | 2013-02-22 | |||||
| 44901-44999 | Unassigned | ||||||||||
| asmp | 45000 | tcp | Nuance AutoStore Status Monitoring Protocol (data transfer) | Nuance Communications, Inc. | Andrew Andrews | 2011-09-01 | 2017-04-26 | ||||
| asmp-mon | 45000 | udp | Nuance AutoStore Status Monitoring Protocol (device monitoring) | Nuance Communications, Inc. | Andrew Andrews | 2011-09-01 | 2017-04-26 | ||||
| asmps | 45001 | tcp | Nuance AutoStore Status Monitoring Protocol (secure data transfer) | Nuance Communications, Inc. | Andrew Andrews | 2011-09-01 | 2017-04-26 | ||||
| 45001 | udp | Reserved | |||||||||
| rs-status | 45002 | tcp | Redspeed Status Monitor | Redspeed International Ltd | Simon Griffiths | 2015-03-10 | |||||
| 45002 | udp | Reserved | |||||||||
| 45003-45044 | Unassigned | ||||||||||
| synctest | 45045 | tcp | Remote application control protocol | Eleks, Ltd. | Andriy Skop | 2013-04-08 | |||||
| 45045 | udp | Reserved | |||||||||
| 45046-45053 | Unassigned | ||||||||||
| invision-ag | 45054 | tcp | InVision AG | Matthias Schroer | Matthias Schroer | ||||||
| invision-ag | 45054 | udp | InVision AG | Matthias Schroer | Matthias Schroer | ||||||
| 45055-45184 | Unassigned | ||||||||||
| mbus | 47000 | tcp | Message Bus | Dirk Kutscher | Dirk Kutscher | ||||||
| mbus | 47000 | udp | Message Bus | Dirk Kutscher | Dirk Kutscher | ||||||
| winrm | 47001 | tcp | Windows Remote Management Service | Ryan Mack | Ryan Mack | 2009-04-29 | |||||
| 47001 | udp | Reserved | |||||||||
| 47002-47099 | Unassigned | ||||||||||
| jvl-mactalk | 47100 | udp | Configuration of motors connected to Industrial Ethernet | JVL Industri Elektronik | Kim Berthelsen | 2012-12-21 | |||||
| 47100 | tcp | Reserved | |||||||||
| 47101-47556 | Unassigned | ||||||||||
| 47625-47805 | Unassigned | ||||||||||
| ap | 47806 | tcp | ALC Protocol | Dave Robin | Dave Robin | ||||||
| ap | 47806 | udp | ALC Protocol | Dave Robin | Dave Robin | ||||||
| 47807 | Unassigned | ||||||||||
| bacnet | 47808 | tcp | Building Automation and Control Networks | Coleman Brumley | Coleman Brumley | 2011-02-10 | |||||
| bacnet | 47808 | udp | Building Automation and Control Networks | Coleman Brumley | Coleman Brumley | 2011-02-10 | |||||
| presonus-ucnet | 47809 | udp | PreSonus Universal Control Network Protocol | PreSonus Audio Electronics, Inc | Matthias Juwan | 2013-07-12 | |||||
| 47809 | tcp | Reserved | |||||||||
| 47810-47999 | Unassigned | ||||||||||
| nimcontroller | 48000 | tcp | Nimbus Controller | Carstein Seeberg | Carstein Seeberg | ||||||
| nimcontroller | 48000 | udp | Nimbus Controller | Carstein Seeberg | Carstein Seeberg | ||||||
| nimspooler | 48001 | tcp | Nimbus Spooler | Carstein Seeberg | Carstein Seeberg | ||||||
| nimspooler | 48001 | udp | Nimbus Spooler | Carstein Seeberg | Carstein Seeberg | ||||||
| nimhub | 48002 | tcp | Nimbus Hub | Carstein Seeberg | Carstein Seeberg | ||||||
| nimhub | 48002 | udp | Nimbus Hub | Carstein Seeberg | Carstein Seeberg | ||||||
| nimgtw | 48003 | tcp | Nimbus Gateway | Carstein Seeberg | Carstein Seeberg | ||||||
| nimgtw | 48003 | udp | Nimbus Gateway | Carstein Seeberg | Carstein Seeberg | ||||||
| nimbusdb | 48004 | tcp | NimbusDB Connector | Stephen Harrison | Stephen Harrison | 2011-01-24 | |||||
| 48004 | udp | Reserved | |||||||||
| nimbusdbctrl | 48005 | tcp | NimbusDB Control | Stephen Harrison | Stephen Harrison | 2011-01-24 | |||||
| 48005 | udp | Reserved | |||||||||
| 48006-48047 | Unassigned | ||||||||||
| juka | 48048 | tcp | Juliar Programming Language Protocol | Juliar | Andrei Mak | 2018-02-16 | 2019-03-08 | ||||
| 48048 | udp | Reserved | |||||||||
| 3gpp-cbsp | 48049 | tcp | 3GPP Cell Broadcast Service Protocol | Gert Thomasen | Gert Thomasen | 2009-12-07 | |||||
| 48049 | udp | Reserved | |||||||||
| weandsf | 48050 | tcp | WeFi Access Network Discovery and Selection Function | WeFi, Inc. | Eran Naveh | 2013-07-19 | |||||
| 48050 | udp | Reserved | |||||||||
| 48051-48127 | Unassigned | ||||||||||
| 48130-48555 | Unassigned | ||||||||||
| 48620-48652 | Unassigned | ||||||||||
| matahari | 49000 | tcp | Matahari Broker | Matahari Project | Zane Bitter | 2011-08-31 | |||||
| 49000 | udp | Reserved | |||||||||
| nusrp | 49001 | tcp | Nuance Unity Service Request Protocol | Nuance Communications, Inc. | Andrew Andrews | 2017-04-20 | |||||
| nusdp-disc | 49001 | udp | Nuance Unity Service Discovery Protocol | Nuance Communications, Inc. | Andrew Andrews | 2017-04-20 | |||||
| 49002-49149 | Unassigned | ||||||||||
| inspider | 49150 | tcp | InSpider System | AnRobot | Zhang Xinnan | 2017-11-06 | |||||
| 49150 | udp | Reserved | |||||||||
| ip-ieee | Internet Protocol on IEEE 802 | ||||||||||
| ip-ipx | Transmission of 802.2 over IPX Networks | ||||||||||
| netconf-beep | NETCONF over BEEP | RFC 4744; RFC 9900 | |||||||||
| netconfsoapbeep | NETCONF for SOAP over BEEP | RFC 4743; RFC 9900 | |||||||||
| netconfsoaphttp | NETCONF for SOAP over HTTPS | RFC 4743; RFC 9900 | |||||||||
| affinity-docs0 | tcp | Affinity Designer document sharing | Serif (Europe) Ltd. | Tom Lachecki | 2023-03-30 | Defined TXT keys: Proprietary | |||||
| ai-adp | tcp | AI Agent Discovery Protocol (ADP) | Harry Lian | Harry Lian | 2026-06-12 | draft-pro-adp-agent-discovery-00 | Defined TXT keys: None |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Anders Brandt | Sigma Designs | anders_brandt&sigmadesigns.com | 2015-06-26 |
| Andrei Mak | andreim&juliar.org | 2018-02-16 | |
| Andrew Andrews | Andrew.Andrews&Nuance.com | 2017-04-26 | |
| Andriy Skop | Eleks, Ltd. | andriy.skop&eleks.com | 2013-04-08 |
| AnRobot | webmaster&anrobot.org | 2017-11-06 | |
| Brian Batke | eip.jsig&gmail.com | ||
| Carstein Seeberg | case&nimsoft.no | ||
| Coleman Brumley | cbrumley&polarsoft.biz | 2011-02-10 | |
| Dave Robin | iana_ports&daverobin.com | ||
| Didier Lahay | dlahay&sierrawireless.com | 2013-02-22 | |
| Dirk Kutscher | dku&informatik.uni-bremen.de | ||
| Eclipse Foundation | license&eclipse.org | 2013-02-22 | |
| Eleks, Ltd. | eleksinfo&eleks.com | 2013-04-08 | |
| Eliot Blennerhassett | eblennerhassett&audioscience.com | 2011-07-07 | |
| Eran Naveh | WeFi, Inc. | eranna&wefi.com | 2013-07-19 |
| Gert Thomasen | gert.thomasen&etsi.org | 2009-12-07 | |
| Harry Lian | harrylian8766&gmail.com | 2026-06-12 | |
| Jesse Ursery | jesse.ursery&ametek.com | 2010-11-22 | |
| John Parello | jparello&cisco.com | 2009-05-19 | |
| Jon Press | IANA.Registions&ca.com | 2005-09 | |
| Juliar | admin&juliar.org | 2018-02-16 | |
| JVL Industri Elektronik | jvl&jvl.dk | 2012-12-21 | |
| Kim Berthelsen | JVL Industri Elektronik | kb&jvl.dk | 2012-12-21 |
| Matahari Project | matahari&lists.fedorahosted.org | 2011-08-31 | |
| Matthias Juwan | PreSonus Audio Electronics, Inc | mjuwan&presonus.com | 2013-07-12 |
| Matthias Schroer | matthias.schroer&invision.de | ||
| Nuance Communications, Inc. | Andrew.Andrews&Nuance.com | 2017-04-20 | |
| Nuance Communications, Inc. | dev&nsius.com | 2017-04-26 | |
| PreSonus Audio Electronics, Inc | mjuwan&presonus.com | 2013-07-12 | |
| Redspeed International Ltd | simon.griffiths&redspeed-int.com | 2015-03-10 | |
| Research Electronics International | software&reiusa.net | 2012-12-20 | |
| Roman Kriis | roman&previo.ee | ||
| Ross Binkley | Research Electronics International | software&reiusa.net | 2012-12-20 |
| Ryan Mack | rmackµsoft.com | 2009-04-29 | |
| Serif (Europe) Ltd. | affinity&serif.com | 2023-03-30 | |
| Shaper Automation Inc. | ports&shaperai.com | 2012-06-22 | |
| Sigma Designs | anders_brandt&sigmadesigns.com | 2015-06-26 | |
| Simon Griffiths | Redspeed International Ltd | simon.griffiths&redspeed-int.com | 2015-03-10 |
| Stephen Harrison | sharrison&nimbusdb.com | 2011-01-24 | |
| Tom Lachecki | Serif (Europe) Ltd. | tlachecki&serif.com | 2023-03-30 |
| WeFi, Inc. | eranna&wefi.com | 2013-07-19 | |
| Yohann Sulaiman | ports&shaperai.com | 2012-06-22 | |
| Zane Bitter | zbitter&redhat.com | 2011-08-31 | |
| Zhang Xinnan | 70331471&qq.com | 2017-11-06 |