Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-22
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| ai-adp | tcp | AI Agent Discovery Protocol (ADP) | Harry Lian | Harry Lian | 2026-06-12 | draft-pro-adp-agent-discovery-00 | Defined TXT keys: None | ||||
| av-chat-ring-01 | tcp | TCP SpyChat Stream Message Exchange | Alexios Vasileiadis | Alexios Vasileiadis | 2018-05-03 | Defined TXT keys: There are two TXT record keys: 1st key: "txt-vers" associated with an 'int' entry. 2nd key: "conn-stat" associated with an 'int' entry. | |||||
| boardgame | tcp | Two-player board game play | Tianren Chen | Tianren Chen | 2026-08-05 | https://github.com/chentianren0/MiniXiangqi/blob/main/docs/boardgame-protocol.md | Defined TXT keys: None | ||||
| certificates | tcp | Server for S/MIME and PGP certificates | IESG | John Levine | 2016-07-26 | draft-bhjl-x509-srv-01 | Defined TXT keys: None | ||||
| convert | tcp | 0-RTT TCP Convert Protocol | IESG | IETF Chair | 2020-03-27 | RFC 8803 | Defined TXT keys: None | ||||
| est | tcp | Enrollment Over Secure Transport | Jack Visoky | Jack Visoky | 2017-10-06 | RFC 7030. Defined TXT keys: None | |||||
| feed-sharing | NetNewsWire 2.0 | Ranchero Software | Ranchero Software | Defined TXT keys: None | |||||||
| fix | Financial Information Exchange (FIX) Protocol | Joakim Johansson | Joakim Johansson | Defined TXT keys: Currently valid enumerated values: FIX Session Protocol Versions (SESSIONVERSION): 1.1 FIX Application Protocol Versions (APPLICATIONVERSION): 2.7, 3.0, 4.0, 4.1, 4.2, 4.3, 4.4, 5.0 Possible TXT records defined and their values (replace uppercase text with enumerations from the list above): txtvers=1 fix=APPLICATIONVERSION fix supported=APPLICATIONVERSION[,APPLICATIONVERSION, ... ,APPLICATIONVERSION] fixt=SESSIONVERSION | |||||||
| help | HELP command | RFC 1078 | TCP Port Service Multiplexer (TCPMUX) | ||||||||
| hpr-bldlnx | HP Remote Build System for Linux-based Systems | Jeffrey J. Walls | Jeffrey J. Walls | Defined TXT keys: rh73, rhel3, rhel4, deb31, suse102 | |||||||
| hpr-toollnx | HP Remote System that houses compilers and tools for Linux-based Systems | Jeffrey J. Walls | Jeffrey J. Walls | Defined TXT keys: rh73, rhel3, rhel4, deb31, suse102 | |||||||
| hpr-tstlnx | HP Remote Test System for Linux-based Systems | Jeffrey J. Walls | Jeffrey J. Walls | Defined TXT keys: rh73, rhel3, rhel4, deb31, suse102 | |||||||
| ichat | iChat 1.0 | Jens Alfke | Jens Alfke | Defined TXT keys: Proprietary | |||||||
| ir-hvac-000 | tcp | HVAC SMIL Server | Ingersoll Rand, Inc. | John Taylor | 2011-09-28 | Defined TXT keys: None | |||||
| jmap | tcp | JSON Meta Application Protocol | IESG | IETF Chair | 2016-01-22 | 2019-07-16 | RFC 8620 | This service name was previously assigned under the name "JSON Mail Access Protocol". This has been de-assigned and re-assigned with the approval of the previous assignee. | |||
| jnx-kcsync | tcp | jollys keychain cloud sync protocol | Patrick Stein | Patrick Stein | 2011-10-24 | Defined TXT keys: hash=<40hex characters> salt=<40hex characters> uuid=<40hex characters> Example: hash=5e7580598c0d7064d4fc79faaeb42585e1a675f8 salt=f0164cb3a0c3d7efe75abea8fda86d2d56c8dda9 uuid=db61dc092922252e45bbb264f59147138c7fd5fa | |||||
| lobby | Gobby | 0x539 dev group | 0x539 dev group | Defined TXT keys: None | |||||||
| M30S1PT | tcp | Moritz30-Project Standard protocol 1 Plain Text | Moritz30 | Matthias Merkel | 2015-12-07 | Defined TXT keys: None | |||||
| M30S1PT | udp | Moritz30-Project Standard protocol 1 Plain Text | Moritz30 | Matthias Merkel | 2015-12-07 | Defined TXT keys: None | |||||
| mavlink | tcp | MAVLink Micro Air Vehicle Communication Protocol | Roderick Mann | Roderick Mann | 2011-10-20 | Defined TXT keys: 0 | |||||
| midi2 | udp | MIDI 2.0 Device Discovery | MIDI Manufacturers Association | Florian Bomers | 2023-11-07 | Defined TXT keys: EndpointName, ProductInstanceId | |||||
| moodring | Bonjour Mood Ring tutorial program | Daniel Steinberg | Daniel Steinberg | Defined TXT keys: txtvers=1 mood=<ascii digit from 0-4> | |||||||
| olpc-activity1 | udp | One Laptop per Child activity | One Laptop per Child/Collabora Ltd. | One Laptop per Child/Collabora Ltd. | Defined TXT keys: Shared_Activity_Protocol_1.0 | ||||||
| presence | Peer-to-peer messaging / Link-Local Messaging | XMPP Registrar | XMPP Registrar | Defined TXT keys: See http://www.xmpp.org/registrar/linklocal.html Note: Registration updated May 2007. Was formerly listed as "iChat AV" (Apple's IM client for Mac OS X) with TXT keys: txtvers, port.p2pj, phsh, vc, 1st, AIM, msg, status, last When first shipped in Mac OS X 10.2, iChat's peer-to-peer messaging protocol was created to solve the problem of serverless messaging between peers on the same link. However, there is nothing inherent in the protocol that limits it to being only link-local; it was simply an artifact of iChat in Mac OS X 10.2 using link-local Multicast DNS to discover peers. With the advent of Wide-Area DNS-SD, it is also possible to use iChat's peer-to-peer messaging between machines on different links. | |||||||
| psap | udp | Progal Service Advertising Protocol | Soren Weber | Soren Weber | Defined TXT keys: c0, c1, ..., cn | ||||||
| ptnetprosrv2 | PTNetPro Service | Apple Computer | Apple Computer | Defined TXT keys: None Profiling and performance analysis protocol for Shark 4.0 and BigTop. | |||||||
| ptp-req | PTP Initiation Request Protocol | Mark Wood | Mark Wood | Defined TXT keys: txtvers, guid, c0, c1, c2, ..., where the number of c_n attributes is variable | |||||||
| recipe-sharing | tcp | Recipe Sharing Protocol | Daniel G. Taylor | Daniel G. Taylor | 2007-11 | Defined TXT keys: http://www.recipemanager.org/rsp/rsp10draft.html#dnssd | |||||
| smartenergy | Smart Energy Profile | Robby Simpson, PhD | Robby Simpson, PhD | 2026-09-01 | Defined TXT keys: See IEEE Std 2030.5 | ||||||
| smimeca | tcp | Domain signing certificate for S/MIME keys | IESG | John Levine | 2016-07-26 | draft-bhjl-x509-srv-01 | Defined TXT keys: None | ||||
| snif-cln | tcp | SNIF End-to-End TLS Relay Client Connection | VESvault Corp | Jim Zubov | 2021-12-15 | 2026-07-22 | draft-zubov-snif-05, Section 4.5 | Defined TXT keys: None | |||
| snif-fifo | tcp | SNIF End-to-End TLS Relay Cluster | VESvault Corp | Jim Zubov | 2021-12-15 | 2026-07-22 | draft-zubov-snif-05, Section 4.6 | Defined TXT keys: None | |||
| snif-srv | tcp | SNIF End-to-End TLS Relay Service Connection | VESvault Corp | Jim Zubov | 2021-12-29 | 2026-07-22 | draft-zubov-snif-05, Section 4.3 | Defined TXT keys: None | |||
| sparql | SPARQL Protocol and RDF Query Language | Alex Tucker | Alex Tucker | Defined TXT keys: txtvers=1 path=<relative or absolute URL of endpoint> protovers=<number> [if not specified then default is 1.0, corresponding to SPARQL version] binding=<HTTP | SOAP> [if not specified then default is HTTP] vocabs=<space separated list of URIs> [RDF vocabularies or OWL ontologies used by the endpoint] metadata=<URL> [to fetch RDF/XML description of SPARQL service] | |||||||
| spx-hmp | tcp | SpinetiX HMP | SpinetiX S.A. | Diego Santa Cruz | 2011-10-18 | Defined TXT keys: txtvers=1 cport= the port for the content HTTP server (secondary HTTP server used for content publishing) mode= the mode in which the HMP device is currently operating, one of "normal", "safe" or "recovery" serial= serial number of the HMP device firmware= firmware version string (e.g., 2.1.0-0.1.7844) model= model string (e.g., HMP100) | |||||
| strobe-sync | tcp | Strobe Synchronization | Jasper Morgal | Richard Morgal | 2019-06-13 | Defined TXT keys: Application will rely upon Bonjour version 3.1.0.1 | |||||
| syncqdea | Synchronize! X Plus 2.0 | Qdea | Qdea | Defined TXT keys: None | |||||||
| timezone | tcp | Time Zone Data Distribution Service - non-TLS | IESG | IETF Chair | 2015-08-03 | RFC 7808 | This is an extension of the http service. Defined TXT keys: path=<context path> (as per Section 6 of RFC 6763). | ||||
| timezones | tcp | Time Zone Data Distribution Service - over TLS | IESG | IETF Chair | 2015-08-03 | RFC 7808 | This is an extension of the https service. Defined TXT keys: path=<context path> (as per Section 6 of RFC 6763). | ||||
| tinavigator | TI Navigator Hub 1.0 Discovery Service | Stephen Reid | Stephen Reid | Defined TXT keys: None | |||||||
| x510 | tcp | Security service to protocols | ITU-T Study Group 17 | Erik Andersen | 2019-08-13 | Defined TXT keys: None |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Alex Tucker | alex&floop.org.uk | ||
| Alexios Vasileiadis | alexvas100&gmail.com | 2018-05-03 | |
| Apple Computer | perftools-feedback&group.apple.com | ||
| Daniel G. Taylor | dan&programmer-art.org | 2007-11 | |
| Daniel Steinberg | daniel&oreilly.com | ||
| Diego Santa Cruz | SpinetiX S.A. | Diego.SantaCruz&spinetix.com | 2011-10-18 |
| Erik Andersen | era&x500.eu | 2019-08-13 | |
| Florian Bomers | Florian.Bomers.iana&bome.com | 2023-11-07 | |
| 0x539 dev group | http://darcs.0x539.de/trac/obby/cgi-bin/trac.cgi | ||
| Harry Lian | harrylian8766&gmail.com | 2026-06-12 | |
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| Ingersoll Rand, Inc. | john.taylor&irco.com | 2011-09-28 | |
| ITU-T Study Group 17 | era&x500.eu | 2019-08-13 | |
| Jack Visoky | jmvisoky&ra.rockwell.com | 2017-10-06 | |
| Jasper Morgal | jpmorgal8&gmail.com | 2019-06-13 | |
| Jeffrey J. Walls | jeff.walls&hp.com | ||
| Jens Alfke | jens&apple.com | ||
| Jim Zubov | VESvault Corp | jz&vesvault.com | 2021-12-29 |
| Joakim Johansson | joakim.johansson&tbricks.com | ||
| John Levine | standards&taugh.com | 2016-07-26 | |
| John Taylor | Ingersoll Rand, Inc. | john.taylor&irco.com | 2011-09-28 |
| Mark Wood | mark.d.wood&kodak.com | ||
| Matthias Merkel | moritz30&moritz30.de | 2015-12-07 | |
| MIDI Manufacturers Association | info&midi.org | 2023-11-07 | |
| Moritz30 | moritz30&moritz30.de | 2015-12-07 | |
| One Laptop per Child/Collabora Ltd. | devel&lists.laptop.org | ||
| Patrick Stein | Patrick.Stein&jinx.eu | 2011-10-24 | |
| Qdea | support&qdea.com | ||
| Ranchero Software | info&ranchero.com | ||
| Richard Morgal | rmorgal&wildblue.net | 2019-06-13 | |
| Robby Simpson, PhD | rsimpson&gmail.com | ||
| Roderick Mann | rmann&latencyzero.com | 2011-10-20 | |
| Soren Weber | sw&ditec-gmbh.de | ||
| SpinetiX S.A. | Diego.SantaCruz&spinetix.com | 2011-10-18 | |
| Stephen Reid | sreid&ti.com | ||
| Tianren Chen | chentianren0&gmail.com | 2026-08-05 | |
| VESvault Corp | info&vesvault.com | 2021-12-29 | |
| XMPP Registrar | registrar&xmpp.org |