Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| pfu-prcallback | 3208 | tcp | PFU PR Callback | Tetsuharu Hanada | Tetsuharu Hanada | ||||||
| pfu-prcallback | 3208 | udp | PFU PR Callback | Tetsuharu Hanada | Tetsuharu Hanada | ||||||
| netwkpathengine | 3209 | tcp | HP OpenView Network Path Engine Server | Anthony Walker | Anthony Walker | ||||||
| netwkpathengine | 3209 | udp | HP OpenView Network Path Engine Server | Anthony Walker | Anthony Walker | ||||||
| xnm-ssl | 3220 | tcp | XML NM over SSL | ||||||||
| xnm-ssl | 3220 | udp | XML NM over SSL | ||||||||
| officelink2000 | 3320 | tcp | Office Link 2000 | Mike Balch | Mike Balch | ||||||
| officelink2000 | 3320 | udp | Office Link 2000 | Mike Balch | Mike Balch | ||||||
| ifcp-port | 3420 | tcp | iFCP User Port | RFC 4172 | |||||||
| ifcp-port | 3420 | udp | iFCP User Port | RFC 4172 | |||||||
| galileolog | 3520 | tcp | Netvion Galileo Log Port | Ray Caruso | Ray Caruso | 2002-06 | |||||
| galileolog | 3520 | udp | Netvion Galileo Log Port | Ray Caruso | Ray Caruso | 2002-06 | |||||
| ep-pcp | 3620 | tcp | EPSON Projector Control Port | ||||||||
| ep-pcp | 3620 | udp | EPSON Projector Control Port | ||||||||
| easl | 3693 | tcp | Emergency Automatic Structure Lockdown System | Mele Associates | Greg Hansen; Randy Yates | 2014-11-26 | This port was previously removed on 2007-04-05. | ||||
| 3693 | udp | Reserved | 2014-11-26 | This port was previously removed on 2007-04-05. | |||||||
| ufastro-instr | 3720 | tcp | UF Astro. Instr. Services | David B. Hon | David B. Hon | 2003-03 | |||||
| ufastro-instr | 3720 | udp | UF Astro. Instr. Services | David B. Hon | David B. Hon | 2003-03 | |||||
| sitewatch-s | 3766 | tcp | SSL e-watch sitewatch server | e-Watch Corporation | John M Baird | 2014-05-13 | this port was previously updated on 2009-06-19 | ||||
| 3766 | udp | Reserved | this port was previously updated on 2009-06-19 | ||||||||
| remotedeploy | 3789 | tcp | RemoteDeploy Administration Port [July 2003] | Detlef Rothe | Detlef Rothe | 2009-05-15 | |||||
| remotedeploy | 3789 | udp | RemoteDeploy Administration Port [July 2003] | Detlef Rothe | Detlef Rothe | 2009-05-15 | |||||
| scp | 3820 | tcp | Siemens AuD SCP | Johann Arnold | Johann Arnold | 2004-10 | |||||
| scp | 3820 | udp | Siemens AuD SCP | Johann Arnold | Johann Arnold | 2004-10 | |||||
| 3864 | udp | Reserved | This entry has been removed on 2006-06-23. | ||||||||
| exasoftport1 | 3920 | tcp | Exasoft IP Port | Alan Malik | Alan Malik | 2003-11 | |||||
| exasoftport1 | 3920 | udp | Exasoft IP Port | Alan Malik | Alan Malik | 2003-11 | |||||
| 3980 | tcp | Reserved | 2006-06 | 2020-12-29 | Historic usage was acms. De-Assigned on 2020-12-29 | ||||||
| trap | 4020 | tcp | TRAP Port | Jeffrey C. Byrd | Jeffrey C. Byrd | ||||||
| trap | 4020 | udp | TRAP Port | Jeffrey C. Byrd | Jeffrey C. Byrd | ||||||
| minirem | 4120 | tcp | MiniRem Remote Telemetry and Control | MobilePro Systems | Sean Solberg | 2017-09-28 | |||||
| 4120 | udp | Reserved | |||||||||
| vrml-multi-use | 4200-4299 | VRML Multi User Systems | Mitra | Mitra | |||||||
| fdt-rcatp | 4320 | tcp | FDT Remote Categorization Protocol | Russell P. Holsclaw | Russell P. Holsclaw | 2006-03 | |||||
| fdt-rcatp | 4320 | udp | FDT Remote Categorization Protocol | Russell P. Holsclaw | Russell P. Holsclaw | 2006-03 | |||||
| 4324 | Reserved | 2015-05-12 | This entry is being removed on 2015-05-12. | ||||||||
| l2c-control | 4371 | tcp | LAN2CAN Control | Phil Tolson | Phil Tolson | 2008-07-07 | Modified: 21 January 2010 | ||||
| l2c-data | 4372 | tcp | LAN2CAN Data | Phil Tolson | Phil Tolson | 2008-07-07 | Modified: 21 January 2010 | ||||
| nvme | 4420 | tcp | NVM Express over Fabrics storage access | NVM Express, Inc. | Amber Huffman | 2016-03-31 | 2018-03-27 | ||||
| nvme | 4420 | udp | NVM Express over Fabrics storage access | NVM Express, Inc. | Amber Huffman | 2016-03-31 | 2018-03-27 | ||||
| 4501 | Unassigned | IANA | IANA | De-registered 08 June 2001 | |||||||
| 4607-4620 | Unassigned | ||||||||||
| zenginkyo-1 | 5020 | tcp | zenginkyo-1 | Masashi Suzaki | Masashi Suzaki | ||||||
| zenginkyo-1 | 5020 | udp | zenginkyo-1 | Masashi Suzaki | Masashi Suzaki | ||||||
| 5030 | tcp | Reserved | 2006-12 | 2022-01-10 | Historic usage was surfpass. De-Assigned on 2022-01-10 | ||||||
| 5030 | udp | Reserved | 2006-12 | 2022-01-10 | Historic usage was surfpass. De-Assigned on 2022-01-10 | ||||||
| i-net-2000-npr | 5069 | tcp | I/Net 2000-NPR | Chris Megede | Chris Megede | ||||||
| i-net-2000-npr | 5069 | udp | I/Net 2000-NPR | Chris Megede | Chris Megede | ||||||
| barracuda-bbs | 5120 | tcp | Barracuda Backup Protocol | Barracuda Networks | Andrew Blyler | 2013-04-05 | |||||
| barracuda-bbs | 5120 | udp | Barracuda Backup Protocol | Barracuda Networks | Andrew Blyler | 2013-04-05 | |||||
| 5153 | tcp | Reserved | 2009-07-01 | 2018-04-19 | Historic usage was toruxserver. De-Assigned on 2018-04-19 | ||||||
| targus-getdata | 5200 | tcp | TARGUS GetData | John Keaveney | John Keaveney | ||||||
| targus-getdata | 5200 | udp | TARGUS GetData | John Keaveney | John Keaveney | ||||||
| targus-getdata1 | 5201 | tcp | TARGUS GetData 1 | John Keaveney | John Keaveney | ||||||
| targus-getdata1 | 5201 | udp | TARGUS GetData 1 | John Keaveney | John Keaveney | ||||||
| targus-getdata2 | 5202 | tcp | TARGUS GetData 2 | John Keaveney | John Keaveney | ||||||
| targus-getdata2 | 5202 | udp | TARGUS GetData 2 | John Keaveney | John Keaveney | ||||||
| targus-getdata3 | 5203 | tcp | TARGUS GetData 3 | John Keaveney | John Keaveney | ||||||
| targus-getdata3 | 5203 | udp | TARGUS GetData 3 | John Keaveney | John Keaveney | ||||||
| 5204-5208 | Unassigned | ||||||||||
| nomad | 5209 | tcp | Nomad Device Video Transfer | Morega Systems Inc. | Ashraf Tahir | 2012-08-20 | |||||
| 5209 | udp | Reserved | |||||||||
| 5216-5220 | Unassigned | ||||||||||
| xmpp-client | 5222 | tcp | XMPP Client Connection | RFC 6120 | |||||||
| xmpp-server | 5269 | tcp | XMPP Server Connection | RFC 6120 | |||||||
| bsfserver-zn | 5320 | tcp | Webservices-based Zn interface of BSF | Bert Paul | Bert Paul | 2008-05-01 | |||||
| 5320 | udp | Reserved | |||||||||
| cylink-c | 5420 | tcp | Cylink-C | John Jobe | John Jobe | ||||||
| cylink-c | 5420 | udp | Cylink-C | John Jobe | John Jobe | ||||||
| ms-licensing | 5720 | tcp | MS-Licensing | Thomas Lindeman | Thomas Lindeman | 2002-11 | |||||
| ms-licensing | 5720 | udp | MS-Licensing | Thomas Lindeman | Thomas Lindeman | 2002-11 | |||||
| autopassdaemon | 5820 | tcp | AutoPass licensing | opentext | AutoPass | 2022-06-10 | 2024-08-01 | ||||
| 5820 | udp | Reserved | |||||||||
| gsmp-ancp | 6068 | tcp | GSMP/ANCP | Avri Doria | Avri Doria | RFC 6320 | |||||
| 6119-6120 | Unassigned | ||||||||||
| lm-x | 6200 | tcp | LM-X License Manager by X-Formation | Henrik Goldman | Henrik Goldman | 2006-10 | Known Unauthorized Use on port 6200 | ||||
| lm-x | 6200 | udp | LM-X License Manager by X-Formation | Henrik Goldman | Henrik Goldman | 2006-10 | Known Unauthorized Use on port 6200 | ||||
| 6201 | tcp | Reserved | |||||||||
| thermo-calc | 6201 | udp | Management of service nodes in a processing grid for thermodynamic calculations | Thermo-Calc Software AB | Thomas Revesz | 2012-06-28 | |||||
| 6202-6208 | Unassigned | ||||||||||
| qmtps | 6209 | tcp | QMTP over TLS | FEHCom | Erwin Hoffmann | 2015-01-09 | |||||
| qmtps | 6209 | udp | QMTP over TLS | FEHCom | Erwin Hoffmann | 2015-01-09 | |||||
| repsvc | 6320 | tcp | Double-Take Replication Service | Carbonite, Inc. | James Wilkinson | 2006-04 | 2019-08-23 | ||||
| repsvc | 6320 | udp | Double-Take Replication Service | Carbonite, Inc. | James Wilkinson | 2006-04 | 2019-08-23 | ||||
| nim-vdrshell | 6420 | tcp | NIM_VDRShell | Rik Ditter | Rik Ditter | 2006-02 | |||||
| nim-vdrshell | 6420 | udp | NIM_VDRShell | Rik Ditter | Rik Ditter | 2006-02 | |||||
| ieee11073-20701 | 6464 | tcp | Port assignment for medical device communication in accordance to IEEE 11073-20701 | David Gregorczyk | David Gregorczyk | 2017-03-02 | |||||
| ieee11073-20701 | 6464 | udp | Port assignment for medical device communication in accordance to IEEE 11073-20701 | David Gregorczyk | David Gregorczyk | 2017-03-02 | |||||
| 6567 | Reserved | 2007-01 | 2011-08-26 | This entry has been removed on 2011-08-26. | |||||||
| kftp-data | 6620 | tcp | Kerberos V5 FTP Data | Robert J. Scott | Robert J. Scott | 2005-08 | |||||
| kftp-data | 6620 | udp | Kerberos V5 FTP Data | Robert J. Scott | Robert J. Scott | 2005-08 | |||||
| dpserve | 7020 | tcp | DP Serve | Allan Stanley | Allan Stanley | ||||||
| dpserve | 7020 | udp | DP Serve | Allan Stanley | Allan Stanley | ||||||
| 7118-7120 | Unassigned | ||||||||||
| fodms | 7200 | tcp | FODMS FLIP | David Anthony | David Anthony | ||||||
| fodms | 7200 | udp | FODMS FLIP | David Anthony | David Anthony | ||||||
| dlip | 7201 | tcp | DLIP | Albert Manfredi | Albert Manfredi | ||||||
| dlip | 7201 | udp | DLIP | Albert Manfredi | Albert Manfredi | ||||||
| pon-ictp | 7202 | tcp | Inter-Channel Termination Protocol (ICTP) for multi-wavelength PON (Passive Optical Network) systems | Broadband Forum | Broadband Forum | 2017-02-22 | 2019-12-16 | TR-352; Inter-Channel-Termination protocol (ICTP) is a peer-to-peer protocol with a binary message format that is used by a set of optical line terminal (OLT) channel terminations (CT) comprising a 40-Gigabit-capable next-generation passive optical network (NG-PON2) system to exchange channel profile configuration and status information and to coordinate the operation of tunable optical network units (ONUs) in a multi-wavelength channel environment. | |||
| 7202 | udp | Reserved | |||||||||
| 7203-7214 | Unassigned |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Alan Malik | alan&exasoft.co.uk | 2003-11 | |
| Albert Manfredi | manfredi&engr05.comsys.rockwell.com | ||
| Allan Stanley | allan&hummingbird.com | ||
| Amber Huffman | amber.huffman&intel.com | 2018-03-27 | |
| Andrew Blyler | Barracuda Networks | ablyler&barracuda.com | 2013-04-05 |
| Anthony Walker | anthony_walker&hp.com | 2002-03 | |
| Ashraf Tahir | Morega Systems Inc. | atahir&morega.com | 2012-08-20 |
| AutoPass | MFI-swpdl.apls_core&opentext.com | 2024-08-01 | |
| Avri Doria | avri.doria&nokia.com | ||
| Barracuda Networks | BackupEngineering_Team&barracuda.com | 2013-04-05 | |
| Bert Paul | bert.paul&apertio.com | 2008-07-03 | |
| Broadband Forum | help&broadband-forum.org | 2020-03-17 | |
| Carbonite, Inc. | jwilkinson&carbonite.com | 2019-08-23 | |
| Chris Megede | chris.megede&tac.com | ||
| David Anthony | anthony&power.amasd.anatcp.rockwell.com | ||
| David B. Hon | hon&astro.ufl.edu | 2003-03 | |
| David Gregorczyk | david.gregorczyk&draeger.com | 2017-03-02 | |
| Detlef Rothe | detlef.rothe&ts.fujitsu.com | 2009-05-15 | |
| e-Watch Corporation | jbaird&e-watch.com | 2014-05-13 | |
| Erwin Hoffmann | FEHCom | feh&fehcom.de | 2015-01-09 |
| FEHCom | feh&fehcom.de | 2015-01-09 | |
| Greg Hansen | Mele Associates | greg.hansen&meleassociates.com | 2014-11-26 |
| Henrik Goldman | hg&x-formation.com | 2006-10 | |
| IANA | iana&iana.org | ||
| James Wilkinson | jwilkinson&carbonite.com | 2019-08-23 | |
| Jeffrey C. Byrd | admin&vspacegroup.com | ||
| Johann Arnold | johann.arnold&siemens.com | 2004-10 | |
| John Jobe | jjobe&cylink.com | ||
| John Keaveney | johnkeaveney&targusinfo.com | ||
| John M Baird | e-Watch Corporation | jbaird&e-watch.com | 2014-05-13 |
| Masashi Suzaki | susakim&noa.nttdata.jp | ||
| Mele Associates | easl&meleassociates.com | 2014-11-26 | |
| Mike Balch | mbalch&teltone.com | ||
| Mitra | mitra&earth.path.net | ||
| MobilePro Systems | info&mobileprosystems.com | 2017-09-28 | |
| Morega Systems Inc. | atahir&morega.com | 2012-08-20 | |
| NVM Express, Inc. | admin&nvmexpress.org | 2018-03-27 | |
| opentext | MFI-swpdl.apls_core&opentext.com | 2024-08-01 | |
| Phil Tolson | philtolson&eaton.com | 2010-01-21 | |
| Randy Yates | Digital Signal Labs | yates&digitalsignallabs.com | 2014-11-26 |
| Ray Caruso | ray.caruso&netvion.com | 2002-06 | |
| Rik Ditter | managers&generationtechnologies.com | 2006-02 | |
| Robert J. Scott | rob&hpcmo.hpc.mil | 2005-08 | |
| Russell P. Holsclaw | Fast Data Technology Inc. | rholsclaw&fastdatatech.com | 2006-03 |
| Sean Solberg | sean.solberg&mobileprosystems.com | 2017-09-28 | |
| Tetsuharu Hanada | hanada&pfu.fujitsu.com | ||
| Thermo-Calc Software AB | thomasr&thermocalc.se | 2012-06-28 | |
| Thomas Lindeman | tlindeµsoft.com | 2002-11 | |
| Thomas Revesz | Thermo-Calc Software AB | thomasr&thermocalc.se | 2012-06-28 |