Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
backup-express 6123 udp Backup Express Catalogic Software, Inc. Chi Shih Chang 2008-03-19 2015-02-04
6223-6240 Unassigned
6323 Unassigned
ktelnet 6623 tcp Kerberos V5 Telnet Robert J. Scott Robert J. Scott 2005-08
ktelnet 6623 udp Kerberos V5 Telnet Robert J. Scott Robert J. Scott 2005-08
6902-6923 Unassigned
ct2nmcs 7023 tcp Comtech T2 NMCS Bryan Wilcutt Bryan Wilcutt 2005-06
ct2nmcs 7023 udp Comtech T2 NMCS Bryan Wilcutt Bryan Wilcutt 2005-06
snif 7123 tcp SNIF End-to-End TLS Relay Control Connection VESvault Corp Jim Zubov 2021-12-24 2026-07-22 draft-zubov-snif-05, Section 4.3
snif 7123 udp SNIF End-to-End TLS Relay over QUIC VESvault Corp Jim Zubov 2026-07-22 2026-07-22 draft-zubov-snif-05, Section 4.4
7230-7233 Unassigned
asa-gateways 7234 tcp Traffic forwarding for Okta cloud infra Okta Inc Sam Hu 2020-07-07
7234 udp Reserved
aspcoordination 7235 udp ASP Coordination Protocol Wi-Fi Alliance Mick Conley 2013-12-31
7235 tcp Reserved
display 7236 tcp Wi-Fi Alliance Wi-Fi Display Protocol Wi-Fi Alliance Thomas Sciorilli 2012-04-09 Defined TXT keys: _display.tcp. Display Protocol
7236 udp Reserved
pads 7237 tcp PADS (Public Area Display System) Server Willie Jan Bons Willie Jan Bons 2011-03-10
7237 udp Reserved
7238-7243 Unassigned
cfw 7563 tcp Control Framework RFC 6230
7607-7623 Unassigned
7721-7723 Unassigned
arca-api 8023 tcp ARCATrust vault API ARCATrust SA Yacince Felk 2018-07-05
arca-api 8023 udp ARCATrust vault API ARCATrust SA Yacince Felk 2018-07-05
8123-8127 Unassigned
rexecj 8230 tcp RexecJ Server Curtiss Howard Curtiss Howard 2004-11
rexecj 8230 udp RexecJ Server Curtiss Howard Curtiss Howard 2004-11
8231 tcp Reserved
hncp-udp-port 8231 udp HNCP IESG IETF Chair 2016-01-13 RFC 7788
8232 tcp Reserved
hncp-dtls-port 8232 udp HNCP over DTLS IESG IETF Chair 2016-01-13 RFC 7788
8233-8242 Unassigned
8323-8350 Unassigned
aritts 8423 tcp Aristech text-to-speech server Aristech GmbH Martin Mende 2017-03-30 2022-02-22
8423 udp Reserved
swa-1 9023 tcp Secure Web Access - 1 Tim McGranaghan Tim McGranaghan
swa-1 9023 udp Secure Web Access - 1 Tim McGranaghan Tim McGranaghan
grcp 9123 tcp Global Relay compliant instant messaging protocol Global Relay Communications Inc Lu Vo 2012-11-28 2025-06-12
9123 udp Reserved
9223-9254 Unassigned
9523-9534 Unassigned
cefd-vmp 10023 udp Comtech EF-Data's Vipersat Management Protocol Comtech Nathan Jeffords 2014-01-23
10023 tcp Reserved
10321 tcp Reserved 2023-12-05 De-Assigned on 2023-12-05.
11212-11234 Unassigned
xcompute 11235 tcp numerical systems messaging Xplicit Computing Inc Graham J. Orr 2020-10-16
11235 udp Reserved
xcompute 11235 sctp numerical systems messaging Xplicit Computing Inc Graham J. Orr 2020-10-16
11236-11318 Unassigned
emc-xsw-dconfig 11623 tcp EMC XtremSW distributed config EMC David Erel 2013-09-18
11623 udp Reserved
h323callsigalt 11720 tcp H.323 Call Control Signalling Alternate ITU-T ITU-T TSB 2013-01-31
h323callsigalt 11720 udp H.323 Call Control Signalling Alternate ITU-T ITU-T TSB 2013-01-31
emc-xsw-dcache 11723 tcp EMC XtremSW distributed cache EMC David Erel 2013-09-18
emc-xsw-dcache 11723 udp EMC XtremSW distributed cache EMC David Erel 2013-09-18
linogridengine 12300 tcp LinoGrid Engine Frans Lundberg Frans Lundberg 2004-11
linogridengine 12300 udp LinoGrid Engine Frans Lundberg Frans Lundberg 2004-11
12301 Unassigned
rads 12302 tcp Remote Administration Daemon (RAD) is a system service that offers secure, remote, programmatic access to Solaris system configuration and run-time state Oracle Corporation Devjani Ray 2012-04-20
12302 udp Reserved
12303-12320 Unassigned
warehouse-sss 12321 tcp Warehouse Monitoring Syst SSS Craig Steffen Craig Steffen 2005-08
warehouse-sss 12321 udp Warehouse Monitoring Syst SSS Craig Steffen Craig Steffen 2005-08
warehouse 12322 tcp Warehouse Monitoring Syst Craig Steffen Craig Steffen 2005-08
warehouse 12322 udp Warehouse Monitoring Syst Craig Steffen Craig Steffen 2005-08
12323-12344 Unassigned
italk 12345 tcp Italk Chat System Takayuki Ito Takayuki Ito
italk 12345 udp Italk Chat System Takayuki Ito Takayuki Ito
12346-12545 Unassigned
powwow-client 13223 tcp PowWow Client Paul K. Peterson Paul K. Peterson
powwow-client 13223 udp PowWow Client Paul K. Peterson Paul K. Peterson
13723 Unassigned
bmdss 13823 tcp Blackmagic Design Streaming Server Sam Vaughan Sam Vaughan 2011-03-01
13823 udp Reserved
isa100-gci 17223 tcp ISA100 GCI is a service utilizing a common interface between an ISA100 Wireless gateway and a client application ISA100 Wireless Compliance Institute Jay Werb 2015-07-24
17223 udp Reserved
17226-17233 Unassigned
integrius-stp 17234 tcp Integrius Secure Tunnel Protocol Christian Klemetsson Christian Klemetsson 2010-03-04
integrius-stp 17234 udp Integrius Secure Tunnel Protocol Christian Klemetsson Christian Klemetsson 2010-03-04
ssh-mgmt 17235 tcp SSH Tectia Manager Ville Laurikari Ville Laurikari 2005-08
ssh-mgmt 17235 udp SSH Tectia Manager Ville Laurikari Ville Laurikari 2005-08
17236-17499 Unassigned
20223-20479 Unassigned
22223-22272 Unassigned
22274-22304 Unassigned
cis 22305 tcp CompactIS Tunnel Justin Paupore Justin Paupore 2007-08-16
cis 22305 udp CompactIS Tunnel Justin Paupore Justin Paupore 2007-08-16
22306-22332 Unassigned
showcockpit-net 22333 tcp ShowCockpit Networking Ricardo Dias Ricardo Dias 2020-11-18
showcockpit-net 22333 udp ShowCockpit Networking Ricardo Dias Ricardo Dias 2020-11-18
22334 Unassigned
shrewd-control 22335 tcp Initium Labs Security and Automation Control Initium Labs LLC Manbir Sahni 2015-03-06
shrewd-stream 22335 udp Initium Labs Security and Automation Streaming Initium Labs LLC Manbir Sahni 2015-03-06
22336-22342 Unassigned
cis-secure 22343 tcp CompactIS Secure Tunnel Justin Paupore Justin Paupore 2007-08-16
cis-secure 22343 udp CompactIS Secure Tunnel Justin Paupore Justin Paupore 2007-08-16
22344-22346 Unassigned
wibukey 22347 tcp WibuKey Standard WkLan Wolfgang Voelker Wolfgang Voelker 2007-06
wibukey 22347 udp WibuKey Standard WkLan Wolfgang Voelker Wolfgang Voelker 2007-06
22348-22349 Unassigned

Contact Information

Name Organization Contact URI Last Updated
ARCATrust SA info&arcatrust.io 2018-07-05
Aristech GmbH aritts&aristech.de 2022-02-22
Bryan Wilcutt bwilcutt&comtechefdata.com 2005-06
Catalogic Software, Inc. cchang&catalogicsoftware.com 2015-02-04
Chi Shih Chang Catalogic Software, Inc. cchang&catalogicsoftware.com 2015-02-04
Christian Klemetsson Integrius AB christian.klemetsson&integrius.se 2010-03-04
Comtech njeffords&comtechefdata.com 2014-01-23
Craig Steffen csteffen&ncsa.uiuc.edu 2005-08
Curtiss Howard cjhoward&unity.ncsu.edu 2004-11
David Erel EMC david.erel&emc.com 2013-09-18
Devjani Ray Oracle Corporation Devjani.Ray&oracle.com 2012-04-20
EMC david.erel&emc.com 2013-09-18
Frans Lundberg frans&linova.com 2004-11
Global Relay Communications Inc info&globalrelay.net 2025-06-12
Graham J. Orr graham&xplicitcomputing.com 2020-10-16
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
ITU-T tsbsg16&itu.int 2013-01-31
ITU-T TSB ITU-T tsbsg16&itu.int 2013-01-31
Initium Labs LLC manbir&initiumlabs.com 2015-03-06
ISA100 Wireless Compliance Institute jay&jwerb.com 2015-07-24
Jay Werb ISA100 Wireless Compliance Institute jay&jwerb.com 2015-07-24
Jim Zubov VESvault Corp jz&vesvault.com 2021-12-29
Justin Paupore jpaupore&blueshiftlabs.net 2007-08-16
Lu Vo Global Relay Communications Inc lu.vo&globalrelay.net 2025-06-12
Manbir Sahni Initium Labs LLC manbir&initiumlabs.com 2015-03-06
Martin Mende Aristech GmbH martin.mende&aristech.de 2022-02-22
Mick Conley Wi-Fi Alliance mconley&wi-fi.org 2013-12-31
Nathan Jeffords Comtech njeffords&comtechefdata.com 2014-01-23
Okta Inc asa-tech&okta.com 2020-07-07
Oracle Corporation Devjani.Ray&oracle.com 2012-04-20
Paul K. Peterson paul&tribal.com
Ricardo Dias general&showcockpit.com 2020-11-18
Robert J. Scott rob&hpcmo.hpc.mil 2005-08
Sam Hu Okta Inc sam.hu&okta.com 2020-07-07
Sam Vaughan samv&blackmagic-design.com 2011-03-01
Takayuki Ito yuki&euc.jp
Thomas Sciorilli Wi-Fi Alliance tsciorilli&wi-fi.org 2012-04-09
Tim McGranaghan tim_mcgranaghan&mech.disa.mil
VESvault Corp info&vesvault.com 2021-12-29
Ville Laurikari vlaurika&ssh.com 2005-08
Wi-Fi Alliance certifications&wi-fi.org 2012-04-09
Wi-Fi Alliance mconley&wi-fi.org 2013-12-31
Willie Jan Bons WillieJan.Bons&nds.eu 2011-03-10
Wolfgang Voelker wolfgang.voelker&wibu.com 2007-06
Xplicit Computing Inc info&xplicitcomputing.com 2020-10-16
Yacince Felk yacine&arcatrust.io 2018-07-05