Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
oma-ilp-s 7277 tcp OMA Internal Location Secure Protocol Khiem Tran Khiem Tran 2007-11-06
oma-ilp-s 7277 udp OMA Internal Location Secure Protocol Khiem Tran Khiem Tran 2007-11-06
oma-dcdocbs 7278 tcp OMA Dynamic Content Delivery over CBS Avi Primo Avi Primo 2008-01-29
oma-dcdocbs 7278 udp OMA Dynamic Content Delivery over CBS Avi Primo Avi Primo 2008-01-29
ctxlic 7279 tcp Citrix Licensing Marc Binstock Marc Binstock 2008-01-29
ctxlic 7279 udp Citrix Licensing Marc Binstock Marc Binstock 2008-01-29
oveadmgr 7427 tcp OpenView DM Event Agent Manager Dave Lamb Dave Lamb
oveadmgr 7427 udp OpenView DM Event Agent Manager Dave Lamb Dave Lamb
soap-http 7627 tcp SOAP Service Port Donald Dylla Donald Dylla 2004-12
soap-http 7627 udp SOAP Service Port Donald Dylla Donald Dylla 2004-12
trident-data 7727 tcp Trident Systems Data Jeremy McClintock Jeremy McClintock 2005-08
trident-data 7727 udp Trident Systems Data Jeremy McClintock Jeremy McClintock 2005-08
papachi-p2p-srv 8027 tcp peer tracker and data relay service Pavel Csefalvay Pavel Csefalvay 2020-09-18
papachi-p2p-srv 8027 udp peer tracker and data relay service Pavel Csefalvay Pavel Csefalvay 2020-09-18
8123-8127 Unassigned
robot-remote 8270 tcp Robot Framework Remote Library Interface Robot Framework Foundation Chris Newman 2017-01-26
8270 udp Reserved
8271-8275 Unassigned
ms-mcc 8276 tcp Microsoft Connected Cache Microsoft Corporation Narkis Engler 2008-02-27 2022-05-03
ms-mcc 8276 udp Microsoft Connected Cache Microsoft Corporation Narkis Engler 2008-02-27 2022-05-03
8277-8279 Unassigned
9027-9049 Unassigned
pdl-datastream 9100 tcp Printer PDL Data Stream Stuart Cheshire Stuart Cheshire 2002-09 The protocol name "pdl-datastream" is primarily registered for use in DNS SRV records (RFC 2782). DNS SRV records allow a protocol to run on any port number, but the default port for this protocol is 9100.
pdl-datastream 9100 udp Printer PDL Data Stream Stuart Cheshire Stuart Cheshire 2002-09 The protocol name "pdl-datastream" is primarily registered for use in DNS SRV records (RFC 2782). DNS SRV records allow a protocol to run on any port number, but the default port for this protocol is 9100.
9256-9276 Unassigned
traingpsdata 9277 udp GPS Data transmitted from train to ground network Alstom Transport, Preston Paul Steane 2012-12-14
9277 tcp Reserved
pegasus 9278 tcp Pegasus GPS Platform Nestor A. Diaz Nestor A. Diaz 2009-05-12
pegasus 9278 udp Pegasus GPS Platform Nestor A. Diaz Nestor A. Diaz 2009-05-12
pegasus-ctl 9279 tcp Pegaus GPS System Control Interface Nestor A. Diaz Nestor A. Diaz 2009-05-12
pegasus-ctl 9279 udp Pegaus GPS System Control Interface Nestor A. Diaz Nestor A. Diaz 2009-05-12
9619-9627 Unassigned
10126-10127 Unassigned
12547-12752 Unassigned
tsaf 12753 tcp tsaf port Andreas Fehr Andreas Fehr
tsaf 12753 udp tsaf port Andreas Fehr Andreas Fehr
12754-12864 Unassigned
22126-22127 Unassigned
22223-22272 Unassigned
wnn6 22273 tcp wnn6 Yasunari Gon Yamasita Yasunari Gon Yamasita
wnn6 22273 udp wnn6 Yasunari Gon Yamasita Yasunari Gon Yamasita
22274-22304 Unassigned
22556-22762 Unassigned
talikaserver 22763 tcp Talika Main Server Laxman C. Marathe Laxman C. Marathe 2006-12
talikaserver 22763 udp Talika Main Server Laxman C. Marathe Laxman C. Marathe 2006-12
22764-22799 Unassigned
23054-23271 Unassigned
23272 tcp Reserved
s102 23272 udp S102 application Kimmo Kymalainen Kimmo Kymalainen 2009-08-26
23273-23293 Unassigned
24727 Unassigned Unauthorized Use Known on port 24727
flex-lm 27000-27009 FLEX LM (1-10) Flexera Software Paul Bland 2018-02-15
flex-lmadmin 27010 tcp A protocol for managing license services Flexera Paul Bland 2018-08-22
27010 udp Reserved
27011-27015 Unassigned
chlenix 27016 tcp Cloud hosting environment network Vlad Bondarenko Vlad Bondarenko 2024-09-23
27016 udp Reserved
mongodb 27017 tcp Mongo database system MongoDB, Inc. Akshay Kumar 2019-02-21
27017 udp Reserved
27018-27344 Unassigned Unauthorized Use Known on ports 27018 and 27019
imagepump 27345 tcp ImagePump Richard Minner Richard Minner
imagepump 27345 udp ImagePump Richard Minner Richard Minner
27346-27441 Unassigned
jesmsjc 27442 tcp Job controller service Chris Newman Chris Newman 2010-10-15
jesmsjc 27442 udp Job controller service Chris Newman Chris Newman 2010-10-15
27443-27503 Unassigned
kopek-httphead 27504 tcp Kopek HTTP Head Port Sten H. Danielsen Sten H. Danielsen 2002-07
kopek-httphead 27504 udp Kopek HTTP Head Port Sten H. Danielsen Sten H. Danielsen 2002-07
27505-27781 Unassigned
ars-vista 27782 tcp ARS VISTA Application Spencer Teran Spencer Teran 2004-11
ars-vista 27782 udp ARS VISTA Application Spencer Teran Spencer Teran 2004-11
27783-27875 Unassigned
astrolink 27876 tcp Astrolink Protocol Alanax Technologies, Inc Wesley Eddy 2013-01-14
27876 udp Reserved
27877-27998 Unassigned
tw-auth-key 27999 tcp TW Authentication/Key Distribution and Alex Duncan Alex Duncan
tw-auth-key 27999 udp Attribute Certificate Services Alex Duncan Alex Duncan
a27-ran-ran 28119 udp A27 cdma2000 RAN Management 3GPP2 Zhiming Li 2012-04-13
32637-32766 Unassigned
filenet-powsrm 32767 tcp FileNet BPM WS-ReliableMessaging Client Chris Adkins Chris Adkins 2006-08
filenet-powsrm 32767 udp FileNet BPM WS-ReliableMessaging Client Chris Adkins Chris Adkins 2006-08
filenet-tms 32768 tcp Filenet TMS Daniel Whelan Daniel Whelan
filenet-tms 32768 udp Filenet TMS Daniel Whelan Daniel Whelan
filenet-rpc 32769 tcp Filenet RPC Daniel Whelan Daniel Whelan
filenet-rpc 32769 udp Filenet RPC Daniel Whelan Daniel Whelan
filenet-nch 32770 tcp Filenet NCH Daniel Whelan Daniel Whelan
filenet-nch 32770 udp Filenet NCH Daniel Whelan Daniel Whelan
filenet-rmi 32771 tcp FileNET RMI Chris Adkins Chris Adkins
filenet-rmi 32771 udp FileNet RMI Chris Adkins Chris Adkins
filenet-pa 32772 tcp FileNET Process Analyzer Chris Adkins Chris Adkins 2003-01
filenet-pa 32772 udp FileNET Process Analyzer Chris Adkins Chris Adkins 2003-01
filenet-cm 32773 tcp FileNET Component Manager Chris Adkins Chris Adkins 2003-08
filenet-cm 32773 udp FileNET Component Manager Chris Adkins Chris Adkins 2003-08
filenet-re 32774 tcp FileNET Rules Engine Chris Adkins Chris Adkins 2003-08
filenet-re 32774 udp FileNET Rules Engine Chris Adkins Chris Adkins 2003-08
filenet-pch 32775 tcp Performance Clearinghouse Tim Morgan Tim Morgan 2005-11
filenet-pch 32775 udp Performance Clearinghouse Tim Morgan Tim Morgan 2005-11
filenet-peior 32776 tcp FileNET BPM IOR Chris Adkins Chris Adkins 2006-05
filenet-peior 32776 udp FileNET BPM IOR Chris Adkins Chris Adkins 2006-05
filenet-obrok 32777 tcp FileNet BPM CORBA Chris Adkins Chris Adkins 2006-10
filenet-obrok 32777 udp FileNet BPM CORBA Chris Adkins Chris Adkins 2006-10

Contact Information

Name Organization Contact URI Last Updated
3GPP2 lizhiming&huawei.com 2012-01-11
Akshay Kumar MongoDB, Inc. akshay&mongodb.com 2019-02-21
Alanax Technologies, Inc brian.barritt&alanax.com 2013-01-14
Alex Duncan Alex.Duncan&sse.ie
Alstom Transport, Preston paul.steane&transport.alstom.com 2012-12-14
Andreas Fehr andreas&mrs.ch
Avi Primo aprimo&celltick.com 2008-01-29
Chris Adkins cadkins&filenet.com 2006-10
Chris Newman chris.newman&oracle.com 2017-01-26
Daniel Whelan dwhelan&filenet.com
Dave Lamb rdl&rdl.cnd.hp.com
Donald Dylla donald.dylla&hp.com 2004-12
Flexera pbland&flexera.com 2018-08-22
Flexera Software security&flexerasoftware.com 2016-07-19
Jeremy McClintock jeremy&tridsys.com 2005-08
Khiem Tran Khiem.Tran&andrew.com 2007-11-06
Kimmo Kymalainen kimmo.kymalainen&etsi.org 2017-05-08
Laxman C. Marathe lcmarathe&thomsonpress.com 2006-12
Marc Binstock marc.binstock&citrix.com 2008-01-29
Microsoft Corporation naengler&microsoft.com 2022-05-03
MongoDB, Inc. akshay&mongodb.com 2019-02-21
Narkis Engler Microsoft Corporation naengler&microsoft.com 2022-05-03
Nestor A. Diaz nestor&tiendalinux.com 2009-05-12
Paul Bland pbland&flexera.com 2018-08-22
Paul Steane Alstom Transport, Preston paul.steane&transport.alstom.com 2012-12-14
Pavel Csefalvay csefalvay&gmail.com 2020-09-18
Richard Minner http://xippix.com
Robot Framework Foundation robotframework-foundation&googlegroups.com 2017-01-26
Spencer Teran steran&ars.com 2004-11
Sten H. Danielsen shd&kopek.net 2002-07
Stuart Cheshire pdl-datastream&apple.com 2002-09
Tim Morgan tmorgan&filenet.com 2005-11
Vlad Bondarenko bondarenko.vlad.univ&gmail.com 2024-09-23
Wesley Eddy Alanax Technologies, Inc wesley.eddy&alanax.com 2013-01-14
Yasunari Gon Yamasita yamasita&omronsoft.co.jp
Zhiming Li 3GPP2 lizhiming&huawei.com 2012-01-11