Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
45679-45823 Unassigned
45967-46335 Unassigned
mihcs MIH Command Services RFC 5679
mihes MIH Event Services RFC 5679
mihis MIH Information Services RFC 5679
caldav tcp Calendaring Extensions to WebDAV (CalDAV) - non-TLS IESG IETF Chair 2012-02-17 RFC 6764 This is an extension of the http service. Defined TXT keys: path=<context path>
caldavs tcp Calendaring Extensions to WebDAV (CalDAV) - over TLS IESG IETF Chair 2012-02-17 RFC 6764 This is an extension of the https service. Defined TXT keys: path=<context path>
jnx-kcsync tcp jollys keychain cloud sync protocol Patrick Stein Patrick Stein 2011-10-24 Defined TXT keys: hash=<40hex characters> salt=<40hex characters> uuid=<40hex characters> Example: hash=5e7580598c0d7064d4fc79faaeb42585e1a675f8 salt=f0164cb3a0c3d7efe75abea8fda86d2d56c8dda9 uuid=db61dc092922252e45bbb264f59147138c7fd5fa
timezone tcp Time Zone Data Distribution Service - non-TLS IESG IETF Chair 2015-08-03 RFC 7808 This is an extension of the http service. Defined TXT keys: path=<context path> (as per Section 6 of RFC 6763).
timezones tcp Time Zone Data Distribution Service - over TLS IESG IETF Chair 2015-08-03 RFC 7808 This is an extension of the https service. Defined TXT keys: path=<context path> (as per Section 6 of RFC 6763).

Contact Information

Name Organization Contact URI Last Updated
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Patrick Stein Patrick.Stein&jinx.eu 2011-10-24