Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| 7203-7214 | Unassigned | ||||||||||
| 7420 | tcp | Reserved | |||||||||
| ipluminary | 7420 | udp | Multichannel real-time lighting control | Tristan Seifert | Tristan Seifert | 2018-01-18 | |||||
| medimageportal | 7720 | tcp | MedImage Portal | Robert Helton | Robert Helton | 2003-10 | |||||
| medimageportal | 7720 | udp | MedImage Portal | Robert Helton | Robert Helton | 2003-10 | |||||
| intu-ec-svcdisc | 8020 | tcp | Intuit Entitlement Service and Discovery | Daniel C. McGloin | Daniel C. McGloin | 2005-05 | |||||
| intu-ec-svcdisc | 8020 | udp | Intuit Entitlement Service and Discovery | Daniel C. McGloin | Daniel C. McGloin | 2005-05 | |||||
| 8077 | tcp | Reserved | 2024-01-05 | De-Assigned on 2024-01-05. | |||||||
| 8119-8120 | Unassigned | ||||||||||
| trivnet1 | 8200 | tcp | TRIVNET | Saar Wilf | Saar Wilf | ||||||
| trivnet1 | 8200 | udp | TRIVNET | Saar Wilf | Saar Wilf | ||||||
| trivnet2 | 8201 | tcp | TRIVNET | Saar Wilf | Saar Wilf | ||||||
| trivnet2 | 8201 | udp | TRIVNET | Saar Wilf | Saar Wilf | ||||||
| 8202 | tcp | Reserved | |||||||||
| aesop | 8202 | udp | Audio+Ethernet Standard Open Protocol | POWERSOFT S.R.L. | Paolo Desii; Claudio Lastrucci | 2012-01-03 | |||||
| 8203-8203 | Unassigned | ||||||||||
| lm-perfworks | 8204 | tcp | LM Perfworks | Chris Flynn | Chris Flynn | ||||||
| lm-perfworks | 8204 | udp | LM Perfworks | Chris Flynn | Chris Flynn | ||||||
| lm-instmgr | 8205 | tcp | LM Instmgr | Chris Flynn | Chris Flynn | ||||||
| lm-instmgr | 8205 | udp | LM Instmgr | Chris Flynn | Chris Flynn | ||||||
| lm-dta | 8206 | tcp | LM Dta | Chris Flynn | Chris Flynn | ||||||
| lm-dta | 8206 | udp | LM Dta | Chris Flynn | Chris Flynn | ||||||
| lm-sserver | 8207 | tcp | LM SServer | Chris Flynn | Chris Flynn | ||||||
| lm-sserver | 8207 | udp | LM SServer | Chris Flynn | Chris Flynn | ||||||
| lm-webwatcher | 8208 | tcp | LM Webwatcher | Chris Flynn | Chris Flynn | ||||||
| lm-webwatcher | 8208 | udp | LM Webwatcher | Chris Flynn | Chris Flynn | ||||||
| 8209-8210 | Unassigned | ||||||||||
| tnp-discover | 8320 | tcp | Thin(ium) Network Protocol | Aly Orady | Aly Orady | 2007-08-07 | |||||
| tnp-discover | 8320 | udp | Thin(ium) Network Protocol | Aly Orady | Aly Orady | 2007-08-07 | |||||
| 8699 | udp | Reserved | 2004-11 | 2013-05-24 | This entry is being removed on 2013-05-24. | ||||||
| tambora | 9020 | tcp | TAMBORA | Jason van Zyl | Jason van Zyl | 2002-03 | |||||
| tambora | 9020 | udp | TAMBORA | Jason van Zyl | Jason van Zyl | 2002-03 | |||||
| xadmin | 9105 | tcp | Xadmin Control Service | Ariën Huisken <xadmin&huisken-systems.nl> 15 June 2009 | |||||||
| xadmin | 9105 | udp | Xadmin Control Service | Ariën Huisken <xadmin&huisken-systems.nl> 15 June 2009 | |||||||
| 9120-9121 | Unassigned | ||||||||||
| wap-wsp | 9200 | tcp | WAP connectionless session service | WAP Forum | WAP Forum | ||||||
| wap-wsp | 9200 | udp | WAP connectionless session service | WAP Forum | WAP Forum | ||||||
| wap-wsp-wtp | 9201 | tcp | WAP session service | WAP Forum | WAP Forum | ||||||
| wap-wsp-wtp | 9201 | udp | WAP session service | WAP Forum | WAP Forum | ||||||
| wap-wsp-s | 9202 | tcp | WAP secure connectionless session service | WAP Forum | WAP Forum | ||||||
| wap-wsp-s | 9202 | udp | WAP secure connectionless session service | WAP Forum | WAP Forum | ||||||
| wap-wsp-wtp-s | 9203 | tcp | WAP secure session service | WAP Forum | WAP Forum | ||||||
| wap-wsp-wtp-s | 9203 | udp | WAP secure session service | WAP Forum | WAP Forum | ||||||
| wap-vcard | 9204 | tcp | WAP vCard | WAP Forum | WAP Forum | ||||||
| wap-vcard | 9204 | udp | WAP vCard | WAP Forum | WAP Forum | ||||||
| wap-vcal | 9205 | tcp | WAP vCal | WAP Forum | WAP Forum | ||||||
| wap-vcal | 9205 | udp | WAP vCal | WAP Forum | WAP Forum | ||||||
| wap-vcard-s | 9206 | tcp | WAP vCard Secure | WAP Forum | WAP Forum | ||||||
| wap-vcard-s | 9206 | udp | WAP vCard Secure | WAP Forum | WAP Forum | ||||||
| wap-vcal-s | 9207 | tcp | WAP vCal Secure | WAP Forum | WAP Forum | ||||||
| wap-vcal-s | 9207 | udp | WAP vCal Secure | WAP Forum | WAP Forum | ||||||
| rjcdb-vcards | 9208 | tcp | rjcdb vCard | Robert John Churchill | Robert John Churchill | 2006-01 | |||||
| rjcdb-vcards | 9208 | udp | rjcdb vCard | Robert John Churchill | Robert John Churchill | 2006-01 | |||||
| almobile-system | 9209 | tcp | ALMobile System Service | Rob Graber | Rob Graber | 2006-01 | |||||
| almobile-system | 9209 | udp | ALMobile System Service | Rob Graber | Rob Graber | 2006-01 | |||||
| 9319-9320 | Unassigned | ||||||||||
| kca-service | 9878 | udp | The KX509 Kerberized Certificate Issuance Protocol in Use in 2012 | IESG | IETF Chair | 2012-07-12 | RFC 6717 | Historically, this service has been referred to as "kca_service", but this service name does not meet the registry requirements. | |||
| abb-hw | 10020 | tcp | Hardware configuration and maintenance | ABB | Adam Norén | 2017-03-28 | |||||
| 10020 | udp | Reserved | |||||||||
| trisoap | 10200 | tcp | Trigence AE Soap Service | Brigitte Gagne | Brigitte Gagne | 2006-08 | |||||
| trisoap | 10200 | udp | Trigence AE Soap Service | Brigitte Gagne | Brigitte Gagne | 2006-08 | |||||
| rsms | 10201 | tcp | Remote Server Management Service | Patrick H. Piper | Patrick H. Piper | 2009-03-06 | |||||
| rscs | 10201 | udp | Remote Server Control and Test Service | Patrick H. Piper | Patrick H. Piper | 2009-03-06 | |||||
| 10202-10251 | Unassigned | ||||||||||
| 10289-10320 | Unassigned | ||||||||||
| 10321 | tcp | Reserved | 2023-12-05 | De-Assigned on 2023-12-05. | |||||||
| 11176-11200 | Unassigned | ||||||||||
| smsqp | 11201 | tcp | smsqp | Andres Seco Hernandez | Andres Seco Hernandez | ||||||
| smsqp | 11201 | udp | smsqp | Andres Seco Hernandez | Andres Seco Hernandez | ||||||
| dcsl-backup | 11202 | tcp | DCSL Network Backup Services | John Reynolds | John Reynolds | 2012-04-17 | Defined TXT keys: DCSL-Service | ||||
| 11202 | udp | Reserved | |||||||||
| 11203-11207 | Unassigned | ||||||||||
| wifree | 11208 | tcp | WiFree Service | Jose Luis Martin Peinado | Jose Luis Martin Peinado | 2006-03 | |||||
| wifree | 11208 | udp | WiFree Service | Jose Luis Martin Peinado | Jose Luis Martin Peinado | 2006-03 | |||||
| 11209-11210 | Unassigned | ||||||||||
| imip-channels | 11320 | tcp | IMIP Channels Port | Len Zuvela | Len Zuvela | ||||||
| imip-channels | 11320 | udp | IMIP Channels Port | Len Zuvela | Len Zuvela | ||||||
| h323callsigalt | 11720 | tcp | H.323 Call Control Signalling Alternate | ITU-T | ITU-T TSB | 2013-01-31 | |||||
| h323callsigalt | 11720 | udp | H.323 Call Control Signalling Alternate | ITU-T | ITU-T TSB | 2013-01-31 | |||||
| entextxid | 12000 | tcp | IBM Enterprise Extender SNA XID Exchange | Eugene Cox | Eugene Cox | ||||||
| entextxid | 12000 | udp | IBM Enterprise Extender SNA XID Exchange | Eugene Cox | Eugene Cox | ||||||
| entextnetwk | 12001 | tcp | IBM Enterprise Extender SNA COS Network Priority | Eugene Cox | Eugene Cox | ||||||
| entextnetwk | 12001 | udp | IBM Enterprise Extender SNA COS Network Priority | Eugene Cox | Eugene Cox | ||||||
| entexthigh | 12002 | tcp | IBM Enterprise Extender SNA COS High Priority | Eugene Cox | Eugene Cox | ||||||
| entexthigh | 12002 | udp | IBM Enterprise Extender SNA COS High Priority | Eugene Cox | Eugene Cox | ||||||
| entextmed | 12003 | tcp | IBM Enterprise Extender SNA COS Medium Priority | Eugene Cox | Eugene Cox | ||||||
| entextmed | 12003 | udp | IBM Enterprise Extender SNA COS Medium Priority | Eugene Cox | Eugene Cox | ||||||
| entextlow | 12004 | tcp | IBM Enterprise Extender SNA COS Low Priority | Eugene Cox | Eugene Cox | ||||||
| entextlow | 12004 | udp | IBM Enterprise Extender SNA COS Low Priority | Eugene Cox | Eugene Cox | ||||||
| dbisamserver1 | 12005 | tcp | DBISAM Database Server - Regular | Tim Young | Tim Young | 2002-05 | |||||
| dbisamserver1 | 12005 | udp | DBISAM Database Server - Regular | Tim Young | Tim Young | 2002-05 | |||||
| dbisamserver2 | 12006 | tcp | DBISAM Database Server - Admin | Tim Young | Tim Young | 2002-05 | |||||
| dbisamserver2 | 12006 | udp | DBISAM Database Server - Admin | Tim Young | Tim Young | 2002-05 | |||||
| accuracer | 12007 | tcp | Accuracer Database System Server | Alexander V. Ivanov | Alexander V. Ivanov | 2004-12 | |||||
| accuracer | 12007 | udp | Accuracer Database System Server | Alexander V. Ivanov | Alexander V. Ivanov | 2004-12 | |||||
| accuracer-dbms | 12008 | tcp | Accuracer Database System Admin | Alexander V. Ivanov | Alexander V. Ivanov | 2004-12 | |||||
| accuracer-dbms | 12008 | udp | Accuracer Database System Admin | Alexander V. Ivanov | Alexander V. Ivanov | 2004-12 | |||||
| 12009 | tcp | Reserved | |||||||||
| ghvpn | 12009 | udp | Green Hills VPN | Green Hills Software | Tom R. Zavisca | 2012-02-07 | |||||
| edbsrvr | 12010 | tcp | ElevateDB Server | Tim Young | Tim Young | 2009-05-06 | |||||
| 12010 | udp | Reserved |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| ABB | adam.noren&se.abb.com | 2017-03-28 | |
| Adam Norén | ABB | adam.noren&se.abb.com | 2017-03-28 |
| Alexander V. Ivanov | support&aidaim.com | 2004-12 | |
| Aly Orady | Atto Devices Inc. | aly.orady&attodevices.com | 2007-08-07 |
| Andres Seco Hernandez | AndresSH&alamin.org | ||
| Brigitte Gagne | bgagne&trigence.com | 2006-08 | |
| Chris Flynn | cflynn&landmark.com | ||
| Claudio Lastrucci | POWERSOFT S.R.L. | claudio.lastrucci&powersoft.it | 2012-01-03 |
| Daniel C. McGloin | daniel_mcgloin&intuit.com | 2005-05 | |
| Eugene Cox | genecox&raleigh.ibm.com | ||
| Green Hills Software | iana-contact&ghs.com | 2012-02-07 | |
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| ITU-T | tsbsg16&itu.int | 2013-01-31 | |
| ITU-T TSB | ITU-T | tsbsg16&itu.int | 2013-01-31 |
| Jason van Zyl | jvanzyl&zenplex.com | 2002-03 | |
| John Reynolds | John.Reynolds&datacoresl.com | 2012-04-17 | |
| Jose Luis Martin Peinado | jooe&wifree-project.net | 2006-03 | |
| Len Zuvela | lenzµsoft.com | ||
| Paolo Desii | POWERSOFT S.R.L. | paolo.desii&powersoft.it | 2012-01-03 |
| Patrick H. Piper | ppiper&netlinxinc.com | 2009-03-06 | |
| POWERSOFT S.R.L. | claudio.lastrucci&powersoft.it | 2012-01-03 | |
| Rob Graber | r.graber&austinlane.com | 2006-01 | |
| Robert Helton | bob_helton&medimage.com | 2003-10 | |
| Robert John Churchill | rjc&rjcdb.com | 2006-01 | |
| Saar Wilf | saar&trivnet.com | ||
| Tim Young | timyoung&elevatesoft.com | 2009-05-06 | |
| Tom R. Zavisca | Green Hills Software | iana-contact&ghs.com | 2012-02-07 |
| Tristan Seifert | t&tseifert.me | 2018-01-18 | |
| WAP Forum | wap-feedback&mail.wapforum.org
pg&uplanet.com |