Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
22348-22349 Unassigned
codemeter 22350 tcp CodeMeter Standard Wolfgang Voelker Wolfgang Voelker 2007-06
codemeter 22350 udp CodeMeter Standard Wolfgang Voelker Wolfgang Voelker 2007-06
codemeter-cmwan 22351 tcp TPC/IP requests of copy protection software to a server WIBU-SYSTEMS AG Wolfgang Völker 2013-06-25
22351 udp Reserved
22352-22536 Unassigned
inovaport1 23000 tcp Inova LightLink Server Type 1 Chris Koeritz Chris Koeritz 2006-10
inovaport1 23000 udp Inova LightLink Server Type 1 Chris Koeritz Chris Koeritz 2006-10
inovaport2 23001 tcp Inova LightLink Server Type 2 Chris Koeritz Chris Koeritz 2006-10
inovaport2 23001 udp Inova LightLink Server Type 2 Chris Koeritz Chris Koeritz 2006-10
inovaport3 23002 tcp Inova LightLink Server Type 3 Chris Koeritz Chris Koeritz 2006-10
inovaport3 23002 udp Inova LightLink Server Type 3 Chris Koeritz Chris Koeritz 2006-10
inovaport4 23003 tcp Inova LightLink Server Type 4 Chris Koeritz Chris Koeritz 2006-10
inovaport4 23003 udp Inova LightLink Server Type 4 Chris Koeritz Chris Koeritz 2006-10
inovaport5 23004 tcp Inova LightLink Server Type 5 Chris Koeritz Chris Koeritz 2006-10
inovaport5 23004 udp Inova LightLink Server Type 5 Chris Koeritz Chris Koeritz 2006-10
inovaport6 23005 tcp Inova LightLink Server Type 6 Chris Koeritz Chris Koeritz 2006-10
inovaport6 23005 udp Inova LightLink Server Type 6 Chris Koeritz Chris Koeritz 2006-10
23006-23052 Unassigned
gntp 23053 tcp Generic Notification Transport Protocol The Growl Project Chris Forsythe 2012-02-07
23053 udp Reserved
23054-23271 Unassigned
23272 tcp Reserved
s102 23272 udp S102 application Kimmo Kymalainen Kimmo Kymalainen 2009-08-26
23273-23293 Unassigned
5afe-dir 23294 tcp 5AFE SDN Directory Ayoda GmbH Laurenz Eschwey 2016-04-01
5afe-disc 23294 udp 5AFE SDN Directory discovery Ayoda GmbH Laurenz Eschwey 2016-04-01
23295-23332 Unassigned
elxmgmt 23333 tcp Emulex HBAnyware Remote Management Maziar Tamadon Maziar Tamadon 2007-11-06
elxmgmt 23333 udp Emulex HBAnyware Remote Management Maziar Tamadon Maziar Tamadon 2007-11-06
23334-23399 Unassigned
novar-dbase 23400 tcp Novar Data Keith Kilroy Keith Kilroy 2006-02
novar-dbase 23400 udp Novar Data Keith Kilroy Keith Kilroy 2006-02
novar-alarm 23401 tcp Novar Alarm Keith Kilroy Keith Kilroy 2006-02
novar-alarm 23401 udp Novar Alarm Keith Kilroy Keith Kilroy 2006-02
novar-global 23402 tcp Novar Global Keith Kilroy Keith Kilroy 2006-02
novar-global 23402 udp Novar Global Keith Kilroy Keith Kilroy 2006-02
23403-23455 Unassigned
aequus 23456 tcp Aequus Service James Anson James Anson 2009-02-12
23456 udp Reserved
aequus-alt 23457 tcp Aequus Service Mgmt James Anson James Anson 2009-02-12
23457 udp Reserved
23458-23545 Unassigned
areaguard-neo 23546 tcp AreaGuard Neo - WebServer SODATSW spol. s r.o. Roman Štěpánek 2012-05-31
23546 udp Reserved
23547-23999 Unassigned
vrmg-ip 24323 tcp Verimag mobile class protocol over TCP Verimag, OOO Denis Ionov 2018-08-15
24323 udp Reserved
24923-24999 Unassigned
28201-28239 Unassigned
32250-32399 Unassigned
aurora-balaena 33123 tcp Aurora (Balaena Ltd) Andrew Mather Andrew Mather 2008-02-14
aurora-balaena 33123 udp Aurora (Balaena Ltd) Andrew Mather Andrew Mather 2008-02-14
slmap 36423 sctp SLm Interface Application Protocol 3GPP Kimmo Kymalainen 2015-06-18
36463-36523 Unassigned
38423-38461 Unassigned
40023 tcp Reserved
k-patentssensor 40023 udp K-PatentsSensorInformation Vaisala Saku Lähteenmäki 2015-12-02 2021-02-02
z-wave-s 41230 tcp Z-Wave Protocol over SSL/TLS Sigma Designs Anders Brandt 2015-06-26
z-wave-s 41230 udp Z-Wave Protocol over DTLS Sigma Designs Anders Brandt 2015-06-26
41231-41793 Unassigned
z-wave-tunnel 44123 tcp Z-Wave Secure Tunnel Sigma Designs, Inc. Anders Brandt 2012-10-12 2015-06-26
44123 udp Reserved
pmwebapi 44323 tcp HTTP binding for Performance Co-Pilot client API Performance Co-Pilot (PCP) Project Ken McDonell 2013-10-09
44323 udp Unassigned "pcp" assignment withdrawn, moved to port 5351 per RFC 6887
45679-45823 Unassigned
47558-47623 Unassigned
brski-pledge tcp The Bootstrapping Remote Secure Key Infrastructure Pledge IESG IETF Chair 2026-05-11 RFC-ietf-anima-brski-prm-23 Defined TXT keys: None
h323 H.323 Real-time audio, video and data communication call setup protocol Will MacDonald Will MacDonald Defined TXT keys: None

Contact Information

Name Organization Contact URI Last Updated
3GPP kimmo.kymalainen&etsi.org 2015-06-18
Anders Brandt Sigma Designs anders_brandt&sigmadesigns.com 2012-10-12
Anders Brandt Sigma Designs anders_brandt&sigmadesigns.com 2015-06-26
Andrew Mather info&balaena.com 2008-02-14
Ayoda GmbH info&ayoda.net 2016-04-01
Chris Forsythe The Growl Project chris&growl.info 2012-02-07
Chris Koeritz portmanager&inovasolutions.com 2006-10
Denis Ionov Verimag, OOO iddi&verimag.ru 2018-07-20
The Growl Project support&growl.info 2012-02-07
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
James Anson janson&bigpond.com 2009-02-12
Keith Kilroy Keith.Kilroy&novarcontrols.com 2006-02
Ken McDonell kenj&kenj.id.au 2025-09-26
Kimmo Kymalainen kimmo.kymalainen&etsi.org 2017-05-08
Laurenz Eschwey laurenz.eschwey&ayoda.net 2016-04-01
Maziar Tamadon maziar.tamadon&emulex.com 2007-11-06
Performance Co-Pilot (PCP) Project pcp-maintainers&groups.io 2025-09-26
Roman Štěpánek SODATSW spol. s r.o. roman.stepanek&sodatsw.cz 2012-05-31
Saku Lähteenmäki saku.lahteenmaki&vaisala.com 2021-02-02
Sigma Designs, Inc. anders_brandt&sigmadesigns.com 2011-10-03
Sigma Designs anders_brandt&sigmadesigns.com 2015-06-26
SODATSW spol. s r.o. info&sodatsw.cz 2012-05-31
Vaisala saku.lahteenmaki&vaisala.com 2021-02-02
Verimag, OOO support&verimag.ru 2018-07-20
WIBU-SYSTEMS AG oliver.winzenried&wibu.com 2013-06-25
Will MacDonald will&codian.com
Wolfgang Voelker wolfgang.voelker&wibu.com 2007-06
Wolfgang Völker WIBU-SYSTEMS AG wolfgang.voelker&wibu.com 2013-06-25