Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
12010 udp Reserved
12011 Unassigned
vipera 12012 tcp Vipera Messaging Service Silvano Maffeis Silvano Maffeis 2005-08
vipera 12012 udp Vipera Messaging Service Silvano Maffeis Silvano Maffeis 2005-08
vipera-ssl 12013 tcp Vipera Messaging Service over SSL Communication Silvano Maffeis Silvano Maffeis 2008-01-16
vipera-ssl 12013 udp Vipera Messaging Service over SSL Communication Silvano Maffeis Silvano Maffeis 2008-01-16
12014-12108 Unassigned
12110-12120 Unassigned
12303-12320 Unassigned
bprd 13720 tcp BPRD Protocol (VERITAS NetBackup) Jeff Holmbeck Jeff Holmbeck
bprd 13720 udp BPRD Protocol (VERITAS NetBackup) Jeff Holmbeck Jeff Holmbeck
dsmcc-passthru 13820 tcp DSMCC Pass-Thru Messages Tim Addington Tim Addington ISO/IEC 13818-6 MPEG-2 DSM-CC
dsmcc-passthru 13820 udp DSMCC Pass-Thru Messages Tim Addington Tim Addington ISO/IEC 13818-6 MPEG-2 DSM-CC
jwpc 16020 tcp Filemaker Java Web Publishing Core Robert Parks Robert Parks 2010-05-12
16020 udp Reserved
16620-16664 Unassigned
avtp 17220 tcp IEEE 1722 Transport Protocol for Time Sensitive Applications Transport Protocol for Time-Sensitive Networking TG Ashley Butterworth 2014-03-07
avtp 17220 udp IEEE 1722 Transport Protocol for Time Sensitive Applications Transport Protocol for Time-Sensitive Networking TG Ashley Butterworth 2014-03-07
j-link 19020 tcp J-Link TCP/IP Protocol SEGGER Microcontroller GmbH & Co. KG SEGGER Microcontroller GmbH & Co. KG
19020 udp Reserved
cora 19220 tcp Client Connection Management and Data Exchange Service Softvise GmbH Ronny Krüger 2016-11-10
cora-disc 19220 udp Discovery for Client Connection Management and Data Exchange Service Softvise GmbH Ronny Krüger 2016-11-10
dnp 20000 tcp DNP Michael Thesing Michael Thesing
dnp 20000 udp DNP Michael Thesing Michael Thesing
dnp 20000 sctp Distributed Network Protocol DNP Users Group Andrew West 2022-12-20
microsan 20001 tcp MicroSAN Thomas E. Ludwig Thomas E. Ludwig 2004-02
microsan 20001 udp MicroSAN Thomas E. Ludwig Thomas E. Ludwig 2004-02
commtact-http 20002 tcp Commtact HTTP Tomas Svoboda Tomas Svoboda 2004-12
commtact-http 20002 udp Commtact HTTP Tomas Svoboda Tomas Svoboda 2004-12
commtact-https 20003 tcp Commtact HTTPS Tomas Svoboda Tomas Svoboda 2004-12
commtact-https 20003 udp Commtact HTTPS Tomas Svoboda Tomas Svoboda 2004-12
20004 Unassigned
openwebnet 20005 tcp OpenWebNet protocol for electric network BTicino S.p.A. BTicino S.p.A. 2008-04-09
openwebnet 20005 udp OpenWebNet protocol for electric network BTicino S.p.A. BTicino S.p.A. 2008-04-09
20006-20011 Unassigned
20012 tcp Reserved
ss-idi-disc 20012 udp Samsung Interdevice Interaction discovery Hong, Jungkih Hong, Jungkih
ss-idi 20013 tcp Samsung Interdevice Interaction Hong, Jungkih Hong, Jungkih
20013 udp Reserved
opendeploy 20014 tcp OpenDeploy Listener Todd Scallan Todd Scallan 2005-08
opendeploy 20014 udp OpenDeploy Listener Todd Scallan Todd Scallan 2005-08
20015-20033 Unassigned
nburn-id 20034 tcp NetBurner ID Port

IANA assigned this well-formed service name as a replacement for "nburn_id".
Paul Breed Paul Breed 2003-11
nburn_id 20034 tcp NetBurner ID Port Paul Breed Paul Breed 2003-11 This entry is an alias to "nburn-id". This entry is now historic, not usable for use with many common service discovery mechanisms.
nburn-id 20034 udp NetBurner ID Port

IANA assigned this well-formed service name as a replacement for "nburn_id".
Paul Breed Paul Breed 2003-11
nburn_id 20034 udp NetBurner ID Port Paul Breed Paul Breed 2003-11 This entry is an alias to "nburn-id". This entry is now historic, not usable for use with many common service discovery mechanisms.
20035-20045 Unassigned
tmophl7mts 20046 tcp TMOP HL7 Message Transfer Service Tim Riley Tim Riley 2009-07-31
tmophl7mts 20046 udp TMOP HL7 Message Transfer Service Tim Riley Tim Riley 2009-07-31
20047-20047 Unassigned
mountd 20048 tcp NFS mount protocol Nicolas Williams Nicolas Williams 2010-08-09
mountd 20048 udp NFS mount protocol Nicolas Williams Nicolas Williams 2010-08-09
nfsrdma 20049 tcp Network File System (NFS) over RDMA 2017-09-05 RFC 8267
nfsrdma 20049 udp Network File System (NFS) over RDMA 2017-09-05 RFC 8267
nfsrdma 20049 sctp Network File System (NFS) over RDMA 2017-09-05 RFC 8267
20050-20056 Unassigned
avesterra 20057 tcp AvesTerra Hypergraph Transfer Protocol (HGTP) Georgetown University J.C. Smart 2016-06-06
20057 udp Reserved
20058-20166 Unassigned
tolfab 20167 tcp TOLfab Data Change Pierre Couderc Pierre Couderc 2006-03
tolfab 20167 udp TOLfab Data Change Pierre Couderc Pierre Couderc 2006-03
20168-20201 Unassigned
ipdtp-port 20202 tcp IPD Tunneling Port Vikki Yin Wei Vikki Yin Wei 2003-01
ipdtp-port 20202 udp IPD Tunneling Port Vikki Yin Wei Vikki Yin Wei 2003-01
20203-20221 Unassigned
ipulse-ics 20222 tcp iPulse-ICS Meggie Garica-Woodruff Meggie Garica-Woodruff
ipulse-ics 20222 udp iPulse-ICS Meggie Garica-Woodruff Meggie Garica-Woodruff
20223-20479 Unassigned
emwavemsg 20480 tcp emWave Message Service Harald Striepe Harald Striepe 2008-02-14
emwavemsg 20480 udp emWave Message Service Harald Striepe Harald Striepe 2008-02-14
20481-20669 Unassigned
track 20670 tcp Track Michael Sweet Michael Sweet
track 20670 udp Track Michael Sweet Michael Sweet
20671-20809 Unassigned
crtech-nlm 20810 tcp CRTech NLM Cullimore And Ring Technologies Dave Wilkins 2021-06-24
20810 udp Reserved
20811-20998 Unassigned
athand-mmp 20999 tcp At Hand MMP Stepan Riha Stepan Riha
athand-mmp 20999 udp AT Hand MMP Stepan Riha Stepan Riha
21214-21220 Unassigned
snapenetio 22000 tcp SNAPenetIO Kevin Kuhns Kevin Kuhns
snapenetio 22000 udp SNAPenetIO Kevin Kuhns Kevin Kuhns
optocontrol 22001 tcp OptoControl Kevin Kuhns Kevin Kuhns
optocontrol 22001 udp OptoControl Kevin Kuhns Kevin Kuhns
optohost002 22002 tcp Opto Host Port 2 Doug Leany Doug Leany 2006-09
optohost002 22002 udp Opto Host Port 2 Doug Leany Doug Leany 2006-09
optohost003 22003 tcp Opto Host Port 3 Doug Leany Doug Leany 2006-09
optohost003 22003 udp Opto Host Port 3 Doug Leany Doug Leany 2006-09
optohost004 22004 tcp Opto Host Port 4 Doug Leany Doug Leany 2006-09
optohost004 22004 udp Opto Host Port 4 Doug Leany Doug Leany 2006-09
optohost004 22005 tcp Opto Host Port 5 Doug Leany Doug Leany 2006-09
optohost004 22005 udp Opto Host Port 5 Doug Leany Doug Leany 2006-09
22006-22124 Unassigned
24250-24320 Unassigned
26134-26207 Unassigned
wnn6-ds 26208 tcp wnn6-ds Yasunari Gon Yamasita Yasunari Gon Yamasita
wnn6-ds 26208 udp wnn6-ds Yasunari Gon Yamasita Yasunari Gon Yamasita
26209-26256 Unassigned
a27-ran-ran 28119 udp A27 cdma2000 RAN Management 3GPP2 Zhiming Li 2012-04-13
28120-28199 Unassigned
voxelstorm 28200 tcp VoxelStorm game server VoxelStorm Eugene Hopkinson 2012-11-08

Contact Information

Name Organization Contact URI Last Updated
3GPP2 lizhiming&huawei.com 2012-01-11
Andrew West andrew.west&ieee.org 2022-12-20
Ashley Butterworth abutterworth&apple.com 2014-03-07
BTicino S.p.A. admin-myopen&myopen-bticino.it 2008-04-09
Cullimore And Ring Technologies dave.wilkins&crtech.com 2021-06-24
Dave Wilkins dave.wilkins&crtech.com 2021-06-24
DNP Users Group chair_tech&dnp.org 2022-12-20
Doug Leany DLEANY&opto22.com 2006-09
Eugene Hopkinson VoxelStorm slowriot&voxelstorm.com 2012-11-08
Georgetown University smart&georgetown.edu 2016-06-06
Harald Striepe harald&quantumintech.com 2008-02-14
Hong, Jungkih jungkih.hong&samsung.com 2010-09-20
J.C. Smart smart&georgetown.edu 2016-06-06
Jeff Holmbeck Jeff.Holmbeck&veritas.com
Kevin Kuhns kkuhns&opto22.com
Meggie Garica-Woodruff ipulse&ericsson.com
Michael Sweet msweet&ctr.nawcad.navy.mil
Michael Thesing michael.thesing&acsatlanta.com
Nicolas Williams Nicolas.Williams&oracle.com 2010-08-09
Paul Breed paul&netburner.com 2003-11
Pierre Couderc pcouderc&tol.fr 2006-03
Robert Parks robert_parks&filemaker.com 2010-05-12
Ronny Krüger from-iana&softvise.de 2016-11-10
SEGGER Microcontroller GmbH & Co. KG info&segger.com 2009-01-16
Silvano Maffeis maffeis&acm.org 2008-01-16
Softvise GmbH from-iana&softvise.de 2016-11-10
Stepan Riha stepan.riha&hand.com
Thomas E. Ludwig tom.ludwig&zetera.com 2004-02
Tim Addington Tim.Addington&sciatl.com
Tim Riley rileyt&saic.com 2009-07-31
Todd Scallan tscallan&interwoven.com 2005-08
Tomas Svoboda svoboda&infima.cz 2004-12
Transport Protocol for Time-Sensitive Networking TG AVBTP&ieee.org 2014-03-07
Vikki Yin Wei vikki&ipdynamics.com 2003-01
VoxelStorm slowriot&voxelstorm.com 2012-11-08
Yasunari Gon Yamasita yamasita&omronsoft.co.jp
Zhiming Li 3GPP2 lizhiming&huawei.com 2012-01-11