Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| voxelstorm | 28200 | tcp | VoxelStorm game server | VoxelStorm | Eugene Hopkinson | 2012-11-08 | |||||
| voxelstorm | 28200 | udp | VoxelStorm game server | VoxelStorm | Eugene Hopkinson | 2012-11-08 | |||||
| 28201-28239 | Unassigned | ||||||||||
| autotrac-acp | 31020 | tcp | Autotrac ACP 245 | Roberto Jorge Dino | Roberto Jorge Dino | ||||||
| 31020 | udp | Reserved | |||||||||
| lm-mon | 31620 | tcp | lm mon | System Administrator | System Administrator | 2003-06 | |||||
| lm-mon | 31620 | udp | lm mon | System Administrator | System Administrator | 2003-06 | |||||
| 31950-32033 | Unassigned | ||||||||||
| iracinghelper | 32034 | tcp | iRacing helper service | Randy Cassidy | Randy Cassidy | 2007-08-30 | |||||
| iracinghelper | 32034 | udp | iRacing helper service | Randy Cassidy | Randy Cassidy | 2007-08-30 | |||||
| 32035-32248 | Unassigned | ||||||||||
| 38003-38200 | Unassigned | ||||||||||
| galaxy7-data | 38201 | tcp | Galaxy7 Data Tunnel | Tatham Oddie | Tatham Oddie | 2002-09 | |||||
| galaxy7-data | 38201 | udp | Galaxy7 Data Tunnel | Tatham Oddie | Tatham Oddie | 2002-09 | |||||
| fairview | 38202 | tcp | Fairview Message Service | Jim Lyle | Jim Lyle | 2005-11 | Defined TXT keys: DevID=<device id>, DevType=<device type>, DevStat=<device status> | ||||
| fairview | 38202 | udp | Fairview Message Service | Jim Lyle | Jim Lyle | 2005-11 | Defined TXT keys: DevID=<device id>, DevType=<device type>, DevStat=<device status> | ||||
| agpolicy | 38203 | tcp | AppGate Policy Server | Martin Forssen | Martin Forssen | 2004-11 | |||||
| agpolicy | 38203 | udp | AppGate Policy Server | Martin Forssen | Martin Forssen | 2004-11 | |||||
| 38204-38411 | Unassigned | ||||||||||
| 41112-41120 | Unassigned | ||||||||||
| 41798-42507 | Unassigned | Unauthorized Use Known on port 42000 | |||||||||
| 43192-43209 | Unassigned | ||||||||||
| 44124-44320 | Unassigned | ||||||||||
| EtherNet-IP-2 | 44818 | tcp | EtherNet/IP messaging IANA assigned this well-formed service name as a replacement for "EtherNet/IP-2". |
Brian Batke | Brian Batke | New contact added for port 44818 on 2008-02-01 | |||||
| EtherNet/IP-2 | 44818 | tcp | EtherNet/IP messaging | Brian Batke | Brian Batke | New contact added for port 44818 on 2008-02-01 This entry is an alias to "EtherNet-IP-2". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| EtherNet-IP-2 | 44818 | udp | EtherNet/IP messaging IANA assigned this well-formed service name as a replacement for "EtherNet/IP-2". |
Brian Batke | Brian Batke | New contact added for port 44818 on 2008-02-01 | |||||
| EtherNet/IP-2 | 44818 | udp | EtherNet/IP messaging | Brian Batke | Brian Batke | New contact added for port 44818 on 2008-02-01 This entry is an alias to "EtherNet-IP-2". This entry is now historic, not usable for use with many common service discovery mechanisms. | |||||
| 48620-48652 | Unassigned | ||||||||||
| jmap | tcp | JSON Meta Application Protocol | IESG | IETF Chair | 2016-01-22 | 2019-07-16 | RFC 8620 | This service name was previously assigned under the name "JSON Mail Access Protocol". This has been de-assigned and re-assigned with the approval of the previous assignee. | |||
| presence | Peer-to-peer messaging / Link-Local Messaging | XMPP Registrar | XMPP Registrar | Defined TXT keys: See http://www.xmpp.org/registrar/linklocal.html Note: Registration updated May 2007. Was formerly listed as "iChat AV" (Apple's IM client for Mac OS X) with TXT keys: txtvers, port.p2pj, phsh, vc, 1st, AIM, msg, status, last When first shipped in Mac OS X 10.2, iChat's peer-to-peer messaging protocol was created to solve the problem of serverless messaging between peers on the same link. However, there is nothing inherent in the protocol that limits it to being only link-local; it was simply an artifact of iChat in Mac OS X 10.2 using link-local Multicast DNS to discover peers. With the advent of Wide-Area DNS-SD, it is also possible to use iChat's peer-to-peer messaging between machines on different links. | |||||||
| smartenergy | Smart Energy Profile | Robby Simpson, PhD | Robby Simpson, PhD | 2026-09-01 | Defined TXT keys: See IEEE Std 2030.5 |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Brian Batke | eip.jsig&gmail.com | ||
| Eugene Hopkinson | VoxelStorm | slowriot&voxelstorm.com | 2012-11-08 |
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| Jim Lyle | jim.lyle&siliconimage.com | 2005-11 | |
| Martin Forssen | maf&appgate.com | 2004-11 | |
| Randy Cassidy | randy.cassidy&iracing.com | 2007-08-30 | |
| Robby Simpson, PhD | rsimpson&gmail.com | ||
| Roberto Jorge Dino | roberto.dino&autotrac.com.br | ||
| System Administrator | sysadmin&silvaco.com | 2003-06 | |
| Tatham Oddie | tatham&e-oddie.com | 2002-09 | |
| VoxelStorm | slowriot&voxelstorm.com | 2012-11-08 | |
| XMPP Registrar | registrar&xmpp.org |