Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-22
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| bmc-net-svc | 1770 | udp | bmc-net-svc | Portnoy Boxman | Portnoy Boxman | ||||||
| dpkeyserv | 1780 | tcp | dpkeyserv | Yasunari Gon Yamasita | Yasunari Gon Yamasita | ||||||
| dpkeyserv | 1780 | udp | dpkeyserv | Yasunari Gon Yamasita | Yasunari Gon Yamasita | ||||||
| 1783 | Decomissioned Port 04/14/00, ms | naonao | naonao | ||||||||
| nmsp | 1790 | tcp | Narrative Media Streaming Protocol | Paul Santinelli Jr. | Paul Santinelli Jr. | ||||||
| nmsp | 1790 | udp | Narrative Media Streaming Protocol | Paul Santinelli Jr. | Paul Santinelli Jr. | ||||||
| ansys-lm | 1800 | tcp | ANSYS-License manager | Suzanne Lorrin | Suzanne Lorrin | ||||||
| ansys-lm | 1800 | udp | ANSYS-License manager | Suzanne Lorrin | Suzanne Lorrin | ||||||
| msmq | 1801 | tcp | Microsoft Message Que | Amnon Horowitz | Amnon Horowitz | ||||||
| msmq | 1801 | udp | Microsoft Message Que | Amnon Horowitz | Amnon Horowitz | ||||||
| concomp1 | 1802 | tcp | ConComp1 | Ed Vincent | Ed Vincent | ||||||
| concomp1 | 1802 | udp | ConComp1 | Ed Vincent | Ed Vincent | ||||||
| hp-hcip-gwy | 1803 | tcp | HP-HCIP-GWY | Allen Baker | Allen Baker | ||||||
| hp-hcip-gwy | 1803 | udp | HP-HCIP-GWY | Allen Baker | Allen Baker | ||||||
| enl | 1804 | tcp | ENL | Brian Olson | Brian Olson | ||||||
| enl | 1804 | udp | ENL | Brian Olson | Brian Olson | ||||||
| enl-name | 1805 | tcp | ENL-Name | Brian Olson | Brian Olson | ||||||
| enl-name | 1805 | udp | ENL-Name | Brian Olson | Brian Olson | ||||||
| musiconline | 1806 | tcp | Musiconline | Craig Weeks | Craig Weeks | ||||||
| musiconline | 1806 | udp | Musiconline | Craig Weeks | Craig Weeks | ||||||
| fhsp | 1807 | tcp | Fujitsu Hot Standby Protocol | Eiki Iwata | Eiki Iwata | ||||||
| fhsp | 1807 | udp | Fujitsu Hot Standby Protocol | Eiki Iwata | Eiki Iwata | ||||||
| oracle-vp2 | 1808 | tcp | Oracle-VP2 | Craig Fowler | Craig Fowler | ||||||
| oracle-vp2 | 1808 | udp | Oracle-VP2 | Craig Fowler | Craig Fowler | ||||||
| oracle-vp1 | 1809 | tcp | Oracle-VP1 | Craig Fowler | Craig Fowler | ||||||
| oracle-vp1 | 1809 | udp | Oracle-VP1 | Craig Fowler | Craig Fowler | ||||||
| jerand-lm | 1810 | tcp | Jerand License Manager | Robert Monat | Robert Monat | ||||||
| jerand-lm | 1810 | udp | Jerand License Manager | Robert Monat | Robert Monat | ||||||
| mcagent | 1820 | tcp | mcagent | Ryoichi Shinohara | Ryoichi Shinohara | ||||||
| mcagent | 1820 | udp | mcagent | Ryoichi Shinohara | Ryoichi Shinohara | ||||||
| net8-cman | 1830 | tcp | Oracle Net8 CMan Admin | Shuvayu Kanjilal | Shuvayu Kanjilal | ||||||
| net8-cman | 1830 | udp | Oracle Net8 CMan Admin | Shuvayu Kanjilal | Shuvayu Kanjilal | ||||||
| netopia-vo2 | 1840 | tcp | netopia-vo2 | ||||||||
| netopia-vo2 | 1840 | udp | netopia-vo2 | ||||||||
| slp-notify | 1847 | tcp | SLP Notification | RFC 3082 | |||||||
| slp-notify | 1847 | udp | SLP Notification | RFC 3082 | |||||||
| gsi | 1850 | tcp | GSI | William Mullaney | William Mullaney | ||||||
| gsi | 1850 | udp | GSI | William Mullaney | William Mullaney | ||||||
| sunscalar-svc | 1860 | tcp | SunSCALAR Services | Sanjay Radia | Sanjay Radia | ||||||
| sunscalar-svc | 1860 | udp | SunSCALAR Services | Sanjay Radia | Sanjay Radia | ||||||
| sunscalar-dns | 1870 | tcp | SunSCALAR DNS Service | Sanjay Radia | Sanjay Radia | ||||||
| sunscalar-dns | 1870 | udp | SunSCALAR DNS Service | Sanjay Radia | Sanjay Radia | ||||||
| canocentral0 | 1871 | tcp | Cano Central 0 | ||||||||
| canocentral0 | 1871 | udp | Cano Central 0 | ||||||||
| vsat-control | 1880 | tcp | Gilat VSAT Control | Yariv Kaplan | Yariv Kaplan | ||||||
| vsat-control | 1880 | udp | Gilat VSAT Control | Yariv Kaplan | Yariv Kaplan | ||||||
| wilkenlistener | 1890 | tcp | wilkenListener | Wilken GmbH | Wilken GmbH | ||||||
| wilkenlistener | 1890 | udp | wilkenListener | Wilken GmbH | Wilken GmbH | ||||||
| ssdp | 1900 | tcp | SSDP | UPnP Forum | UPnP Forum | ||||||
| ssdp | 1900 | udp | SSDP | UPnP Forum | UPnP Forum | ||||||
| fjicl-tep-a | 1901 | tcp | Fujitsu ICL Terminal Emulator Program A | Bob Lyon | Bob Lyon | ||||||
| fjicl-tep-a | 1901 | udp | Fujitsu ICL Terminal Emulator Program A | Bob Lyon | Bob Lyon | ||||||
| fjicl-tep-b | 1902 | tcp | Fujitsu ICL Terminal Emulator Program B | Bob Lyon | Bob Lyon | ||||||
| fjicl-tep-b | 1902 | udp | Fujitsu ICL Terminal Emulator Program B | Bob Lyon | Bob Lyon | ||||||
| linkname | 1903 | tcp | Local Link Name Resolution | Dan Harrington | Dan Harrington | ||||||
| linkname | 1903 | udp | Local Link Name Resolution | Dan Harrington | Dan Harrington | ||||||
| fjicl-tep-c | 1904 | tcp | Fujitsu ICL Terminal Emulator Program C | Bob Lyon | Bob Lyon | ||||||
| fjicl-tep-c | 1904 | udp | Fujitsu ICL Terminal Emulator Program C | Bob Lyon | Bob Lyon | ||||||
| sugp | 1905 | tcp | Secure UP.Link Gateway Protocol | Peter King | Peter King | ||||||
| sugp | 1905 | udp | Secure UP.Link Gateway Protocol | Peter King | Peter King | ||||||
| tpmd | 1906 | tcp | TPortMapperReq | Sheila Devins | Sheila Devins | ||||||
| tpmd | 1906 | udp | TPortMapperReq | Sheila Devins | Sheila Devins | ||||||
| intrastar | 1907 | tcp | IntraSTAR | Peter Schoenberger | Peter Schoenberger | ||||||
| intrastar | 1907 | udp | IntraSTAR | Peter Schoenberger | Peter Schoenberger | ||||||
| dawn | 1908 | tcp | Dawn | Michael Crawford | Michael Crawford | ||||||
| dawn | 1908 | udp | Dawn | Michael Crawford | Michael Crawford | ||||||
| global-wlink | 1909 | tcp | Global World Link | Nicholas Davies | Nicholas Davies | ||||||
| global-wlink | 1909 | udp | Global World Link | Nicholas Davies | Nicholas Davies | ||||||
| ultrabac | 1910 | tcp | UltraBac Software communications port | Paul Bunn | Paul Bunn | ||||||
| ultrabac | 1910 | udp | UltraBac Software communications port | Paul Bunn | Paul Bunn | ||||||
| can-ferret | 1920 | tcp | IBM Tivoli Directory Service - FERRET | Nic Catrambone | Nic Catrambone | ||||||
| can-ferret | 1920 | udp | IBM Tivoli Directory Service - FERRET | Nic Catrambone | Nic Catrambone | ||||||
| driveappserver | 1930 | tcp | Drive AppServer | Andrew Johnson | Andrew Johnson | ||||||
| driveappserver | 1930 | udp | Drive AppServer | Andrew Johnson | Andrew Johnson | ||||||
| jvclient | 1940 | tcp | JetVision Client Port | Stephen Tsun | Stephen Tsun | ||||||
| jvclient | 1940 | udp | JetVision Client Port | Stephen Tsun | Stephen Tsun | ||||||
| ismaeasdaqtest | 1950 | tcp | ISMA Easdaq Test | Stephen Dunne | Stephen Dunne | ||||||
| ismaeasdaqtest | 1950 | udp | ISMA Easdaq Test | Stephen Dunne | Stephen Dunne | ||||||
| nasmanager | 1960 | tcp | Merit DAC NASmanager | Richard S. Conto | Richard S. Conto | ||||||
| nasmanager | 1960 | udp | Merit DAC NASmanager | Richard S. Conto | Richard S. Conto | ||||||
| netop-rc | 1970 | tcp | NetOp Remote Control | ||||||||
| netop-rc | 1970 | udp | NetOp Remote Control | ||||||||
| panquest-xact | 1980 | tcp | PanQuest XACT | Chris Vertonghen | Chris Vertonghen | 2025-11-20 | |||||
| panquest-xact | 1980 | udp | PanQuest XACT | Chris Vertonghen | Chris Vertonghen | 2025-11-20 | |||||
| stun-p1 | 1990 | tcp | cisco STUN Priority 1 port | ||||||||
| stun-p1 | 1990 | udp | cisco STUN Priority 1 port | ||||||||
| cisco-sccp | 2000 | tcp | Cisco SCCP | Dan Wing | Dan Wing | 2003-11 | |||||
| cisco-sccp | 2000 | udp | Cisco SCCp | Dan Wing | Dan Wing | 2003-11 | |||||
| dc | 2001 | tcp | |||||||||
| wizard | 2001 | udp | curry | ||||||||
| globe | 2002 | tcp | |||||||||
| globe | 2002 | udp | |||||||||
| brutus | 2003 | tcp | Brutus Server | Johannes Skov Frandsen | Johannes Skov Frandsen | 2008-02-28 | |||||
| brutus | 2003 | udp | Brutus Server | Johannes Skov Frandsen | Johannes Skov Frandsen | 2008-02-28 | |||||
| mailbox | 2004 | tcp | |||||||||
| emce | 2004 | udp | CCWS mm conf | ||||||||
| berknet | 2005 | tcp | |||||||||
| oracle | 2005 | udp | |||||||||
| invokator | 2006 | tcp | |||||||||
| raid-cd | 2006 | udp | raid | ||||||||
| dectalk | 2007 | tcp |