Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
sftp 115 tcp Simple File Transfer Protocol Mark Lottor Mark Lottor
sftp 115 udp Simple File Transfer Protocol Mark Lottor Mark Lottor
ardus-trns 1115 tcp ARDUS Transfer
ardus-trns 1115 udp ARDUS Transfer
blaze 1150 tcp Blaze File Server Curt Schimmel Curt Schimmel 2005-11
blaze 1150 udp Blaze File Server Curt Schimmel Curt Schimmel 2005-11
unizensus 1151 tcp Unizensus Login Server Dirk Materlik Dirk Materlik 2005-11
unizensus 1151 udp Unizensus Login Server Dirk Materlik Dirk Materlik 2005-11
winpoplanmess 1152 tcp Winpopup LAN Messenger Vitali Fomine Vitali Fomine 2005-11
winpoplanmess 1152 udp Winpopup LAN Messenger Vitali Fomine Vitali Fomine 2005-11
c1222-acse 1153 tcp ANSI C12.22 Port RFC 6142
c1222-acse 1153 udp ANSI C12.22 Port RFC 6142
resacommunity 1154 tcp Community Service Stéphane MONS Stéphane MONS 2005-09
resacommunity 1154 udp Community Service Stéphane MONS Stéphane MONS 2005-09
nfa 1155 tcp Network File Access James Powell James Powell
nfa 1155 udp Network File Access James Powell James Powell
iascontrol-oms 1156 tcp iasControl OMS Todd Guay Todd Guay 2004-11
iascontrol-oms 1156 udp iasControl OMS Todd Guay Todd Guay 2004-11
iascontrol 1157 tcp Oracle iASControl Todd Guay Todd Guay 2004-11
iascontrol 1157 udp Oracle iASControl Todd Guay Todd Guay 2004-11
dbcontrol-oms 1158 tcp dbControl OMS Todd Guay Todd Guay 2004-11
dbcontrol-oms 1158 udp dbControl OMS Todd Guay Todd Guay 2004-11
oracle-oms 1159 tcp Oracle OMS Todd Guay Todd Guay 2004-11
oracle-oms 1159 udp Oracle OMS Todd Guay Todd Guay 2004-11
kdm 2115 tcp Key Distribution Manager Mike Little Mike Little
kdm 2115 udp Key Distribution Manager Mike Little Mike Little
mctet-master 3115 tcp MCTET Master
mctet-master 3115 udp MCTET Master
cds 4115 tcp CDS Transfer Agent Neil Coggins Neil Coggins 2006-07
cds 4115 udp CDS Transfer Agent Neil Coggins Neil Coggins 2006-07
autobuild 5115 tcp Symantec Autobuild Service David Warden David Warden 2008-11-17
5115 udp Reserved
xic 6115 tcp Xic IPC Service Stephen R. Whiteley Stephen R. Whiteley 2010-10-07
6115 udp Reserved
mtl8000-matrix 8115 tcp MTL8000 Matrix David Pinch David Pinch 2002-04
mtl8000-matrix 8115 udp MTL8000 Matrix David Pinch David Pinch 2002-04
netiq-endpt 10115 tcp NetIQ Endpoint Gary Weichinger Gary Weichinger
netiq-endpt 10115 udp NetIQ Endpoint Gary Weichinger Gary Weichinger
11490-11599 Unassigned

Contact Information

Name Contact URI Last Updated
Curt Schimmel curt&small-tree.com 2005-11
David Pinch dpinch&mtl-inst.com 2002-04
David Warden david_warden&symantec.com 2008-11-17
Dirk Materlik materlik&blubbsoft.de 2005-11
Gary Weichinger gary.weichinger&netiq.com
James Powell james&mailhost.unidata.com
Mark Lottor MKL&nisc.sri.com
Mike Little mike.little&gdc4s.com
Neil Coggins neil.coggins&6thsight.com 2006-07
Stéphane MONS stephane.mons&free.fr 2005-09
Stephen R. Whiteley stevew&wrcad.com 2010-10-07
Todd Guay todd.guay&oracle.com 2005-08
Vitali Fomine info&winpopup-lan-messenger.com 2005-11