Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
bl-idm 142 tcp Britton-Lee IDM Susie Snitzer Susie Snitzer
bl-idm 142 udp Britton-Lee IDM Susie Snitzer Susie Snitzer
edtools 1142 tcp User Discovery Service Lee Dolson Lee Dolson 2006-01
edtools 1142 udp User Discovery Service Lee Dolson Lee Dolson 2006-01
c1222-acse 1153 tcp ANSI C12.22 Port RFC 6142
c1222-acse 1153 udp ANSI C12.22 Port RFC 6142
timbuktu-srv4 1420 tcp Timbuktu Service 4 Port Marc Epard Marc Epard
timbuktu-srv4 1420 udp Timbuktu Service 4 Port Marc Epard Marc Epard
gandalf-lm 1421 tcp Gandalf License Manager gilmer gilmer
gandalf-lm 1421 udp Gandalf License Manager gilmer gilmer
autodesk-lm 1422 tcp Autodesk License Manager David Ko David Ko
autodesk-lm 1422 udp Autodesk License Manager David Ko David Ko
essbase 1423 tcp Essbase Arbor Software
essbase 1423 udp Essbase Arbor Software
hybrid 1424 tcp Hybrid Encryption Protocol Howard Hart Howard Hart
hybrid 1424 udp Hybrid Encryption Protocol Howard Hart Howard Hart
zion-lm 1425 tcp Zion Software License Manager David Ferrero David Ferrero
zion-lm 1425 udp Zion Software License Manager David Ferrero David Ferrero
sais 1426 tcp Satellite-data Acquisition System 1 Bill Taylor Bill Taylor
sais 1426 udp Satellite-data Acquisition System 1 Bill Taylor Bill Taylor
mloadd 1427 tcp mloadd monitoring tool Bob Braden Bob Braden
mloadd 1427 udp mloadd monitoring tool Bob Braden Bob Braden
informatik-lm 1428 tcp Informatik License Manager Harald Schlangmann Harald Schlangmann
informatik-lm 1428 udp Informatik License Manager Harald Schlangmann Harald Schlangmann
nms 1429 tcp Hypercom NMS
nms 1429 udp Hypercom NMS
tdmoip 2142 tcp TDM OVER IP Yaakov Stein Yaakov Stein 2016-09-21 RFC 5087
tdmoip 2142 udp TDM OVER IP Yaakov Stein Yaakov Stein 2016-09-21 RFC 5087
rdc-wh-eos 3142 tcp RDC WH EOS Udi Nir Udi Nir
rdc-wh-eos 3142 udp RDC WH EOS Udi Nir Udi Nir
oidocsvc 4142 tcp Document Server
oidocsvc 4142 udp Document Server
aspentec-lm 6142 tcp Aspen Technology License Manager Kevin Massey Kevin Massey
aspentec-lm 6142 udp Aspen Technology License Manager Kevin Massey Kevin Massey
11372-11429 Unassigned
icpp 14142 tcp IceWall Cert Protocol Tsutomu Fujinami Tsutomu Fujinami 2005-08
icpp 14142 udp IceWall Cert Protocol Tsutomu Fujinami Tsutomu Fujinami 2005-08
14155-14249 Unassigned
cps 14250 tcp Fencing Server Mayank Vasa Mayank Vasa 2008-04-03
cps 14250 udp Fencing Server Mayank Vasa Mayank Vasa 2008-04-03
14251-14413 Unassigned

Contact Information

Name Contact URI Last Updated
Bill Taylor sais&ssec.wisc.edu
Bob Braden braden&isi.edu
David Ferrero david&zion.com
David Ko dko&autodesk.com
Harald Schlangmann schlangm&informatik.uni-muenchen.de
Howard Hart hch&hybrid.com
Kevin Massey massey&aspentec.com
Lee Dolson dolson&f-net.co.kr 2006-01
Marc Epard marc&netopia.com
Mayank Vasa mayank_vasa&symantec.com 2008-04-03
Susie Snitzer
Tsutomu Fujinami tsutomu.fujinami&hp.com 2005-08
Udi Nir udi_nir&ncc.co.il
Yaakov Stein yaakovjstein&gmail.com 2022-02-04
gilmer&gandalf.ca