Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
namp 167 tcp NAMP Marty Schoffstahl Marty Schoffstahl
namp 167 udp NAMP Marty Schoffstahl Marty Schoffstahl
cisco-ipsla 1167 tcp Cisco IP SLAs Control Protocol Emmanuel Tychon Emmanuel Tychon 2006-03
cisco-ipsla 1167 udp Cisco IP SLAs Control Protocol Emmanuel Tychon Emmanuel Tychon 2006-03
cisco-ipsla 1167 sctp Cisco IP SLAs Control Protocol Emmanuel Tychon Emmanuel Tychon 2006-03
netview-aix-10 1670 tcp netview-aix-10
netview-aix-10 1670 udp netview-aix-10
netview-aix-11 1671 tcp netview-aix-11
netview-aix-11 1671 udp netview-aix-11
netview-aix-12 1672 tcp netview-aix-12 Martha Crisson Martha Crisson
netview-aix-12 1672 udp netview-aix-12 Martha Crisson Martha Crisson
proshare-mc-1 1673 tcp Intel Proshare Multicast
proshare-mc-1 1673 udp Intel Proshare Multicast
proshare-mc-2 1674 tcp Intel Proshare Multicast Mark Lewis Mark Lewis
proshare-mc-2 1674 udp Intel Proshare Multicast Mark Lewis Mark Lewis
pdp 1675 tcp Pacific Data Products Gary Morton Gary Morton
pdp 1675 udp Pacific Data Products Gary Morton Gary Morton
netcomm1 1676 tcp netcomm1
netcomm2 1676 udp netcomm2 Bulent Kasman Bulent Kasman
groupwise 1677 tcp groupwise Brent Bradshaw Brent Bradshaw
groupwise 1677 udp groupwise Brent Bradshaw Brent Bradshaw
prolink 1678 tcp prolink Brian Abramson Brian Abramson
prolink 1678 udp prolink Brian Abramson Brian Abramson
darcorp-lm 1679 tcp darcorp-lm DARcorp DARcorp
darcorp-lm 1679 udp darcorp-lm DARcorp DARcorp
raw-serial 2167 tcp Raw Async Serial Link Benjamin Green Benjamin Green
raw-serial 2167 udp Raw Async Serial Link Benjamin Green Benjamin Green
nowcontact 3167 tcp Now Contact Public Server
nowcontact 3167 udp Now Contact Public Server
ddgn 4167 tcp DeskDirect Global Network Laurie Charlwood Laurie Charlwood 2007-08-22
ddgn 4167 udp DeskDirect Global Network Laurie Charlwood Laurie Charlwood 2007-08-22
rwhois 4321 tcp Remote Who Is Mark Kosters Mark Kosters RFC 2167
rwhois 4321 udp Remote Who Is Mark Kosters Mark Kosters RFC 2167
scte104 5167 tcp SCTE104 Connection Thomas Russell Thomas Russell 2005-05
scte104 5167 udp SCTE104 Connection Thomas Russell Thomas Russell 2005-05
casrmagent 7167 tcp CA SRM Agent Venkata Krishna Venkata Krishna 2010-02-24
7167 udp Reserved
12122-12167 Unassigned
16667-16788 Unassigned
cadsisvr 16789 tcp This server provides callable services to mainframe External Security Managers from any TCP/IP platform Broadcom Thomas Sakowski 2015-06-02 2023-03-29
16789 udp Reserved
16790-16899 Unassigned
tolfab 20167 tcp TOLfab Data Change Pierre Couderc Pierre Couderc 2006-03
tolfab 20167 udp TOLfab Data Change Pierre Couderc Pierre Couderc 2006-03
otmp 29167 tcp ObTools Message Protocol Paul Clark Paul Clark 2006-02
otmp 29167 udp ObTools Message Protocol Paul Clark Paul Clark 2006-02

Contact Information

Name Organization Contact URI Last Updated
Benjamin Green ben&lh.co.nz
Brent Bradshaw bbradshaw&novell.com
Brian Abramson brianab&soul.tv.tek.com
Broadcom thomas.sakowski&broadcom.com 2023-03-29
Bulent Kasman BKasman&symantec.com
DARcorp&aol.com
Emmanuel Tychon etychon&cisco.com 2006-03
Gary Morton mortong&pacdata.com
Laurie Charlwood laurie.charlwood&printsoft.com 2007-08-22
Mark Kosters markk&internic.net
Mark Lewis Mark_Lewis&ccm.jf.intel.com
Martha Crisson CRISSON&ralvm12.vnet.ibm.com
Marty Schoffstahl schoff&nisc.nyser.net
Paul Clark paul&xmill.com 2006-02
Pierre Couderc pcouderc&tol.fr 2006-03
Thomas Russell trussell&scte.org 2005-05
Thomas Sakowski Broadcom thomas.sakowski&broadcom.com 2023-03-29
Venkata Krishna VenkataKrishna.Bezawada&ca.com 2010-02-24