Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
rsvd 168 tcp RSVD Alan Sandell Alan Sandell 2008-05-01
rsvd 168 udp RSVD Alan Sandell Alan Sandell 2008-05-01
vchat 1168 tcp VChat Conference Service Andreas Wetzel Andreas Wetzel 2002-09
vchat 1168 udp VChat Conference Service Andreas Wetzel Andreas Wetzel 2002-09
microcom-sbp 1680 tcp microcom-sbp Boris B. Maiden Boris B. Maiden
microcom-sbp 1680 udp microcom-sbp Boris B. Maiden Boris B. Maiden
sd-elmd 1681 tcp sd-elmd Bryan Otey Bryan Otey
sd-elmd 1681 udp sd-elmd Bryan Otey Bryan Otey
lanyon-lantern 1682 tcp lanyon-lantern Robin Lewis Robin Lewis
lanyon-lantern 1682 udp lanyon-lantern Robin Lewis Robin Lewis
ncpm-hip 1683 tcp ncpm-hip Ken Hearn Ken Hearn
ncpm-hip 1683 udp ncpm-hip Ken Hearn Ken Hearn
snaresecure 1684 tcp SnareSecure Marty Batchelder Marty Batchelder
snaresecure 1684 udp SnareSecure Marty Batchelder Marty Batchelder
n2nremote 1685 tcp n2nremote Kin Chan Kin Chan
n2nremote 1685 udp n2nremote Kin Chan Kin Chan
cvmon 1686 tcp cvmon Carol Ann Krug Carol Ann Krug
cvmon 1686 udp cvmon Carol Ann Krug Carol Ann Krug
nsjtp-ctrl 1687 tcp nsjtp-ctrl
nsjtp-ctrl 1687 udp nsjtp-ctrl
nsjtp-data 1688 tcp nsjtp-data Orazio Granato Orazio Granato
nsjtp-data 1688 udp nsjtp-data Orazio Granato Orazio Granato
firefox 1689 tcp firefox Mark S. Edwards Mark S. Edwards
firefox 1689 udp firefox Mark S. Edwards Mark S. Edwards
easy-soft-mux 2168 tcp easy-soft Multiplexer Norbert Kintzler Norbert Kintzler 2004-11
easy-soft-mux 2168 udp easy-soft Multiplexer Norbert Kintzler Norbert Kintzler 2004-11
poweronnud 3168 tcp Now Up-to-Date Public Server John Wallace John Wallace
poweronnud 3168 udp Now Up-to-Date Public Server John Wallace John Wallace
pslicser 4168 tcp PrintSoft License Server David Weisgerber David Weisgerber 2007-09-27
pslicser 4168 udp PrintSoft License Server David Weisgerber David Weisgerber 2007-09-27
dtn-bundle 4556 dccp DTN Bundle DCCP CL Protocol 2013-11-12 2014-02-21 RFC 7122 1685351985
sip 5060 sctp SIP RFC 4168
sips 5061 sctp SIP-TLS RFC 4168
scte30 5168 tcp SCTE30 Connection Thomas Russell Thomas Russell 2005-05
scte30 5168 udp SCTE30 Connection Thomas Russell Thomas Russell 2005-05
cnckadserver 7168 tcp cncKadServer DB & Inventory Services Micha Ben-Efraim Micha Ben-Efraim 2011-01-31
7168 udp Reserved
cawas 12168 tcp CA Web Access Service Jon Press Jon Press 2005-08
cawas 12168 udp CA Web Access Service Jon Press Jon Press 2005-08
16790-16899 Unassigned
20168-20201 Unassigned
29168 tcp Reserved
29168 udp Reserved
sbcap 29168 sctp SBcAP in 3GPP Dongwook Kim Dongwook Kim 2009-06-11
31621-31684 Unassigned
dsx-monitor 31685 tcp DS Expert Monitor

IANA assigned this well-formed service name as a replacement for "dsx_monitor".
John Lowery John Lowery 2008-08-21
dsx_monitor 31685 tcp DS Expert Monitor John Lowery John Lowery 2008-08-21 This entry is an alias to "dsx-monitor". This entry is now historic, not usable for use with many common service discovery mechanisms.
31685 udp Reserved
31686-31764 Unassigned

Contact Information

Name Organization Contact URI Last Updated
Alan Sandell alan.sandell&ist.co.uk 2008-05-01
Andreas Wetzel mickey&enforcer.cc 2002-09
Boris B. Maiden Boris_Maiden&smtp.microcom.com
Bryan Otey bwo&softdesk.com
Carol Ann Krug carolann&hpmfas3.cup.hp.com
David Weisgerber david.weisgerber&printsoft.de 2007-09-27
Dongwook Kim 3GPP Specifications Manager dongwook.kim&etsi.org 2026-01-23
John Lowery NetPro Computing jlowery&netpro.com 2008-08-21
John Wallace john&nowsoftware.com
Jon Press IANA.Registions&ca.com 2005-09
Ken Hearn hearn&hpindacx.cup.hp.com
Kin Chan kchan&net2net.com
Mark S. Edwards marke&firefox.co.uk
Marty Batchelder marty&capres.com
Micha Ben-Efraim micha&metalix.net 2011-01-31
Norbert Kintzler NKintzler&easy-soft-dresden.de 2004-11
Orazio Granato og&wsbgrd01.italy.hp.com
Robin Lewis robin.lewis&lanyon.com
Thomas Russell trussell&scte.org 2005-05