Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| qft | 189 | tcp | Queued File Transport | Wayne Schroeder | Wayne Schroeder | ||||||
| qft | 189 | udp | Queued File Transport | Wayne Schroeder | Wayne Schroeder | ||||||
| cybercash | 551 | tcp | cybercash | Donald E. Eastlake 3rd | Donald E. Eastlake 3rd | RFC 1898 | |||||
| cybercash | 551 | udp | cybercash | Donald E. Eastlake 3rd | Donald E. Eastlake 3rd | RFC 1898 | |||||
| unet | 1189 | tcp | Unet Connection | Anthony Stahler | Anthony Stahler | 2004-11 | |||||
| unet | 1189 | udp | Unet Connection | Anthony Stahler | Anthony Stahler | 2004-11 | |||||
| wilkenlistener | 1890 | tcp | wilkenListener | Wilken GmbH | Wilken GmbH | ||||||
| wilkenlistener | 1890 | udp | wilkenListener | Wilken GmbH | Wilken GmbH | ||||||
| childkey-notif | 1891 | tcp | ChildKey Notification | ||||||||
| childkey-notif | 1891 | udp | ChildKey Notification | ||||||||
| childkey-ctrl | 1892 | tcp | ChildKey Control | Ivan Berardinelli | Ivan Berardinelli | ||||||
| childkey-ctrl | 1892 | udp | ChildKey Control | Ivan Berardinelli | Ivan Berardinelli | ||||||
| elad | 1893 | tcp | ELAD Protocol | Franco Milan | Franco Milan | ||||||
| elad | 1893 | udp | ELAD Protocol | Franco Milan | Franco Milan | ||||||
| o2server-port | 1894 | tcp | O2Server Port | Tim Howard | Tim Howard | ||||||
| o2server-port | 1894 | udp | O2Server Port | Tim Howard | Tim Howard | ||||||
| 1895 | tcp | unassigned | Microsoft (unoffically) using 1895 | ||||||||
| 1895 | udp | unassigned | Microsoft (unoffically) using 1895 | ||||||||
| b-novative-ls | 1896 | tcp | b-novative license server | Matthias Riese | Matthias Riese | ||||||
| b-novative-ls | 1896 | udp | b-novative license server | Matthias Riese | Matthias Riese | ||||||
| metaagent | 1897 | tcp | MetaAgent | Marie-France Dubreuil | Marie-France Dubreuil | ||||||
| metaagent | 1897 | udp | MetaAgent | Marie-France Dubreuil | Marie-France Dubreuil | ||||||
| cymtec-port | 1898 | tcp | Cymtec secure management | Michael Mester | Michael Mester | ||||||
| cymtec-port | 1898 | udp | Cymtec secure management | Michael Mester | Michael Mester | ||||||
| mc2studios | 1899 | tcp | MC2Studios | Michael Coon | Michael Coon | ||||||
| mc2studios | 1899 | udp | MC2Studios | Michael Coon | Michael Coon | ||||||
| radware-rpm-s | 2189 | tcp | Secure Radware Resource Pool Manager | Radware LTD. | Samuel Bercovici | 2011-08-05 | |||||
| 2189 | udp | Reserved | |||||||||
| pcle-infex | 3189 | tcp | Pinnacle Sys InfEx Port | Anthon van der Neut | Anthon van der Neut | ||||||
| pcle-infex | 3189 | udp | Pinnacle Sys InfEx Port | Anthon van der Neut | Anthon van der Neut | ||||||
| pcep | 4189 | tcp | Path Computation Element Communication Protocol | ||||||||
| 4189 | udp | Reserved | RFC 5440 | ||||||||
| 5173-5189 | Unassigned | ||||||||||
| 8185-8189 | Unassigned | ||||||||||
| 18889-18999 | Unassigned | ||||||||||
| ndm-agent-port | 43189 | tcp | NDM-AGENT-PORT | Roman Kriis | Roman Kriis | ||||||
| ndm-agent-port | 43189 | udp | NDM-AGENT-PORT | Roman Kriis | Roman Kriis |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Anthon van der Neut | anthon&mnt.org | ||
| Anthony Stahler | imunfair&yahoo.com | 2004-11 | |
| Donald E. Eastlake 3rd | d3e3e3&gmail.com | ||
| Franco Milan | franco&eladit.com | ||
| Ivan Berardinelli | ivan&gestweb.com | ||
| Marie-France Dubreuil | Marie-France.Dubreuil&evidian.com | 2002-11 | |
| Matthias Riese | Matthias.Riese&b-novative.de | ||
| Michael Coon | michael&thecube.com | ||
| Michael Mester | mmester&cymtec.com | ||
| Radware LTD. | samuelb&radware.com | 2011-08-05 | |
| Roman Kriis | roman&previo.ee | ||
| Samuel Bercovici | samuelb&radware.com | 2011-08-05 | |
| Tim Howard | timothygh&hotmail.com | ||
| Wayne Schroeder | schroeder&sds.sdsc.edu | ||
| Wilken GmbH | fy&wilken.de |