Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| 2 | tcp | Reserved | 2025-02-13 | De-assigned on 2025-02-13, previously compressnet by Bernie Volz | |||||||
| 2 | udp | Reserved | 2025-02-13 | De-assigned on 2025-02-13, previously compressnet by Bernie Volz | |||||||
| 3 | tcp | Reserved | 2025-02-13 | De-assigned on 2025-02-13, previously compressnet by Bernie Volz | |||||||
| 3 | udp | Reserved | 2025-02-13 | De-assigned on 2025-02-13, previously compressnet by Bernie Volz | |||||||
| ftp-data | 20 | tcp | File Transfer [Default Data] | Jon Postel | Jon Postel | ||||||
| ftp-data | 20 | udp | File Transfer [Default Data] | Jon Postel | Jon Postel | ||||||
| ftp-data | 20 | sctp | FTP | Randall Stewart | Randall Stewart | 2022-02-07 | RFC 9260 | ||||
| 47 | tcp | Reserved | 2017-05-18 | This entry has been removed on 2017-05-18. | |||||||
| 47 | udp | Reserved | 2017-05-18 | This entry has been removed on 2017-05-18. | |||||||
| 51 | Reserved | 2013-05-24 | This entry is being removed on 2013-05-24. | ||||||||
| 61 | tcp | Reserved | 2017-05-18 | This entry has been removed on 2017-05-18. | |||||||
| 61 | udp | Reserved | 2017-05-18 | This entry has been removed on 2017-05-18. | |||||||
| kerberos | 88 | tcp | Kerberos | B. Clifford Neuman | B. Clifford Neuman | 2022-02-18 | RFC 4120 | ||||
| kerberos | 88 | udp | Kerberos | B. Clifford Neuman | B. Clifford Neuman | 2022-02-18 | RFC 4120 | ||||
| 114 | unassigned | Deprecated June 2004 | |||||||||
| cfdptkt | 120 | tcp | CFDPTKT | John Ioannidis | John Ioannidis | ||||||
| cfdptkt | 120 | udp | CFDPTKT | John Ioannidis | John Ioannidis | ||||||
| src | 200 | tcp | IBM System Resource Controller | Gerald McBrearty | Gerald McBrearty | ||||||
| src | 200 | udp | IBM System Resource Controller | Gerald McBrearty | Gerald McBrearty | ||||||
| at-rtmp | 201 | tcp | AppleTalk Routing Maintenance | ||||||||
| at-rtmp | 201 | udp | AppleTalk Routing Maintenance | ||||||||
| at-nbp | 202 | tcp | AppleTalk Name Binding | ||||||||
| at-nbp | 202 | udp | AppleTalk Name Binding | ||||||||
| at-3 | 203 | tcp | AppleTalk Unused | ||||||||
| at-3 | 203 | udp | AppleTalk Unused | ||||||||
| at-echo | 204 | tcp | AppleTalk Echo | ||||||||
| at-echo | 204 | udp | AppleTalk Echo | ||||||||
| at-5 | 205 | tcp | AppleTalk Unused | ||||||||
| at-5 | 205 | udp | AppleTalk Unused | ||||||||
| at-zis | 206 | tcp | AppleTalk Zone Information | ||||||||
| at-zis | 206 | udp | AppleTalk Zone Information | ||||||||
| at-7 | 207 | tcp | AppleTalk Unused | ||||||||
| at-7 | 207 | udp | AppleTalk Unused | ||||||||
| at-8 | 208 | tcp | AppleTalk Unused | Rob Chandhok | Rob Chandhok | ||||||
| at-8 | 208 | udp | AppleTalk Unused | Rob Chandhok | Rob Chandhok | ||||||
| qmtp | 209 | tcp | The Quick Mail Transfer Protocol | D. J. Bernstein | D. J. Bernstein | 2018-04-05 | |||||
| qmtp | 209 | udp | The Quick Mail Transfer Protocol | D. J. Bernstein | D. J. Bernstein | 2018-04-05 | |||||
| imap3 | 220 | tcp | Interactive Mail Access Protocol v3 | James Rice | James Rice | ||||||
| imap3 | 220 | udp | Interactive Mail Access Protocol v3 | James Rice | James Rice | ||||||
| ptp-general | 320 | tcp | PTP General | Kang Lee | Kang Lee | 2010-07-27 | |||||
| ptp-general | 320 | udp | PTP General | Kang Lee | Kang Lee | 2010-07-27 | |||||
| 359 | tcp | Reserved | 2023-11-16 | De-Assigned on 2023-11-16. | |||||||
| 359 | udp | Reserved | 2023-11-16 | De-Assigned on 2023-11-16. | |||||||
| smpte | 420 | tcp | SMPTE | Si Becker | Si Becker | ||||||
| smpte | 420 | udp | SMPTE | Si Becker | Si Becker | ||||||
| efs | 520 | tcp | extended file name server | ||||||||
| router | 520 | udp | local routing process (on site); uses variant of Xerox NS routing information protocol - RIP | ||||||||
| tunnel | 604 | tcp | TUNNEL | RFC 3620 | |||||||
| tunnel | 604 | udp | TUNNEL | RFC 3620 | |||||||
| sco-websrvrmgr | 620 | tcp | SCO WebServer Manager | Christopher Durham | Christopher Durham | ||||||
| sco-websrvrmgr | 620 | udp | SCO WebServer Manager | Christopher Durham | Christopher Durham | ||||||
| lmp | 701 | tcp | Link Management Protocol (LMP) | RFC 4204 | |||||||
| lmp | 701 | udp | Link Management Protocol (LMP) | RFC 4204 | |||||||
| 1011-1020 | Reserved | ||||||||||
| 1030 | Reserved | 2013-05-24 | This entry is being removed on 2013-05-24. | ||||||||
| 1031 | Reserved | 2013-05-24 | This entry is being removed on 2013-05-24. | ||||||||
| 1032 | Reserved | 2013-05-24 | This entry is being removed on 2013-05-24. | ||||||||
| bnetfile | 1120 | tcp | Battle.net File Transfer Protocol | Domain Tech | Domain Tech | 2005-04 | |||||
| bnetfile | 1120 | udp | Battle.net File Transfer Protocol | Domain Tech | Domain Tech | 2005-04 | |||||
| scol | 1200 | tcp | SCOL | Cryo-Networks | Cryo-Networks | ||||||
| scol | 1200 | udp | SCOL | Cryo-Networks | Cryo-Networks | ||||||
| nucleus-sand | 1201 | tcp | Nucleus Sand Database Server | James Marsh | James Marsh | ||||||
| nucleus-sand | 1201 | udp | Nucleus Sand Database Server | James Marsh | James Marsh | ||||||
| caiccipc | 1202 | tcp | caiccipc | Vince Re | Vince Re | ||||||
| caiccipc | 1202 | udp | caiccipc | Vince Re | Vince Re | ||||||
| ssslic-mgr | 1203 | tcp | License Validation | ||||||||
| ssslic-mgr | 1203 | udp | License Validation | ||||||||
| ssslog-mgr | 1204 | tcp | Log Request Listener | Eric Bruno | Eric Bruno | ||||||
| ssslog-mgr | 1204 | udp | Log Request Listener | Eric Bruno | Eric Bruno | ||||||
| accord-mgc | 1205 | tcp | Accord-MGC | Roni Even | Roni Even | ||||||
| accord-mgc | 1205 | udp | Accord-MGC | Roni Even | Roni Even | ||||||
| anthony-data | 1206 | tcp | Anthony Data | Paul Dollemore | Paul Dollemore | ||||||
| anthony-data | 1206 | udp | Anthony Data | Paul Dollemore | Paul Dollemore | ||||||
| metasage | 1207 | tcp | MetaSage | Peter Anvelt | Peter Anvelt | ||||||
| metasage | 1207 | udp | MetaSage | Peter Anvelt | Peter Anvelt | ||||||
| seagull-ais | 1208 | tcp | SEAGULL AIS | Lee Breisacher | Lee Breisacher | ||||||
| seagull-ais | 1208 | udp | SEAGULL AIS | Lee Breisacher | Lee Breisacher | ||||||
| ipcd3 | 1209 | tcp | IPCD3 | Mark Ciskey | Mark Ciskey | ||||||
| ipcd3 | 1209 | udp | IPCD3 | Mark Ciskey | Mark Ciskey | ||||||
| qt-serveradmin | 1220 | tcp | QT SERVER ADMIN | Chris LeCroy | Chris LeCroy | ||||||
| qt-serveradmin | 1220 | udp | QT SERVER ADMIN | Chris LeCroy | Chris LeCroy | ||||||
| 1276 | tcp | Reserved | 2014-05-23 | This entry has been removed on 2014-05-23. | |||||||
| 1276 | udp | Reserved | 2014-05-23 | This entry has been removed on 2014-05-23. | |||||||
| 1301 | tcp | Reserved | 2019-10-30 | De-Assigned on 2019-10-30 | |||||||
| 1301 | udp | Reserved | 2019-10-30 | De-Assigned on 2019-10-30 | |||||||
| 1302 | tcp | Reserved | 2019-10-30 | De-Assigned on 2019-10-30 | |||||||
| 1302 | udp | Reserved | 2019-10-30 | De-Assigned on 2019-10-30 | |||||||
| amx-axbnet | 1320 | tcp | AMX-AXBNET | Jeff Burch | Jeff Burch | ||||||
| amx-axbnet | 1320 | udp | AMX-AXBNET | Jeff Burch | Jeff Burch | ||||||
| tibet-server | 1407 | tcp | TIBET Data Server | Technical Pursuit Inc. | Scott Shattuck | 2015-06-16 | This port has been retasked on 2015-06-16. | ||||
| 1407 | udp | Reserved | This port has been removed on 2015-06-16. | ||||||||
| timbuktu-srv4 | 1420 | tcp | Timbuktu Service 4 Port | Marc Epard | Marc Epard | ||||||
| timbuktu-srv4 | 1420 | udp | Timbuktu Service 4 Port | Marc Epard | Marc Epard | ||||||
| atm-zip-office | 1520 | tcp | atm zip office | Wilson Kwan | Wilson Kwan | ||||||
| atm-zip-office | 1520 | udp | atm zip office | Wilson Kwan | Wilson Kwan | ||||||
| mil-2045-47001 | 1581 | tcp | MIL-2045-47001 | Eric Whitehill | Eric Whitehill | ||||||
| mil-2045-47001 | 1581 | udp | MIL-2045-47001 | Eric Whitehill | Eric Whitehill | ||||||
| faxportwinport | 1620 | tcp | faxportwinport | Chris Wells | Chris Wells | ||||||
| faxportwinport | 1620 | udp | faxportwinport | Chris Wells | Chris Wells | ||||||
| h323hostcall | 1720 | tcp | H.323 Call Control Signalling | ITU-T | ITU-T TSB | 2013-01-31 |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| B. Clifford Neuman | bcn&isi.edu | 2022-02-18 | |
| Bernie Volz | volz&cisco.com | ||
| Chris LeCroy | lecroy&apple.com | ||
| Chris Wells | chris_wells&lansource.com | ||
| Christopher Durham | chrisdu&sco.com | ||
| Cryo-Networks | p.favre&cryo-networks.fr | ||
| D. J. Bernstein | ports&box.cr.yp.to | 2018-04-05 | |
| Domain Tech | Domainnametech&blizzard.com | 2005-04 | |
| Eric Bruno | ebruno&solution-soft.com | ||
| Eric Whitehill | Eric.Whitehill&itt.com | ||
| Gerald McBrearty | |||
| ITU-T | tsbsg16&itu.int | 2013-01-31 | |
| ITU-T TSB | ITU-T | tsbsg16&itu.int | 2013-01-31 |
| James Marsh | James_T_Marsh&hotmail.com | ||
| James Rice | RICE&sumex-aim.stanford.edu | ||
| Jeff Burch | jeff.burch&amx.com | ||
| John Ioannidis | ji&close.cs.columbia.ed | ||
| Jon Postel | postel&isi.edu | ||
| Kang Lee | I&M Society TC-9 | kang.lee&nist.gov | 2010-07-27 |
| Lee Breisacher | lbreisacher&seagullsw.com | ||
| Marc Epard | marc&netopia.com | ||
| Mark Ciskey | mlciskey&plato.com | ||
| Paul Dollemore | pauld&anthonydata.com | ||
| Peter Anvelt | panvelt&xnai.com | ||
| Randall Stewart | IETF TSVWG | rrs&lakerest.net | |
| Rob Chandhok | chandhok&gnome.cs.cmu.edu | ||
| Roni Even | roni_e&accord.co.il | ||
| Scott Shattuck | Technical Pursuit Inc. | ss&technicalpursuit.com | 2015-06-16 |
| Si Becker | 71362.22&compuserve.com | ||
| Technical Pursuit Inc. | ss&technicalpursuit.com | 2015-06-16 | |
| Vince Re | Vincent.Re&cai.com | ||
| Wilson Kwan | wilsonk%25toronto@zip.atm.com |