Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
at-echo 204 tcp AppleTalk Echo
at-echo 204 udp AppleTalk Echo
lmp 701 tcp Link Management Protocol (LMP) RFC 4204
lmp 701 udp Link Management Protocol (LMP) RFC 4204
ssslog-mgr 1204 tcp Log Request Listener Eric Bruno Eric Bruno
ssslog-mgr 1204 udp Log Request Listener Eric Bruno Eric Bruno
mil-2045-47001 1581 tcp MIL-2045-47001 Eric Whitehill Eric Whitehill
mil-2045-47001 1581 udp MIL-2045-47001 Eric Whitehill Eric Whitehill
lam 2040 tcp
lam 2040 udp
interbase 2041 tcp
interbase 2041 udp
isis 2042 tcp isis
isis 2042 udp isis
isis-bcast 2043 tcp isis-bcast Ken Chapman Ken Chapman
isis-bcast 2043 udp isis-bcast Ken Chapman Ken Chapman
rimsl 2044 tcp
rimsl 2044 udp
cdfunc 2045 tcp
cdfunc 2045 udp
sdfunc 2046 tcp
sdfunc 2046 udp
dls 2047 tcp
dls 2047 udp
dls-monitor 2048 tcp
dls-monitor 2048 udp
shilp 2049 tcp <== NOTE Conflict on 2049 !
shilp 2049 udp <== NOTE Conflict on 2049 !
nfs 2049 tcp Network File System - Sun Microsystems Brent Callaghan Brent Callaghan Defined TXT keys: path=<path to mount point>
nfs 2049 udp Network File System - Sun Microsystems Brent Callaghan Brent Callaghan Defined TXT keys: path=<path to mount point>
nfs 2049 sctp Network File System RFC 5665 Defined TXT keys: path=<path to mount point>
b2-license 2204 tcp b2 License Server Helge-Frank Zimpel Helge-Frank Zimpel 2006-01
b2-license 2204 udp b2 License Server Helge-Frank Zimpel Helge-Frank Zimpel 2006-01
netwatcher-db 3204 tcp Network Watcher DB Access Hirokazu Fujisawa Hirokazu Fujisawa
netwatcher-db 3204 udp Network Watcher DB Access Hirokazu Fujisawa Hirokazu Fujisawa
5204-5208 Unassigned
lm-perfworks 8204 tcp LM Perfworks Chris Flynn Chris Flynn
lm-perfworks 8204 udp LM Perfworks Chris Flynn Chris Flynn
wap-vcard 9204 tcp WAP vCard WAP Forum WAP Forum
wap-vcard 9204 udp WAP vCard WAP Forum WAP Forum
20223-20479 Unassigned
emwavemsg 20480 tcp emWave Message Service Harald Striepe Harald Striepe 2008-02-14
emwavemsg 20480 udp emWave Message Service Harald Striepe Harald Striepe 2008-02-14
20481-20669 Unassigned
38204-38411 Unassigned

Contact Information

Name Contact URI Last Updated
Brent Callaghan brent&terra.eng.sun.com
Chris Flynn cflynn&landmark.com
Eric Bruno ebruno&solution-soft.com
Eric Whitehill Eric.Whitehill&itt.com
Harald Striepe harald&quantumintech.com 2008-02-14
Helge-Frank Zimpel helge.zimpel&baeurer.de 2006-01
Hirokazu Fujisawa fujisawa&pfu.fujitsu.com
Ken Chapman kchapman&isis.com
WAP Forum wap-feedback&mail.wapforum.org
pg&uplanet.com