Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
telnet 23 tcp Telnet Jon Postel Jon Postel RFC 854 Defined TXT keys: u=<username> p=<password>
telnet 23 udp Telnet Jon Postel Jon Postel RFC 854 Defined TXT keys: u=<username> p=<password>
ntp 123 tcp Network Time Protocol Dave Mills Dave Mills RFC 5905
ntp 123 udp Network Time Protocol Dave Mills Dave Mills RFC 5905
cdc 223 tcp Certificate Distribution Center Kannan Alagappan Kannan Alagappan
cdc 223 udp Certificate Distribution Center Kannan Alagappan Kannan Alagappan
rpki-rtr 323 tcp Resource PKI to Router Protocol IESG IETF Chair RFC 6810
323 udp Reserved
matip-type-a 350 tcp MATIP Type A Alain Robert Alain Robert RFC 2351
matip-type-a 350 udp MATIP Type A Alain Robert Alain Robert RFC 2351
matip-type-b 351 tcp MATIP Type B Alain Robert Alain Robert RFC 2351
matip-type-b 351 udp MATIP Type B Alain Robert Alain Robert RFC 2351
359 tcp Reserved 2023-11-16 De-Assigned on 2023-11-16.
359 udp Reserved 2023-11-16 De-Assigned on 2023-11-16.
opc-job-start 423 tcp IBM Operations Planning and Control Start
opc-job-start 423 udp IBM Operations Planning and Control Start
ibm-db2 523 tcp IBM-DB2 Juliana Hsu Juliana Hsu
ibm-db2 523 udp IBM-DB2 Juliana Hsu Juliana Hsu
oob-ws-http 623 tcp DMTF out-of-band web services management protocol Jim Davis Jim Davis 2007-06
asf-rmcp 623 udp ASF Remote Management and Control Protocol Carl First Carl First
1023 tcp Reserved 2024-12-20 RFC 6335
1023 udp Reserved 2024-12-20 RFC 6335
murray 1123 tcp Murray Stu Mark Stu Mark
murray 1123 udp Murray Stu Mark Stu Mark
tgp 1223 tcp TrulyGlobal Protocol Gur Kimchi Gur Kimchi 2008-05-20
tgp 1223 udp TrulyGlobal Protocol Gur Kimchi Gur Kimchi 2008-05-20
periscope 1230 tcp Periscope Kevin Madden Kevin Madden
periscope 1230 udp Periscope Kevin Madden Kevin Madden
menandmice-lpm 1231 tcp menandmice-lpm Sigfus Magnusson Sigfus Magnusson
menandmice-lpm 1231 udp menandmice-lpm Sigfus Magnusson Sigfus Magnusson
first-defense 1232 tcp Remote systems monitoring Nexum, Inc. Michael Fread 2012-09-21 Microsoft (unoffically) using 1232
first-defense 1232 udp Remote systems monitoring Nexum, Inc. Michael Fread 2012-09-21 Microsoft (unoffically) using 1232
univ-appserver 1233 tcp Universal App Server Tim Sent Tim Sent
univ-appserver 1233 udp Universal App Server Tim Sent Tim Sent
search-agent 1234 tcp Infoseek Search Agent Jackie Wu Jackie Wu
search-agent 1234 udp Infoseek Search Agent Jackie Wu Jackie Wu
mosaicsyssvc1 1235 tcp mosaicsyssvc1 Brian Matthews Brian Matthews
mosaicsyssvc1 1235 udp mosaicsyssvc1 Brian Matthews Brian Matthews
bvcontrol 1236 tcp bvcontrol Daniel J Walsh Daniel J Walsh
bvcontrol 1236 udp bvcontrol Daniel J Walsh Daniel J Walsh
tsdos390 1237 tcp tsdos390 Ben Pracht Ben Pracht
tsdos390 1237 udp tsdos390 Ben Pracht Ben Pracht
hacl-qs 1238 tcp hacl-qs Farid Faez Farid Faez
hacl-qs 1238 udp hacl-qs Farid Faez Farid Faez
nmsd 1239 tcp NMSD Yuri Machkasov Yuri Machkasov
nmsd 1239 udp NMSD Yuri Machkasov Yuri Machkasov
1276 tcp Reserved 2014-05-23 This entry has been removed on 2014-05-23.
1276 udp Reserved 2014-05-23 This entry has been removed on 2014-05-23.
h323hostcallsc 1300 tcp H.323 Secure Call Control Signalling ITU-T ITU-T TSB 2013-01-31
h323hostcallsc 1300 udp H.323 Secure Call Control Signalling ITU-T ITU-T TSB 2013-01-31
brcd 1323 tcp brcd Todd Picquelle Todd Picquelle
brcd 1323 udp brcd Todd Picquelle Todd Picquelle
essbase 1423 tcp Essbase Arbor Software
essbase 1423 udp Essbase Arbor Software
cichild-lm 1523 tcp cichild Andy Burgess Andy Burgess
cichild-lm 1523 udp cichild Andy Burgess Andy Burgess
jaleosnd 1623 tcp jaleosnd Christian Schormann Christian Schormann
jaleosnd 1623 udp jaleosnd Christian Schormann Christian Schormann
h323gatedisc 1718 tcp H.323 Multicast Gatekeeper Discover ITU-T ITU-T TSB 2013-01-31
h323gatedisc 1718 udp H.323 Multicast Gatekeeper Discover ITU-T ITU-T TSB 2013-01-31
h323gatestat 1719 tcp H.323 Unicast Gatekeeper Signaling ITU-T ITU-T TSB 2013-01-31
h323gatestat 1719 udp H.323 Unicast Gatekeeper Signaling ITU-T ITU-T TSB 2013-01-31
h323hostcall 1720 tcp H.323 Call Control Signalling ITU-T ITU-T TSB 2013-01-31
h323hostcall 1720 udp H.323 Call Control Signalling ITU-T ITU-T TSB 2013-01-31
h323hostcall 1720 sctp H.323 Call Control ITU-T 2014-07-30
pptp 1723 tcp pptp Ken Crocker Ken Crocker 2021-09-21 RFC 2637
pptp 1723 udp pptp Ken Crocker Ken Crocker 2021-09-21 RFC 2637
unisys-lm 1823 tcp Unisys Natural Language License Manager Raymond A. Diedrichs Raymond A. Diedrichs
unisys-lm 1823 udp Unisys Natural Language License Manager Raymond A. Diedrichs Raymond A. Diedrichs
spice 1923 tcp SPICE Nicholas Chua Nicholas Chua
spice 1923 udp SPICE Nicholas Chua Nicholas Chua
xinuexpansion3 2023 tcp
xinuexpansion3 2023 udp
gtp-control 2123 tcp GTP-Control Plane (3GPP) Alessio Casati Alessio Casati
gtp-control 2123 udp GTP-Control Plane (3GPP) Alessio Casati Alessio Casati
rockwell-csp2 2223 tcp Rockwell CSP2 Brian Batke Brian Batke
rockwell-csp2 2223 udp Rockwell CSP2 Brian Batke Brian Batke
queueadm 2230 tcp MetaSoft Job Queue Administration Service Ilya Melamed Ilya Melamed 2006-06
queueadm 2230 udp MetaSoft Job Queue Administration Service Ilya Melamed Ilya Melamed 2006-06
wimaxasncp 2231 tcp WiMAX ASN Control Plane Protocol Prakash Iyer Prakash Iyer 2006-06
wimaxasncp 2231 udp WiMAX ASN Control Plane Protocol Prakash Iyer Prakash Iyer 2006-06
ivs-video 2232 tcp IVS Video default Thierry Turletti Thierry Turletti
ivs-video 2232 udp IVS Video default Thierry Turletti Thierry Turletti
infocrypt 2233 tcp INFOCRYPT Erica Liu Erica Liu
infocrypt 2233 udp INFOCRYPT Erica Liu Erica Liu
directplay 2234 tcp DirectPlay Ajay Jindal Ajay Jindal
directplay 2234 udp DirectPlay Ajay Jindal Ajay Jindal
sercomm-wlink 2235 tcp Sercomm-WLink Melinda Tsao Melinda Tsao
sercomm-wlink 2235 udp Sercomm-WLink Melinda Tsao Melinda Tsao
nani 2236 tcp Nani Steve Benoit Steve Benoit
nani 2236 udp Nani Steve Benoit Steve Benoit
optech-port1-lm 2237 tcp Optech Port1 License Manager Gerard Cannie Gerard Cannie
optech-port1-lm 2237 udp Optech Port1 License Manager Gerard Cannie Gerard Cannie
aviva-sna 2238 tcp AVIVA SNA SERVER Vick Keshishian Vick Keshishian
aviva-sna 2238 udp AVIVA SNA SERVER Vick Keshishian Vick Keshishian
imagequery 2239 tcp Image Query Charles Jacobs Charles Jacobs
imagequery 2239 udp Image Query Charles Jacobs Charles Jacobs
cvmmon 2300 tcp CVMMON Roger Kumpf Roger Kumpf
cvmmon 2300 udp CVMMON Roger Kumpf Roger Kumpf
cpq-wbem 2301 tcp Compaq HTTP Scott Shaffer Scott Shaffer

Contact Information

Name Organization Contact URI Last Updated
Ajay Jindal ajayj&microsoft.com
Alain Robert arobert&par.sita.int
Alessio Casati a.casati&computer.org
Andy Burgess aab&cichlid.com
Ben Pracht ben.pracht&tivoli.com
Brian Batke csp.protocol&gmail.com
Brian Matthews bmatthews&mosaicsystems.com
Carl First Carl.L.First&intel.com
Charles Jacobs cjacobs&numinous.com
Christian Schormann 100410.3063&compuserve.com
Daniel J Walsh dwalsh&bindview.com
Dave Mills mills&udel.edu 2022-06-03
Erica Liu liue&isolation.com
Farid Faez farid_faez&hp.com
Gerard Cannie jcannie&opticaltech.com
Gur Kimchi gkimchi&microsoft.com 2008-05-20
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
ITU-T tsbsg16&itu.int 2013-01-31
ITU-T TSB ITU-T tsbsg16&itu.int 2013-01-31
Ilya Melamed ilya77&gmail.com 2006-06
Jackie Wu jackiew&infoseek.com
Jim Davis jim.davis&wbemsolutions.com 2007-06
Jon Postel postel&isi.edu
Juliana Hsu jhsu&ca.ibm.com
Kannan Alagappan kannan&sejour.enet.dec.com
Ken Crocker kcrocker&microsoft.com
Kevin Madden Kevin&emailxtras.com
Melinda Tsao melinda&tpe1.sercomm.com.tw
Michael Fread Nexum, Inc. mfread&nexuminc.com 2012-09-21
Nexum, Inc. mfread&nexuminc.com 2012-09-21
Nicholas Chua nick&sendit.se
Prakash Iyer prakash.iyer&intel.com 2009-08-10
Raymond A. Diedrichs rayd&slu.tr.unisys.com
Roger Kumpf kumpf&cup.hp.com
Scott Shaffer scott.shaffer&hp.com
Sigfus Magnusson sigfusm&menandmice.com
Steve Benoit benoit&math.colostate.edu 2015-09-07
Stu Mark fordii&j51.com
Thierry Turletti Thierry.Turletti&sophia.inria.fr
Tim Sent tim.sent&systemsarchitects.com
Todd Picquelle todd&picquelle.com
Vick Keshishian vickenK&192.219.82.71
Yuri Machkasov yuri&ptc.com