Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
matip-type-a 350 tcp MATIP Type A Alain Robert Alain Robert RFC 2351
matip-type-a 350 udp MATIP Type A Alain Robert Alain Robert RFC 2351
matip-type-b 351 tcp MATIP Type B Alain Robert Alain Robert RFC 2351
matip-type-b 351 udp MATIP Type B Alain Robert Alain Robert RFC 2351
bhoetty 351 tcp bhoetty John Kelly John Kelly This entry records an unassigned but widespread use (added 5/21/97)
bhoetty 351 udp bhoetty John Kelly John Kelly This entry records an unassigned but widespread use (added 5/21/97)
equationbuilder 1351 tcp Digital Tool Works (MIT) Terrence J. Talbot Terrence J. Talbot
equationbuilder 1351 udp Digital Tool Works (MIT) Terrence J. Talbot Terrence J. Talbot
psrserver 2351 tcp psrserver
psrserver 2351 udp psrserver
btrieve 3351 tcp Btrieve port
btrieve 3351 udp Btrieve port
xss-port 3510 tcp XSS Port Joe Purcell Joe Purcell 2002-05
xss-port 3510 udp XSS Port Joe Purcell Joe Purcell 2002-05
webmail-2 3511 tcp WebMail/2 Dimitris Michelinakis Dimitris Michelinakis 2002-05
webmail-2 3511 udp WebMail/2 Dimitris Michelinakis Dimitris Michelinakis 2002-05
aztec 3512 tcp Aztec Distribution Port Alan Francis Alan Francis 2002-05
aztec 3512 udp Aztec Distribution Port Alan Francis Alan Francis 2002-05
arcpd 3513 tcp Adaptec Remote Protocol Hardy Doelfel Hardy Doelfel 2002-05
arcpd 3513 udp Adaptec Remote Protocol Hardy Doelfel Hardy Doelfel 2002-05
must-p2p 3514 tcp MUST Peer to Peer
must-p2p 3514 udp MUST Peer to Peer
must-backplane 3515 tcp MUST Backplane Rick Stefanik Rick Stefanik 2002-05
must-backplane 3515 udp MUST Backplane Rick Stefanik Rick Stefanik 2002-05
smartcard-port 3516 tcp Smartcard Port Scott Guthery Scott Guthery 2002-05
smartcard-port 3516 udp Smartcard Port Scott Guthery Scott Guthery 2002-05
802-11-iapp 3517 tcp IEEE 802.11 WLANs WG IAPP Stuart J. Kerry Stuart J. Kerry 2002-05
802-11-iapp 3517 udp IEEE 802.11 WLANs WG IAPP Stuart J. Kerry Stuart J. Kerry 2002-05
artifact-msg 3518 tcp Artifact Message Server Ron Capwell Ron Capwell 2002-06
artifact-msg 3518 udp Artifact Message Server Ron Capwell Ron Capwell 2002-06
nvmsgd 3519 tcp Netvion Messenger Port
galileo 3519 udp Netvion Galileo Port
plcy-net-svcs 4351 tcp PLCY Net Services J.J. Ekstrom J.J. Ekstrom
plcy-net-svcs 4351 udp PLCY Net Services J.J. Ekstrom J.J. Ekstrom
dtn-bundle 4556 dccp DTN Bundle DCCP CL Protocol 2013-11-12 2014-02-21 RFC 7122 1685351985
5351 tcp Reserved
pcp 5351 udp Port Control Protocol IESG IETF Chair RFC 6887
6351-6354 Unassigned
server-find 8351 tcp Server Find Chris Brown Chris Brown
server-find 8351 udp Server Find Chris Brown Chris Brown
codemeter-cmwan 22351 tcp TPC/IP requests of copy protection software to a server WIBU-SYSTEMS AG Wolfgang Völker 2013-06-25
22351 udp Reserved
axio-disc 35100 tcp Axiomatic discovery protocol Axiomatic Technologies Corporation Oleksandr_Bogush 2016-12-09
axio-disc 35100 udp Axiomatic discovery protocol Axiomatic Technologies Corporation Oleksandr_Bogush 2016-12-09
35101-35353 Unassigned
44323 udp Unassigned "pcp" assignment withdrawn, moved to port 5351 per RFC 6887

Contact Information

Name Organization Contact URI Last Updated
Alain Robert arobert&par.sita.int
Alan Francis AlanF&zonal.co.uk 2002-05
Axiomatic Technologies Corporation obogush&axiomatic.com 2016-12-09
Chris Brown chrisb&chancery.com
Dimitris Michelinakis dimitris&michelinakis.gr 2002-05
Hardy Doelfel hardy_doelfel&adaptec.com 2002-05
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
J.J. Ekstrom
Joe Purcell jpurcell&ensuretech.com 2003-01
John Kelly johnk&bellhow.com
Oleksandr_Bogush obogush&axiomatic.com 2016-12-09
Rick Stefanik r.stefanik&gatelinx.com 2002-05
Ron Capwell ron&artifactsoftware.com 2002-06
Scott Guthery sguthery&mobile-mind.com 2002-05
Stuart J. Kerry Chair IEEE 802.11 WG stuart&ok-brit.com 2002-05
Terrence J. Talbot lexcube!tjt&bu.edu
WIBU-SYSTEMS AG oliver.winzenried&wibu.com 2013-06-25
Wolfgang Völker WIBU-SYSTEMS AG wolfgang.voelker&wibu.com 2013-06-25