Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| bhevent | 357 | tcp | bhevent | John Kelly | John Kelly | ||||||
| bhevent | 357 | udp | bhevent | John Kelly | John Kelly | ||||||
| twamp-control | 862 | tcp | TWAMP-Control | IESG | IETF Chair | RFC 5357 | |||||
| pegboard | 1357 | tcp | Electronic PegBoard | Chris Cuilla | Chris Cuilla | ||||||
| pegboard | 1357 | udp | Electronic PegBoard | Chris Cuilla | Chris Cuilla | ||||||
| unihub-server | 2357 | tcp | UniHub Server | Tim Kenyon | Tim Kenyon | ||||||
| unihub-server | 2357 | udp | UniHub Server | Tim Kenyon | Tim Kenyon | ||||||
| adtech-test | 3357 | tcp | Adtech Test IP | Robin Uyeshiro | Robin Uyeshiro | ||||||
| adtech-test | 3357 | udp | Adtech Test IP | Robin Uyeshiro | Robin Uyeshiro | ||||||
| mccwebsvr-port | 3570 | tcp | MCC Web Server Port | ||||||||
| mccwebsvr-port | 3570 | udp | MCC Web Server Port | ||||||||
| megardsvr-port | 3571 | tcp | MegaRAID Server Port | ||||||||
| megardsvr-port | 3571 | udp | MegaRAID Server Port | ||||||||
| megaregsvrport | 3572 | tcp | Registration Server Port | Sreenivas Bagalkote | Sreenivas Bagalkote | 2002-08 | |||||
| megaregsvrport | 3572 | udp | Registration Server Port | Sreenivas Bagalkote | Sreenivas Bagalkote | 2002-08 | |||||
| tag-ups-1 | 3573 | tcp | Advantage Group UPS Suite | James Goddard | James Goddard | 2002-08 | |||||
| tag-ups-1 | 3573 | udp | Advantage Group UPS Suite | James Goddard | James Goddard | 2002-08 | |||||
| dmaf-server | 3574 | tcp | DMAF Server | ||||||||
| dmaf-caster | 3574 | udp | DMAF Caster | Ramakrishna Nadendla | Ramakrishna Nadendla | 2002-08 | |||||
| ccm-port | 3575 | tcp | Coalsere CCM Port | ||||||||
| ccm-port | 3575 | udp | Coalsere CCM Port | ||||||||
| cmc-port | 3576 | tcp | Coalsere CMC Port | Chris Hawkinson | Chris Hawkinson | 2002-08 | |||||
| cmc-port | 3576 | udp | Coalsere CMC Port | Chris Hawkinson | Chris Hawkinson | 2002-08 | |||||
| config-port | 3577 | tcp | Configuration Port | ||||||||
| config-port | 3577 | udp | Configuration Port | ||||||||
| data-port | 3578 | tcp | Data Port | Anupam Bharali | Anupam Bharali | 2002-08 | |||||
| data-port | 3578 | udp | Data Port | Anupam Bharali | Anupam Bharali | 2002-08 | |||||
| ttat3lb | 3579 | tcp | Tarantella Load Balancing | Jim Musgrave | Jim Musgrave | 2002-08 | |||||
| ttat3lb | 3579 | udp | Tarantella Load Balancing | Jim Musgrave | Jim Musgrave | 2002-08 | |||||
| radius-dynauth | 3799 | tcp | RADIUS Dynamic Authorization | RFC 3576 | |||||||
| radius-dynauth | 3799 | udp | RADIUS Dynamic Authorization | RFC 3576 | |||||||
| qsnet-cond | 4357 | tcp | QSNet Conductor | ||||||||
| qsnet-cond | 4357 | udp | QSNet Conductor | ||||||||
| wsdapi | 5357 | tcp | Web Services for Devices | Henry Rawas | Henry Rawas | 2005-08 | |||||
| wsdapi | 5357 | udp | Web Services for Devices | Henry Rawas | Henry Rawas | 2005-08 | |||||
| openstack-id | 35357 | tcp | OpenStack ID Service | Rackspace Hosting | Ziad Sawalha | 2011-08-15 | |||||
| 35357 | udp | Reserved |
Contact Information
| Name | Organization | Contact URI | Last Updated |
|---|---|---|---|
| Anupam Bharali | ianaports&juniper.net | 2002-08 | |
| Chris Cuilla | balr!vpnet!cuilla!chris&clout.chi.il.us | ||
| Chris Hawkinson | chawkinson&coalsere.com | 2002-08 | |
| Henry Rawas | henryrµsoft.com | 2005-08 | |
| IESG | iesg&ietf.org | ||
| IETF Chair | IETF | chair&ietf.org | |
| James Goddard | jamesg&taglim.com | 2005-08 | |
| Jim Musgrave | jimm&tarantella.com | 2002-08 | |
| John Kelly | johnk&bellhow.com | ||
| Rackspace Hosting | ziad.sawalha&rackspace.com | 2011-08-15 | |
| Ramakrishna Nadendla | rama_nadendla&agilent.com | 2002-08 | |
| Robin Uyeshiro | robin_u&adtech-inc.com | ||
| Sreenivas Bagalkote | sreenib&lsil.com | 2002-08 | |
| Tim Kenyon | Tim_Kenyon&csicontrols.com | ||
| Ziad Sawalha | Rackspace Hosting | ziad.sawalha&rackspace.com | 2011-08-15 |