Service Name and Transport Protocol Port Number Registry
Last Updated
- 2026-10-15
Expert(s)
- TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
- SCTP: Michael Tuexen
- DCCP: Eddie Kohler and Yoshifumi Nishida
Reference
- RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry
Note
Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.
Service names are assigned on a First Come First Served basis, as described in RFC 6335.
Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:
- System Ports (0-1023) are assigned using the IETF Review or IESG Approval procedures.
- User Ports (1024-49151) are assigned using the IETF Review, IESG Approval, or Expert Review procedures.
- Dynamic and/or Private Ports (49152-65535) are not assigned.
The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.
Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.
Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.
Registration Forms
- To request a new assignment, please use the Application for Service Names and User Port Numbers form.
- To modify an existing assignment, please use the Modify a Port Number Assignment form.
Available Formats
| Service Name | Port Number | Transport Protocol | Description | Assignee | Contact | Registration Date | Modification Date | Reference | Service Code | Unauthorized Use Reported | Assignment Notes |
|---|---|---|---|---|---|---|---|---|---|---|---|
| shrinkwrap | 358 | tcp | Shrinkwrap | Bill Simpson | Bill Simpson | ||||||
| shrinkwrap | 358 | udp | Shrinkwrap | Bill Simpson | Bill Simpson | ||||||
| connlcli | 1358 | tcp | CONNLCLI | ||||||||
| connlcli | 1358 | udp | CONNLCLI | ||||||||
| futrix | 2358 | tcp | Futrix | Peter Frankenberg | Peter Frankenberg | ||||||
| futrix | 2358 | udp | Futrix | Peter Frankenberg | Peter Frankenberg | ||||||
| mpsysrmsvr | 3358 | tcp | Mp Sys Rmsvr | Hiroyuki Kawabuchi | Hiroyuki Kawabuchi | ||||||
| mpsysrmsvr | 3358 | udp | Mp Sys Rmsvr | Hiroyuki Kawabuchi | Hiroyuki Kawabuchi | ||||||
| nati-svrloc | 3580 | tcp | NATI-ServiceLocator | Jason Case | Jason Case | 2002-08 | |||||
| nati-svrloc | 3580 | udp | NATI-ServiceLocator | Jason Case | Jason Case | 2002-08 | |||||
| kfxaclicensing | 3581 | tcp | Ascent Capture Licensing | Brad Hamilton | Brad Hamilton | 2002-08 | |||||
| kfxaclicensing | 3581 | udp | Ascent Capture Licensing | Brad Hamilton | Brad Hamilton | 2002-08 | |||||
| press | 3582 | tcp | PEG PRESS Server | Jim DeLisle | Jim DeLisle | 2002-08 | |||||
| press | 3582 | udp | PEG PRESS Server | Jim DeLisle | Jim DeLisle | 2002-08 | |||||
| canex-watch | 3583 | tcp | CANEX Watch System | Peter Kollath | Peter Kollath | 2002-08 | |||||
| canex-watch | 3583 | udp | CANEX Watch System | Peter Kollath | Peter Kollath | 2002-08 | |||||
| u-dbap | 3584 | tcp | U-DBase Access Protocol | Bodo Rueskamp | Bodo Rueskamp | 2002-08 | |||||
| u-dbap | 3584 | udp | U-DBase Access Protocol | Bodo Rueskamp | Bodo Rueskamp | 2002-08 | |||||
| emprise-lls | 3585 | tcp | Emprise License Server | ||||||||
| emprise-lls | 3585 | udp | Emprise License Server | ||||||||
| emprise-lsc | 3586 | tcp | License Server Console | James J. Diaz | James J. Diaz | 2002-08 | |||||
| emprise-lsc | 3586 | udp | License Server Console | James J. Diaz | James J. Diaz | 2002-08 | |||||
| p2pgroup | 3587 | tcp | Peer to Peer Grouping | Igor Kostic | Igor Kostic | 2002-08 | |||||
| p2pgroup | 3587 | udp | Peer to Peer Grouping | Igor Kostic | Igor Kostic | 2002-08 | |||||
| sentinel | 3588 | tcp | Sentinel Server | Ian Gordon | Ian Gordon | 2002-08 | |||||
| sentinel | 3588 | udp | Sentinel Server | Ian Gordon | Ian Gordon | 2002-08 | |||||
| isomair | 3589 | tcp | isomair | Richard Fleming | Richard Fleming | 2002-08 | |||||
| isomair | 3589 | udp | isomair | Richard Fleming | Richard Fleming | 2002-08 | |||||
| diameter | 3868 | sctp | DIAMETER | RFC 3588 | |||||||
| qsnet-nucl | 4358 | tcp | QSNet Nucleus | Neer Kleinman | Neer Kleinman | ||||||
| qsnet-nucl | 4358 | udp | QSNet Nucleus | Neer Kleinman | Neer Kleinman | ||||||
| wsdapi-s | 5358 | tcp | WS for Devices Secured | Henry Rawas | Henry Rawas | 2005-08 | |||||
| wsdapi-s | 5358 | udp | WS for Devices Secured | Henry Rawas | Henry Rawas | 2005-08 | |||||
| 35358-36000 | Unassigned |
Contact Information
| Name | Contact URI | Last Updated |
|---|---|---|
| Bill Simpson | wsimpson&greendragon.com | |
| Bodo Rueskamp | iana+spam&pinda.de | 2020-06-04 |
| Brad Hamilton | brad_hamilton&kofax.com | 2002-08 |
| Henry Rawas | henryrµsoft.com | 2005-08 |
| Hiroyuki Kawabuchi | buchi&ael.fujitsu.co.jp | |
| Ian Gordon | ian.s.gordon&btopenworld.com | 2002-08 |
| Igor Kostic | igorkoµsoft.com | 2002-08 |
| James J. Diaz | JDiaz&emprisecorporation.com | 2002-08 |
| Jason Case | jason.case&ni.com | 2002-08 |
| Jim DeLisle | jdelisle&swellsoftware.com | 2002-08 |
| Neer Kleinman | neer&qsr.co.il | |
| Peter Frankenberg | pcfberg&ibm.net | |
| Peter Kollath | peter.kollath&canex.sk | 2002-08 |
| Richard Fleming | richard&apoapsis.com | 2002-08 |