Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
uis 390 tcp UIS Ed Barron Ed Barron
uis 390 udp UIS Ed Barron Ed Barron
tsdos390 1237 tcp tsdos390 Ben Pracht Ben Pracht
tsdos390 1237 udp tsdos390 Ben Pracht Ben Pracht
iclpv-sc 1390 tcp Storage Controller
iclpv-sc 1390 udp Storage Controller
rsmtp 2390 tcp RSMTP Geoff Collyer Geoff Collyer
rsmtp 2390 udp RSMTP Geoff Collyer Geoff Collyer
dsc 3390 tcp Distributed Service Coordinator Charles Honton Charles Honton
dsc 3390 udp Distributed Service Coordinator Charles Honton Charles Honton
udt-os 3900 tcp Unidata UDT OS

IANA assigned this well-formed service name as a replacement for "udt_os".
James Powell James Powell
udt_os 3900 tcp Unidata UDT OS James Powell James Powell This entry is an alias to "udt-os". This entry is now historic, not usable for use with many common service discovery mechanisms.
udt-os 3900 udp Unidata UDT OS

IANA assigned this well-formed service name as a replacement for "udt_os".
James Powell James Powell
udt_os 3900 udp Unidata UDT OS James Powell James Powell This entry is an alias to "udt-os". This entry is now historic, not usable for use with many common service discovery mechanisms.
nimsh 3901 tcp NIM Service Handler Paul B. Finley Paul B. Finley 2003-10
nimsh 3901 udp NIM Service Handler Paul B. Finley Paul B. Finley 2003-10
nimaux 3902 tcp NIMsh Auxiliary Port Paul B. Finley Paul B. Finley 2003-10
nimaux 3902 udp NIMsh Auxiliary Port Paul B. Finley Paul B. Finley 2003-10
charsetmgr 3903 tcp CharsetMGR Tatsuya Ueda Tatsuya Ueda 2003-10
charsetmgr 3903 udp CharsetMGR Tatsuya Ueda Tatsuya Ueda 2003-10
omnilink-port 3904 tcp Arnet Omnilink Port Ronen Shaul Ronen Shaul 2003-10
omnilink-port 3904 udp Arnet Omnilink Port Ronen Shaul Ronen Shaul 2003-10
mupdate 3905 tcp Mailbox Update (MUPDATE) protocol RFC 3656
mupdate 3905 udp Mailbox Update (MUPDATE) protocol RFC 3656
topovista-data 3906 tcp TopoVista elevation data Gregg Townsend Gregg Townsend 2003-11
topovista-data 3906 udp TopoVista elevation data Gregg Townsend Gregg Townsend 2003-11
imoguia-port 3907 tcp Imoguia Port Emidio Cunha Emidio Cunha 2003-11
imoguia-port 3907 udp Imoguia Port Emidio Cunha Emidio Cunha 2003-11
hppronetman 3908 tcp HP Procurve NetManagement Devon Dawson Devon Dawson 2003-11
hppronetman 3908 udp HP Procurve NetManagement Devon Dawson Devon Dawson 2003-11
surfcontrolcpa 3909 tcp SurfControl CPA Hywel Morgan Hywel Morgan 2003-11
surfcontrolcpa 3909 udp SurfControl CPA Hywel Morgan Hywel Morgan 2003-11
wiegand 4390 tcp Physical Access Control Scott Guthery Scott Guthery 2008-08-25
wiegand 4390 udp Physical Access Control Scott Guthery Scott Guthery 2008-08-25
metaedit-ws 6390 tcp MetaEdit+ WebService API Steven Kelly Steven Kelly 2007-11-12
metaedit-ws 6390 udp MetaEdit+ WebService API Steven Kelly Steven Kelly 2007-11-12
7366-7390 Unassigned 2006-02-06
otp 9390 tcp OpenVAS Transfer Protocol Tim Brown Tim Brown 2008-12-24
9390 udp Reserved
38866-39062 Unassigned
vroa 39063 tcp Children's hearing test/Telemedicine Hearing Australia Dan Zhou 2021-12-23
39063 udp Reserved
39064-39680 Unassigned

Contact Information

Name Organization Contact URI Last Updated
Ben Pracht ben.pracht&tivoli.com
Charles Honton chas&honton.org
Dan Zhou Hearing Australia dan.zhou&hearing.com.au 2021-12-23
Devon Dawson devon.dawson&hp.com 2003-11
Ed Barron
Emidio Cunha emidio&janeladigital.com 2003-11
Geoff Collyer geoff&research.bell-labs.com
Gregg Townsend gmt&cs.arizona.edu 2003-11
Hearing Australia dan.zhou&hearing.com.au 2021-12-23
Hywel Morgan hywelm&surfcontrol.com 2003-11
James Powell james&mailhost.unidata.com
Paul B. Finley pfinley&us.ibm.com 2003-10
Ronen Shaul ronen&arnetsystems.com 2003-10
Scott Guthery sguthery&hidcorp.com 2008-08-25
Steven Kelly stevek&metacase.com 2007-11-12
Tatsuya Ueda tatsu&ist.fujitsu.com 2003-10
Tim Brown timb&openvas.org 2008-12-24