Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
ssh 22 tcp The Secure Shell (SSH) Protocol RFC 4251 Defined TXT keys: u=<username> p=<password>
ssh 22 udp The Secure Shell (SSH) Protocol RFC 4251 Defined TXT keys: u=<username> p=<password>
icad-el 425 tcp ICAD Larry Stone Larry Stone
icad-el 425 udp ICAD Larry Stone Larry Stone
zion-lm 1425 tcp Zion Software License Manager David Ferrero David Ferrero
zion-lm 1425 udp Zion Software License Manager David Ferrero David Ferrero
fjitsuappmgr 2425 tcp Fujitsu App Manager Hiroyuki Kawabuchi Hiroyuki Kawabuchi
fjitsuappmgr 2425 udp Fujitsu App Manager Hiroyuki Kawabuchi Hiroyuki Kawabuchi
agps-port 3425 tcp AGPS Access Port Kristoffer Nilsson Kristoffer Nilsson 2002-02
agps-port 3425 udp AGPS Access Port Kristoffer Nilsson Kristoffer Nilsson 2002-02
netrockey6 4425 tcp NetROCKEY6 SMART Plus Service Feitian Technologies Feitian Technologies 2010-09-15
netrockey6 4425 udp NetROCKEY6 SMART Plus Service Feitian Technologies Feitian Technologies 2010-09-15
br-channel 5425 tcp Beyond Remote Command Channel Michael Berg Michael Berg 2005-08
br-channel 5425 udp Beyond Remote Command Channel Michael Berg Michael Berg 2005-08
syslog-tls 6514 tcp Syslog over TLS RFC 5425
7422-7425 Unassigned
cps 14250 tcp Fencing Server Mayank Vasa Mayank Vasa 2008-04-03
cps 14250 udp Fencing Server Mayank Vasa Mayank Vasa 2008-04-03
14251-14413 Unassigned
24250-24320 Unassigned
34250-34377 Unassigned
36425-36442 Unassigned
41798-42507 Unassigned Unauthorized Use Known on port 42000
candp 42508 tcp Computer Associates network discovery protocol Jon Press Jon Press 2005-09
candp 42508 udp Computer Associates network discovery protocol Jon Press Jon Press 2005-09
candrp 42509 tcp CA discovery response Jon Press Jon Press 2005-08
candrp 42509 udp CA discovery response Jon Press Jon Press 2005-08
caerpc 42510 tcp CA eTrust RPC Jon Press Jon Press 2005-08
caerpc 42510 udp CA eTrust RPC Jon Press Jon Press 2005-08
42511-42998 Unassigned
jnx-kcsync tcp jollys keychain cloud sync protocol Patrick Stein Patrick Stein 2011-10-24 Defined TXT keys: hash=<40hex characters> salt=<40hex characters> uuid=<40hex characters> Example: hash=5e7580598c0d7064d4fc79faaeb42585e1a675f8 salt=f0164cb3a0c3d7efe75abea8fda86d2d56c8dda9 uuid=db61dc092922252e45bbb264f59147138c7fd5fa

Contact Information

Name Contact URI Last Updated
David Ferrero david&zion.com
Feitian Technologies product&ftsafe.com 2010-09-15
Hiroyuki Kawabuchi buchi&ael.fujitsu.co.jp
Jon Press IANA.Registions&ca.com 2005-09
Kristoffer Nilsson kristoffer.nilsson&hutchison3g.com 2002-02
Larry Stone lcs&icad.com
Mayank Vasa mayank_vasa&symantec.com 2008-04-03
Michael Berg mike&dataapples.com 2005-08
Patrick Stein Patrick.Stein&jinx.eu 2011-10-24