Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
manet 269 tcp MANET Protocols RFC 5498
manet 269 udp MANET Protocols RFC 5498
idfp 549 tcp IDFP Ramana Kovi Ramana Kovi
idfp 549 udp IDFP Ramana Kovi Ramana Kovi
shivahose 1549 tcp Shiva Hose
shivasound 1549 udp Shiva Sound Kin Chan Kin Chan
ipass 2549 tcp IPASS Michael Fischer Michael Fischer
ipass 2549 udp IPASS Michael Fischer Michael Fischer
tellumat-nms 3549 tcp Tellumat MDR NMS Hennie van der Merwe Hennie van der Merwe 2002-07
tellumat-nms 3549 udp Tellumat MDR NMS Hennie van der Merwe Hennie van der Merwe 2002-07
aegate 4549 tcp Aegate PMR Service Nick Warrington Nick Warrington 2006-03
aegate 4549 udp Aegate PMR Service Nick Warrington Nick Warrington 2006-03
5476-5499 Unassigned
5544-5549 Unassigned
apc-6549 6549 tcp APC 6549 American Power Conversion American Power Conversion
apc-6549 6549 udp APC 6549 American Power Conversion American Power Conversion
nls-tl 7549 tcp Network Layer Signaling Transport Layer Melinda Shore Melinda Shore 2006-05
nls-tl 7549 udp Network Layer Signaling Transport Layer Melinda Shore Melinda Shore 2006-05
10549-10630 Unassigned

Contact Information

Name Organization Contact URI Last Updated
American Power Conversion ports&apcc.com 2002-02
Hennie van der Merwe hvandermerwe&tellumat.com 2002-07
Kin Chan kchan&shiva.com
Melinda Shore mshore&cisco.com 2006-05
Michael Fischer otterley&pass.com
Nick Warrington nick.warrington&paconsulting.com 2006-03
Ramana Kovi ramana&kovi.com