Service Name and Transport Protocol Port Number Registry

Last Updated

  • 2026-10-15

Expert(s)

  • TCP/UDP: Joe Touch; Eliot Lear, Kumiko Ono, Wes Eddy, Brian Trammell, and Michael Scharf
  • SCTP: Michael Tuexen
  • DCCP: Eddie Kohler and Yoshifumi Nishida

Reference

  • RFC 6335: Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number Registry

Note

Service names and port numbers are used to distinguish between different services that run over transport protocols such as TCP, UDP, DCCP, and SCTP.

Service names are assigned on a First Come First Served basis, as described in RFC 6335.

Port numbers are divided into three ranges, with their uses and assignment procedures specified in Section 8.1.2 of RFC 6335:

The registration procedures for service names and port numbers are specified in RFC 6335, while the registration policies referenced above are defined in RFC 8126.

Assigned ports both System and User ports SHOULD NOT be used without or prior to IANA registration.

Assignment of a port number does not in any way imply an endorsement of an application or product, and the fact that network traffic is flowing to or from a registered port does not mean that it is "good" traffic, nor that it necessarily corresponds to the assigned service. Firewall and system administrators should choose how to configure their systems based on their knowledge of the traffic in question, not whether there is a port number registered or not.

Registration Forms

Available Formats

Service Name Port Number Transport Protocol Description Assignee Contact Registration Date Modification Date Reference Service Code Unauthorized Use Reported Assignment Notes
eyelink 589 tcp EyeLink Dave Stampe Dave Stampe
eyelink 589 udp EyeLink Dave Stampe Dave Stampe
vqp 1589 tcp VQP Keith McCloghrie Keith McCloghrie
vqp 1589 udp VQP Keith McCloghrie Keith McCloghrie
quartus-tcl 2589 tcp quartus tcl Subroto Datta Subroto Datta
quartus-tcl 2589 udp quartus tcl Subroto Datta Subroto Datta
isomair 3589 tcp isomair Richard Fleming Richard Fleming 2002-08
isomair 3589 udp isomair Richard Fleming Richard Fleming 2002-08
4574-4589 Unassigned
5884-5899 Unassigned
netconf-tls 6513 tcp NETCONF over TLS IESG IETF Chair 2024-01-24 RFC 7589; RFC 9918
6589-6599 Unassigned
7589-7605 Unassigned
21555-21589 Unassigned
25794-25899 Unassigned
bosswave 28589 tcp Building operating system services wide area verified exchange University of California, Berkeley Michael Andersen 2016-06-13
28589 udp Reserved

Contact Information

Name Organization Contact URI Last Updated
Dave Stampe dstampe&psych.toronto.edu
IESG iesg&ietf.org
IETF Chair IETF chair&ietf.org
Keith McCloghrie kzm&cisco.com
Michael Andersen michael&steelcode.com 2016-06-13
Richard Fleming richard&apoapsis.com 2002-08
Subroto Datta subrotod&altera.com
University of California, Berkeley m.andersen&cs.berkeley.edu 2016-06-13